Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

  • »fischefr« ist männlich
  • »fischefr« ist der Autor dieses Themas

Beiträge: 11

Registrierungsdatum: 15.02.2006

  • Nachricht senden

1

17.02.2006, 14:51

Einsteigerprobleme - ipw2100 & wpasupplicant

Hallo zusammen!

Ich bin momentan etwas hilflos, evtl. könnt ihr mir helfen. Mein Notebook besitzt eth0 (Netzwerkanschluß) und eth1 (wlan, ist ein Centrino-Notebook mit dem ipw2100 Chipsatz).
Mein 1. Problem bei der Sache: unter System Settings wird eth1 als disabled angezeigt und ich habe keine Ahnung, wie ich das ändere bzw. ob ich da was ändern muss. "ifconfig" zeigt eth0 an, aber nicht eth1. "ifconfig eth1" liefert mir allerdings die Daten.
Ist das so in Ordnung und ich kann gleich mit wpa-supplicant loslegen, oder muss ich da zuvor noch etwas umstellen?
Gibts evtl. ein HowTo für wpa-supplicant auf Kubuntu? Ich bräuchte lediglich Unterstützung für wpa2.

NACHTRAG: ETH2 ist jetzt up wie gewünscht, aber evtl. kann mir jemand mit wpa_supplicant weiterhelfen. Ich bekomme da unverständliche Fehlermeldungen:

franz@notebook:/usr/sbin$ sudo wpa_supplicant -Dipw -ieth2 -c/etc/wpa_supplicant.conf
ioctl[SIOCSIWPMKSA]: No such device
ioctl[SIOCSIWMODE]: No such device
Could not configure driver to use managed mode
ioctl[SIOCGIFFLAGS]: No such device
Could not set interface 'eth2' UP
ioctl[SIOCGIWRANGE]: No such device
ioctl[SIOCGIFINDEX]: No such device
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: No such device
Failed to set encryption.
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: No such device
Failed to set encryption.
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: No such device
Failed to set encryption.
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: No such device
Failed to set encryption.
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: No such device
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: No such device
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: No such device
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: No such device
ioctl[SIOCSIWAP]: No such device
ioctl[SIOCGIFFLAGS]: No such device

NACHTRAG: HABE DAS PROBLEM JETZT SOWEIT IM GRIFF

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »fischefr« (19.02.2006, 06:41)


s0nic

User

Beiträge: 23

Registrierungsdatum: 03.05.2005

  • Nachricht senden

2

09.03.2006, 12:17

Wie hast du es denn in den Griff bekommen?

  • »fischefr« ist männlich
  • »fischefr« ist der Autor dieses Themas

Beiträge: 11

Registrierungsdatum: 15.02.2006

  • Nachricht senden

3

09.03.2006, 17:13

mit der Hasenfuß-Methode *g*: habs als Paket mit Synaptics geholt.
Wenn du mir sagen kannst, wie ich rausbekomme, von welcher meiner X Quellen das stammt, kann ich dir das sogar sagen.

.. ich gehe mal davon aus, du stehst vor dem gleichen Problem ?!

s0nic

User

Beiträge: 23

Registrierungsdatum: 03.05.2005

  • Nachricht senden

4

09.03.2006, 23:41

hmmm ich habe leider einen anderen fehler, der im ubuntu kernel verwendete alte treiber für die ipw2100 ist buggy und ich habe auch synaptic benutzt... muss also weiter suchen, oder den kernel ohne treiber kompilieren und module laden... aber danke für die schnelle antwort.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »s0nic« (09.03.2006, 23:44)


s0nic

User

Beiträge: 23

Registrierungsdatum: 03.05.2005

  • Nachricht senden

5

23.03.2006, 14:18

Also bei mir gehtes nicht!
Hat jemand eine Idee, wie es zu den Meldungen "ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported" & "Failed to set encryption" kommt?

sudo wpa_supplicant -Dipw -ieth1 -dd -c/etc/wpa_supplicant.conf

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
Initializing interface 'eth1' conf '/etc/wpa_supplicant.conf' driver 'ipw' ctrl_interface 'N/A'
Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant.conf'
ctrl_interface='/var/run/wpa_supplicant'
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1
Line: 15 - start of a new network block
ssid - hexdump_ascii(len=2):
     48 47                                             HG              
proto: 0x1
key_mgmt: 0x2
pairwise: 0x8
group: 0x18
PSK - hexdump(len=32): [REMOVED]
Line 23: removed CCMP from group cipher list since it was not allowed for pairwise cipher
Priority group 0
   id=0 ssid='HG'
Initializing interface (2) 'eth1'
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
wpa_driver_ipw_init is called
SIOCGIWRANGE: WE(compiled)=19 WE(source)=18 enc_capa=0xf
  capabilities: key_mgmt 0xf enc 0xf
Own MAC address: 00:09:2d:8d:60:36
wpa_driver_ipw_set_wpa: enabled=1
wpa_driver_ipw_set_key: alg=none key_idx=0 set_tx=0 seq_len=0 key_len=0
Failed to set encryption.
wpa_driver_ipw_set_key: alg=none key_idx=1 set_tx=0 seq_len=0 key_len=0
Failed to set encryption.
wpa_driver_ipw_set_key: alg=none key_idx=2 set_tx=0 seq_len=0 key_len=0
Failed to set encryption.
wpa_driver_ipw_set_key: alg=none key_idx=3 set_tx=0 seq_len=0 key_len=0
Failed to set encryption.
wpa_driver_ipw_set_countermeasures: enabled=0
wpa_driver_ipw_set_drop_unencrypted: enabled=1
Setting scan request: 0 sec 100000 usec
Added interface eth1
Wireless event: cmd=0x8b06 len=8
RTM_NEWLINK, IFLA_IFNAME: Interface 'eth1' added
RTM_NEWLINK, IFLA_IFNAME: Interface 'eth1' added
State: DISCONNECTED -> SCANNING
Starting AP scan (broadcast SSID)
CTRL-EVENT-TERMINATING - signal 2 received
Removing interface eth1
State: SCANNING -> DISCONNECTED
No keys have been configured - skip key clearing
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
wpa_driver_ipw_set_wpa: enabled=0
wpa_driver_ipw_set_drop_unencrypted: enabled=0
wpa_driver_ipw_set_countermeasures: enabled=0
No keys have been configured - skip key clearing
Cancelling scan request


iwconfig eth1

Quellcode

1
2
3
4
5
6
7
8
9
eth1      unassociated  ESSID:"HG"  Nickname:"ipw2100"
          Mode:Managed  Channel=0  Access Point: Not-Associated   
          Bit Rate=0 kb/s   Tx-Power:off   
          Retry min limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0


ifconfig eth1

Quellcode

1
2
3
4
5
6
7
eth1      Protokoll:Ethernet  Hardware Adresse 00:09:2D:8D:60:36
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:5 Speicher:fafef000-fafeffff


iwlist eth1 scanning

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
eth1      Scan completed :
          Cell 01 - Address: 00:0E:84:4B:0B:12
                    ESSID:"HG"
                    Protocol:IEEE 802.11b
                    Mode:Master
                    Channel:1
                    Encryption key:on
                    Bit Rates:11 Mb/s
                    Extra: Rates (Mb/s): 1 2 5.5 11
                    Quality=56/100  Signal level=-67 dBm
                    Extra:wpa_ie=ZENSIERT ;)
                    Extra: Last beacon: 134ms ago

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »s0nic« (23.03.2006, 14:20)


s0nic

User

Beiträge: 23

Registrierungsdatum: 03.05.2005

  • Nachricht senden

6

23.03.2006, 15:20

Nachtrag...


sudo wpa_supplicant -Dwext -ieth1 -dd -c/etc/wpa_supplicant.conf

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
Initializing interface 'eth1' conf '/etc/wpa_supplicant.conf' driver 'wext' ctrl_interface 'N/A'
Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant.conf'
ctrl_interface='/var/run/wpa_supplicant'
ctrl_interface_group=0
eapol_version=1
ap_scan=2
fast_reauth=1
Line: 15 - start of a new network block
ssid - hexdump_ascii(len=2):
     48 47                                             HG              
PSK - hexdump(len=32): [REMOVED]
Priority group 0
   id=0 ssid='HG'
Initializing interface (2) 'eth1'
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
SIOCGIWRANGE: WE(compiled)=19 WE(source)=18 enc_capa=0xf
  capabilities: key_mgmt 0xf enc 0xf
Own MAC address: 00:09:2d:8d:60:36
wpa_driver_wext_set_wpa
wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_countermeasures
wpa_driver_wext_set_drop_unencrypted
Setting scan request: 0 sec 100000 usec
Added interface eth1
Wireless event: cmd=0x8b06 len=8
RTM_NEWLINK, IFLA_IFNAME: Interface 'eth1' added
RTM_NEWLINK, IFLA_IFNAME: Interface 'eth1' added
State: DISCONNECTED -> SCANNING
Trying to associate with SSID 'HG'
Cancelling scan request
WPA: clearing own WPA/RSN IE
Automatic auth_alg selection: 0x1
WPA: No WPA/RSN IE available from association info
WPA: Set cipher suites based on configuration
WPA: Selected cipher suites: group 30 pairwise 24 key_mgmt 3
WPA: clearing AP WPA IE
WPA: clearing AP RSN IE
WPA: using GTK CCMP
WPA: using PTK CCMP
WPA: using KEY_MGMT 802.1X
WPA: Set own WPA IE default - hexdump(len=22): ZENSIERT ;)
No keys have been configured - skip key clearing
wpa_driver_wext_set_drop_unencrypted
State: SCANNING -> ASSOCIATING
wpa_driver_wext_associate
Setting authentication timeout: 60 sec 0 usec
EAPOL: External notification - portControl=Auto
Wireless event: cmd=0x8b06 len=8
Wireless event: cmd=0x8b1a len=11
CTRL-EVENT-TERMINATING - signal 2 received
Removing interface eth1
State: ASSOCIATING -> DISCONNECTED
No keys have been configured - skip key clearing
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
wpa_driver_wext_set_wpa
wpa_driver_wext_set_drop_unencrypted
wpa_driver_wext_set_countermeasures
No keys have been configured - skip key clearing
Cancelling scan request

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »s0nic« (23.03.2006, 15:21)


s0nic

User

Beiträge: 23

Registrierungsdatum: 03.05.2005

  • Nachricht senden

7

27.03.2006, 10:14

Es geht, mit folgenden Daten...

/etc/wpa_supplicant.conf.heimnetz

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
ctrl_interface=/var/run/wpa_supplicant
eapol_version=1
ap_scan=1
network={

      ssid="HEIMNETZ"
      proto=WPA
      key_mgmt=WPA-PSK
      pairwise=TKIP
      group=TKIP CCMP
      #psk="denschreibeichhiernichthin"
      psk=unddenlasseichauchweg

}

ap_scan=1 hat geholfen!

/usr/sbin/wpa_heimnetz

Quellcode

1
2
3
#!/bin/sh
wpa_supplicant -B -Dwext -ieth1 -dd -c/etc/wpa_supplicant.conf.heimnetz
dhclient eth1

wext ist die Lösung gewesen!