Sie sind nicht angemeldet.

smaba

User

  • »smaba« ist der Autor dieses Themas

Beiträge: 16

Registrierungsdatum: 30.10.2007

  • Nachricht senden

1

30.08.2021, 19:43

/home Partition nach Partitionierung nicht mehr erreichbar

Hallo,
meine /root Partition wurde zu klein und ich wollte mit Boot Stick und KDE Partition Manager was von der /home Partition abzwacken (20GB) und der /root Partition hinzufuegen. Problem war, dass hier noch die /swap Partition zwischen root und home lag.
Meine Vorgehensweise war: 20GB links von der /home zu trennen, diese 20GB dann an die swap und anschliessend an die root zu allokieren. Ist gruendlich schief gegangen. Jetzt habe ich statt einer /home nur noch eine Partition, bei der keine Formatierung hinterlegt ist und die auch nicht mehr gemountet werden kann.

Gesichert habe ich vorher natuerlich nichts. Wobei es mir eigentlich nur um meine gespeicherten Fotos geht.
Gibt es eine Moeglichkeit, die unallocated Parition aus dem unten abgebildeten Screenshot wieder an die /sdb3 zu haengen (letztere war die bisherige home Partition)?
Vielen Dank,
smaba


2

30.08.2021, 22:13

Wenn da (seltsamerweise) nur der Anfang abgeschnitten wurde und nicht etwa noch formatiert (was aus "unallocated" zu folgern ist) oder vielleicht Blöcke verschoben wurden, dann sollte es auf den ersten Blick reichen, die sdb3 zu löschen und im entstandenen Gesamtbereich wieder anzulegen. Natürlich ohne Formatierung! Wenn, wie angenommen, sonst keine Änderungen erfolgt sind müsste sie dann genauso wieder da stehen wie ursprünglich.

Das ganze ist in der aktuellen Situation natürlich hoch riskant, aber das scheint Dich ja nicht zu schrecken. :-)

Tipp: Wenn man eine Abneigung gegen Sicherungen hat, sollte man sich wenigstens zum abspeichern der Patitionstabelle durchringen. Damit lässt sich so ein Malheur leicht wieder aufheben. Kannst Du auch jetzt machen, damit wenigstens der Ist-Zustand wieder erreichbar bleibt. Die nächste Option wäre nämlich, die alte Partitionierung mittels testdisk wieder herstellen zu lassen. Dauert halt länger und erfordert ggf. Interaktivität.
Beim Erstellen dieser Nachricht kamen keine Tiere zu Schaden.
me is all sausage
but don't call me Ferdl

smaba

User

  • »smaba« ist der Autor dieses Themas

Beiträge: 16

Registrierungsdatum: 30.10.2007

  • Nachricht senden

3

30.08.2021, 22:57

Ich habe die sdb3 gelöscht (und die Partitionierung gesichert) und den Gesamtbereich als Primary Partition angelegt. Allerdings klappt der Bootvorgang weiterhin nicht. ich komme bis zum Anmeldefenster. Nach Eingabe des Passworts wird der Bildschirm kurz schwarz und kehr wieder zurück auf den Anfangsbildschirm. Hast du eine Idee, wie ich weiter vorgehen könnte?

Vielen Dank,
smaba

wowi

Ubuntu-Forum-Team

  • »wowi« ist männlich

Beiträge: 4 180

Registrierungsdatum: 03.05.2007

Derivat: Xubuntu

Architektur: 64-Bit PC

Desktop: XFCE

  • Nachricht senden

4

31.08.2021, 01:05

Hi smaba,

wenn nach der Anmeldemaske ein schwarzer Bildschirm erscheint, danach wieder die Maske, liegt das AFAIR oft an fehlenden Rechten! Kannst Du mit <Alt><Strg>-<F1> in die Console wechseln und Dich da anmelden? Wenn ja, gib mal den folgenden Befehl ein:

Quellcode

1
sudo chown DeinUserName:DeinUserName /home/DeinUserName/.ICEauthority
wechsle mit <Alt>-<F7> wieder in die Anmeldemaske, und versuche Dich normal anzumelden.

Wenn es nicht klappen sollte, dann erstelle für das Problem bitte einen eigenen Thread im entsprechenden Bereich!

Greetz
wowi