Sie sind nicht angemeldet.

  • »Dor Dühringer« ist männlich
  • »Dor Dühringer« ist der Autor dieses Themas

Beiträge: 22

Registrierungsdatum: 25.09.2013

Derivat: Kubuntu

Version: Ubuntu 20.04 LTS - Focal Fossa

Architektur: 64-Bit PC

Desktop: KDE4

Andere Betriebssysteme: Ubuntu 18.04; Win_XP, 7,10 in der VM, Dualboot mit Win7 und Win10 auf versch. Maschinen

  • Nachricht senden

1

17.02.2021, 00:18

Gparted und KDE-Partitionsverwaltung schreiben Änderungen nicht in die fstab zurück

Hatte bei der Neuinstallation von Kubuntu 20.04 mehrfach das Problem. daß Änderungen am Dateisystem nach der Installation weder mit Gparted noch mit der KDE-Partitionsverwaltung in die fstab zurückgeschrieben wurden. Die Änderungen wurden zwar in beiden Programmen akzeptiert und auch bestätigt. Die fstab blieb aber davon gänzlich unberührt, was in der Folge jedesmal zu einem unbootbarem System führte.
Ich arbeite seit 12 Jahren mit Ubuntu, kann mich auf derartige Ausrutscher jedoch nicht besinnen. Hat da jemand einen Lösungsvorschlag?
Kaum macht man's richtig, schon gehts...

wowi

Ubuntu-Forum-Team

  • »wowi« ist männlich

Beiträge: 4 149

Registrierungsdatum: 03.05.2007

Derivat: Xubuntu

Architektur: 64-Bit PC

Desktop: XFCE

  • Nachricht senden

2

20.02.2021, 23:27

Hi Dor Dühringer,

ich habe zwar keine KDE, aber m.E. kümmern sich weder gparted, noch eben Partitionsverwaltungs-Programme um die fstab. Je nach Änderung, die durchgeführt wird, kann natürlich hier ein Problem entstehen. Das solltest Du aber zumindest mit einer erneuten Konfiguration von grub wieder korrigieren können. Suche am Besten dazu den Wiki-Eintrag zu grub2 bei ubuntuusers.de
Ansonsten gäbe es dazu ja auch noch die Super-Grub-Disk.

Greetz
wowi

  • »Dor Dühringer« ist männlich
  • »Dor Dühringer« ist der Autor dieses Themas

Beiträge: 22

Registrierungsdatum: 25.09.2013

Derivat: Kubuntu

Version: Ubuntu 20.04 LTS - Focal Fossa

Architektur: 64-Bit PC

Desktop: KDE4

Andere Betriebssysteme: Ubuntu 18.04; Win_XP, 7,10 in der VM, Dualboot mit Win7 und Win10 auf versch. Maschinen

  • Nachricht senden

3

21.02.2021, 21:20

Hi Wowi,
ich habe zwar keine KDE, aber m.E. kümmern sich weder gparted, noch eben Partitionsverwaltungs-Programme um die fstab.


Das ist wohl wahr,

Änderungen am Dateisystem nach der Installation

Die Installation verlief schon ordnungsgemäß. Nachdem ich aber am laufenden System noch die Windowspartition einbinden wollte trat das Problem auf. Habe's dann händisch eingetragen nachdem ich nach dem 3. Versuch die fstab nach dem abspeichern im jeweiligen Programm nochmal geprüft hatte. Verwunderlich ist, daß das das Abspeichern in beiden Programmen nicht funktioniert, obwohl die Änderungen korrekt angezeigt werden.
Kaum macht man's richtig, schon gehts...

Beiträge: 683

Registrierungsdatum: 03.07.2010

Derivat: Ubuntu

Version: Ubuntu 16.04 LTS - Xenial Xerus

Architektur: 64-Bit PC

Desktop: Unity

  • Nachricht senden

4

23.02.2021, 14:03

Hi Dor Dühringer,

...Verwunderlich ist, daß das das Abspeichern in beiden Programmen nicht funktioniert, obwohl die Änderungen korrekt angezeigt werden.

kann ich hier nicht nachvollziehen!

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
test@test-VirtualBox:~$ lsblk -f
NAME FSTYPE LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINT
loop0
[...]                                             
sda                                                                   
├─sda1
│    vfat         144A-8706                               511M     0% /home/xyz
├─sda2
│                                                                     
└─sda5
     ext4         bf7e9db3-4ac3-4aa7-9566-a3d836572934    3,6G    56% /
sr0                                                                   
test@test-VirtualBox:~$

Quellcode

1
2
3
4
5
test@test-VirtualBox:~$ cat /etc/fstab | grep -v "^#"
UUID=bf7e9db3-4ac3-4aa7-9566-a3d836572934 /               ext4    errors=remount-ro 0       1
/swapfile                                 none            swap    sw              0       0
UUID=144A-8706 /home/xyz vfat umask=0077 0 1
test@test-VirtualBox:~$

Möglich, daß das Windows nicht richtig heruntergefahren war (der unsägliche Schnellstrat), somit die Partition von Linux nur als "ro" eingehängt wird?

Gruß Tüftler
»Tüftler« hat folgendes Bild angehängt:
  • Bildschirmfoto von 2021-02-23 13-52-56.png
Fragen sind dazu da, gefragt zu werden, fällt Dir keine ein, dann mußt Du fragen.
Benutze eine Suchmaschine, z. B. Tuxsucht , oder das Wiki
Auch hier gibt 's die FAQ besonders wir brauchen input