Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

01.02.2021, 22:00

WLAN muss nach Neustart immer manuell eingeschaltet werden

Moin,
ich habe ein Problem mit einem Medion Erazer und den WLAN-Einstellungen auf Ubuntu 20.04
Wenn der Computer eingeschaltet wird oder neu gestartet wird, fährt er ganz normal hoch. Leider startet das WLAN nicht von selber. Auch kann ich unter WLAN - Einstellung den Schieberegler nicht auf "EIN" schieben. Er springt sofort zurück auf OFF.

Ich kann das WLAN nur mit der Tastenkombination " FN + F2 " = WLAN ein einschalten.
Gruß
Ulli
Wenn man sich von vorn herein auf das Schlimmste einstellt, braucht man sich am Ende nicht zu ärgern........ ;)

  • »praseodym« ist männlich

Beiträge: 932

Registrierungsdatum: 16.02.2010

Derivat: Xubuntu

Architektur: 64-Bit PC

Desktop: anderer Desktop

  • Nachricht senden

2

02.02.2021, 21:46

Zeig mal die Ausgaben im nicht funktionierenden Zustand von

Quellcode

1
2
3
iwconfig
rfkill list
lsmod
Was es alles gibt, das ich nicht brauche.
(Aristoteles)
COPY/PASTE funktioniert auch im Terminal

3

03.02.2021, 12:10

Moin praseodym,
nun lässt sich das Notebook nicht mehr hochfahren :cursing: ?( . Was auch der Grund war ein neues Betriebssystem zu installieren. Vorher ließ sich ein Windows 7 System nicht mehr hochfahren. Darauf hin probierte ich Ubuntu zu installieren. Das sah ja anfangs auch gut aus bis auf die Sache mit dem WLAN. Nun fängt er gar nicht mehr an Ubuntu zu starten. Ich werde noch einmal probieren Ubuntu zu installieren.
Ich würde das Thema gerne offen lassen und mich nach einem neuen Versuch Ubuntu zu installieren noch einmal zu melden.
praseodym,
danke schon mal für deinen ersten Lösungsvorschlag.
Gruß
Ulli
Wenn man sich von vorn herein auf das Schlimmste einstellt, braucht man sich am Ende nicht zu ärgern........ ;)

4

04.02.2021, 15:38

Zeig mal die Ausgaben im nicht funktionierenden Zustand von

Quellcode

1
2
3



iwconfig
rfkill list
lsmod

Moin,

der Rechner startet wieder. ;) Leider bleibt nach dem Start immer noch das WLAN aus. Hier die Inhalte, die mir ausgegeben wurden: iwconfig
lo no wireless extensions.

enp5s0 no wireless extensions.

wlp3s0 IEEE 802.11 ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=off
Retry short limit:7 RTS thr:off Fragment thr:off
Power Management:off

rfkill list
0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes





lsmod
Module Size Used by
rfcomm 81920 4
bnep 24576 2
snd_hda_codec_realtek 126976 1
snd_hda_codec_generic 81920 1 snd_hda_codec_realtek
uvcvideo 98304 0
intel_rapl_msr 20480 0
intel_rapl_common 28672 1 intel_rapl_msr
ledtrig_audio 16384 1 snd_hda_codec_generic
iwldvm 237568 0
snd_hda_codec_hdmi 61440 5
snd_hda_intel 53248 4
mac80211 905216 1 iwldvm
snd_intel_dspcfg 24576 1 snd_hda_intel
snd_hda_codec 139264 4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
snd_hda_core 94208 5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek
snd_hwdep 20480 1 snd_hda_codec
x86_pkg_temp_thermal 20480 0
intel_powerclamp 20480 0
libarc4 16384 1 mac80211
snd_pcm 114688 4 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_core
videobuf2_vmalloc 20480 1 uvcvideo
snd_seq_midi 20480 0
snd_seq_midi_event 16384 1 snd_seq_midi
snd_rawmidi 36864 1 snd_seq_midi
iwlwifi 352256 1 iwldvm
videobuf2_memops 20480 1 videobuf2_vmalloc
snd_seq 69632 2 snd_seq_midi,snd_seq_midi_event
videobuf2_v4l2 24576 1 uvcvideo
mei_hdcp 24576 0
videobuf2_common 53248 2 videobuf2_v4l2,uvcvideo
i915 2195456 13
snd_seq_device 16384 3 snd_seq,snd_seq_midi,snd_rawmidi
snd_timer 40960 2 snd_seq,snd_pcm
videodev 237568 3 videobuf2_v4l2,uvcvideo,videobuf2_common
snd 94208 19 snd_hda_codec_generic,snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_pcm,snd_rawmidi
mc 57344 4 videodev,videobuf2_v4l2,uvcvideo,videobuf2_common
nouveau 1998848 1
mei_me 40960 1
coretemp 20480 0
mxm_wmi 16384 1 nouveau
mei 106496 3 mei_hdcp,mei_me
ttm 102400 1 nouveau
kvm_intel 286720 0
soundcore 16384 1 snd
cfg80211 778240 3 iwldvm,iwlwifi,mac80211
btusb 57344 0
drm_kms_helper 217088 2 i915,nouveau
btrtl 24576 1 btusb
cec 53248 2 drm_kms_helper,i915
kvm 712704 1 kvm_intel
rc_core 57344 1 cec
btbcm 16384 1 btusb
btintel 28672 1 btusb
bluetooth 577536 27 btrtl,btintel,btbcm,bnep,btusb,rfcomm
crct10dif_pclmul 16384 1
ghash_clmulni_intel 16384 0
ecdh_generic 16384 1 bluetooth
ecc 32768 1 ecdh_generic
i2c_algo_bit 16384 2 i915,nouveau
fb_sys_fops 16384 1 drm_kms_helper
syscopyarea 16384 1 drm_kms_helper
sysfillrect 16384 1 drm_kms_helper
at24 24576 0
sysimgblt 16384 1 drm_kms_helper
aesni_intel 372736 0
crypto_simd 16384 1 aesni_intel
cryptd 24576 2 crypto_simd,ghash_clmulni_intel
glue_helper 16384 1 aesni_intel
rapl 20480 0
intel_cstate 20480 0
input_leds 16384 0
joydev 24576 0
serio_raw 20480 0
wmi_bmof 16384 0
mac_hid 16384 0
sch_fq_codel 20480 2
parport_pc 45056 0
ppdev 24576 0
lp 20480 0
parport 65536 3 parport_pc,lp,ppdev
drm 552960 8 drm_kms_helper,i915,ttm,nouveau
ip_tables 32768 0
x_tables 45056 1 ip_tables
autofs4 45056 2
ums_realtek 24576 0
uas 28672 0
usb_storage 73728 2 uas,ums_realtek
hid_generic 16384 0
usbhid 57344 0
hid 135168 2 usbhid,hid_generic
crc32_pclmul 16384 0
psmouse 155648 0
r8169 77824 0
i2c_i801 32768 0
ahci 40960 2
xhci_pci 20480 0
i2c_smbus 20480 1 i2c_i801
realtek 24576 1
lpc_ich 24576 0
libahci 36864 1 ahci
xhci_pci_renesas 20480 1 xhci_pci
video 49152 2 i915,nouveau
wmi 32768 3 wmi_bmof,mxm_wmi,nouveau

Mit der Tastenkombination FN + F2 kann das WLAN einschalten und dann läuft es auch einwandfrei.
Gruß
Ulli
Wenn man sich von vorn herein auf das Schlimmste einstellt, braucht man sich am Ende nicht zu ärgern........ ;)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »helgadm« (04.02.2021, 15:47)


  • »praseodym« ist männlich

Beiträge: 932

Registrierungsdatum: 16.02.2010

Derivat: Xubuntu

Architektur: 64-Bit PC

Desktop: anderer Desktop

  • Nachricht senden

5

05.02.2021, 21:10

Ist WLAN im BIOS permanent aktivierbar? Zeig noch

Quellcode

1
dmesg | egrep 'toggle|wlp3s0|switch'
Was es alles gibt, das ich nicht brauche.
(Aristoteles)
COPY/PASTE funktioniert auch im Terminal

6

06.02.2021, 18:20

Nach der Eingabe kam diese Ausgabe (mit eingeschaltetem WLAN) Ob WLAN im BIOS eingeschaltet werden kann, gucke ich gleich.

HTML

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
$ dmesg | egrep 'toggle|wlp3s0|switch'
[	0.000503] Spectre V2 : Spectre v2 / SpectreRSB mitigation: Filling RSB on context switch
[   15.479182] Console: switching to colour dummy device 80x25
[   15.652189] VGA switcheroo: detected Optimus DSM method \_SB_.PCI0.RP00.VGA_ handle
[   16.327191] Console: switching to colour frame buffer device 240x67
[   16.375478] snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client
[   16.428028] iwlwifi 0000:03:00.0: RF_KILL bit toggled to disable radio.
[   16.559089] iwlwifi 0000:03:00.0 wlp3s0: renamed from wlan0
[   16.751903] vga_switcheroo: enabled
[  479.049396] iwlwifi 0000:03:00.0: RF_KILL bit toggled to enable radio.
[  479.881638] wlp3s0: authenticate with e0:28:6d:01:3a:20
[  479.884985] wlp3s0: send auth to e0:28:6d:01:3a:20 (try 1/3)
[  479.887977] wlp3s0: authenticated
[  479.888152] wlp3s0: waiting for beacon from e0:28:6d:01:3a:20
[  479.940174] wlp3s0: associate with e0:28:6d:01:3a:20 (try 1/3)
[  479.947914] wlp3s0: RX AssocResp from e0:28:6d:01:3a:20 (capab=0x1431 status=0 aid=2)
[  479.967968] wlp3s0: associated
[  480.033845] IPv6: ADDRCONF(NETDEV_CHANGE): wlp3s0: link becomes ready
[  480.039888] wlp3s0: Limiting TX power to 20 (20 - 0) dBm as advertised by e0:28:6d:01:3a:20
Wenn man sich von vorn herein auf das Schlimmste einstellt, braucht man sich am Ende nicht zu ärgern........ ;)

7

06.02.2021, 18:30

Habe gerade eben das BIOS-Setup durchgesehen.
Es gibt dort keine WLAN-Einstellungen. :-(
Gruß
Ulli
Wenn man sich von vorn herein auf das Schlimmste einstellt, braucht man sich am Ende nicht zu ärgern........ ;)

  • »praseodym« ist männlich

Beiträge: 932

Registrierungsdatum: 16.02.2010

Derivat: Xubuntu

Architektur: 64-Bit PC

Desktop: anderer Desktop

  • Nachricht senden

8

07.02.2021, 17:09

Quellcode

1
[   16.428028] iwlwifi 0000:03:00.0: RF_KILL bit toggled to disable radio.


Der zeitliche Abstand zu "enable radio" deutet auf deine Tastenkombination hin. Lies mal https://wiki.ubuntuusers.de/rfkill/

BIOS-Reset versucht?

Oftmals hilft es auch, die Tastenkombination beim Booten gedrückt zuhalten bzw. mehrfach zu betätigen. Prüfe das jeweils danach mit

Quellcode

1
rfkill list
Was es alles gibt, das ich nicht brauche.
(Aristoteles)
COPY/PASTE funktioniert auch im Terminal

9

08.02.2021, 16:31

Moin,
das BIOS habe ich auf alle Default-Werte zurückgesetzt. Keine Änderung
Beim Booten habe ich auch die Tastenkombination gehalten oder auch mal nur kurz gedrückt. Keine Änderung
Ich habe nun laut ubuntuusers.de/rfkill in die Datei etc/modules das Modul zum Starten während des bootens eingetragen. Keine Änderung Da war nichts eingetragen......

Beim Duchlesen von ubuntuusers.de/rfkill wurde auf einen Schalter hingewiesen. Nach durchlesen der BA auf Medion.de habe ich den Schalter auch gefunden.

Diesen habe ich dann auch mal beim Booten gedrückt. Keine Änderung Der ist ohne Funktion. Auch wenn Ubuntu schon gestartet ist hat er keine Funktion.

Ich denke hier liegt das Problem. :(
Gruß
Ulli
Wenn man sich von vorn herein auf das Schlimmste einstellt, braucht man sich am Ende nicht zu ärgern........ ;)

  • »praseodym« ist männlich

Beiträge: 932

Registrierungsdatum: 16.02.2010

Derivat: Xubuntu

Architektur: 64-Bit PC

Desktop: anderer Desktop

  • Nachricht senden

10

08.02.2021, 19:44

Dann teste mal

Quellcode

1
2
3
4
5
sudo systemctl stop NetworkManager.service
sudo modprobe -rfv iwlwifi
sudo rfkill unblock all
sudo modprobe -v iwlwifi
sudo systemctl start NetworkManager.service
Was es alles gibt, das ich nicht brauche.
(Aristoteles)
COPY/PASTE funktioniert auch im Terminal

11

09.02.2021, 18:01

Moin,
leider kann ich kein Erfolg vermelden :(
Ich habe die Befehle mal im eingeschalteten WLAN (Fn + F2) eingegeben und auch im ausgeschaltetem Zustand.
Hochgefahren und dabei den kleinen Schalter mal gedrückt.
Hochgefahren und dabei die Tastenkombination gedrückt. Es bleibt immer aus. Händisch einschalten kein Problem.
Das habe ich gemacht:

HTML

1
2
3
4
5
6
7
8
9
10
11
12
roelrichs@Computer:~$ sudo systemctl stop NetworkManager.service
[sudo] Passwort für roelrichs: 
roelrichs@Computer:~$ sudo modprobe -rfv iwlwifi
remove (/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) && /sbin/modprobe -r mac80211
rmmod mac80211
rmmod libarc4
rmmod cfg80211
roelrichs@Computer:~$ sudo rfkill unblock all
roelrichs@Computer:~$ sudo modprobe -v iwlwifi
insmod /lib/modules/5.8.0-41-generic/kernel/net/wireless/cfg80211.ko 
insmod /lib/modules/5.8.0-41-generic/kernel/drivers/net/wireless/intel/iwlwifi/iwlwifi.ko 
roelrichs@Computer:~$ sudo systemctl start NetworkManager.service

Gruß
Ulli
Wenn man sich von vorn herein auf das Schlimmste einstellt, braucht man sich am Ende nicht zu ärgern........ ;)

Beiträge: 1 094

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

Andere Betriebssysteme: Debian bullseye-testing / 5.10.0-3-amd64

  • Nachricht senden

12

09.02.2021, 19:24

rfkill überlebt ja keinen reboot, deswegen wird das so nichts.

Du könntest das WLAN beim booten unblocken.

Dazu editierst Du die Datei /etc/default/grub und fügst folgende Option hinzu rfkill.default_state=1

Quellcode

1
GRUB_CMDLINE_LINUX_DEFAULT="quiet rfkill.default_state=1"


Danach abspeichern und

Quellcode

1
sudo update-grub
Heute ist keiner da! Komm morgen wieder. :-)

13

15.02.2021, 17:09

Moin,
sorry das ich mich jetzt erst wieder melde. Ich war ein paar Tage verhindert.

das habe ich gemacht:

HTML

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
Danach abspeichern und 


	
		
			
			
				
				
					sudo update-grub
				
					
				
				
					Quellcode
				
			
					1

				

				
					Quellcode
				
				
					1

				
				
					GRUB_CMDLINE_LINUX_DEFAULT="quiet rfkill.default_state=1"
				
			

Nach einem Neustart nimmt er nun gar keine Tasten Touchpatt etc mehr an auch der Ausschalter ist tot. Ich lasse ihn nun mal so lange laufen bis er von selber ausschaltet :(
Dann probiere ich ihn noch einmal hochzufahren.
Gruß
Ulli
Wenn man sich von vorn herein auf das Schlimmste einstellt, braucht man sich am Ende nicht zu ärgern........ ;)

14

15.02.2021, 18:39

Die Datei ........ grub sieht nun so aus geupdatet habe ich auch:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
GRUB_CMDLINE_LINUX_DEFAULT="quiet rfkill.default_state=1"

Leider hat die Erweiterung der Datei "grub" auch nichts gebracht. Ich muss na wie vor WLAN, nach dem Hochfahren, von Hand einschalten.
Gruß
Ulli
Wenn man sich von vorn herein auf das Schlimmste einstellt, braucht man sich am Ende nicht zu ärgern........ ;)

Beiträge: 1 094

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

Andere Betriebssysteme: Debian bullseye-testing / 5.10.0-3-amd64

  • Nachricht senden

15

16.02.2021, 05:24

Du solltest nur etwas hinzufügen in Zeile 10. Nicht die ganze Zeile 34 neu erstellen. 8|
Heute ist keiner da! Komm morgen wieder. :-)

16

17.02.2021, 11:07

Moin,
ich habe jetzt die Zeile 10 geändert und danach update grub durchgeführt.

Leider bleibt das WLAN nach wie vor nach einem Start aus und man muss es händisch einschalten :(
Die Datei "grub" sieht jetzt so aus:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet rfkill.default_state=1"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Ich denke ich belasse es bei der händischen Einschaltung. Das Notebook gehört ja nicht mir sondern einem Freund. Dafür, dass hier vorher gar nichts mehr ging, ist ihm hier mit schon sehr geholfen. Perfekt wäre es natürlich anders.

Ich habe in diesem Beitrag aber wieder einiges zu Linux (Ubuntu) dazu gelernt.

Nun weiß ich nicht ob ich das Thema als "offen" stehen lassen soll??
Ich bedanke mich für eure Mühe.

Gruß Ulli
Wenn man sich von vorn herein auf das Schlimmste einstellt, braucht man sich am Ende nicht zu ärgern........ ;)

wowi

Ubuntu-Forum-Team

  • »wowi« ist männlich

Beiträge: 4 145

Registrierungsdatum: 03.05.2007

Derivat: Xubuntu

Architektur: 64-Bit PC

Desktop: XFCE

  • Nachricht senden

17

20.02.2021, 23:53

Hi helgadm,

Leider bleibt das WLAN nach wie vor nach einem Start aus und man muss es händisch einschalten

Wie musst Du es denn einschalten? Gehst Du nur über das WLAN-Symbol in der Leiste und aktivierst Dein Netz hier? Dann müsste es möglich sein, dort in den Einstellungen unter "Verbindungen bearbeiten"/Netz auswählen/Reiter "Allgemein" festzulegen, dass dieses WLAN immer automatisch für alle Benutzer aktiviert wird.

Greetz
wowi

18

22.02.2021, 18:28

Wie musst Du es denn einschalten?

Moin,
ich kann es nur über die Tastenkombination " Fn + F2 " einschalten.

Wenn das nicht so eingeschaltet ist kann ich unter Einstellungen > WLAN keine Einstellungen machen. Wenn ich nach dem Einschalten "automatisch verbinden" einstelle, muss ich aber nach einem Neustart das WLAN wieder mit der Tastenkombination starten.
Gruß Ulli
Wenn man sich von vorn herein auf das Schlimmste einstellt, braucht man sich am Ende nicht zu ärgern........ ;)