Sie sind nicht angemeldet.

  • »Tiedemate« ist der Autor dieses Themas

Beiträge: 4

Registrierungsdatum: 30.10.2011

Derivat: Kubuntu

Architektur: 64-Bit PC

Desktop: KDE4

  • Nachricht senden

1

20.12.2020, 14:39

Lenovo IdeaPad 1 11ADA05: eMMC wird vom Installer nicht erkannt

Moin,

ich versuche gerade, auf meinem Lenovo IdeaPad 1 11ADA05 Unbuntu (bzw. Kubuntu) zu isntallieren. Der Live-USB-Stick läuft super, alles funktioniert. Nur installieren kann ich nicht, da die eMMC nicht erkannt wird. Ich habe jetzt testhalber Kubuntu 20.10 auf einen USB-stick installiert, und auf den Mainline-Kernel 5.10.1 aktualisiert, eMMC wird auch von dem nicht erkannt. Hab's mit Sucureboot an und aus, UEFI und CSM probiert, keine Änderung. Kann ich noch irgendetwas probieren?
Hier ein HW-probe von dem System: https://linux-hardware.org/?probe=5885335d44
Falls jemand Tipps hat, immer her damit.

Björn

Beiträge: 81

Registrierungsdatum: 31.10.2018

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: unbekannt

Desktop: anderer Desktop

  • Nachricht senden

2

22.12.2020, 06:47

MoinMoin.

U/Kubuntu 20.10 wird bestimmt 6 Monate Unterstützt ich empfehle 20.04 10 Jahre. (mein erster Gedanke)
x86_64 fällt mir sofort i686 ein. 32 Bit Prozessor der 64 Bit Unterstützt.
Gib mal Bitte : uname -a
im Terminal ein und Poste das hier.
Bestimmt ist dein Rechner UEFI. Dann versuche mal F11 EFI/HDD oder EFI/USB.

Ich muss dich aber davor Warnen auf einem UEFI Rechner Linux zu Installieren damit könntest Du das CMOS zerstören. Ich habe es selbst erlebt. Nach 6 Monaten ging gar nichst mehr.

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »ubuntuli« (22.12.2020, 07:30)


  • »Klaus P« ist männlich

Beiträge: 4 592

Registrierungsdatum: 25.10.2009

Derivat: anderes Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: 7/10

  • Nachricht senden

3

22.12.2020, 16:25

Hallo Björn!

Unbedingt zunächst Fastboot ausschalten im UEFI/BIOS. Falls Windows parallel installiert ist, dort auch unbedingt abschalten. Google sagt wie!

Ist der Stick für den UEFI Modus eingerichtet worden?

Bitte die Terminalausgabe von

Quellcode

1
sudo parted -l
hier posten.

Im UEFI/BIOS wird die Platte erkannt?

Das Ding scheint ja ziemlich neu zu sein. Also eher schlechte Linux, oder besser, Ubuntu-Ware. Mit 20.10 hast aber schon das aktuellste Ubuntu. Ggf. noch mal eine aktuellere Linuxversion, wie z.B. Manjaro mit Rolling Release probieren.
Dass das Ding noch ein 32Bit UEFI hat glaube ich eher nicht. Imho wird dieser Unsinn nicht mehr verwendet.



U/Kubuntu 20.10 wird bestimmt 6 Monate Unterstützt

Nein!

ich empfehle 20.04 10 Jahre. (mein erster Gedanke)

Unsinn!

Ich muss dich aber davor Warnen auf einem UEFI Rechner Linux zu Installieren......

Kompletter Unsinn!

Ich habe es selbst erlebt. Nach 6 Monaten ging gar nichst mehr.

Ja, dann muss das ja auch auf alle anderen zutreffen!

Gib mal Bitte : uname -a

Warum nicht

Quellcode

1
 cowsay Hallo!
Bringt genau so viel Erkenntnis für den TE!
Des modernen Menschen Computer ist sein Himmelreich! :rolleyes: Der Weg zur Hölle, ist allzu kurz auf dem falschen "EFI-Pfad" ;( : Kleiner Leitfaden zur UEFI-Installation

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Klaus P« (22.12.2020, 16:32)


  • »Tiedemate« ist der Autor dieses Themas

Beiträge: 4

Registrierungsdatum: 30.10.2011

Derivat: Kubuntu

Architektur: 64-Bit PC

Desktop: KDE4

  • Nachricht senden

4

28.12.2020, 13:20

Weitere erfolglsoe Versuche

Hallo Jungs,

vielen Dank für die Hinweise! Ich habe mal versucht, Eure Tipps umzusetzen, mit folgenden Ergebnissen:
UEFI Einstellungen:
UEFI modus aktiv, hab's auch mit legacy probiert, keine Änderung
Secureboot ist aus

Fastboot gibt's leider nicht
AHCI / legacy gibt's leider auch nicht, das hätte mir die meisten Hoffnungen gemacht...
Platform mode Setup mode ich weiß aber nicht, was der Seupt Mode macht, außer automatisch secure boot zu deaktivieren

AMD platform security processor ist aus
AMD SVM ist aus, ist aber wahrtscheinlich eh nicht relevant, hat was mit Virtualisierung zu tun soweit ich weiß

Dieses 64 bit System mit 32 bit UEFI Vergwaltigung hat mein Rechner glaub ich nicht.

Ich hab auch mal arch linux mit 5.9 kernel im legacy modus ohne UEFI gebootet, sieht den eMMC auch nicht.
Guix mit 5.10 kernel bleibt mittem im boot stehen und macht nix mehr.

Das UEFI erkennt den eMMC, lässt sich als boot device auswählen und startet dann Win10.

Anbei noch paar Screnshot, vielleicht fällt ja jemandem was auf?



Danke!
Björn
»Tiedemate« hat folgende Bilder angehängt:
  • IMG_20201227_135457.jpg
  • IMG_20201227_135840.jpg
  • IMG_20201227_135853.jpg
  • IMG_20201227_140000.jpg
  • IMG_20201227_140056.jpg

  • »Klaus P« ist männlich

Beiträge: 4 592

Registrierungsdatum: 25.10.2009

Derivat: anderes Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: 7/10

  • Nachricht senden

5

28.12.2020, 16:38

Hmmm! Komisch!

Poste bitte noch mal die Ausgaben von

Quellcode

1
2
3
sudo parted -l  ## -l = kleines L
sudo fdisk -l
sudo efibootmgr -v

falls möglich als Code oder Text, nicht Screenshot.

Hast du jeweils den automatischen Modus beim Installieren genommen oder auch den manuellen? Falls letzteres nicht, mach das mal und schau was der Partitionierer sagt.

Noch mal, wurde der Stick für den UEFI Modus erstellt oder wie wurde er überhaupt erstellt?

Ist Windows verschlüsselt?
Des modernen Menschen Computer ist sein Himmelreich! :rolleyes: Der Weg zur Hölle, ist allzu kurz auf dem falschen "EFI-Pfad" ;( : Kleiner Leitfaden zur UEFI-Installation

  • »Tiedemate« ist der Autor dieses Themas

Beiträge: 4

Registrierungsdatum: 30.10.2011

Derivat: Kubuntu

Architektur: 64-Bit PC

Desktop: KDE4

  • Nachricht senden

6

28.12.2020, 22:17

Moin,

hier die Ausgaben, die Vollinstallation auf dem USB-Stick wurde im UEFI-Modus erstellt:



Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
tidy@IdeaPad:~$ sudo parted -l                             
[sudo] password for tidy:  
Model: ADATA USB Flash Drive (scsi)

Disk /dev/sda: 31,0GB

Sector size (logical/physical): 512B/512B

Partition Table: gpt

Disk Flags:  


Number  Start   End     Size    File system  Name                  Flags

 1      1049kB  538MB   537MB   fat32        EFI System Partition  boot, esp

 2      538MB   31,0GB  30,5GB  ext4





tidy@IdeaPad:~$ sudo fdisk -l

Disk /dev/sda: 28,91 GiB, 31037849600 bytes, 60620800 sectors

Disk model: USB Flash Drive  
Units: sectors of 1 * 512 = 512 bytes

Sector size (logical/physical): 512 bytes / 512 bytes

I/O size (minimum/optimal): 512 bytes / 512 bytes

Disklabel type: gpt

Disk identifier: BFB6B7C2-B08C-4301-80FB-FB5F86337349



Device       Start      End  Sectors  Size Type

/dev/sda1     2048  1050623  1048576  512M EFI System

/dev/sda2  1050624 60618751 59568128 28,4G Linux filesystem

tidy@IdeaPad:~$ sudo efibootmgr -v    
BootCurrent: 0001

Timeout: 0 seconds

BootOrder: 0001,0016,0000,0014,0015,0017,0018,0019

Boot0000* Windows Boot Manager  HD(1,GPT,955eb278-6add-4282-9909-f433d0e47ee9,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.
T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...a................

Boot0001* ubuntu        HD(1,GPT,124102a0-b269-4a9a-a481-38dc40f0e458,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)

Boot0010  Setup FvFile(721c8b66-426c-4e86-8e99-3457c46ab0b9)

Boot0011  Boot Menu     FvFile(86488440-41bb-42c7-93ac-450fbf7766bf)

Boot0012  Diagnostic Splash     FvFile(a7d8d9a6-6ab0-4aeb-ad9d-163e59a7a380)

Boot0013  UEFI Diagnostics      FvFile(f8397897-e203-4a62-b977-9e7e5d94d91b)

Boot0014* NVMe: VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,001c199932d94c4eae9aa0b6e98eb8a4)

Boot0015* eMMC Card: Ramaxel  64GB      PciRoot(0x0)/Pci(0x13,0x1)/eMMC(0)/Ctrl(0x0)c.J8.p[H...S....

Boot0016* USB HDD: ADATA USB Flash Drive        PciRoot(0x0)/Pci(0x8,0x1)/Pci(0x0,0x3)/USB(7,0)3.!..3.G..A.....

Boot0017* USB FDD:      VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,6ff015a28830b543a8b8641009461e49)

Boot0018* USB CD:       VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,86701296aa5a7848b66cd49dd3ba6a55)

Boot0019* USB LAN:      VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,e854bca4cae7704ca322b00da0376322)

tidy@IdeaPad:~$


  • »Klaus P« ist männlich

Beiträge: 4 592

Registrierungsdatum: 25.10.2009

Derivat: anderes Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: 7/10

  • Nachricht senden

7

28.12.2020, 22:59

Keine Platte!

Sehr komisch!

Bin gerade was ratlos. Hab ich so imho noch nicht erlebt . Muss ich noch mal drüber schlafen.

Melde dich ggf. noch mal bei Ubuntuusers.de an. Da hats mehr Supporter wie hier.

L.G.

Edit: In das Ding kann man ja scheinbar noch ne nvme einbauen, lt. BIOS. Wenn das eine Option ist....!?
Des modernen Menschen Computer ist sein Himmelreich! :rolleyes: Der Weg zur Hölle, ist allzu kurz auf dem falschen "EFI-Pfad" ;( : Kleiner Leitfaden zur UEFI-Installation

  • »Tiedemate« ist der Autor dieses Themas

Beiträge: 4

Registrierungsdatum: 30.10.2011

Derivat: Kubuntu

Architektur: 64-Bit PC

Desktop: KDE4

  • Nachricht senden

8

29.12.2020, 00:22

Daran hatte ich auch schon gedacht, und hab das Teil auseinandergeschraubt. Auf dem Board sind Lötflächen, es ist aber kein NVMe-Sockel eingelötet. Und für so mikroskopische Lötereien habe ich nicht die Ausrüstung...
Danke für den Tipp, mit Ubuntuusers, da werde ich mal vorbeischauen.
Ist es denkbar, dass sich ein Kernelentwickler für sowas interessiert? Wenn ja, wie kann ich die kontaktieren?

  • »Klaus P« ist männlich

Beiträge: 4 592

Registrierungsdatum: 25.10.2009

Derivat: anderes Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: 7/10

  • Nachricht senden

9

29.12.2020, 16:24

Ist es denkbar, dass sich ein Kernelentwickler für sowas interessiert?


Nein! Ich geh hier von einem Firmwareproblem aus. Vielleicht noch mal schauen, ob es ein BIOS-Update gibt.

Wäre es mein Rechner, würde ich alles komplett löschen, bzw. die Platte/mmc neu formatieren und/oder eine neue Partitionstabelle anlegen und einen clean-install, zunächst mit Linux probieren. Damit habe ich schon manch widerspenstige UEFI-Firmware gezähmt, da die Interaktion mit dem vorinstallierten Windows weg ist.
Das ist aber kein Erfolgsgarant und letztlich ist es dein Ding, ob das eine Option ist. So gut Lenovo bei den Thinkpads mit Linux ist, so besch..... ist es mit den billigen Geräten.

Edit: Die Kollegen waren bis jetzt auch nicht so richtig hilfreich/erfolgreich....! :(
Des modernen Menschen Computer ist sein Himmelreich! :rolleyes: Der Weg zur Hölle, ist allzu kurz auf dem falschen "EFI-Pfad" ;( : Kleiner Leitfaden zur UEFI-Installation

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Klaus P« (29.12.2020, 16:32)