Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

26.07.2020, 15:50

bash-login erzeugt Ausgabe "-bash: /home/pi: Ist ein Verzeichnis"

Hallo zusammen,
mir ist kürzlich aufgefallen, dass jedes Mal, wenn ich auf meinem Raspberry Pi die bash öffne (egal ob per ssh, oder auf dem Gerät selbst) die letzte Ausgabe vor dem ersten Prompt folgende ist:
"-bash: /home/pi: Ist ein Verzeichnis"
Daraus schließe ich, dass die bash immer, wenn sie als login-shell geöffnet wird, versucht, den Befehl "/home/pi" auszuführen bzw. "$HOME", denn dieser Befehl (der ja kein korrekter Befehl ist) erzeugt die gleiche Ausgabe.
Nun habe ich bereits die Dateien .bashrc und .profile im Homeverzeichnis durchsucht, ob sie einen solchen Befehl enthalten (.bash_aliases kann ich ausschließen), konnte aber nichts finden.
Die Ausgabe bewirkt zwar nichts weiter, aber irgendwie nervt sie mich, insbesondere weil sich mir nicht erschließt, wie sie zustande kommt. Auf einem anderen Raspberry Pi kann ich die bash öffnen, ohne, dass diese Ausgabe erzeugt wird.
Vielleicht hat ja hier jemand eine Idee, wie ich die Ursache dafür finde und/oder beseitige. Natürlich stelle ich gerne weitere benötigte Informationen zur Verfügung.
Gruß
kzi

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »kzi« (27.07.2020, 15:56)


2

27.07.2020, 13:43

Die Variable kommt ja in einigen Dateien vor, übrigens auch in ~/.bash_profile
Wenn sich da irgendwo ein Leerzeichen eingeschlichen hat, könnte sowas passieren.
Nachdem du aber zwei RasPis hat, könntest du einfach einen Dateivergleich mit diff machen.
Aus der WALDheimat von Kurt WALDheim, Ernst WALDbrunn, WALDemar Bankhofer, EWALD Stadler und dem Wiener WALDser. America First - Austria Förster!
me is all sausage
but don't call me Ferdl

3

27.07.2020, 15:56

Hey Fredl,
danke für deine Antwort. Nachdem ich alle Dateien verglichen habe, von denen ich weiß, dass sie beim öffnen der bash ausgeführt werden, habe ich den Fehler gefunden und musste ein wenig darüber schmunzeln: Es lag doch an meiner Datei .bash_aliases, die ich mir selbst angelegt habe. Diese besteht lediglich aus einer Zeile - dachte ich.. Als ich sie nochmal überprüft habe, fiel mir auf, dass in der 2. Zeile ein einzelnes Tilde-Zeichen (~) stand. Da dies von der bash genauso gewertet wird, wie die Variable $HOME, wurde die besagte Ausgabe erzeugt.
Das Zeichen fiel mir zuvor nicht auf, weil ich die Datei .bash_aliases mit dem Editor vi bearbeitet habe. Dort werden alle Zeilen nach der letzten Zeile durch das Zeichen ~ dargestellt. Vermutlich ist das Zeichen zuvor versehentlich bei einem Kopiervorgang dorthin gelangt. :D

4

27.07.2020, 20:46

QED: Die besten Eier legt man sich selbst. :D
Aus der WALDheimat von Kurt WALDheim, Ernst WALDbrunn, WALDemar Bankhofer, EWALD Stadler und dem Wiener WALDser. America First - Austria Förster!
me is all sausage
but don't call me Ferdl

Zurzeit ist neben Ihnen 1 Benutzer in diesem Thema unterwegs:

1 Besucher

Verwendete Tags

bash, Login, shell, verzeichnis