Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

  • »xAlex1337« ist der Autor dieses Themas

Beiträge: 3

Registrierungsdatum: 19.12.2019

Derivat: Kein Ubuntu-Derivat

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: unbekannt

Andere Betriebssysteme: Linux mint 19.02

  • Nachricht senden

1

19.12.2019, 19:01

Windows startet nicht vom Grub im Dual Boot mit Linux Mint

Hallo zusammen,
ich habe mir Gestern Linux Mint auf eine seperate SSD installiert und wollte es mit Windows 10 im Dual-Boot laufen lassen.Linux gefällt mir sehr gut allerdings läuft das mit den Dual-Boot noch nicht wie geplant,

wen ich

Quellcode

1
sudo os-prober
eingebe erkennt Linux leider nicht Windows auf der anderen SSD obwohl sie angeschlossen und sichtbar ist.
Ich habe folgenden Eintrag in das Grub Menü hinzugefügt:

Quellcode

1
2
3
4
5
=================== /etc/grub.d/40_custom :menuentry "Windows 10 (loader (on /dev/sda1)" {insmod part_msdos
insmod ntfs
set root='(hd0,msdos1)'
chainloader +1
}



Dadurch ist Windows 10 zwar auswählbar aber wen ich es auswähle kommt der Fehler "invalid efi filepath".
Wen ich die SSD mit Windows 10 als #1 in der Boot Reihenfolge einstelle bekomme ich einen Bluescreen und Windows sagt das es nicht richtig gestartet wurde.
Ich habe mir auch das Tool "boot-repair" heruntergeladen, ich denke der Output von diesem Tool zeigt ziemlich eindeutig was die Antwort für mein Problem ist aber ich bin noch ein Anfänger und werde leider daraus nicht so richtig schlau.
Der Output des Tools:


http://paste.ubuntu.com/p/yfkmkV5Ctk
Ich wollte nicht einfach irgendwelche Fixes ausprobieren die ich aus dem Pastebin heraus interpretieren würde deswegen hoffe ich das mir hier jemand helfen kann.
Vielen Dank im voraus.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »xAlex1337« (21.12.2019, 00:42)


  • »Klaus P« ist männlich

Beiträge: 4 583

Registrierungsdatum: 25.10.2009

Derivat: anderes Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: 7/10

  • Nachricht senden

2

19.12.2019, 19:29

Hallo!

Du hast den gerne genommenen Fehler gemacht, die beiden BS in unterschiedlichen Modi zu installieren. Siehe, achte auf "disklabel type", sowie die UEFI Bootfiles auf der sdb....

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
Boot Info Script 8f991e4 + Boot-Repair extra info      [Boot-Info 25oct2017]


============================= Boot Info Summary: ===============================

 => Windows 7/8/2012 is installed in the MBR of /dev/sda.
 => No boot loader is installed in the MBR of /dev/sdb.

sda1: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows 8/2012: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /bootmgr /Boot/BCD

sda2: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows 7/2008: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /Windows/System32/winload.exe

sda3: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows 8/2012: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        

sdb1: __________________________________________________________________________

    File system:       vfat
    Boot sector type:  FAT32
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /EFI/ubuntu/grub.cfg /EFI/BOOT/fbx64.efi 
                       /EFI/ubuntu/fwupx64.efi /EFI/ubuntu/grubx64.efi 
                       /EFI/ubuntu/mmx64.efi /EFI/ubuntu/shimx64.efi

sdb2: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info: 
    Operating System:  Linux Mint 19.3
    Boot files:        /boot/grub/grub.cfg /etc/fstab

============================ Drive/Partition Info: =============================

Drive: sda _____________________________________________________________________
Disk /dev/sda: 447.1 GiB, 480103981056 bytes, 937703088 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos

Partition  Boot  Start Sector    End Sector  # of Sectors  Id System

/dev/sda1    *          2,048       206,847       204,800   7 NTFS / exFAT / HPFS
/dev/sda2             206,848   936,592,601   936,385,754   7 NTFS / exFAT / HPFS
/dev/sda3         936,593,408   937,699,327     1,105,920  27 Hidden NTFS (Recovery Environment)


Drive: sdb _____________________________________________________________________
Disk /dev/sdb: 931.5 GiB, 1000207286272 bytes, 1953529856 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt

Partition  Boot  Start Sector    End Sector  # of Sectors  Id System

/dev/sdb1                   1 1,953,529,855 1,953,529,855  ee GPT


GUID Partition Table detected.

Partition  Attrs   Start Sector    End Sector  # of Sectors System
/dev/sdb1                 2,048     1,050,623     1,048,576 EFI System partition
/dev/sdb2             1,050,624 1,953,527,807 1,952,477,184 Data partition (Linux)


Die Platte sda mit Windows ist im klassischen BIOS/MBR installiert und die sdb mit Linux ist UEFI auf GPT. Daher kann Grub Windows nicht erkennen und einbinden.

Ist die Frage, was deine Prioritäten sind. Entweder installierst du Linux neu im klassischen Modus oder eben Windows neu mit UEFI. Oder du musst jedesmal im Set-Up den Modus wechseln (UEFI auf Legacy und umgekehrt). Sollte dein Set-up über eine "both" Funktion im Bereich Booten und CSM verfügen, könntest auch über das Bootmenü des Rechners jedesmal auswählen.

Eine weitere Lösung bestünde darin, Windows in ein UEFI system umzuwandeln. Das geht mit Bordmitteln auf den neueren W10 Systemen. Auskunft gibt Google, wie das geht.

L.G.
Des modernen Menschen Computer ist sein Himmelreich! :rolleyes: Der Weg zur Hölle, ist allzu kurz auf dem falschen "EFI-Pfad" ;( : Kleiner Leitfaden zur UEFI-Installation

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Klaus P« (19.12.2019, 19:36)


Beiträge: 665

Registrierungsdatum: 03.07.2010

Derivat: Ubuntu

Version: Ubuntu 16.04 LTS - Xenial Xerus

Architektur: 64-Bit PC

Desktop: Unity

  • Nachricht senden

3

19.12.2019, 22:56

Hi xAlex1337,

Ist die Frage, was deine Prioritäten sind. Entweder installierst du Linux neu im klassischen Modus

wie so oft, es führen viele Wege nach ROM.
Eine weitere Möglichkeit ist Rückwandlung in den BIOS Modus

Gruß Tüftler
Fragen sind dazu da, gefragt zu werden, fällt Dir keine ein, dann mußt Du fragen.
Benutze eine Suchmaschine, z. B. Tuxsucht , oder das Wiki
Auch hier gibt 's die FAQ besonders wir brauchen input

  • »xAlex1337« ist der Autor dieses Themas

Beiträge: 3

Registrierungsdatum: 19.12.2019

Derivat: Kein Ubuntu-Derivat

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: unbekannt

Andere Betriebssysteme: Linux mint 19.02

  • Nachricht senden

4

19.12.2019, 22:57

Erstmal vielen Dank für deine Hilfe.
Ich habe auf meinem USB Stick jetzt eine Linux Mint ISO mit MBR als Paritionsschema.
Meine Rufus Einstellungen für den Stick:
https://gyazo.com/d7daff36409a3e51bbe05dc1f59dd7b7
Damit habe ich dann mein Linux neu Installiert, danach die 2 anderen Festplatten angeschlossen und

Quellcode

1
sudo os-prober
eingegeben.
(Im Grunde habe ich https://www.youtube.com/watch?v=Xw__bTvQKsY&t=393s dieses Tutorial befolgt nur ist mein Rufus aktueller und ich habe im BIOS keine Secure Boot Option gefunden)
Und

Quellcode

1
sudo os-prober
hat nichts gefunden, das ist auch logisch den das Tool "boot-repair" zeigt nach wie vor: sdb disklable type: GTP.

Jetzt kann ich wieder nur mutmaßen, warum wurde der Disklable type nicht geändert ? was habe ich falsch gemacht ?

Beiträge: 665

Registrierungsdatum: 03.07.2010

Derivat: Ubuntu

Version: Ubuntu 16.04 LTS - Xenial Xerus

Architektur: 64-Bit PC

Desktop: Unity

  • Nachricht senden

5

19.12.2019, 23:39

Hi xAlex1337,

zeigt nach wie vor: sdb disklable type: GTP.
Jetzt kann ich wieder nur mutmaßen, warum wurde der Disklable type nicht geändert ? was habe ich falsch gemacht ?

nun ja, womit hast Du denn das Partitionsschema von GPT auf MBR/MPT geändert? Der Installer macht das jedenfalls nicht!

Dazu benutzt Du

Quellcode

1
sudo gdisk /dev/sdX
X=die Platte, die du ändern willst. Da mußt Du Dich dann über "x" zu "z" durchhangeln "z" für destroi! Achtung, alles auf der gewählten Platte ist anschließend FUTSCH! Einen neuen MBR anlegen kannst Du am Ende dabei auch.

Und wenn Du dann von vorne anfängst, prüfst Du mit

Quellcode

1
 [ -d /sys/firmware/efi ] && echo UEFI || echo BIOS 
ob Du auch wirklich im CSM Modus bist.

Oder, Du verfährst, wie ich oben verlinkt hatte.

Gruß Tüftler
Fragen sind dazu da, gefragt zu werden, fällt Dir keine ein, dann mußt Du fragen.
Benutze eine Suchmaschine, z. B. Tuxsucht , oder das Wiki
Auch hier gibt 's die FAQ besonders wir brauchen input

  • »xAlex1337« ist der Autor dieses Themas

Beiträge: 3

Registrierungsdatum: 19.12.2019

Derivat: Kein Ubuntu-Derivat

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: unbekannt

Andere Betriebssysteme: Linux mint 19.02

  • Nachricht senden

6

21.12.2019, 00:04

Hallo nochmal an alle hier,
wollte bloß sagen das ich das Problem jetzt behoben habe indem ich Windows 10 auf GPT umgestellt habe.
Vielen Dank nochmal für die Antworten die haben mir sehr geholfen und ich konnte sogar noch einiges lernen.
L.G.

wowi

Ubuntu-Forum-Team

  • »wowi« ist männlich

Beiträge: 4 136

Registrierungsdatum: 03.05.2007

Derivat: Xubuntu

Architektur: 64-Bit PC

Desktop: XFCE

  • Nachricht senden

7

21.12.2019, 00:16

Hi xAlex1337,

dann setze bitte in Deinem ersten Post noch ein [gelöst] oder [erledigt], dann sind auch wir alle zufrieden ;)

Greetz
wowi