Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

30.06.2019, 12:07

Startprobleme nach Neustart

Guten Tag an die Community,
ich habe seit längerer Zeit ein Problem, welches ich bisher in Kauf genommen habe. Da ich nun die Zeit habe, mich darum zu kümmern, hoffe ich, dass mir hier jemand dabei helfen kann, dieses Problem für die Zukunft abzustellen.
Ich benutze gerade das Laptop meiner Freundin, auf dem ich letztes Jahr als erstes Betriebssystem (ohne Betriebssystem gekauft) Ubuntu 18.04 LTS installiert habe. Hin und wieder mache ich über das Terminal ein Update. Dies deshalb, weil trotz der Einstellung in der Aktualisierungsverwaltung, dass Updates automatisch heruntergeladen und installiert werden sollen, dies nicht passiert. Falls jemand weiß, woran das liegen könnte, wäre mir schon etwas geholfen.
Das eigentliche Problem aber ist folgendes: Jedes mal, wenn beim Updaten ein Kernel-Update dabei ist, startet das Laptop beim Neustart nicht richtig. Stattdessen sehe ich das grub-boot-menü mit den Optionen "Ubuntu", "Erweiterte Optionen" und "System Setup". Die erweiterten Optionen enthalten ältere Kernel-Versionen sowie zu jeder Kernel-Version einen Recovery-Mode. Meine Vorgehensweise, die dann erfahrungsgemäß funktioniert ist folgende: Ich wähle "System Setup", dann erscheint ein Menü, in dem ich mit F11 "System Recovery" auswähle. Der Bildschirm wird schwarz und nichts passiert mehr. Ich drücke nach kurzer Zeit den Power-Knopf und das Laptop schaltet sich sofort ab. Ich drücke wieder den Power-Knopf und Ubuntu startet ganz normal.
Manchmal, wenn es so nicht klappt, wähle ich den Recovery-Modus einer älteren Kernel-Version und dort die Option "kaputte Pakete reparieren". Danach funktioniert es dann gewöhnlich.

Wenn der Start einmal funktioniert hat, gibt es in der Regel keine Probleme mehr bis zum nächsten Kernel-Update.
Auf Dauer nervt es schon ziemlich und ich würde mich freuen, das Problem lösen zu können.Vielen Dank im Voraus!
Gruß
kzi

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »kzi« (02.07.2019, 09:23)


chroot

Ubuntu-Forum-Team

  • »chroot« ist männlich

Beiträge: 2 312

Registrierungsdatum: 04.03.2008

Derivat: Kein Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: KDE4

Andere Betriebssysteme: Fedora 27

  • Nachricht senden

2

30.06.2019, 12:55

Hi,

hast du schon einmal versucht, "Ubuntu" im grub auszuwählen?
"Do or do not. There is no try." (Yoda) || Thread auf gelöst/erledigt setzen

3

30.06.2019, 13:27

Danke für die schnelle Antwort. Ja, habe ich versucht mit der Folge, dass er versucht zu starten, dann jedoch wieder neu startet und mir wieder das gleiche Menü zeigt.

4

30.06.2019, 18:14

Wenn das Problem aktuell gerade nicht vorhanden ist, wird es schwierig zu verfolgen sein.
Denkbar wäre, daß in der bei jedem kernel-update neu generierten initrd ein wichtiges Modul nicht eingebunden wird. Du könntest beim nächsten kernel-update den Neustart ohne Option "quiet" und mit der Option "nosplash" machen, damit man die Startmeldungen sieht. Wenn er dann hängen bleibt, ein Bildschirmfoto der Meldung machen.
mir is wurscht

5

30.06.2019, 20:15

Danke, mache ich beim nächsten Mal. Ich wünsche zunächst noch einen angenehmen Rest-Sonntag!

6

01.07.2019, 16:48

Hallo zusammen,


gerade wurde mir bei einem Neustart wieder das besagte Menü gezeigt, obwohl seit dem letzten Mal kein Kernel-Update stattgefunden hat. Vielleicht täusche ich mich auch in der Annahme, dass das damit zusammenhängt. Womöglich hat das Laptop grundsätzlich ein Problem mit Neustarts. Ich hatte angenommen, dass die Kernel-Updates eine Rolle spielen, weil ich wohl meistens zu diesen Zeitpunkten einen Neustart durchgeführt habe. Den Neustart jetzt habe ich gemacht, um zu testen, ob es geklappt hat, die Option "noplymouth" ein- und "quiet" auszuschalten. Das hat funktioniert. Ich habe ein Foto der Meldungen gemacht, die mir angezeigt wurden, kurz bevor der Startvorgang abgebrochen und mir wieder das grub-Menü angezeigt wurde. Entschuldigt bitte die schlechte Qualität des Bildes, aber mit etwas Anstrengung kann man die Kernelmeldungen lesen.edit: Nach einem weiteren Neustart kamen noch die "Kernelmeldungen2" und, nachdem ich erneut den Punkt "System Recovery" gewählt hatte und danach neu gestartet habe, die "Kernelmeldungen3". Nach den "Kernelmeldungen3" wurde das Anmeldemenü mit Benutzerkonten angezeigt und man konnte ganz normal starten.
»kzi« hat folgende Bilder angehängt:
  • Kernelmeldungen.jpg
  • Kernelmeldungen2.jpg
  • Kernelmeldungen3.jpg

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »kzi« (01.07.2019, 17:18)


Beiträge: 975

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

Andere Betriebssysteme: Debian 9.9 "stretch" / 4.9.0-9-amd64

  • Nachricht senden

7

01.07.2019, 22:41

Ich kann auf den Bildern nichts entsprechendes sehen.

Zeig mal die Ausgabe von:

Quellcode

1
ls -la .Xauthority

8

02.07.2019, 09:11

Quellcode

1
ls -la .Xauthority
ausgeführt im Home-Verzeichnis, ergibt folgende Ausgabe:

Quellcode

1
ls: Zugriff auf '.Xauthority' nicht möglich: Datei oder Verzeichnis nicht gefunden

Es gibt allerdings eine Datei mit dem Namen Xauthority unter dem Pfad /run/user/1000/gdm/Xauthority. Beim Versuch, diese mit gedit zu öffnen, kam folgende Fehlermeldung: "Die geöffnete Datei enthält einige ungültige Zeichen. Wenn Sie die Bearbeitung fortsetzen, könnten Sie das Dokument unbrauchbar machen.
Sie können auch eine andere Zeichenkodierung wählen und es erneut versuchen."
Hier ist noch die Ausgabe von "ls -la" also alle Ordner und Dateien im Home-Verzeichnis, für den Fall, dass das weiterhilft:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
insgesamt 336
drwxr-xr-x 32 cara cara  4096 Jul  2 08:51 .
drwxr-xr-x  4 root root  4096 Jun 20 14:36 ..
drwxrwxr-x  3 cara cara  4096 Sep  6  2018 .acetoneiso
drwx------  3 cara cara  4096 Jan 10 08:32 .adobe
-rw-rw-r--  1 cara cara   107 Sep  6  2018 .apport-ignore.xml
drwxr-xr-x  2 cara cara 81920 Jun 27 19:23 .backup
-rw-r--r--  1 cara cara   129 Aug 19  2018 .bash_aliases
-rw-------  1 cara cara 11200 Jul  1 17:12 .bash_history
-rw-r--r--  1 cara cara   220 Aug  4  2018 .bash_logout
-rw-r--r--  1 cara cara  3771 Aug  4  2018 .bashrc
drwxr-xr-x 25 cara cara  4096 Mai 10 21:20 Bilder
drwx------ 23 cara cara  4096 Jul  1 16:33 .cache
drwx------ 26 cara cara  4096 Jun 21 22:59 .config
drwxr-xr-x  3 cara cara  4096 Mär 16 11:59 .dbus
drwxr-xr-x  9 cara cara  4096 Mai 13 20:41 Dokumente
drwxr-xr-x  2 cara cara  4096 Jul  1 20:17 Downloads
-rw-r--r--  1 cara cara  8980 Aug  4  2018 examples.desktop
drwx------  3 cara cara  4096 Jul  2 08:51 .gconf
drwxr-xr-x 24 cara cara  4096 Jul  1 16:33 .gimp-2.8
drwx------  3 cara cara  4096 Feb  2 15:17 .gnome
drwx------  3 cara cara  4096 Aug  4  2018 .gnupg
drwxr-xr-x  2 cara cara  4096 Sep  6  2018 .gphoto
-rw-------  1 cara cara 42588 Jul  2 08:51 .ICEauthority
drwxrwxr-x  3 cara cara  4096 Mai 11 21:30 .java
drwx------  3 cara cara  4096 Aug  4  2018 .local
drwx------  3 cara cara  4096 Jan 10 08:32 .macromedia
drwx------  5 cara cara  4096 Aug  4  2018 .mozilla
drwxr-xr-x 21 cara cara  4096 Feb 17 21:22 Musik
drwxr-xr-x  2 cara cara  4096 Aug  4  2018 Öffentlich
drwx------  3 cara cara  4096 Feb  2 15:17 .pki
drwxrwxr-x  2 cara cara  4096 Feb 17 21:03 Podcasts
-rw-r--r--  1 cara cara   807 Aug  4  2018 .profile
drwxr-xr-x  8 cara cara  4096 Aug  4  2018 .rtl8723de
-rw-rw-r--  1 cara cara 32915 Mai 11 21:33 .sambox.cache
drwxr-xr-x  6 cara cara  4096 Jul  1 20:14 Schreibtisch
drwxr-xr-x  3 cara cara  4096 Okt  9  2018 snap
drwxr-xr-x  2 cara cara  4096 Okt 27  2018 Spiele
drwx------  2 cara cara  4096 Aug  5  2018 .ssh
-rw-r--r--  1 cara cara 	0 Aug  4  2018 .sudo_as_admin_successful
drwxr-xr-x  3 cara cara  4096 Aug  5  2018 Videos
drwxr-xr-x  2 cara cara  4096 Aug  4  2018 Vorlagen
drwxr-xr-x  4 cara cara  4096 Mai 25 18:23 .wine

9

02.07.2019, 21:43

Ich habe den unbestimmten Verdacht, daß es mit der AMD Grafik zu tun haben könnte. Es sind mindestens zwei Meldungen zu "amdgpu" enthalten. Leider kann ich die Hinweise zu den weiteren Informationen nicht entziffern.

Am letzten Bild wird auch der Abschluss von "unattended-upgrades" verkündet. Das könnte bedeuten, daß er zuvor gar nicht abgestorben, sondern mit einem Hintergrund-Upgrade beschäftigt war. Was natürlich beim Hochfahren ein ziemlicher Unsinn wäre... Speziell, wenn da vielleicht noch gar kein Netz verfügbar ist. Das sähe dann natürlich nach einem Freeze aus.

Das wären jetzt zwei Richtungen, in die man bohren könnte.

Hilfreich wäre vielleicht eine Version von /var/log/dmesg von diesem Zeitpunkt. Je nach Alter heißt die Datei dmesg.0 oder dmesg.1.gz dmesg.2.gz dmesg.3.gz ...
mir is wurscht

Beiträge: 975

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

Andere Betriebssysteme: Debian 9.9 "stretch" / 4.9.0-9-amd64

  • Nachricht senden

10

02.07.2019, 22:20

Die dmesg Datei gibts doch schon seit gefühlten 5 Jahren nicht mehr. Schau im syslog File nach.

hogra

User

  • »hogra« ist männlich

Beiträge: 9

Registrierungsdatum: 24.12.2014

Derivat: Kubuntu

Architektur: 64-Bit PC

Desktop: KDE4

Andere Betriebssysteme: Windows 7

  • Nachricht senden

11

03.07.2019, 09:03

Startprobleme nach Neustart

Hallo
Ich habe Grub Customizer installiert und kann nach jedem Update die Einstellung bei Grub ändern.

12

03.07.2019, 14:46

Die dmesg Datei gibts doch schon seit gefühlten 5 Jahren nicht mehr.
Echt jetzt? Dann hab ich was verpasst. Bei mir wächst jeden Tag eine nach :)

Aber okay, /var/log/syslog ist auch gut. Oder /var/log/syslog.1 /var/log/syslog.2.gz /var/log/syslog.3.gz usw., je nach Dateidatum...
mir is wurscht

Beiträge: 975

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

Andere Betriebssysteme: Debian 9.9 "stretch" / 4.9.0-9-amd64

  • Nachricht senden

13

03.07.2019, 15:43

Ja, wenn Du noch mit Debian Woody arbeitest! :D

Mein Debian 9.9 schreibt auch keine /var/log/dmesg mehr. Es wird systemd eingesetzt, was andere Werkzeuge bietet.
Es lohnt sich, diese mal anzuschauen.

Um den Log vom letzten Boot einzusehen, eignet sich gut:

Quellcode

1
journalctl -k


(als root oder per sudo).

14

03.07.2019, 18:28

Hallo zusammen und danke für die rege Beteiligung!

Im Anhang befindet sich die Ausgabe des Befehls "journalctl -k" sowie ein syslog file.
»kzi« hat folgende Dateien angehängt:
  • journalctl-k.txt (184,11 kB - 3 mal heruntergeladen - zuletzt: 03.07.2019, 22:21)
  • syslog.1.txt (3,97 MB - 1 mal heruntergeladen - zuletzt: 03.07.2019, 19:01)

15

04.07.2019, 00:32

Naja, wir bräuchten halt den Ausschnitt der Datei von einem erfolglosen Bootvorgang bzw. die journalctl-Ausgabe davon.

Dein Syslog erstreckt sich über mehrere Tage und da gibt's echt echt viel zu durchsuchen, wenn man nicht weiß wann der abgebrochene Bootvorgang war. Da du letztens was von "gerade eben" geschrieben hast, könnte es der Abschnitt vom 1.7. kurz nach 16:00 gewesen sein. Der sieht nicht viel anders aus als alle anderen, aber zum genauen inspizieren ist das doch etwas zu umfangreich.

Ich meine aber, daß er mit irgendwas beschäftigt war, als er neu gestartet wurde. Es hatte demnach nur den Anschein als er wäre eingefroren. Wenn ich damit richtig liege, müsste bei so einem Anlass auch ein "journalctl -k" möglich sein, wenn du mit <Alt-Strg-F2> auf eine Textkonsole wechselst. Um uns das dann zu zeigen könntest du die Ausgabe in eine Datei umleiten:

Quellcode

1
journalctl -k > ~/journalctl_$(date +%s).txt

Die Datei liegt dann in deinem Home-Verzeichnis.

Wie gesagt - das hat nur Sinn bei einem (scheinbar) erfolglosen Hochfahren.
mir is wurscht

Beiträge: 975

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

Andere Betriebssysteme: Debian 9.9 "stretch" / 4.9.0-9-amd64

  • Nachricht senden

16

04.07.2019, 02:13

Man kann auch einen Startzeitpunkt fürs das Logging angeben, Beispiel 01.07. 16 Uhr:

Quellcode

1
journalctl -k -S "2019-07-01 16:00:00"

17

04.07.2019, 06:48

Sorry, hätte ich auch selbst drauf kommen können, mir schien das syslog file auch ziemlich groß und unübersichtlich.
Ich habe jetzt heute morgen das Laptop erfolgreich gestartet, bei einem Neustart bin ich dann im grub-Menü hängen geblieben. Dann erst versucht "Ubuntu" zu wählen --> erfolglos, wieder im grub-Menü gelandet. "System setup" -> "System Recovery" gewählt --> schwarzer Bildschirm, ausgeschaltet, wieder eingeschaltet --> grub-Menü, "Ubuntu" gewählt --> ins Anmeldemenü gelangt, angemeldet. Dann habe ich "journalctl -k > ~/journalctl_$(date +%s).txt" ausgeführt, die Datei ist im Anhang, genau wie der syslog-Abschnitt von heute.
»kzi« hat folgende Dateien angehängt:

Beiträge: 975

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

Andere Betriebssysteme: Debian 9.9 "stretch" / 4.9.0-9-amd64

  • Nachricht senden

18

07.07.2019, 12:55

Ich sehe da nur ein paar ACPI Errors, zu denen ich nichts sagen kann. Das ist WIndows Standard (die Fehler auch) *grins*

Aber wir können versuchen, dem auf den Grund zu gehen.

Nach dem nächsten Fehlstart postest Du mal die Ausgaben von:

Quellcode

1
2
3
4
5
systemd-analyze blame

#und

systemd-analyze critical-chain

19

07.07.2019, 13:29

Seltsam, Windows war nie auf dem Laptop installiert. Ich habe den Fehlstart jetzt wie beim letzten mal reproduziert und die Befehle ausgeführt, nachdem ich mich anmelden konnte. Die Ausgaben sind angehängt.
»kzi« hat folgende Dateien angehängt:

Beiträge: 975

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

Andere Betriebssysteme: Debian 9.9 "stretch" / 4.9.0-9-amd64

  • Nachricht senden

20

07.07.2019, 13:58

Sind das alle Seiten beim ersten File? Da fehlt noch was oder?

Ansonsten sehen diese Werte gut aus. Vermutlich von einem sauberen Start.