Sie sind nicht angemeldet.

  • »qwertzuiopü« ist der Autor dieses Themas

Beiträge: 9

Registrierungsdatum: 05.01.2019

Derivat: Lubuntu

Version: Ubuntu 18.04 LTS - Bionic Beaver

Architektur: 64-Bit PC

Desktop: LXDE

  • Nachricht senden

1

05.01.2019, 12:24

Umlaute und Akzenttasten funktionieren nicht (Lubuntu 18.04.1 LTS)

Guten Tag,
ich habe auf ein kürzlich gekauftes Notebook (Lenovo V130-15IGM) Lubuntu 18.04 LTS aufgespielt. Es läuft soweit alles gut, allerdings habe ich das Problem, dass

1) die Akzenttasten nicht funktionieren (weder innerhalb von LibreOffice noch bei Benutzung eines Browsers)
2) die Umlaute zwar innerhalb von LibreOffice funktionieren, aber die Dateinamen, die Umlaute enthalten, nun mit anderen Schriftzeichen dargestellt werden (Kyrillisch, glaube ich) und daher nicht geöffnet werden können, es sei denn, ich ersetze manuell sämtliche Umlaute durch Diphthonge.

Ich habe mich schon durch diverse Hilfeseiten geklickt und einiges ausprobiert (IBUS, Sprach-und Tastatureinstellungen usw.), aber das Problem bleibt bestehen.
Es sind alle Updates ausgeführt worden. Das Programm "System Profiler und Benchmark" zeigt als Tastatur "AT Tanslated Set 2 keyboard" an.
Für eine Hilfestellung wäre ich sehr dankbar.

Beiträge: 849

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

Andere Betriebssysteme: Debian 9.5 "stretch" / 4.9.0-8-amd64

  • Nachricht senden

2

05.01.2019, 15:19

Öffne mal ein Terminal und gib ein:

Quellcode

1
locale


Was kommt dabei raus?
Kannibalismus auch heute noch. -> *klick mich*
(video wie einer den anderen einfach auffrisst)


banane tanzt.gif

  • »qwertzuiopü« ist der Autor dieses Themas

Beiträge: 9

Registrierungsdatum: 05.01.2019

Derivat: Lubuntu

Version: Ubuntu 18.04 LTS - Bionic Beaver

Architektur: 64-Bit PC

Desktop: LXDE

  • Nachricht senden

3

06.01.2019, 13:46

Hallo,
vielen Dank für die Antwort. Folgende Nachricht erhalte ich:

LANG=de_DE.UTF-8
LANGUAGE=de_DE
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC=de_DE.UTF-8
LC_TIME=de_DE.UTF-8
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY=de_DE.UTF-8
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER=de_DE.UTF-8
LC_NAME=de_DE.UTF-8
LC_ADDRESS=de_DE.UTF-8
LC_TELEPHONE=de_DE.UTF-8
LC_MEASUREMENT=de_DE.UTF-8
LC_IDENTIFICATION=de_DE.UTF-8
LC_ALL=

Beiträge: 849

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

Andere Betriebssysteme: Debian 9.5 "stretch" / 4.9.0-8-amd64

  • Nachricht senden

4

06.01.2019, 14:01

Hast Du das Paket hier auch installiert?

Quellcode

1
sudo apt-get install language-pack-de
Kannibalismus auch heute noch. -> *klick mich*
(video wie einer den anderen einfach auffrisst)


banane tanzt.gif

  • »qwertzuiopü« ist der Autor dieses Themas

Beiträge: 9

Registrierungsdatum: 05.01.2019

Derivat: Lubuntu

Version: Ubuntu 18.04 LTS - Bionic Beaver

Architektur: 64-Bit PC

Desktop: LXDE

  • Nachricht senden

5

06.01.2019, 14:17

Ja, das Paket ist schon installiert.

Beiträge: 849

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

Andere Betriebssysteme: Debian 9.5 "stretch" / 4.9.0-8-amd64

  • Nachricht senden

6

06.01.2019, 16:32

Was ergibt denn im Terminal ein:

Quellcode

1
echo $LANG
Kannibalismus auch heute noch. -> *klick mich*
(video wie einer den anderen einfach auffrisst)


banane tanzt.gif

  • »qwertzuiopü« ist der Autor dieses Themas

Beiträge: 9

Registrierungsdatum: 05.01.2019

Derivat: Lubuntu

Version: Ubuntu 18.04 LTS - Bionic Beaver

Architektur: 64-Bit PC

Desktop: LXDE

  • Nachricht senden

7

06.01.2019, 18:34

Hallo,
die Anzeige ist dann:
de_DE.UTF-8

Beiträge: 849

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

Andere Betriebssysteme: Debian 9.5 "stretch" / 4.9.0-8-amd64

  • Nachricht senden

8

07.01.2019, 15:07

Also bei mir ist das auch so eingestellt. Ich habe aber ein Debian stable mit LXDE, weil mir das Lubuntu zu instabil war und merkwürdige Fehler zeigte.

Kannst Du denn Umlaute im Terminal schreiben?

Was kommt bei:

Quellcode

1
2
3
touch böse

ls b*
Kannibalismus auch heute noch. -> *klick mich*
(video wie einer den anderen einfach auffrisst)


banane tanzt.gif

  • »qwertzuiopü« ist der Autor dieses Themas

Beiträge: 9

Registrierungsdatum: 05.01.2019

Derivat: Lubuntu

Version: Ubuntu 18.04 LTS - Bionic Beaver

Architektur: 64-Bit PC

Desktop: LXDE

  • Nachricht senden

9

07.01.2019, 16:38

Hallo,

die Umlaute funktionieren im Terminal, nicht aber die Akzenttasten (é wird als e dargestellt, è als `e, à als `a).

Wenn ich die besagten Kommandos eingebe, erscheint
~$ ls b*
böse


Bin etwas ratlos....

Beiträge: 849

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

Andere Betriebssysteme: Debian 9.5 "stretch" / 4.9.0-8-amd64

  • Nachricht senden

10

07.01.2019, 18:36

Was kommt denn hier bei raus:

Quellcode

1
cat /etc/default/keyboard
Kannibalismus auch heute noch. -> *klick mich*
(video wie einer den anderen einfach auffrisst)


banane tanzt.gif

  • »qwertzuiopü« ist der Autor dieses Themas

Beiträge: 9

Registrierungsdatum: 05.01.2019

Derivat: Lubuntu

Version: Ubuntu 18.04 LTS - Bionic Beaver

Architektur: 64-Bit PC

Desktop: LXDE

  • Nachricht senden

11

07.01.2019, 22:25

Dann erhalte ich:
XKBMODEL=deadgraveacute
XKBLAYOUT=de
BACKSPACE=guess

Beiträge: 849

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

Andere Betriebssysteme: Debian 9.5 "stretch" / 4.9.0-8-amd64

  • Nachricht senden

12

08.01.2019, 04:50

Imho fehlt da noch was. Die Option "deadgraveacute" scheint nicht falsch zu sein, aber ich habe das bei mir auf Standard.

Editiere doch mal deine Datei so:

Quellcode

1
2
3
4
5
6
7
#Erst ein Backup der alten Datei erstellen:

sudo cp /etc/default/keyboard /etc/default/keyboard.bak

#Jetzt die Datei ändern:

sudo leafpad /etc/default/keyboard


Und dann setzt Du folgenden Block rein und löschst deins vorher raus:

Quellcode

1
2
3
4
5
6
7
8
9
10
# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="de"
XKBVARIANT=""
XKBOPTIONS=""

BACKSPACE="guess"


Nach dem Abspeichern mal ein Reboot und testen.
Kannibalismus auch heute noch. -> *klick mich*
(video wie einer den anderen einfach auffrisst)


banane tanzt.gif

  • »qwertzuiopü« ist der Autor dieses Themas

Beiträge: 9

Registrierungsdatum: 05.01.2019

Derivat: Lubuntu

Version: Ubuntu 18.04 LTS - Bionic Beaver

Architektur: 64-Bit PC

Desktop: LXDE

  • Nachricht senden

13

08.01.2019, 19:46

Hallo,
vielen Dank für die geduldige Hilfe. Ich fürchte, ich stelle mich gerade blöd an.
1)
#Erst ein Backup der alten Datei erstellen:

sudo cp /etc/default/keyboard /etc/default/keyboard.bak

#Jetzt die Datei ändern:

sudo leafpad /etc/default/keyboard

Ok, das habe ich erledigt. Im Leafpad erscheint:
XKBMODEL=deadgraveacute
XKBLAYOUT=de
BACKSPACE=guess

Wo setze ich jetzt genau die folgenden Kommandos ein?
# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="de"
XKBVARIANT=""
XKBOPTIONS=""

BACKSPACE="guess"

Beiträge: 849

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

Andere Betriebssysteme: Debian 9.5 "stretch" / 4.9.0-8-amd64

  • Nachricht senden

14

08.01.2019, 20:00

Du sollst deinen Inhalt der Datei komplett löschen und meine Konfiguration da rein kopieren und abspeichern:

XKBMODEL="pc105"
XKBLAYOUT="de"
XKBVARIANT=""
XKBOPTIONS=""

BACKSPACE="guess"
Kannibalismus auch heute noch. -> *klick mich*
(video wie einer den anderen einfach auffrisst)


banane tanzt.gif

  • »qwertzuiopü« ist der Autor dieses Themas

Beiträge: 9

Registrierungsdatum: 05.01.2019

Derivat: Lubuntu

Version: Ubuntu 18.04 LTS - Bionic Beaver

Architektur: 64-Bit PC

Desktop: LXDE

  • Nachricht senden

15

08.01.2019, 20:22

Hallo,
habe ich gemacht und den Computer wieder hochgefahren. Die Akzente funktionieren aber immer noch nicht, d.h. sie stehen vor bzw. nach dem betreffenden Vokal. Die Dateien, die ursprünglich Umlaute im Titel hatten, können immer noch nicht geöffnet werden und enthalten statt der Umlaute immer noch die komischen Sonderzeichen...
Vielen Dank für die Geduld...

Beiträge: 849

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

Andere Betriebssysteme: Debian 9.5 "stretch" / 4.9.0-8-amd64

  • Nachricht senden

16

09.01.2019, 05:51

Wie sieht jetzt die Datei aus?

Quellcode

1
cat /etc/default/keyboard




Nachtrag:

Gib mir mal auch noch die Ausgaben von folgenden Kommandos (am besten auch in Code Tags / Quellcodefenster):

Quellcode

1
2
3
4
cat /etc/fstab


mount


Und sag mir, auf welcher Festplatte/Partition die Daten mit den kryptischen Dateinamen liegen.
Kannibalismus auch heute noch. -> *klick mich*
(video wie einer den anderen einfach auffrisst)


banane tanzt.gif

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Horsemanchip« (09.01.2019, 22:49)


  • »qwertzuiopü« ist der Autor dieses Themas

Beiträge: 9

Registrierungsdatum: 05.01.2019

Derivat: Lubuntu

Version: Ubuntu 18.04 LTS - Bionic Beaver

Architektur: 64-Bit PC

Desktop: LXDE

  • Nachricht senden

17

12.01.2019, 20:15

Hallo,
bei der Eingabe von
cat /etc/default/keyboard

erhalte ich:
XKBMODEL=deadgraveacute
XKBLAYOUT=de
BACKSPACE=guess
Bei der Eingabe von

cat /etc/fstab


mount

erhalte ich:
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
# / was on /dev/sda2 during installation
UUID=d7f20679-008b-49d2-8ab6-de3c34ed8329 / ext4 errors=remount-ro 0 1
# /boot/efi was on /dev/sda1 during installation
UUID=1D1E-7B60 /boot/efi vfat umask=0077 0 1
/swapfile none swap sw 0 0

Die Dateien mit den seltsamen Dateinamen liegen auf:
/home/user/Dokumente
Vielen Dank für die Mühen...

Beiträge: 849

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

Andere Betriebssysteme: Debian 9.5 "stretch" / 4.9.0-8-amd64

  • Nachricht senden

18

12.01.2019, 21:23

Posting 12 hast Du aber nicht korrekt abgearbeitet. Deine Datei sieht aus wie vorher.

Öffne die Datei mit root Rechten wie vorgeschlagen im Leafpad, nimm deinen Block komplett raus und kopier meine Konfigurationr rein.

Dann abspeichern und neu starten.

DAS hätte Dir selber auffallen müssen, dass da keine Änderung stattgefunden hat. :rolleyes: Du mußt deine eignene Arbeit immer überprüfen. ^^

PS: Diese Dateien mit den kryptischen Zeichen, kommen die von einer Windows Platte oder wo wurden diese Files angelegt?
Kannibalismus auch heute noch. -> *klick mich*
(video wie einer den anderen einfach auffrisst)


banane tanzt.gif