Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

  • »qwertzuiopü« ist der Autor dieses Themas

Beiträge: 29

Registrierungsdatum: 05.01.2019

Derivat: Lubuntu

Version: Ubuntu 18.04 LTS - Bionic Beaver

Architektur: 64-Bit PC

Desktop: LXDE

  • Nachricht senden

41

03.02.2019, 12:20

Und bei der Eingabe von

Quellcode

1
sudo systemctl status rc-local

erhalte ich

Quellcode

1
2
3
4
5
6
7
● rc-local.service - /etc/rc.local Compatibility
   Loaded: loaded (/lib/systemd/system/rc-local.service; static; vendor preset: 
  Drop-In: /lib/systemd/system/rc-local.service.d
       	└─debian.conf
   Active: inactive (dead)
 	Docs: man:systemd-rc-local-generator(8)
log file: udo systemctl status rc-local

42

05.02.2019, 22:08

Ok, keine User-config die dazwischenfunkt.
Dann probieren wir mal einen stunt:

Quellcode

1
2
3
cd /etc/
sudo cp rc.local rc.local.save
sudo sed -i 's|\(^exit 0$\)|cp /etc/default/keyboard.save /etc/default/keyboard\n\1|g' rc.local


Hoffentlich habe ich das mit dem Quellcode richtig gemacht
Wird schon langsam :)
mir is wurscht

  • »qwertzuiopü« ist der Autor dieses Themas

Beiträge: 29

Registrierungsdatum: 05.01.2019

Derivat: Lubuntu

Version: Ubuntu 18.04 LTS - Bionic Beaver

Architektur: 64-Bit PC

Desktop: LXDE

  • Nachricht senden

43

06.02.2019, 11:33

Hallo,
vielen Dank! Bei der Eingabe erhalte ich:

Quellcode

1
2
3
user@user-Lenovo-V130-15IGM:/etc$ sudo cp rc.local rc.local.save
cp: Aufruf von stat für 'rc.local' nicht möglich: Datei oder Verzeichnis nicht gefunden
user@user-Lenovo-V130-15IGM:/etc$ sudo sed -i 's|\(^exit 0$\)|cp /etc/default/keyboard.save /etc/default/keyboard\n\1|g' rc.local

Die Akzente funktionieren leider immer noch nicht, auch nicht nach Neustart...

44

06.02.2019, 19:24

Ja gut, okay... Muss man auch draufkommen, daß die Emulation für rc.local zwar aktiviert ist aber keine rc.local vorhanden... ;(
Dann eben anders:

Quellcode

1
echo -e  'cp /etc/default/keyboard.save /etc/default/keyboard\nexit 0' | sudo tee /etc/rc.local
mir is wurscht

Beiträge: 937

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

Andere Betriebssysteme: Debian 9.8 "stretch" / 4.9.0-8-amd64

  • Nachricht senden

45

06.02.2019, 22:10

Ich sagte ja, die ist nicht mehr aktiviert. Und mit dem einfachen Erstellen und chmod der Datei ist es nicht getan. Das Einschalten per systemctl wird vermutlich auch nicht gehen,
weil im service File für die rc.local keine Install Einheit eingetragen ist. Das müßte man dann per Hand erstellen.

Kann man machen, ist imho der falsche Weg. Man sollte sich lieber mit systemd abfinden und einarbeiten, wie es ist.

Für ein einfaches Ausführen eines Kommandos beim reboot, würde ich die @reboot Option der crontab nutzen und dann das entsprechende Kommando oder ein Scirpt mit sleep inkludiert, falls die Aktion zu früh gestartet wird beim Booten.
Kannibalismus auch heute noch. -> *klick mich*
(video wie einer den anderen einfach auffrisst)


banane tanzt.gif

46

07.02.2019, 15:30

Ich sagte ja, die ist nicht mehr aktiviert.
Stimmt, ich habe "Active: inactive (dead)" übersehen. (Was für eine tolle Meldung nach "Loaded: loaded..." Man orientiert sich zusehends an proprietären OSs.)

Dem Rest stimme ich auch zu. Ich hätt's halt lieber einfacher für Nicht-Level3-Administratoren gemacht. :(
Beste Lösung wäre, die Ursache für dieses Fehlverhalten zu finden. Aber wo? Eventuell mal die Logs vom Bootvorgang ansehen. So eine Änderung sollte doch geloggt werden.
mir is wurscht

Beiträge: 937

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

Andere Betriebssysteme: Debian 9.8 "stretch" / 4.9.0-8-amd64

  • Nachricht senden

47

07.02.2019, 17:51

Ich habe seit Debian 9 die rc.local nicht mehr vermißt, weil alles rund lief. Aber ich nahm sie auch immer ganz gerne für workarounds.

Aber gut, man kann sie ja aktivieren:

1.) Man erstellt mit root Rechten und Editor das service File /etc/systemd/system/rc-local.service und schreibt folgendes rein:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
[Unit]
 Description=/etc/rc.local Compatibility
 ConditionPathExists=/etc/rc.local

[Service]
 Type=forking
 ExecStart=/etc/rc.local start
 TimeoutSec=0
 StandardOutput=tty
 RemainAfterExit=yes
 SysVStartPriority=99 #in trauriger Erinnerung an alte Zeiten

[Install]
 WantedBy=multi-user.target


2.) Anlegen, Ausführbar machen und einschalten:

Quellcode

1
2
3
4
5
printf '%s\n' '#!/bin/bash' 'exit 0' | sudo tee -a /etc/rc.local

sudo chmod +x /etc/rc.local

sudo systemctl enable rc-local


3.) Nun prüfen:

Quellcode

1
2
sudo systemctl start rc-local.service
sudo systemctl status rc-local.service


Jetzt müsste da sowas stehen wie:

rc-local.service - /etc/rc.local Compatibility
Loaded: loaded (/etc/systemd/system/rc-local.service; enabled; vendor preset: enabled)
Active: active (running)



*****

Ja, die Logfiles könnte er hier mal anhängen. /var/log/syslog und /var/log/Xorg.0.log.
Kannibalismus auch heute noch. -> *klick mich*
(video wie einer den anderen einfach auffrisst)


banane tanzt.gif

Dieser Beitrag wurde bereits 6 mal editiert, zuletzt von »Horsemanchip« (07.02.2019, 22:03)


  • »qwertzuiopü« ist der Autor dieses Themas

Beiträge: 29

Registrierungsdatum: 05.01.2019

Derivat: Lubuntu

Version: Ubuntu 18.04 LTS - Bionic Beaver

Architektur: 64-Bit PC

Desktop: LXDE

  • Nachricht senden

48

08.02.2019, 19:58

Hallo,
vielen Dank für Antworten. Ich war die letzten Tage nicht da und komme leider erst jetzt dazu zu antworten.
Bei der Eingabe von

Quellcode

1
echo -e  'cp /etc/default/keyboard.save /etc/default/keyboard\nexit 0' | sudo tee /etc/rc.local

erhalte ich

Quellcode

1
2
cp /etc/default/keyboard.save /etc/default/keyboard
exit 0


Die Akzente funktionieren aber immer noch nicht...
Den Antworten von Horsemanchip vom 06.02.2019, 22:10 und von Fredl vom 07.02.2019 um 15h30 kann ich leider nicht folgen, dafür sind meine Computerkenntnisse leider zu spärlich :(
Nun habe ich die Datei

Quellcode

1
rc-local.service
angelegt, sie ausführbar gemacht und geprüft wie beschrieben, Ergebnis:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
user@user-Lenovo-V130-15IGM:~$ sudo systemctl enable rc-local
Created symlink /etc/systemd/system/multi-user.target.wants/rc-local.service → /etc/systemd/system/rc-local.service.
user@user-Lenovo-V130-15IGM:~$ sudo systemctl start rc-local.service
Job for rc-local.service failed because the control process exited with error code.
See "systemctl status rc-local.service" and "journalctl -xe" for details.
user@user-Lenovo-V130-15IGM:~$ sudo systemctl status rc-local.service
● rc-local.service - /etc/rc.local Compatibility
   Loaded: loaded (/etc/systemd/system/rc-local.service; enabled; vendor preset:
  Drop-In: /lib/systemd/system/rc-local.service.d
       	└─debian.conf
   Active: failed (Result: exit-code) since Fri 2019-02-08 20:18:12 CET; 1min 0s
  Process: 1837 ExecStart=/etc/rc.local start (code=exited, status=203/EXEC)

Feb 08 20:18:12 user-Lenovo-V130-15IGM systemd[1]: Starting /etc/rc.local Compa
Feb 08 20:18:12 user-Lenovo-V130-15IGM systemd[1]: rc-local.service: Control pr
Feb 08 20:18:12 user-Lenovo-V130-15IGM systemd[1]: rc-local.service: Failed wit
Feb 08 20:18:12 user-Lenovo-V130-15IGM systemd[1]: Failed to start /etc/rc.loca
lines 1-11/11 (END)

Akzenzttechnisch hat sich leider nix getan. Ich würde gut verstehen, wenn ihr langsam keine Lust mehr habt. Ich ärgere mich, den dämlichen Lenovo-Computer überhaupt gekauft zu haben :-(

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »qwertzuiopü« (08.02.2019, 20:26)


Beiträge: 937

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

Andere Betriebssysteme: Debian 9.8 "stretch" / 4.9.0-8-amd64

  • Nachricht senden

49

09.02.2019, 08:32

Poste mal diese beiden Dateien:

Quellcode

1
2
3
cat /etc/systemd/system/rc-local.service

cat /etc/rc.local


Und noch:

Quellcode

1
ls -la /etc/rc.local


Ich möchte die Ausführbarkeit da sehen, wegen dem hier:

Zitat

Process: 1837 ExecStart=/etc/rc.local start (code=exited, status=203/EXEC)
Kannibalismus auch heute noch. -> *klick mich*
(video wie einer den anderen einfach auffrisst)


banane tanzt.gif

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Horsemanchip« (09.02.2019, 09:26)


  • »qwertzuiopü« ist der Autor dieses Themas

Beiträge: 29

Registrierungsdatum: 05.01.2019

Derivat: Lubuntu

Version: Ubuntu 18.04 LTS - Bionic Beaver

Architektur: 64-Bit PC

Desktop: LXDE

  • Nachricht senden

50

10.02.2019, 14:44

Hallo,
dann erhalte ich:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
user@user-Lenovo-V130-15IGM:~$ cat /etc/systemd/system/rc-local.service
[Unit]
 Description=/etc/rc.local Compatibility
 ConditionPathExists=/etc/rc.local

[Service]
 Type=forking
 ExecStart=/etc/rc.local start
 TimeoutSec=0
 StandardOutput=tty
 RemainAfterExit=yes
 SysVStartPriority=99 #in trauriger Erinnerung an alte Zeiten

[Install]
 WantedBy=multi-user.targetuser@user-Lenovo-V130-15IGM:~$ 
user@user-Lenovo-V130-15IGM:~$ cat /etc/rc.local

und dann:

Quellcode

1
2
user@user-Lenovo-V130-15IGM:~$ ls -la /etc/rc.local
-rwxr-xr-x 1 root root 97 Feb  8 20:17 /etc/rc.local

Ich hoffe, es stimmt so.

Beiträge: 937

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

Andere Betriebssysteme: Debian 9.8 "stretch" / 4.9.0-8-amd64

  • Nachricht senden

51

10.02.2019, 15:10

[Install]
WantedBy=multi-user.targetuser@user-Lenovo-V130-15IGM:~$


Sieht die Zeile wirklich genau so aus unten in deiner Datei? Dieses Prompt (rot) gehört da nicht rein oder ist das ein Kopierfehler?

Du kannst auch mal die Ausgabe von folgendem Kommando posten, wie es in der Meldung vorgeschlagen wird:

Quellcode

1
sudo journalctl -xe


PS: Ich hab das bei mir ausprobiert wie in Posting#47. Läuft 1 A.
Kannibalismus auch heute noch. -> *klick mich*
(video wie einer den anderen einfach auffrisst)


banane tanzt.gif

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Horsemanchip« (10.02.2019, 15:30)


  • »qwertzuiopü« ist der Autor dieses Themas

Beiträge: 29

Registrierungsdatum: 05.01.2019

Derivat: Lubuntu

Version: Ubuntu 18.04 LTS - Bionic Beaver

Architektur: 64-Bit PC

Desktop: LXDE

  • Nachricht senden

52

10.02.2019, 19:15

Hallo,
ich hab die Befehle nochmal eingegeben. Ich habe wohl die Zeile mit dem Befehl versehentlich kopiert, pardon. Nun sieht es bei der EIngabe von

Quellcode

1
2
3
cat /etc/systemd/system/rc-local.service

cat /etc/rc.local

so aus:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
[Unit]
 Description=/etc/rc.local Compatibility
 ConditionPathExists=/etc/rc.local

[Service]
 Type=forking
 ExecStart=/etc/rc.local start
 TimeoutSec=0
 StandardOutput=tty
 RemainAfterExit=yes
 SysVStartPriority=99 #in trauriger Erinnerung an alte Zeiten

[Install]
 WantedBy=multi-user.targetuser@user-Lenovo-V130-15IGM:~$ 
user@user-Lenovo-V130-15IGM:~$ cat /etc/rc.local

Und bei

Quellcode

1
ls -la /etc/rc.local


erhalte ich:

Quellcode

1
-rwxr-xr-x 1 root root 97 Feb  8 20:17 /etc/rc.local

Bei der Eingabe von

Quellcode

1
sudo journalctl -xe

erhalte ich:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
Feb 10 19:07:51 julia-Lenovo-V130-15IGM wpa_supplicant[518]: wlp2s0: SME: Trying
Feb 10 19:07:52 user-Lenovo-V130-15IGM kernel: wlp2s0: disconnect from AP cc:ce
Feb 10 19:07:52 user-Lenovo-V130-15IGM kernel: wlp2s0: authenticate with cc:ce:
Feb 10 19:07:52 user-Lenovo-V130-15IGM kernel: wlp2s0: send auth to cc:ce:1e:dc
Feb 10 19:07:52 user-Lenovo-V130-15IGM kernel: wlp2s0: authenticated
Feb 10 19:07:52 user-Lenovo-V130-15IGM kernel: wlp2s0: associate with cc:ce:1e:
Feb 10 19:07:52 user-Lenovo-V130-15IGM kernel: wlp2s0: RX ReassocResp from cc:c
Feb 10 19:07:52 user-Lenovo-V130-15IGM kernel: wlp2s0: associated
Feb 10 19:07:52 user-Lenovo-V130-15IGM kernel: wlp2s0: Limiting TX power to 20 
Feb 10 19:07:51 user-Lenovo-V130-15IGM NetworkManager[519]: <info>  [1549822071
Feb 10 19:07:51 user-Lenovo-V130-15IGM wpa_supplicant[518]: wlp2s0: Trying to a
Feb 10 19:07:51 user-Lenovo-V130-15IGM NetworkManager[519]: <info>  [1549822071
Feb 10 19:07:51 user-Lenovo-V130-15IGM wpa_supplicant[518]: wlp2s0: Associated 
Feb 10 19:07:51 user-Lenovo-V130-15IGM NetworkManager[519]: <info>  [1549822071
Feb 10 19:07:51 user-Lenovo-V130-15IGM wpa_supplicant[518]: wlp2s0: CTRL-EVENT-
Feb 10 19:07:51 user-Lenovo-V130-15IGM NetworkManager[519]: <info>  [1549822071
Feb 10 19:07:51 user-Lenovo-V130-15IGM wpa_supplicant[518]: wlp2s0: WPA: Key ne
Feb 10 19:07:51 user-Lenovo-V130-15IGM NetworkManager[519]: <info>  [1549822071
Feb 10 19:07:51 user-Lenovo-V130-15IGM wpa_supplicant[518]: wlp2s0: CTRL-EVENT-
Feb 10 19:07:51 user-Lenovo-V130-15IGM wpa_supplicant[518]: wlp2s0: CTRL-EVENT-
Feb 10 19:13:57 user-Lenovo-V130-15IGM sudo[1363]: pam_unix(sudo:auth): authent
Feb 10 19:14:03 user-Lenovo-V130-15IGM sudo[1363]: julia : TTY=pts/0 ; PWD=/hom
Feb 10 19:14:03 user-Lenovo-V130-15IGM sudo[1363]: pam_unix(sudo:session): sess
lines 2124-2146/2146 (END)

Vielen Dank für die geduldige Hilfe!

53

10.02.2019, 20:58

Mach bitte Kopien von den Dateien und füge sie hier als Anhang an.
Also erstens:

Quellcode

1
sudo journalctl -xe > /tmp/journal.txt

Und dann noch

Quellcode

1
2
cat /etc/systemd/system/rc-local.service > /tmp/rc-local.service.txt
cat /etc/rc.local > /tmp/rc-local.txt


Danach findest Du im Verzeichnis /tmp die drei Dateien journal.txt, rc-local.service.txt und rc-local.txt. Diese hänge uns dann bitte hier als Anhang an, damit wir 1:1-Inhalte mit ganzen Zeilen sehen können.
mir is wurscht

  • »qwertzuiopü« ist der Autor dieses Themas

Beiträge: 29

Registrierungsdatum: 05.01.2019

Derivat: Lubuntu

Version: Ubuntu 18.04 LTS - Bionic Beaver

Architektur: 64-Bit PC

Desktop: LXDE

  • Nachricht senden

54

14.02.2019, 11:35

Hallo,
erstmal Entschuldigung für die späte Antwort, ich war die letzten Tage nicht zu Hause.
Bei der Eingabe von

Quellcode

1
sudo journalctl -xe > /tmp/journal.txt
erscheint gar nichts, d.h. nur

Quellcode

1
user@user-Lenovo-V130-15IGM:~$ 
,
bei der Eingabe von

Quellcode

1
2
cat /etc/systemd/system/rc-local.service > /tmp/rc-local.service.txt
cat /etc/rc.local > /tmp/rc-local.txt
ebenfalls.
Die Dateien journal.txt, rc-local.service.txt und rc-local.txt schicke ich im Anhang.
Vielen Dank weiterhin!
»qwertzuiopü« hat folgende Dateien angehängt:
  • journal.txt (156,13 kB - 2 mal heruntergeladen - zuletzt: 14.02.2019, 14:29)
  • rc-local.service.txt (294 Byte - 1 mal heruntergeladen - zuletzt: 14.02.2019, 13:05)
  • rc-local.txt (97 Byte - 2 mal heruntergeladen - zuletzt: 14.02.2019, 14:26)

Beiträge: 937

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

Andere Betriebssysteme: Debian 9.8 "stretch" / 4.9.0-8-amd64

  • Nachricht senden

55

14.02.2019, 13:13

Die Datei /etc/rc.local ist total falsch aufgebaut. Schau Sie Dir selber an und ändere sie dann selbstständig so:

Quellcode

1
2
3
#!/bin/bash
cp /etc/default/keyboard.save /etc/default/keyboard
exit 0


Nachdem Du das erledigt hast mit der Änderung und Abspeichern nochmal nacheinander folgende Kommandos:

Quellcode

1
2
3
4
5
6
7
8
sudo systemctl enable rc-local


sudo systemctl start rc-local.service

# und danach noch

sudo systemctl status rc-local.service
Kannibalismus auch heute noch. -> *klick mich*
(video wie einer den anderen einfach auffrisst)


banane tanzt.gif

56

14.02.2019, 14:54

Die Datei /etc/rc.local ist total falsch aufgebaut.
War vielleicht mein Fehler, als ich das sed Kommando einfach in ein echo umgestrickt habe.

Ich würde gerne die Ausgabe sehen von: (Bitte mit maximal vergrößertem Terminalfenster!)

Quellcode

1
for i in  /etc/systemd/system/sysinit.target.wants/keyboard-setup.service /etc/console-setup/cached_setup_keyboard.sh /etc/default/locale; do echo; echo $i:; cat $i; done

und

Quellcode

1
for i in  /etc/systemd/system/multi-user.target.wants/console-setup.service /lib/console-setup/console-setup.sh /etc/console-setup/cached_setup_terminal.sh; do echo; echo $i:; cat $i; done


(Grund: Log-Zeile 6401-645: "Unit keyboard-setup.service has finished starting up", Zeile 803-809 ditto für console font and keymap)

Zeile 1759 wäre imho noch verdächtiger:

Zitat

Feb 14 11:26:12 user-Lenovo-V130-15IGM dbus-daemon[517]: [system] Activating via systemd: service name='org.freedesktop.locale1' unit='dbus-org.freedesktop.locale1.service' requested by ':1.19' (uid=1000 pid=795 comm="localectl set-x11-keymap de deadgraveacute " label="unconfined")

"deadgraveacute" sieht nicht gut aus. Nur weiß ich gerade nicht, wo da genau anzusetzen wäre.
mir is wurscht

  • »qwertzuiopü« ist der Autor dieses Themas

Beiträge: 29

Registrierungsdatum: 05.01.2019

Derivat: Lubuntu

Version: Ubuntu 18.04 LTS - Bionic Beaver

Architektur: 64-Bit PC

Desktop: LXDE

  • Nachricht senden

57

14.02.2019, 18:06

Hallo,
nur damit ich nicht die Datei komplett schrotte: Soll

Quellcode

1
/etc/rc.local
so aussehen:

Quellcode

1
2
3
4
5
cp /etc/default/keyboard.save /etc/default/keyboard
exit 0
#!/bin/bash
cp /etc/default/keyboard.save /etc/default/keyboard
exit 0

oder so:

Quellcode

1
2
3
#!/bin/bash
cp /etc/default/keyboard.save /etc/default/keyboard
exit 0

Bei der Eingabe von

Quellcode

1
for i in  /etc/systemd/system/sysinit.target.wants/keyboard-setup.service /etc/console-setup/cached_setup_keyboard.sh /etc/default/locale; do echo; echo $i:; cat $i; done

erhalte ich:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
/etc/systemd/system/sysinit.target.wants/keyboard-setup.service:
[Unit]
Description=Set the console keyboard layout
DefaultDependencies=no
Before=local-fs-pre.target
Wants=local-fs-pre.target
ConditionPathExists=/bin/setupcon

[Service]
Type=oneshot
ExecStart=/lib/console-setup/keyboard-setup.sh
RemainAfterExit=yes

[Install]
WantedBy=sysinit.target

/etc/console-setup/cached_setup_keyboard.sh:
#!/bin/sh

if [ -f /run/console-setup/keymap_loaded ]; then
	rm /run/console-setup/keymap_loaded
	exit 0
fi
kbd_mode '-u' < '/dev/tty1' 
kbd_mode '-u' < '/dev/tty2' 
kbd_mode '-u' < '/dev/tty3' 
kbd_mode '-u' < '/dev/tty4' 
kbd_mode '-u' < '/dev/tty5' 
kbd_mode '-u' < '/dev/tty6' 
loadkeys '/etc/console-setup/cached_UTF-8_del.kmap.gz' > '/dev/null' 

/etc/default/locale:
#  File generated by update-locale
LANG=de_DE.UTF-8

und bei

Quellcode

1
for i in  /etc/systemd/system/multi-user.target.wants/console-setup.service /lib/console-setup/console-setup.sh /etc/console-setup/cached_setup_terminal.sh; do echo; echo $i:; cat $i; done

kriege ich:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
/etc/systemd/system/multi-user.target.wants/console-setup.service:
[Unit]
Description=Set console font and keymap
DefaultDependencies=no
After=console-screen.service kbd.service local-fs.target
RequiresMountsFor=/usr
ConditionPathExists=/bin/setupcon

[Service]
Type=oneshot
ExecStart=/lib/console-setup/console-setup.sh
RemainAfterExit=yes

[Install]
WantedBy=multi-user.target

/lib/console-setup/console-setup.sh:
#!/bin/sh

do_configure=no
case "`uname 2>/dev/null`" in
    *FreeBSD*)
        do_configure=yes
        ;;
    *) # assuming Linux with udev

        # Skip only the first time (i.e. when the system boots)
        [ ! -f /run/console-setup/boot_completed ] || do_configure=yes
        mkdir -p /run/console-setup
        > /run/console-setup/boot_completed
        
        [ /etc/console-setup/cached_setup_terminal.sh \
              -nt /etc/default/keyboard ] || do_configure=yes
        [ /etc/console-setup/cached_setup_terminal.sh \
              -nt /etc/default/console-setup ] || do_configure=yes
        ;;
esac

if [ "$do_configure" = no ]; then
    :
else
    if [ -f /etc/default/locale ]; then
        # In order to permit auto-detection of the charmap when
        # console-setup-mini operates without configuration file.
        . /etc/default/locale
        export LANG
    fi
    setupcon --save
fi

/etc/console-setup/cached_setup_terminal.sh:
#!/bin/sh

{ :
printf '\033%%G' 
} < /dev/tty${1#vcs} > /dev/tty${1#vcs}

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »qwertzuiopü« (14.02.2019, 18:12)


58

15.02.2019, 15:14

/etc/rc.local soll so aussehen wie Horsemanchip gesagt hat:

Quellcode

1
2
3
#!/bin/bash
cp /etc/default/keyboard.save /etc/default/keyboard
exit 0


Den Rest kann ich mir erst später ansehen.
mir is wurscht

Beiträge: 937

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

Andere Betriebssysteme: Debian 9.8 "stretch" / 4.9.0-8-amd64

  • Nachricht senden

59

15.02.2019, 20:53

Nur damit Du verstehst was wir hier machen:

Wir möchten die tote Kuh retten, damit sie wieder Milch gibt. Sie war eine gute Kuh.

Durch die Milch könntest Du deine Akzente wieder bekommen, wie als wenn man Kakaopulver reinmacht.

:)
Kannibalismus auch heute noch. -> *klick mich*
(video wie einer den anderen einfach auffrisst)


banane tanzt.gif

60

16.02.2019, 02:25

Ich kämpfe mich durch das dbus-Zeug. Ist nicht meins, das geb ich zu. Aber ich hab den Verdacht, daß es dort passiert.
"localectl set-x11-keymap de deadgraveacute" wird irgendwo über das freedesktop+dbus Gemangel vom systemd aufgerufen. Ich glaube da liegt der Hund, denn laut man-page muss nach so einer Aktion die initrd neu erzeugt werden. Das würde erklären, warum das nach jedem Neustart wieder beim alten ist und sich im Betrieb nicht ändern lässt.

Wie sieht denn diese Ausgabe aus:

Quellcode

1
localectl status


Und schau mal bitte in den Systemeinstellungen unter "Tastatur", ob du vielleicht ein zweites Tastaturlayout aktiviert hast.
mir is wurscht