Sie sind nicht angemeldet.

  • »chicho1704« ist männlich
  • »chicho1704« ist der Autor dieses Themas

Beiträge: 16

Registrierungsdatum: 06.08.2011

Derivat: Ubuntu

Architektur: 32-Bit PC

Desktop: GNOME 2.x

  • Nachricht senden

1

25.11.2018, 15:34

FEHLERMELDUNG: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete

Hallo Leute! ich benutze ubuntu 16.04.
Ich versuche verschiedene Anwendungen (u.a. Classic GNOME Flashback,
Unity core, usw) zu installieren und immer wieder kommt diese Meldung
vor: "Probleme können nicht korrigiert werden, Sie haben zurückgehaltene
defekte Pakete".
Wie kann ich das lösen?

Jetzt zu den Meldungen:

  • sudo apt-get install gnome-session-flashback
  • Paketlisten werden gelesen... Fertig
  • Abhängigkeitsbaum wird aufgebaut.
  • Statusinformationen werden eingelesen.... Fertig
  • Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
  • Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
  • Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
  • nicht erstellt wurden oder Incoming noch nicht verlassen haben.
  • Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen
  • * Die folgenden Pakete haben unerfüllte Abhängigkeiten:
  • gnome-session-flashback : Hängt ab von: metacity (>= 3.17.2) soll aber nicht installiert werden
  • E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.


Und dann diese:

  • sudo apt-get install ubuntu-desktop
  • Paketlisten werden gelesen... Fertig
  • Abhängigkeitsbaum wird aufgebaut.
  • Statusinformationen werden eingelesen.... Fertig
  • Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
  • Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
  • Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
  • nicht erstellt wurden oder Incoming noch nicht verlassen haben.
  • Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:
  • * Die folgenden Pakete haben unerfüllte Abhängigkeiten:
  • ubuntu-desktop : Hängt ab von: unity soll aber nicht installiert werden


und noch eine:

  • sudo apt install ubuntu-desktop unity
  • Paketlisten werden gelesen... Fertig
  • Abhängigkeitsbaum wird aufgebaut.
  • Statusinformationen werden eingelesen.... Fertig
  • Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
  • Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
  • Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
  • nicht erstellt wurden oder Incoming noch nicht verlassen haben.
  • Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:
  • * Die folgenden Pakete haben unerfüllte Abhängigkeiten:
  • unity
    : Hängt ab von: libunity-core-6.0-9 (= 7.4.0+16.04.20160415-0ubuntu1)
    aber 7.4.5+16.04.20180221-0ubuntu1 soll installiert werden
  • Hängt ab von: compiz-core-abiversion-20151010
  • Empfiehlt: unity-scope-manpages soll aber nicht installiert werden
  • Empfiehlt: unity-lens-files soll aber nicht installiert werden
  • Empfiehlt: unity-scope-tomboy soll aber nicht installiert werden
  • Empfiehlt: unity-scope-colourlovers soll aber nicht installiert werden
  • Empfiehlt: unity-scope-yelp soll aber nicht installiert werden
  • Empfiehlt: unity-scope-gdrive soll aber nicht installiert werden
  • Empfiehlt: unity-scope-zotero soll aber nicht installiert werden
  • Empfiehlt: unity-scope-texdoc soll aber nicht installiert werden
  • Empfiehlt: unity-lens-photos soll aber nicht installiert werden
  • Empfiehlt: unity-scope-chromiumbookmarks soll aber nicht installiert werden
  • Empfiehlt: unity-lens-video soll aber nicht installiert werden
  • Empfiehlt: unity-lens-music soll aber nicht installiert werden
  • Empfiehlt: unity-scope-openclipart soll aber nicht installiert werden
  • Empfiehlt: unity-scope-firefoxbookmarks soll aber nicht installiert werden
  • Empfiehlt: unity-lens-applications soll aber nicht installiert werden
  • Empfiehlt: unity-scope-calculator soll aber nicht installiert werden
  • Empfiehlt: unity-scope-devhelp soll aber nicht installiert werden
  • Empfiehlt: unity-scope-virtualbox soll aber nicht installiert werden
  • Empfiehlt: unity-scope-video-remote soll aber nicht installiert werden
  • Empfiehlt: indicator-appmenu (>= 15.02.0) soll aber nicht installiert werden
  • Empfiehlt: session-shortcuts soll aber nicht installiert werden
  • E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.


dieses Problem habe ich auch:

  • sudo apt install gnome-session-flashback metacity
  • Paketlisten werden gelesen... Fertig
  • Abhängigkeitsbaum wird aufgebaut.
  • Statusinformationen werden eingelesen.... Fertig
  • Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
  • Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
  • Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
  • nicht erstellt wurden oder Incoming noch nicht verlassen haben.
  • Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:
  • * Die folgenden Pakete haben unerfüllte Abhängigkeiten:
  • metacity : Hängt ab von: metacity-common (= 1:3.18.3-1ubuntu3) aber 1:3.18.7-0ubuntu0.3 soll installiert werden
  • E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.



Was kann ich tun?
Vielen Dank!!

  • »Klaus P« ist männlich

Beiträge: 4 532

Registrierungsdatum: 25.10.2009

Derivat: anderes Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: 7/10

  • Nachricht senden

2

25.11.2018, 17:50

Hallo!

Gib mal diese Befehle (alle) nacheinander ins Terminal ein:

Quellcode

1
2
3
4
5
sudo dpkg --configure -a
sudo apt update
sudo apt full-upgrade
sudo apt-get autoremove
sudo apt-get -f install


Das soll folgendes bewirken:
-Konfigurieren, was noch konfigurierbar vorhanden ist
-Paketlisten neu einlesen
-Alle Pakete auf den neuesten Stand bringen
-Unbenötigte entfernen
-Fehlende Abhängigkeiten nachinstallieren


Gruß
Des modernen Menschen Computer ist sein Himmelreich! :rolleyes: Der Weg zur Hölle, ist allzu kurz auf dem falschen "EFI-Pfad" ;( : Kleiner Leitfaden zur UEFI-Installation

3

25.11.2018, 22:15

--
Verschoben aus "Manuelles Installieren von Programmen". Bitte die Forenbeschreibungen beachten, danke!

--
Terminal-Ausgaben zur besseren Lesbarkeit bitte in Code-Blöcke setzen. Das funktioniert nur im Quelltext-Modus des Editors!
mir is wurscht