Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Sjard

User

  • »Sjard« ist männlich
  • »Sjard« ist der Autor dieses Themas

Beiträge: 11

Registrierungsdatum: 09.05.2017

Derivat: Kubuntu

Version: Ubuntu 18.04 LTS - Bionic Beaver

Architektur: 64-Bit PC

Desktop: KDE4

Andere Betriebssysteme: Manjaro Xfce, Win10

  • Nachricht senden

1

23.11.2018, 11:14

Mupen64Plus und die liebe lib

Hallo Ihr Lieben,

ich hab wieder ein Luxusproblem: die Installation von Mupen64Plus (v.2.5) via github-Seite (ubuntu-bundle -> shell-Datei) war kein Problem. Ebenso wie die Installation des Frontend M64Py (.deb). M64qt hab ich irgendwie nicht kompiliert gekriegt. Keine Ahnung, was da nicht wollte wie sollte.

Nun, das Problem ist, dass beim Start von M64Py die Fehlermeldung kam, die library sei nicht gefunden worden. Also hab ich brav den richtigen Pfad wie im Wiki (https://wiki.ubuntuusers.de/Mupen64Plus/) beschrieben herausgefunden. Und diese Datei samt Pfad hab ich bei M64Py im Librarypfad eingefügt; seither startet das Frontend nicht einmal. Ab un an bequemt es sich Minuten später zu einer Fehlermeldung, von wegen unerwartet frühzeitig beendet... Allerdings hab ich bei der graphischen "Durchsuchen"-Auswahl des Bibliothekenpfads die im selben Ordner vorhandene Datei libmupen64plus.so.2 aus Versehen ausgewählt, statt die soeben genannte. Ich kann mir also gut vorstellen, dass deswegen nüscht mehr klappt. >_<

a) Wie kann ich diese falsche Pfandangabe wieder herausoperieren?

b) Wie löse ich allgemein das Problem mit der lib?

Das Problem dürfte wohl auch bei RetroArch vorgelegen haben, da aber offenbar ohne Fehlermeldung. Nach Auswahl des cores und der Spieldatei kam einfach nur ein schwarzer Bildschirm...

Bei Mupen64Plus hab ich es natürlich zunächst noch übers Terminal versucht:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
mupen64plus --corelib /usr/lib/x86_64-linux-gnu/libmupen64plus.so.2.0.0 ~/Downloads/star_wars_rogue_squadron.z64 
 __  __                         __   _  _   ____  _             
|  \/  |_   _ _ __   ___ _ __  / /_ | || | |  _ \| |_   _ ___ 
| |\/| | | | | '_ \ / _ \ '_ \| '_ \| || |_| |_) | | | | / __|  
| |  | | |_| | |_) |  __/ | | | (_) |__   _|  __/| | |_| \__ \  
|_|  |_|\__,_| .__/ \___|_| |_|\___/   |_| |_|   |_|\__,_|___/  
             |_|         http://code.google.com/p/mupen64plus/  
Mupen64Plus Console User-Interface Version 2.5.0

UI-Console: attached to core library 'Mupen64Plus Core' version 2.5.0
UI-Console:             Includes support for Dynamic Recompiler.
UI-Console:             Includes support for MIPS r4300 Debugger.
Core: Goodname: Star Wars - Rogue Squadron (E) (M3) (V1.1) [!]
Core: Name: rogue squadron      
Core: MD5: A9DD498E6A28F55311CE4EF057E164B8
Core: CRC: 219191C1 33183C61
Core: Imagetype: .z64 (native)
Core: Rom size: 16777216 bytes (or 16 Mb or 128 Megabits)
Core: Version: 1444
Core: Manufacturer: Nintendo
Core: Country: Unknown (0x150)
UI-Console Status: Cheat codes disabled.
UI-Console Error: dlopen('/usr/local/lib/mupen64plus/mupen64plus-video-rice.so') failed: libpng12.so.0: cannot open shared object file: No such file or directory
UI-Console Error: dlopen('/usr/local/lib/mupen64plus/mupen64plus-audio-sdl.so') failed: libSDL-1.2.so.0: cannot open shared object file: No such file or directory
UI-Console Error: dlopen('/usr/local/lib/mupen64plus/mupen64plus-input-sdl.so') failed: libSDL-1.2.so.0: cannot open shared object file: No such file or directory
UI-Console Error: dlopen('/usr/local/lib/mupen64plus/mupen64plus-video-rice.so') failed: libpng12.so.0: cannot open shared object file: No such file or directory
UI-Console Error: dlopen('/usr/local/lib/mupen64plus/mupen64plus-video-glide64mk2.so') failed: libpng12.so.0: cannot open shared object file: No such file or directory
UI-Console: using Video plugin: <dummy>
UI-Console Error: dlopen('/usr/local/lib/mupen64plus/mupen64plus-audio-sdl.so') failed: libSDL-1.2.so.0: cannot open shared object file: No such file or directory
UI-Console Error: dlopen('/usr/local/lib/mupen64plus/mupen64plus-audio-sdl.so') failed: libSDL-1.2.so.0: cannot open shared object file: No such file or directory
UI-Console Error: dlopen('/usr/local/lib/mupen64plus/mupen64plus-input-sdl.so') failed: libSDL-1.2.so.0: cannot open shared object file: No such file or directory
UI-Console Error: dlopen('/usr/local/lib/mupen64plus/mupen64plus-video-rice.so') failed: libpng12.so.0: cannot open shared object file: No such file or directory
UI-Console Error: dlopen('/usr/local/lib/mupen64plus/mupen64plus-video-glide64mk2.so') failed: libpng12.so.0: cannot open shared object file: No such file or directory
UI-Console: using Audio plugin: <dummy>
UI-Console Error: dlopen('/usr/local/lib/mupen64plus/mupen64plus-input-sdl.so') failed: libSDL-1.2.so.0: cannot open shared object file: No such file or directory
UI-Console Error: dlopen('/usr/local/lib/mupen64plus/mupen64plus-audio-sdl.so') failed: libSDL-1.2.so.0: cannot open shared object file: No such file or directory
UI-Console Error: dlopen('/usr/local/lib/mupen64plus/mupen64plus-input-sdl.so') failed: libSDL-1.2.so.0: cannot open shared object file: No such file or directory
UI-Console Error: dlopen('/usr/local/lib/mupen64plus/mupen64plus-video-rice.so') failed: libpng12.so.0: cannot open shared object file: No such file or directory
UI-Console Error: dlopen('/usr/local/lib/mupen64plus/mupen64plus-video-glide64mk2.so') failed: libpng12.so.0: cannot open shared object file: No such file or directory
UI-Console: using Input plugin: <dummy>
UI-Console: using RSP plugin: 'Hacktarux/Azimer High-Level Emulation RSP Plugin' v2.5.0
Core Warning: No video plugin attached.  There will be no video output.
Core Warning: No audio plugin attached.  There will be no sound output.
Core Warning: No input plugin attached.  You won't be able to control the game.
Core Warning: OpenGL function glActiveTexture() not supported.  OSD deactivated.
Core: Starting R4300 emulator: Dynamic Recompiler
Core: R4300: starting 64-bit dynamic recompiler at: 0x7f4b485ba860


...in diesem Zustand verharrt das Terminal.

Ich versteh mittlerweile nur noch Bahnhof. Könnte mir jemand bitte einen Wink mim Zaunpfahl geben? :)

LG Sjard