Sie sind nicht angemeldet.

Ubuntu 16.04 LTS - Xenial Xerus - single/dual-boot - Zweite Festplatte wird nicht erkannt, UEFI-Frage

zebra

User

  • »zebra« ist der Autor dieses Themas

Beiträge: 2

Registrierungsdatum: 17.08.2018

Derivat: Ubuntu

Version: Ubuntu 16.04 LTS - Xenial Xerus

Architektur: 64-Bit PC

Desktop: Mate

  • Nachricht senden

1

17.08.2018, 22:07

Zweite Festplatte wird nicht erkannt, UEFI-Frage

Das System läuft auf der ersten Festplatte (SSD am ersten SATA-Platz des Mainboards), die mit ihren Partitionen als sda erkannt wird.

Die zweite, neu gekaufte, noch nicht bearbeitete (formatierung, partitionierung) Festplatte ist jetzt auf SATA-Platz 4 mit dem Mainboard verbunden, davor hatte ich es Auf SATA-Platz 2 probiert, erscheint aber weder in "Orte" noch in gparted, noch sonst.

Beim Hochfahren nach dem Einbau der Platte erschienen ungewohnte Anzeigen:

166...(langeZahl)....92 softreset failed (device not ready)

dies Zeile wiederholte sich mit anderen, noch längeren Zahlen mehrmals.

Wie komme ich an die neue Platte ran?

Weitere Überlegung

Edit: Wahrscheinlich bin ich hier erstmal im falschen Abteil des Forums gelandet. Dass es einen Extra-Forums-Bereich für Hardware-Probleme gibt, hatte ich heute nacht nicht geblickt, SORRY. Aber vielleicht bin ich jetzt ja doch im richtigen, nämlich im Installationproblem-Forum, weil ich eine andere Strategie überlegt habe.


Ursprünglich wollte ich die zweite Platte nur als Datenspeicher haben, aber inzwischen habe ich überlegt, ob ich von einer Installations-CD aus am leichtesten die Möglichkeit hätte auf die neue Platte zuzugreifen.
Neuer Plan mit der Frage ob das funktionieren könnte:


Ich würde die erste Platte SSD auf SATA-1 ausstöpseln und mit einer Installations-CD versuchen auf der verbleibenden zweiten Platte Bionic Beaver in eine kleine Partition zu installieren.
Dann wäre die zweite Platte hoffentlich soweit Ubuntu-fähig gemacht, dass sie nach wieder angestöpselter erster Platte auch vom dort befindlichen Xenial aus erkannt würde, so dass ich dann den restlichen Platz auf der Platte als Datenspeicher für Xenial verwenden könnte.


Fragen:


Lässt EFI das mit sich machen, ohne dass es zu Komplikationen kommt, spätestens wenn dann beide Platten mit zwei Systemen (Xenial und Bionic) angestöpselt sind?
Ich habe mir zwar verschiedene Artikel zu (U)EFI durchgelesen, aber nur bruchstückweise verstanden und früher auf BIOS konnte ich auch nur die Boot-Reihenfolge einstellen, alles andere war mir Dschungel (soviel zur Einschätzung meiner Computer-Fähigkeiten).


Oder würde das schon vorher scheitern, weil das Festplatten-Erkennungsproblem ganz woanders liegt und da auch eine Installations-CD nicht helfen könnte?


Falls letzteres der Fall wäre oder der neue Plan sowieso zu kompliziert würde, bitte ich den Moderator, meine Frage doch in den Hardware-Bereich zu verschieben.


Mit freundlichen Grüßen und der Bitte um Hilfe


Zebra

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »zebra« (18.08.2018, 08:58) aus folgendem Grund: weitere Überlegung via Installation


Beiträge: 836

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

Andere Betriebssysteme: Debian 9.5 "stretch" / 4.9.0-8-amd64

  • Nachricht senden

2

18.08.2018, 12:42

Ich würde mit einer Live CD erstmal einen fsck bei der Platte machen. Korrekt angeschlossen ist Sie?
Auch mal mit smartctl testen auf Fehler.


https://wiki.ubuntuusers.de/Dateisystemc…nuelle-Pruefung
Hast Du Schnotten an der Nase, bist Du in der Schnupfenphase! :)












banane tanzt.gif

  • »Klaus P« ist männlich

Beiträge: 4 526

Registrierungsdatum: 25.10.2009

Derivat: anderes Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: 7/10

  • Nachricht senden

3

18.08.2018, 17:50

Hallo!

Wird die Platte denn im Set-Up (UEFI/BIOS) erkannt? Zu der Fehlermeldung "92 soft.........." gibt es ja haufenweise Beiträge zu finden. Ggf. mal nachschauen! Ansonsten siehe Link des Kollegen!

Zitat

aber inzwischen habe ich überlegt, ob ich von einer Installations-CD aus am leichtesten die Möglichkeit hätte auf die neue Platte zuzugreifen.
Wenn sie nicht erkannt wird, wird sie eben nicht erkannt. Ein Livesystem ändert daran nichts. Die Software ist ja die gleiche wie im fest installierten System.

Zitat

Lässt EFI das mit sich machen,....
Das hat nichts mit UEFI zu tun. Die Platte ist das Problem!

Die UEFI-Installation unterscheidet sich nicht großartig von der klassischen. Man muss nur relativ wenig beachten. Mehr dazu siehe unten! Das Problem ist oft die Firmware der Hersteller, die hier Murks am Fliessband auf die Menschheit los lassen. Immerhin, du hast ja schon eine Linuxinstallation drauf. Liefere aus der ggf. ein paar Infos. Z.B.

Quellcode

1
2
sudo parted -l  ## l = kleines L
sudo fdisk -l  ## dto.
. Dann weiss man mehr zum Modus und der Belegung!

Gruß
Des modernen Menschen Computer ist sein Himmelreich! :rolleyes: Der Weg zur Hölle, ist allzu kurz auf dem falschen "EFI-Pfad" ;( : Kleiner Leitfaden zur UEFI-Installation

zebra

User

  • »zebra« ist der Autor dieses Themas

Beiträge: 2

Registrierungsdatum: 17.08.2018

Derivat: Ubuntu

Version: Ubuntu 16.04 LTS - Xenial Xerus

Architektur: 64-Bit PC

Desktop: Mate

  • Nachricht senden

4

19.08.2018, 20:30

Hallo Ihr Beiden, Danke für Eure Antworten!

bei sudo parted -l erscheint nur die erste Platte:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
Modell: ATA Samsung SSD 850 (scsi)
Festplatte /dev/sda: 250GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: gpt
Disk-Flags: 

Nummer Anfang Ende Größe Dateisystem Name Flags
 1 1049kB 58,7MB 57,7MB fat32 boot, esp
 2 58,7MB 246GB 246GB ext4
 3 246GB 250GB 4162MB linux-swap(v1)


Modell: Linux device-mapper (crypt) (dm)
Festplatte /dev/mapper/cryptswap1: 4161MB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: loop
Disk-Flags: 

Nummer Anfang Ende Größe Dateisystem Flags
 1 0,00B 4161MB 4161MB linux-swap(v1)



bei fsck ebenso:
fsck /dev/sdb
fsck von

Quellcode

1
fsck /dev/sdbfsck von util-linux 2.27.1e2fsck 1.42.13 (17-May-2015)fsck.ext2: Datei oder Verzeichnis nicht gefunden beim Versuch, /dev/sdb zu öffnenIst das Gerät möglicherweise nicht vorhanden?
util-linux 2.27.1
e2fsck 1.42.13 (17-May-2015)
fsck.ext2: Datei oder Verzeichnis nicht gefunden beim Versuch, /dev/sdb zu öffnen
Ist das Gerät möglicherweise nicht vorhanden?




Ist auf einer neugekauften Platte überhaupt ein fs drauf? Das wird doch erst beim Partitionieren erstellt?

Das Stromversorgungskabel der Platte vom Netzteil habe ich ein paarmal aus- und wieder eingesteckt, ebenso das Datenkabel, auch auf verschiedenen Steckplätzen probiert.
Irgendwas wird erkannt. Das Hochfahren des Computers dauert deutlich länger als sonst und er macht Klackgeräusche.

Ich bin ratlos.

Gruß
Zebra

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »zebra« (19.08.2018, 20:38)


Beiträge: 836

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

Andere Betriebssysteme: Debian 9.5 "stretch" / 4.9.0-8-amd64

  • Nachricht senden

5

20.08.2018, 00:55

Was kommt denn bei:

Quellcode

1
sudo blkid


Scheint ja fast so, als würde sie null erkannt. Als wäre sie defekt.
Hast Du Schnotten an der Nase, bist Du in der Schnupfenphase! :)












banane tanzt.gif