Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Sjard

User

  • »Sjard« ist männlich
  • »Sjard« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 09.05.2017

Derivat: Ubuntu

Version: Ubuntu 16.04 LTS - Xenial Xerus

Architektur: 64-Bit PC

Desktop: KDE4

  • Nachricht senden

1

12.06.2018, 21:30

XDG_RUNTIME_DIR not set?

Liebe Ubuntu-Gemeinde,

ich habe ein kleines Problem mit dem Programm usb-creator-kde, das ich (mit gleichlautenden Paketnamen) aus den offiziellen Quellen soweit ohne Probleme installiert habe. Beim Start erscheint aber ein Dialogfenster, das weder nach einer Autorisierung noch sonstigem fragt, beim Schließen aber, ob ich die Installation (!) wirklich abbrechen wolle. Führe ich das Programm im Terminal aus, kommt zusätzlich folgende Ausgabe:

Quellcode

1
2
3
4
5
6
7
8
 sjard@Mechthild:~$ sudo usb-creator-kde
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
qt.svg: QSvgHandler: Image filename is empty
qt.svg: /usr/share/icons/hicolor/scalable/apps/usb-creator-kde.svg:1584:45: Could not resolve property: linearGradient5167
qt.svg: QSvgHandler: Image filename is empty
qt.svg: /usr/share/icons/hicolor/scalable/apps/usb-creator-kde.svg:1584:45: Could not resolve property: linearGradient5167
qt.svg: QSvgHandler: Image filename is empty
qt.svg: /usr/share/icons/hicolor/scalable/apps/usb-creator-kde.svg:1584:45: Could not resolve property: linearGradient5167 


Ich nutze übrigens Kubuntu Bionic (was in meinem Profil hier noch nicht anzugeben ist).

Wie gehe ich am besten vor? Die im Netz angebotenen Lösungsmöglichkeiten bezogen sich auf alte Ubuntuversionen, andere Distros und andere Programme mit entsprechend starken Abweichungen voneinander, sodass lieber vorher hier nachfrage.

LG Sjard

  • »alt-medregnet« ist männlich

Beiträge: 560

Registrierungsdatum: 22.01.2015

Derivat: Ubuntu GNOME

Architektur: 32-Bit PC

Desktop: GNOME 3.0

Andere Betriebssysteme: Siduction (Debian 64 Bit), Ubuntu XFCE (64 Bit), Windows 10

  • Nachricht senden

2

14.06.2018, 15:34

aus den offiziellen Quellen soweit ohne Probleme installiert habe

Hallo Sjard!
Hattest du damals per Terminal installiert?

Deinstalliere doch mal

Quellcode

1
sudo apt-get --purge usb-creator-kde 

und installiere noch einmal

Quellcode

1
sudo apt-get install usb-creator-kde

Läuft das im Terminal fehlerfrei ab?

Gruss Uli

Beiträge: 722

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

Andere Betriebssysteme: Debian 10 / 4.15.0-3-amd64

  • Nachricht senden

3

14.06.2018, 16:33

Die Meldung hat damit zu tun, dass bei der genannten Variable kein /tmp gesetzt.

Was da neu installieren bringen soll, erschließt sich mir nicht.

Starte mal so:

Quellcode

1
sudo -E usb-creator-kde


Wobei sich mir die Frage stellt, ob man das Programm überhaupt mit root Rechten ausführen muss, oder als User. Das solltest Du noch prüfen.
Ich kenne die Anwendung und KDE nicht. Unter gewissen Umständen könntest Du Dir sogar Rechte im /home/user dadurch verändern, was
zu Folgeproblemen führen könnte. Hab ich aber nicht weiter überprüft.

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Horsemanchip« (14.06.2018, 22:21)


  • »alt-medregnet« ist männlich

Beiträge: 560

Registrierungsdatum: 22.01.2015

Derivat: Ubuntu GNOME

Architektur: 32-Bit PC

Desktop: GNOME 3.0

Andere Betriebssysteme: Siduction (Debian 64 Bit), Ubuntu XFCE (64 Bit), Windows 10

  • Nachricht senden

4

14.06.2018, 19:35

Was da neu installieren bringen soll, erschließt sich mir nicht.

Hallo Horsemanchip!
Der Gedanke war: Vielleicht hat es ja doch eine Fehlermeldung gegeben? Im Terminal hätte man die gesehen.
Aus den offiziellen Quellen soweit ohne Probleme installiert ist etwas schwammig.

Gruss

Beiträge: 722

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

Andere Betriebssysteme: Debian 10 / 4.15.0-3-amd64

  • Nachricht senden

5

14.06.2018, 22:17

Der Gedanke war: Vielleicht hat es ja doch eine Fehlermeldung gegeben? Im Terminal hätte man die gesehen.


Wenn man schauen möchte, ob das Paket korrekt installiert wurde, fragt man besser dpkg:

Quellcode

1
dpkg -l usb-creator-kde


Das finde ich praktikabler als stumpf drüber bügeln.