Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

  • »spykie« ist der Autor dieses Themas

Beiträge: 1

Registrierungsdatum: 08.05.2018

Derivat: Kein Ubuntu-Derivat

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: Windows 10, Windows 8, Ubuntu Server

  • Nachricht senden

1

08.05.2018, 19:10

Probleme mit Autostart /etc/rc.local

Hallo,

ich habe mir Ubuntu Server installiert. Ich wurschtel mich aktuell ins Thema Ubuntu und weiß bereits einiges aber mit Sicherheit noch lange nicht alles.

Mein Problem ist das der Server beim Start ein paar Netzlaufwerke mounten soll. Sofern ich nach dem booten den Befehl eingebe klappt das auch. Jedoch nicht automatisch. Ich habe folgende Anleitung in diversen Sprachen gefunden und bin nach dieser auch vorgegangen.

https://4noobs.de/viewtopic.php?t=69

Prinzipiell klappt auch alles bis auf diesen Befehl: sudo systemctl enable rc-local

Dabei kommt folgende Meldung:

Zitat

The unit files have no installation config (WantedBy, RequiredBy, Also, Alias
settings in the [Install] section, and DefaultInstance for template units).
This means they are not meant to be enabled using systemctl.
Possible reasons for having this kind of units are:
1) A unit may be statically enabled by being symlinked from another unit's
.wants/ or .requires/ directory.
2) A unit's purpose may be to act as a helper for some other unit which has
a requirement dependency on it.
3) A unit may be started when needed via activation (socket, path, timer,
D-Bus, udev, scripted systemctl call, ...).
4) In case of template units, the unit is meant to be enabled with some
instance name specified.

Wenn ich den Dienst anhand manuell mit den in dem Beitrag aufgeführten Befehle starte läuft es auch und alle LAufwerke werden gemountet, Jedoch nur bis zum näöchsten Neustart.

Was mache ich falsch?

Installiert habe ich Ubuntu Server 18.04 LTS

LG Christian

Beiträge: 693

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

Andere Betriebssysteme: Debian 10 / 4.15.0-3-amd64

  • Nachricht senden

2

09.05.2018, 14:03

Zeige mal den kompletten Inhalt der Datei:

/etc/systemd/system/rc-local.service

Und poste mal die Ausgabe von dem Kommando:

Quellcode

1
ls -la /etc/rc.local

Zurzeit ist neben Ihnen 1 Benutzer in diesem Thema unterwegs:

1 Besucher