Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

  • »P.Kalb« ist der Autor dieses Themas

Beiträge: 27

Registrierungsdatum: 07.02.2018

Derivat: Xubuntu

Version: Ubuntu 16.04 LTS - Xenial Xerus

Architektur: 32-Bit PC

Desktop: XFCE

Andere Betriebssysteme: Windows7

  • Nachricht senden

1

07.02.2018, 16:23

Desktop verschwunden und Anmeldung nicht mehr möglich

Hallo liebe Ubuntu-Gemeinde,

seit dem letzten Update habe ich ein Problem mit der Anmeldung und dem Desktop. Erst konnte ich mich noch anmelden, aber es erschienen nur das Hintergrundbild ohne Anwendungen. Ich konnte aber noch im Terminal arbeiten, oder die Programme über Strg + F2 aufrufen. Nachdem ich einiges probiert hatte, was ich im Forum gelesen habe, versuchte ich mich als Gast anzumelden. Dort war es genauso, nur kam ich dann nicht mehr raus, weil ja keine Anwendungen zu sehen waren. Also ließ ich ihn neu hochfahren und seitdem komme ich gar nicht mehr hinein, sondern hänge in einer Endlosschleife bei der Anmeldung, die immer wieder neu erscheint.

Über die Konsole haben wir einige Anweisungen aus dem Forum ausprobiert ohne Erfolg.
XAuthority findet er nicht.
.cache findet er nicht.
Desktop findet er nicht.

Es scheint fast, als würde die Anmeldung ins Leere laufen und immer wieder zu sich selbst zurückkehren.

Wiederherstellung über Recovery hat ebenfalls nicht funktioniert.

Für Hilfe wäre ich sehr dankbar. Derzeit schreibe ich über Windows7, da ich ein Dualbootsystem habe. Deshalb kann es etwas dauern, bis ich Eure Tipps umgesetzt habe und wieder hier bin, um sagen zu können, ob es etwas gebracht hat oder nicht.

Ich habe Xubuntu 16.04.
Dualbootsystem mit Windows 7
32 bit
Desktop war xfce
Grafikkarte NVidia

Falls ihr noch was wissen müsst, gebt mir bitte Bescheid, da ich kein Computerspezialist bin, aber dafür ein begeisterter Linuxianer mit rudimentärem Wissen ;)


Liebe Grüße
P.Kalb

Beiträge: 626

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: unbekannt

Desktop: unbekannt

Andere Betriebssysteme: Linux 3.16.0-4-686-pae

  • Nachricht senden

2

07.02.2018, 17:11

Wenn es erst noch ging und dann nach und nach nicht mehr, liegt die Vermutung nahe, dass die Festplatte vollgelaufen ist. Die Login Schleife kann durch veränderte Zugehörigkeitsrechte von:

.Xauthority
.ICEauthority

stammen. Musst Du mal im recovery Modus den PC starten (Auswahl in Grub) und dann folgendes prüfen:

Quellcode

1
2
3
4
5
df -h

ls -la /home/DEINUSERNAME/.Xauthority

ls -la /home/DEINUSERNAME/.ICEauthority


Die Punkte sind wichtig.
Informative Videos ohne Windows, für ALLE zum anschauen:

Click me!

NEUER VIRUS, DER FÜR JEDEN GEFÄHRLICH WERDEN KANN -> Infolink

  • »P.Kalb« ist der Autor dieses Themas

Beiträge: 27

Registrierungsdatum: 07.02.2018

Derivat: Xubuntu

Version: Ubuntu 16.04 LTS - Xenial Xerus

Architektur: 32-Bit PC

Desktop: XFCE

Andere Betriebssysteme: Windows7

  • Nachricht senden

3

07.02.2018, 17:50

df -h verwendet 21%

.Xauthority keine Berechtigung
.ICEauthority ungültige Option

Das wurde mir so angezeigt. Also habe ich meine Berechtigung irgendwie verloren, oder ?

Beiträge: 626

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: unbekannt

Desktop: unbekannt

Andere Betriebssysteme: Linux 3.16.0-4-686-pae

  • Nachricht senden

4

07.02.2018, 20:03

Hast Du das als root gemacht im recovery modus?

Ich glaube Du hast nicht gemacht, was ich gesagt habe. Die Fehlermeldungen sind auch nicht original vom System.

Du sollst im recovery Modus als root die beiden ls Kommandos absetzen. Wenn da steht "keine Berechtigung" bist Du nicht root und wenn da steht "ungültige Option" hast Du vermutlich das Kommando falsch geschrieben.

Die Ausgabe, die ich erwarte sollte zum Beispiel so aussehen:

Quellcode

1
2
3
-rw------- 1 root root 51 Feb  7 05:06 .Xauthority

-rw------- 1 root root 578 Jun 22  2015 .ICEauthority
Informative Videos ohne Windows, für ALLE zum anschauen:

Click me!

NEUER VIRUS, DER FÜR JEDEN GEFÄHRLICH WERDEN KANN -> Infolink

  • »P.Kalb« ist der Autor dieses Themas

Beiträge: 27

Registrierungsdatum: 07.02.2018

Derivat: Xubuntu

Version: Ubuntu 16.04 LTS - Xenial Xerus

Architektur: 32-Bit PC

Desktop: XFCE

Andere Betriebssysteme: Windows7

  • Nachricht senden

5

08.02.2018, 01:53

Vielleicht gehe ich falsch rein? Ich habe es jetzt nochmal versucht über Recovery und dann in root und es erscheint wieder : Zugriff nicht möglich : Datei und Verzeichnis nicht gefunden

  • »P.Kalb« ist der Autor dieses Themas

Beiträge: 27

Registrierungsdatum: 07.02.2018

Derivat: Xubuntu

Version: Ubuntu 16.04 LTS - Xenial Xerus

Architektur: 32-Bit PC

Desktop: XFCE

Andere Betriebssysteme: Windows7

  • Nachricht senden

6

08.02.2018, 19:43

Ich habe jetzt eine Live-CD eingelegt und versuche darüber Zugriff auf meinen Computer zu bekommen. Es scheint jedoch irgendwie nicht zu funktionieren. Folgende Meldung habe ich gerade bekommen:

xubuntu@xubuntu:~$ sudo mount /dev/sda1 /mnt/boot
Mount is denied because the NTFS volume is already exclusively opened.
The volume may be already mounted, or another software may use it which
could be identified for example by the help of the 'fuser' command.

Hat jemand einen Tipp für mich, wie ich weitermachen kann?

Liebe Grüße
P.Kalb

7

09.02.2018, 14:19

/dev/sda1 ist offensichtlich eine Windows-Partition. Hat hier keinen Sinn die zu mounten.

Du solltest erstmal den Vorschlag von horsemanchip erfolgreich zu Ende bringen. "DEINUSERNAME" musst du natürlich durch deinen normalen Login-Namen ersetzen.
Wenn das wieder nicht klappt zeig uns die Ausgabe von

Quellcode

1
ls -l /home/


Das alles aus dem Recovery-Mode/root-shell.
mir is wurscht

  • »P.Kalb« ist der Autor dieses Themas

Beiträge: 27

Registrierungsdatum: 07.02.2018

Derivat: Xubuntu

Version: Ubuntu 16.04 LTS - Xenial Xerus

Architektur: 32-Bit PC

Desktop: XFCE

Andere Betriebssysteme: Windows7

  • Nachricht senden

8

09.02.2018, 14:56

Habe jetzt meinen Fehler gefunden und die Anweisungen von horseman noch einmal durchgeführt.

ls: Zugriff auf .Xauthority nicht möglich: Datei oder Verzeichnis nicht gefunden.

drwx ------ 3 root root 4096 Feb 6 17:00 .
drwxr -xr-x 4 root root 4096 Feb 6 17.00 ..
drwxr ------ 3 root root 4096 Feb. 6. 17:00 -cache

Das gleiche wurde aufgeführt bei ICEauthority

Dann habe ich in einem anderen Thread im Forum gefunden, dass das so auf keinen Fall aussehen darf. Daraufhin habe ich folgende Anweisungen in der Konsole eingegeben:

sudo chown -R Benutzername:Benutzername /home/Benutzername

Jetzt kann ich mich anmelden, bin aber scheinbar auf einem neuen Xubuntu, ohne Panel nur mit Ordnern und HIntergrundbild. Meine ganzen Daten sind nicht vorhanden, als wäre es ein neues System.

Entschuldigung für die Anfängerfehler. Wir haben noch nicht soviele Probleme mit unserem Xubuntu gehabt, sodass wir diese Arbeiten in Konsole, oder Terminal nicht wirklich kennen. Vielen Dank für die Geduld.

Beiträge: 626

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: unbekannt

Desktop: unbekannt

Andere Betriebssysteme: Linux 3.16.0-4-686-pae

  • Nachricht senden

9

09.02.2018, 15:12

Also es scheint deine /home Partition weg zu sein. Ich sehe da keinen Eintrag für einen User.

Poste doch mal die Ausgaben von:

Quellcode

1
2
3
sudo blkid

mount
Informative Videos ohne Windows, für ALLE zum anschauen:

Click me!

NEUER VIRUS, DER FÜR JEDEN GEFÄHRLICH WERDEN KANN -> Infolink

  • »P.Kalb« ist der Autor dieses Themas

Beiträge: 27

Registrierungsdatum: 07.02.2018

Derivat: Xubuntu

Version: Ubuntu 16.04 LTS - Xenial Xerus

Architektur: 32-Bit PC

Desktop: XFCE

Andere Betriebssysteme: Windows7

  • Nachricht senden

10

09.02.2018, 15:27

Da kommt eine ellenlange Geschichte, die ich Dir gerne zeigen möchte. Kannst Du mir vielleicht sagen, wie ich die Angaben im Terminal kopieren und hier einfügen kann? Das würde mir sehr helfen. STRG-C funktioniert jedenfalls nicht und auch Rechtsklick geht nicht.

  • »P.Kalb« ist der Autor dieses Themas

Beiträge: 27

Registrierungsdatum: 07.02.2018

Derivat: Xubuntu

Version: Ubuntu 16.04 LTS - Xenial Xerus

Architektur: 32-Bit PC

Desktop: XFCE

Andere Betriebssysteme: Windows7

  • Nachricht senden

11

09.02.2018, 15:51

sudo blkid

/dev/loop0: Type="squashfs"
/dev/loop1: Type="squashfs"
/dev/sda1: Label="HP Pavilion" UUID= ECBC935FBC93235E" Type="ntfs" PARTUUID= "17151714-01"
/dev/sda2: Label="HP Recovery" UUID="68OE-15F7" Type="vfat" PARTUUID "17151714-02"
/dev/sda5 UUID= "34df662a-f39a-4d8d-aa26-1152ch5d213b" Type="ext4" PARTUUID = "17151714-05"
/dev/sda6 UUID="e6102889-156d-454fa698-e50cd51cfb29" Type="swap" PARTUUID="17151714-06"
/dev/sdb1: LABEL="My passport" UUID="4E1AEA7B1AEA6007" Type="ntfs" PARTUUID="ac3adb47-01"

Beiträge: 626

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: unbekannt

Desktop: unbekannt

Andere Betriebssysteme: Linux 3.16.0-4-686-pae

  • Nachricht senden

12

09.02.2018, 16:03

Ok, Du hast nur 1 Linux Partition und kein seperates /home. Deine Partiton ist sda5.

Zeig doch mal folgende Ausgabe:

Quellcode

1
mount | grep sda5


Tipp: Kopieren aus dem Terminal mache ich immer so -> Text mit der Maus "markieren" und dann im Browser mit Klick aufs Scrollrad einfügen.
Informative Videos ohne Windows, für ALLE zum anschauen:

Click me!

NEUER VIRUS, DER FÜR JEDEN GEFÄHRLICH WERDEN KANN -> Infolink

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Horsemanchip« (09.02.2018, 16:14)


  • »P.Kalb« ist der Autor dieses Themas

Beiträge: 27

Registrierungsdatum: 07.02.2018

Derivat: Xubuntu

Version: Ubuntu 16.04 LTS - Xenial Xerus

Architektur: 32-Bit PC

Desktop: XFCE

Andere Betriebssysteme: Windows7

  • Nachricht senden

13

09.02.2018, 16:14

Leider funktioniert das kopieren bei mir nicht, weder mit STRG + Shift +C

Die Ausgabe ist wieder ellenlang. Ich werde mich mal schlau machen, wie ich das mit dem kopieren machen kann und mich dann wieder melden. Vielen Dank jedenfalls für die Hilfe.

Liebe Grüße
P. Kalb

14

09.02.2018, 21:01

Im einem "echten" Text-Terminal (also ohne grafischen Desktop) geht das Kopieren so nicht. Mach ausnahmsweise Bildschirmfotos und hänge sie hier als Datei an.
Ich würde gerne eines von diesem leeren Desktop mit den Ordnern sehen.
mir is wurscht

  • »P.Kalb« ist der Autor dieses Themas

Beiträge: 27

Registrierungsdatum: 07.02.2018

Derivat: Xubuntu

Version: Ubuntu 16.04 LTS - Xenial Xerus

Architektur: 32-Bit PC

Desktop: XFCE

Andere Betriebssysteme: Windows7

  • Nachricht senden

15

09.02.2018, 21:03

Jetzt habe ich das Terminal gewechselt auf Guake und jetzt funktioniert das kopieren. Folgendes kam unter mount / grep sda5

Usage:
mount [-lhV]
mount -a [options]
mount [options] [--source] <source> | [--target] <directory>
mount [options] <source> <directory>
mount <operation> <mountpoint> [<target>]

Mount a filesystem.

Optionen:
-a, --all mount all filesystems mentioned in fstab
-c, --no-canonicalize don't canonicalize paths
-f, --fake dry run; skip the mount(2) syscall
-F, --fork fork off for each device (use with -a)
-T, --fstab <path> alternative file to /etc/fstab
-i, --internal-only don't call the mount.<type> helpers
-l, --show-labels show also filesystem labels
-n, --no-mtab don't write to /etc/mtab
-o, --options <list> comma-separated list of mount options
-O, --test-opts <list> limit the set of filesystems (use with -a)
-r, --read-only mount the filesystem read-only (same as -o ro)
-t, --types <list> limit the set of filesystem types
--source <src> explicitly specifies source (path, label, uuid)
--target <target> explicitly specifies mountpoint
-v, --verbose say what is being done
-w, --rw, --read-write mount the filesystem read-write (default)

-h, --help display this help and exit
-V, --version output version information and exit

Source:
-L, --label <label> synonym for LABEL=<label>
-U, --uuid <uuid> synonym for UUID=<uuid>
LABEL=<label> specifies device by filesystem label
UUID=<uuid> specifies device by filesystem UUID
PARTLABEL=<label> specifies device by partition label
PARTUUID=<uuid> specifies device by partition UUID
<device> specifies device by path
<directory> mountpoint for bind mounts (see --bind/rbind)
<file> regular file for loopdev setup

Operations:
-B, --bind mount a subtree somewhere else (same as -o bind)
-M, --move move a subtree to some other place
-R, --rbind mount a subtree and all submounts somewhere else
--make-shared mark a subtree as shared
--make-slave mark a subtree as slave
--make-private mark a subtree as private
--make-unbindable mark a subtree as unbindable
--make-rshared recursively mark a whole subtree as shared
--make-rslave recursively mark a whole subtree as slave
--make-rprivate recursively mark a whole subtree as private
--make-runbindable recursively mark a whole subtree as unbindable

  • »P.Kalb« ist der Autor dieses Themas

Beiträge: 27

Registrierungsdatum: 07.02.2018

Derivat: Xubuntu

Version: Ubuntu 16.04 LTS - Xenial Xerus

Architektur: 32-Bit PC

Desktop: XFCE

Andere Betriebssysteme: Windows7

  • Nachricht senden

16

09.02.2018, 22:56

Hier der Screenshot

  • »alt-medregnet« ist männlich

Beiträge: 512

Registrierungsdatum: 22.01.2015

Derivat: Ubuntu GNOME

Architektur: 32-Bit PC

Desktop: GNOME 3.0

Andere Betriebssysteme: Siduction (Debian 64 Bit), Ubuntu XFCE (64 Bit), Windows 10

  • Nachricht senden

17

10.02.2018, 00:00

Hallo P.Kalb!
So ein leerer Desktop erscheint bei mir wenn ich den Desktop vom Root anzeige.
Als was bist du überhaupt angemeldet?

Quellcode

1
id
http://manpages.ubuntu.com/manpages/trusty/de/man1/id.1.html
Wieviel Benutzer hat dein System?

Quellcode

1
lastlog

Wenn kein Desktop kommt, könntest du auch mal die Tastenkombination Strg-Alt-F1 versuchen.

Funktioniert sudo rm ~/.Xauthority bzw. rm .xauthority && rm .iceauthority nicht, gibt es noch die Holzhammermethode, wenn ein Desktop nicht mehr startet ihn zu erneuern. Bei Unity ist das sudo apt-get install ubuntudesktop. Bei Xubuntu dürfte das dann wohl

Quellcode

1
sudo apt-get install xubuntu-desktop
sein, wenn ich mich nicht irre.
Aber Startprobleme sind vielfältig. Wenn es wirklich ein Benutzer-Problem ist, nutzt die Neuinstallation nicht viel.

Uli

  • »P.Kalb« ist der Autor dieses Themas

Beiträge: 27

Registrierungsdatum: 07.02.2018

Derivat: Xubuntu

Version: Ubuntu 16.04 LTS - Xenial Xerus

Architektur: 32-Bit PC

Desktop: XFCE

Andere Betriebssysteme: Windows7

  • Nachricht senden

18

10.02.2018, 00:41

Bei id erscheint:
uid=1000(petergisela) gid=1000(petergisela) Gruppen=1000(petergisela),4(adm),24(cdrom),27(sudo),30(dip),46(plugdev),108(lpadmin),124(sambashare)

Der zweite Befehl zeigt auch, dass bisher nur peter/gisela angemeldet war und sonst nichts. Ich habe nur diesen Benutzernamen.

Ich glaube, dass ich den Zugang zu /home$ verloren habe. Zuerst war der Desktop weg und dann konnte ich mich nicht mehr anmelden. Das Anmelden hat jetzt funktioniert, aber es sieht aus, als wäre es ein neues System und nicht mein altes Xubuntu, mit meinen ganzen Daten. Jetzt versuche ich irgendwie wieder an mein /home Verzeichnis zu gelangen und bin wirklich für jede Hilfe dankbar.

  • »alt-medregnet« ist männlich

Beiträge: 512

Registrierungsdatum: 22.01.2015

Derivat: Ubuntu GNOME

Architektur: 32-Bit PC

Desktop: GNOME 3.0

Andere Betriebssysteme: Siduction (Debian 64 Bit), Ubuntu XFCE (64 Bit), Windows 10

  • Nachricht senden

19

10.02.2018, 01:11

Verschlüsselt hast du aber nicht? 8|
Dann liegen deine Daten nicht direkt in /home, sondern im versteckten /home/.ecryptfs.
https://wiki.ubuntuusers.de/Homeverzeich…-verschluesseln
Überprüfen:

Quellcode

1
du -hs /home/.ecryptfs/*/
- Bei mir gibt es den Ordner nicht. Ich habe aber bei der Installation von Ubuntu aber auch kein Verschlüsseln aktiviert.
https://4.bp.blogspot.com/-rIDztfNcjY8/V…gspot.de_26.png

  • »P.Kalb« ist der Autor dieses Themas

Beiträge: 27

Registrierungsdatum: 07.02.2018

Derivat: Xubuntu

Version: Ubuntu 16.04 LTS - Xenial Xerus

Architektur: 32-Bit PC

Desktop: XFCE

Andere Betriebssysteme: Windows7

  • Nachricht senden

20

10.02.2018, 01:38

Das hatte ich vorhin gelesen mit dem /home/.ecryptfs. (oder so ähnlich ... schreibe gerade alles aus dem Gedächtnis) und gleich nachgesehen, aber den Ordner gab es bei mir auch nicht.

Leider habe ich jetzt noch einmal versucht mich als Benutzer von Home auszuweisen mit dem Befehl

sudo chown -R -v Benutzername/Benutzername /home/ Benutzername
sudo chmod -R -v u+rwX /home/ Benutzername

und jetzt komme ich wieder nicht mehr auf Xubuntu, sondern hänge wieder im Anmeldeloop fest.

Jetzt also wieder über Windows, weil ich nicht mehr reinkomme. Zefix!