Sie sind nicht angemeldet.

  • »dieselschleicher« ist der Autor dieses Themas

Beiträge: 18

Registrierungsdatum: 21.11.2010

Derivat: Kubuntu

Architektur: 64-Bit PC

Desktop: KDE4

  • Nachricht senden

1

27.01.2018, 10:35

Eingabe- und Ausgabegeräte unter Kubuntu 17.10 plötzlich verschwunden

Hallo,
Ich nutze auf meinem PC Kubuntu 17.10 (Kernelversion 4.13.0-32-generic).

Wie die Überschrift schon sagt, sind meine Eingabe- und Ausgabegeräte plötzlich weg
(vorher hat alles tadellos funktioniert).

Soundkarten (intern + USB) werden unter ALSA erkannt:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
0 [HDMI           ]: HDA-Intel - HDA ATI HDMI

                      HDA ATI HDMI at 0xfef44000 irq 34

 1 [Generic        ]: HDA-Intel - HD-Audio Generic

                      HD-Audio Generic at 0xfef40000 irq 16

 2 [DACE17         ]: USB-Audio - FiiO USB DAC-E17

                      FiiO FiiO USB DAC-E17 at usb-0000:00:12.0-1, full speed


"aplay /usr/share/sounds/alsa/Front_Right.wav"
gibt:

Quellcode

1
ALSA lib pcm_dmix.c:1052:(snd_pcm_dmix_open) unable to open slave aplay: main:788: Fehler beim Öffnen des Gerätes: Datei oder Verzeichnis nicht gefunden


... zuletzt hatte ich nur meine Maus umgesteckt, weil diese immer die Soundausgabe (knistern) gestört hat ... nachdem die Maus auf dem USB 3.0 Port war, war das weg.
Zurückstecken der Maus hat allerdings auch nix gebracht.

Habe von der Materie wenig Ahnung und freue mich über Unterstützung

Gruß
Dieselschleicher

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »dieselschleicher« (01.02.2018, 17:12)


  • »dieselschleicher« ist der Autor dieses Themas

Beiträge: 18

Registrierungsdatum: 21.11.2010

Derivat: Kubuntu

Architektur: 64-Bit PC

Desktop: KDE4

  • Nachricht senden

3

27.01.2018, 17:34

bitteschön:

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=17.10
DISTRIB_CODENAME=artful
DISTRIB_DESCRIPTION="Ubuntu 17.10"
Linux MARAX 4.13.0-32-generic #35-Ubuntu SMP Thu Jan 25 09:13:46 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
-e
---------------
00:01.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Trinity HDMI Audio Controller
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD] FCH Azalia Controller (rev 01)
-e
---------------
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 004: ID 04d9:a09e Holtek Semiconductor, Inc.
Bus 003 Device 003: ID 0461:4dbf Primax Electronics, Ltd
Bus 003 Device 002: ID 1852:50d0 GYROCOM C&C Co., LTD
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 003: ID 05e3:0749 Genesys Logic, Inc.
Bus 006 Device 002: ID 05e3:0616 Genesys Logic, Inc. hub
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 003: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
-e
---------------
0 [HDMI ]: HDA-Intel - HDA ATI HDMI
HDA ATI HDMI at 0xfef44000 irq 34
1 [Generic ]: HDA-Intel - HD-Audio Generic
HD-Audio Generic at 0xfef40000 irq 16
2 [DACE17 ]: USB-Audio - FiiO USB DAC-E17
FiiO FiiO USB DAC-E17 at usb-0000:00:12.0-1, full speed
-e
---------------
-e
---------------
ls -la /dev/snd/
insgesamt 0
drwxr-xr-x 4 root root 360 Jan 27 16:55 .
drwxr-xr-x 19 root root 4520 Jan 27 16:55 ..
drwxr-xr-x 2 root root 60 Jan 27 16:55 by-id
drwxr-xr-x 2 root root 100 Jan 27 16:55 by-path
crw-rw----+ 1 root audio 116, 2 Jan 27 16:55 controlC0
crw-rw----+ 1 root audio 116, 5 Jan 27 16:55 controlC1
crw-rw----+ 1 root audio 116, 11 Jan 27 16:55 controlC2
crw-rw----+ 1 root audio 116, 4 Jan 27 16:55 hwC0D0
crw-rw----+ 1 root audio 116, 10 Jan 27 16:55 hwC1D0
crw-rw----+ 1 root audio 116, 3 Jan 27 17:26 pcmC0D3p
crw-rw----+ 1 root audio 116, 7 Jan 27 17:26 pcmC1D0c
crw-rw----+ 1 root audio 116, 6 Jan 27 17:26 pcmC1D0p
crw-rw----+ 1 root audio 116, 8 Jan 27 17:26 pcmC1D1p
crw-rw----+ 1 root audio 116, 9 Jan 27 16:55 pcmC1D2c
crw-rw----+ 1 root audio 116, 12 Jan 27 17:26 pcmC2D0p
crw-rw----+ 1 root audio 116, 13 Jan 27 16:55 pcmC2D1p
crw-rw----+ 1 root audio 116, 1 Jan 27 16:55 seq
crw-rw----+ 1 root audio 116, 33 Jan 27 16:55 timer
-e
---------------
cat /home/juern/.asoundrc
-e
---------------
cat /home/juern/.asoundrc.asoundconf
-e
---------------
cat /etc/asound.conf
-e
---------------
dmesg
[ 3.264753] [drm] Connector 0:
[ 3.264753] [drm] HDMI-A-1
[ 3.264754] [drm] HPD1
--
[ 6.522337] piix4_smbus 0000:00:14.0: Auxiliary SMBus Host Controller at 0xb20
[ 6.549297] snd_hda_intel 0000:00:01.1: enabling device (0000 -> 0002)
[ 6.549431] snd_hda_intel 0000:00:01.1: Force to non-snoop mode
[ 6.563380] input: HDA ATI HDMI HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.1/sound/card0/input7
[ 6.569147] snd_hda_codec_realtek hdaudioC1D0: autoconfig for ALC887-VD: line_outs=4 (0x14/0x15/0x16/0x17/0x0) type:line
[ 6.569150] snd_hda_codec_realtek hdaudioC1D0: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[ 6.569156] snd_hda_codec_realtek hdaudioC1D0: hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
[ 6.569158] snd_hda_codec_realtek hdaudioC1D0: mono: mono_out=0x0
[ 6.569159] snd_hda_codec_realtek hdaudioC1D0: dig-out=0x11/0x1e
[ 6.569160] snd_hda_codec_realtek hdaudioC1D0: inputs:
[ 6.569163] snd_hda_codec_realtek hdaudioC1D0: Front Mic=0x19
[ 6.569164] snd_hda_codec_realtek hdaudioC1D0: Rear Mic=0x18
[ 6.569166] snd_hda_codec_realtek hdaudioC1D0: Line=0x1a
[ 6.569560] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
[ 6.587432] input: HD-Audio Generic Front Mic as /devices/pci0000:00/0000:00:14.2/sound/card1/input8
[ 6.587501] input: HD-Audio Generic Rear Mic as /devices/pci0000:00/0000:00:14.2/sound/card1/input9
[ 6.587561] input: HD-Audio Generic Line as /devices/pci0000:00/0000:00:14.2/sound/card1/input10
[ 6.587625] input: HD-Audio Generic Line Out Front as /devices/pci0000:00/0000:00:14.2/sound/card1/input11
[ 6.587686] input: HD-Audio Generic Line Out Surround as /devices/pci0000:00/0000:00:14.2/sound/card1/input12
[ 6.587748] input: HD-Audio Generic Line Out CLFE as /devices/pci0000:00/0000:00:14.2/sound/card1/input13
[ 6.587809] input: HD-Audio Generic Line Out Side as /devices/pci0000:00/0000:00:14.2/sound/card1/input14
[ 6.587871] input: HD-Audio Generic Front Headphone as /devices/pci0000:00/0000:00:14.2/sound/card1/input15
[ 6.597941] asus_wmi: ASUS WMI generic driver loaded
-e
---------------

  • »dieselschleicher« ist der Autor dieses Themas

Beiträge: 18

Registrierungsdatum: 21.11.2010

Derivat: Kubuntu

Architektur: 64-Bit PC

Desktop: KDE4

  • Nachricht senden

4

01.02.2018, 17:11

...für alle Interessierten:
Ich habe inzwischen nach weiterer Recherche eine Lösung gefunden.
Es handelt sich um ein Problem mit dem PulseAudio - Server.
Nach dem Auskommentieren der letzten drei Zeilen in: "/etc/pulse/default.pa" tauchen alle Geräte wieder auf.

Quellcode

1
2
3
#.ifexists module-switch-on-connect.so
#load-module module-switch-on-connect
#.endif


Ich glaube anderswo gelesen zu haben, dass eine Neuinstallation des Soundservers auch Abhilfe schafft ... hab' ich aber nicht ausprobiert.

Gruß

dieselscheicher