Sie sind nicht angemeldet.

  • »Ishikura« ist der Autor dieses Themas

Beiträge: 11

Registrierungsdatum: 16.04.2012

  • Nachricht senden

1

11.12.2017, 21:38

festplatte mit root einhängen, wo ist der Fehler

Hallo zusammen,

ich hatte mich eigentlich erkundigt, wie man automatisch beim Hochfahren eine Festplatte einhängt, aber irgendwie funktioniert es nicht bei mir und ich finde den Fehler nicht.

Über blkid habe ich mir die Festplatten-Infos geholt:
/dev/sda1: LABEL="Data" UUID="[b]656b57ad-f71e-4003-9dfb-5fac4e5989c7[/b]" TYPE="[b]ext4[/b]" PARTLABEL="Data" PARTUUID="bcb43d09-88f0-423d-bc7f-3ecc8c6abb2f"

Mein /etc/fstab Eintrag sieht folgendermaßen aus: [b]UUID=656b57ad-f71e-4003-9dfb-5fac4e5989c7 /home/ishikura/Data ext4 rw 0 1 [/b](mit Tabbstop getrennt)

Anstatt rw habe ich auch defaults usw. funktioniert aber irgendwie klappt es nicht. Ich kann im Nautilus die Festplatte sehen, allerdings kommt folgende Fehlermeldung sobald ich einen Ordner versuche zu öffnen:
The folder contents could not be displayed. -> You do not have the permissions necessary to view the contents of "Download".

Wie gesagt, ich habe mir eigentlich angeguckt wie der Befehl funktionieren sollte aber es haut net hin. Wäre für Hilfe echt dankbar.

Schönen Abend miteinander :)

Ishikura

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Ishikura« (12.12.2017, 18:53)


2

11.12.2017, 23:03

Du musst dir einmal die Eigentümerschaft an der Platte von root übergeben lassen, wenn sie bereits gemountet ist:

Quellcode

1
sudo chown ishikura: /home/ishikura/Data
Ab dann kannst du sie als User verwenden.

Wenn bereits Daten drauf sind, die du dir selbst zuteilen willst, dann einmal:

Quellcode

1
sudo chown -R ishikura: /home/ishikura/Data
Mach das aber nur mit selbst angelegten Daten, keinesfalls mit Systemdateien, auch nicht von anderen Systemen benutzten!

Die "1" am Ende der fstab-Zeile würde ich auf "2" ändern; und statt "rw" "defaults".

Nächstes Mal Terminaldaten bitte mit Code-Tags formatieren, danke.
mir is wurscht

  • »Ishikura« ist der Autor dieses Themas

Beiträge: 11

Registrierungsdatum: 16.04.2012

  • Nachricht senden

3

12.12.2017, 18:53

Problem gelöst

Hallo,

vielen Dank Fredl für deinen Tipp.

die fstab Zeile hatte ich bereits so ausgefüllt wie du beschrieben hattest, allerdings ohne Erfolg.

Was letzendlich funktioniert hat war die Übertragung der Eigentümerschaft.

Jetzt funktioniert alles super, nochmal besten Dank für die super schnelle Hilfe! ISt echt sehr nett!!!

Viele Grüße, Ishikura

4

13.12.2017, 01:24

Aber gerne. :)
Viel Spaß noch!
mir is wurscht