Sie sind nicht angemeldet.

  • »AnfängerPaule« ist männlich
  • »AnfängerPaule« ist der Autor dieses Themas

Beiträge: 71

Registrierungsdatum: 16.02.2016

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: unbekannt

Andere Betriebssysteme: Lubuntu und Windows 10 in Virtueller Box (VirtualBox graphische Benutzeroberfläche Version 5.0.14 r105127)

  • Nachricht senden

1

09.12.2017, 15:06

(Rechte-?)Probleme bei VirtualBox

Hallo Forum,

ich kann W10 auf der VirtualBox nicht starten, es erscheint das im Anhang befindliche Fenster.
Insalliert ist Version 5.0.32 r11293. Will ich das 5.1.-Update einspielen und drücke die Installations-Schaltfläche, so wechselt der Text in der Schaltfäche kurzzeitig auf "wird installiert..." und sofort zurück auf "Installieren". Zudem erscheint in der Sidebar ein Icon "Installation abwartend", wobei sich im Fortschrittsanzeigebalken nichts tut.

Versucht habe ich:
  • Datensicherung einspielen (lies sich durchführen - aber keine Problembehebung)
  • Partitionsclone zurück gesichert
  • Festplattenclone zurück gesichert mit anschließendem "chown root:root /usr/bin/sudo && chomd 4755 /usr/bin/sudo" im Recoverymodus (aus diesem Artikel Beitrag 2)
  • Im Terminal dieser Befehl: chown peterh /media/peterh/SSD1Part2/
  • Die im Fenster (s. Anhang) genannte UUID taucht bei der "sudo blkid"-Abfrage nicht auf.
Auf den Rechteverdacht komme ich wegen Fedl's Beitrag 17 im selben Artikel .

Fragen:
Kann mir jemand helfen die VirtualBox zum laufen zu bringen?
Gibt es eine Abfrage, vergleichbar "sudo blkid", mit der eine Übersicht über die Rechte herbeigeführt werden kann?

Auf der VB liegt meine Fakturierung, weshalb ich z.Z. keine Rechnungen schreiben kann. Ein, auch im Hinblick auf den Jahresabschluß, definitives Problem.

Für Hilfe meinen Dank im Voraus,
LG
»AnfängerPaule« hat folgendes Bild angehängt:
  • Fehlermeldungsfenster.png
Und am Ende des Tunnels ist ein Licht! :)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »AnfängerPaule« (15.12.2017, 10:29)


2

09.12.2017, 17:45

Unten im Fenster steht, daß die virtuelle Platte nicht angeschlossen ist. Normal Rechtsklick und in die entsprechende Maschine einbinden lassen. Oder umgekehrt aus den Einstellungen der VM diese Datei als Platte anschließen.
Liegt vermutlich daran, daß die Platte mit dieser Datei nicht immer vorhanden ist.
Wenn das Einbinden nicht geht, dann einmal mit "ls -l /media/peterh/.........xy.vdi" ansehen. (Sorry, screenshots abtippen ist mühsam)
mir is wurscht

  • »AnfängerPaule« ist männlich
  • »AnfängerPaule« ist der Autor dieses Themas

Beiträge: 71

Registrierungsdatum: 16.02.2016

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: unbekannt

Andere Betriebssysteme: Lubuntu und Windows 10 in Virtueller Box (VirtualBox graphische Benutzeroberfläche Version 5.0.14 r105127)

  • Nachricht senden

3

09.12.2017, 20:35

Okay, rechte Maustaste ergibt nur "kopieren".
Habe deshalb bei VB im Menüpunkt "Massenspeicher" den SATA-Controller entfernt und versucht eine neue virtuelle Festplatte aus einem bestehenden Plattenabbild zu erzeugen.

VB meldet dieses:
>>>>>
Die Plattenabbilddatei /media/peterh/SSD1Part2/PeterHVirtual.vdi konnte nicht geöffnet werden.
Cannot register the hard disk '/media/peterh/SSD1Part2/PeterHVirtual.vdi' {cb26a54e-645a-4951-b1d5-723bab574878} because a hard disk '/media/peterh/WBlue1Part2/PeterHVirtual.vdi' with UUID {cb26a54e-645a-4951-b1d5-723bab574878} already exists.
Fehlercode: NS_ERROR_INVALID_ARG (0x80070057)
Komponente: VirtualBoxWrap
Interface: IVirtualBox {0169423f-46b4-cde9-91af-1e9d5b6cd945}
Callee RC: VBOX_E_OBJECT_NOT_FOUND (0x80BB0001)
<<<<<

Hierzu blkid:
>>>>>
device fs_type label mount point UUID
-------------------------------------------------------------------------------
/dev/sda1 ntfs SeagateT1ntfs /media/peterh/SeagateT1ntfs 13EFCBB040774384
/dev/sda2 ext4 SeagateT2ext4 /media/peterh/SeagateT2ext4 74cbdd85-bfd8-47cc-87c8-83383da87c23
/dev/sda3 ntfs SeagateT3ntfs /media/peterh/SeagateT3ntfs 06328603272217A4
/dev/sda4 ext4 SeagateT4ext4 /media/peterh/SeagateT4ext4 5d94edf7-4be0-428b-b19a-53e3c3ba6fe8
/dev/sdb1 linux_raid_member AMD-2016:0 (in use) 8fa464e3-bb8b-ba21-8d78-0a37950a0a51
/dev/sdc1 ext4 WBblue1Part1 / dd13247c-6704-432a-85dd-cbdc3cebdbc4
/dev/sdc2 swap [SWAP] 73ce5b7c-dfbc-44c6-9ace-9c25cb21cdc8
/dev/sdc3 ntfs SSD1Part2 /media/peterh/SSD1Part2 0780DF57600B90AB
/dev/sdd1 linux_raid_member AMD-2016:0 (in use) 8fa464e3-bb8b-ba21-8d78-0a37950a0a51
/dev/sdd3 ntfs WB2_T3_ntfs (not mounted) 166D54491EDB44CB
/dev/sdd4 ext4 WB2_T4_ext4 (not mounted) 9c9b6ed7-bc33-4eb2-8248-cd5a57237ef6
/dev/sde1 ntfs terra HDD (not mounted) 5C709FA4709F8404
/dev/sdf1 ext4 WBblue1Part1 (not mounted) 6f0edc3a-1d32-44b1-8d83-2260eaa2ea4e
/dev/sdf2 swap (not mounted) f93b1746-6f41-414b-b9b1-2789653fc0e0
/dev/sdf3 ntfs WBlue1Part2 (not mounted) 0780DF57600B90AB
<<<<<

Ergebnis:
Die von VB genannte UUID=cb26a54e-645a-4951-b1d5-723bab574878 gibt's bei meiner Hardware/Partitionen/RAID nicht.
(sdc3 = SSD und sdf3 = HDD haben die selbe UUID, werden aber nur alternativ, mittels ziehen des Netzsteckers am Gerät, einzeln betrieben.)
Es ist die SSD als Träger von Ubuntu, swap und VB im Einsatz.

Fragen:
Handelt es sich bei cb26a54e-645a-4951-b1d5-723bab574878 um eine reale oder virtuelle Platte?
Wie verklicker ich VB, das die Daten von sdc3 genommen werden sollen?
Und am Ende des Tunnels ist ein Licht! :)

wowi

Ubuntu-Forum-Team

  • »wowi« ist männlich

Beiträge: 4 090

Registrierungsdatum: 03.05.2007

Derivat: Xubuntu

Architektur: 64-Bit PC

Desktop: XFCE

  • Nachricht senden

4

10.12.2017, 00:16

Hi AnfängerPaule,

(sdc3 = SSD und sdf3 = HDD haben die selbe UUID, werden aber nur alternativ, mittels ziehen des Netzsteckers am Gerät, einzeln betrieben.)
Wenn Du bei 2 unterschiedlichen Platten die gleiche UUID hast, musst Du m.E. zumindest zwischen dem Wechsel den PC neu starten. Hast Du das gemacht?

Greetz
wowi

5

10.12.2017, 00:36

Manchmal vermute ich hinter Deinen Aktionen so eine Art Härtetest. :)
Zwei Partitionen mit gleicher UUID, Abmelden per Netzstecker. Beides ein Garant für programmierte Brösel.

Die vom VM-Manager genannte UUID bezieht sich auf eine virtuelle.
mir is wurscht

Beiträge: 768

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

Andere Betriebssysteme: Debian 10 / 4.15.0-3-amd64

  • Nachricht senden

6

10.12.2017, 07:26

Manchmal vermute ich hinter Deinen Aktionen so eine Art Härtetest.


Der Paule kratzt nicht morgens Eis, nein er machts richtig und schlägt die Scheibe ein! :D
Linux ist wie eine Suppe! Je besser die Zutaten, desto größer der Geschmack! :)

  • »AnfängerPaule« ist männlich
  • »AnfängerPaule« ist der Autor dieses Themas

Beiträge: 71

Registrierungsdatum: 16.02.2016

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: unbekannt

Andere Betriebssysteme: Lubuntu und Windows 10 in Virtueller Box (VirtualBox graphische Benutzeroberfläche Version 5.0.14 r105127)

  • Nachricht senden

7

14.12.2017, 20:44

Der Plattenwechsel per Netzstecker findet nur bei ausgeschaltetem Rechner statt! Wie dabei "programmierte Brösel" entstehen sollen erschließt sich mir, aus allem was ich bisher gelesen habe, nicht.

In irgend einer Datei muss Ubuntu diesen Pfad hinterlegt haben: /media/peterh/WBlue1Part2/PeterHVirtual.vdi
und der muss dort weg. Danach müsste das Anlegen einer neuen/vorhandenen Festplatte (die SSD) am Sata-Controllers in VB möglich sein, der dann diesen Pfad verwendet: /media/peterh/SSD1Part2/PeterHVirtual.vdi

Um die Datei, in der das steht, zu finden habe ich mich an "grep" versucht, natürlich ohne Erfolg. :(

Frage:
Wie kann ich den Umfang der Suche sinnvoll eingrenzen (z.B. auf die Partition) und wie lautet dann die Syntax dazu, um nach diesem Text /media/peterh/WBlue1Part2/PeterHVirtual.vdi zu suchen?


Eine kleine Randbemerkung:
Das es die beiden Partitionen mit gleicher UUID gibt ist eine Altlast aus dem Stadium, als die HDD mittels Clonzilla auf die SSD umgezogen ist. Für 3-5 Tage sind damals tatsächlich beide Platten gelaufen, weil ich von der Existenz der UUID's zu dem Zeitpunkt noch nichts wusste. Es wurden aber nur Benutzerdateien gespeichert, keine Änderungen am System vorgenommen. Wenn jetzt die VB auf der SSD wieder läuft, und keine Probleme dort auftreten, so wird die HDD ohnehin umformatiert und als Reserve ins RAID integriert. Dafür muss ich aber erst wissen, was auf der SSD los ist (und die Rechnungen schreiben).

LG
Und am Ende des Tunnels ist ein Licht! :)

8

15.12.2017, 01:26

In Virtualbox unter Maschine/ändern/Massenspeicher.
Eine neue Platte mit dem richtigem Pfad angeben und die falsche entfernen.
mir is wurscht

  • »AnfängerPaule« ist männlich
  • »AnfängerPaule« ist der Autor dieses Themas

Beiträge: 71

Registrierungsdatum: 16.02.2016

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: unbekannt

Andere Betriebssysteme: Lubuntu und Windows 10 in Virtueller Box (VirtualBox graphische Benutzeroberfläche Version 5.0.14 r105127)

  • Nachricht senden

9

15.12.2017, 10:29

Hallo Fredl,

jetzt hat's geklappt! :thumbsup: :thumbsup: :thumbsup:

Danke!

LG
Und am Ende des Tunnels ist ein Licht! :)