Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

  • »AnfängerPaule« ist männlich
  • »AnfängerPaule« ist der Autor dieses Themas

Beiträge: 71

Registrierungsdatum: 16.02.2016

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: unbekannt

Andere Betriebssysteme: Lubuntu und Windows 10 in Virtueller Box (VirtualBox graphische Benutzeroberfläche Version 5.0.14 r105127)

  • Nachricht senden

1

14.11.2017, 19:21

Was sagt mir diese sudo-Rückmeldung?

Hallo Forum,

heute habe ich es geschafft, mittels nachstehendem Befehl die Schreibrechte bei ext4-Partitionen auf internen Festplatten zu erlangen. Hurra ein Erfolgserlebnis! :)
Selbiges habe ich dann mit meiner externen USB-Platte versucht und nachstehende Meldung erhalten:

peterh@AMD-2016:~$ sudo chown peterh /media/peterh/SeagateT4ext4/
sudo: /usr/bin/sudo muss dem Benutzer mit UID 0 gehören und das »setuid«-Bit gesetzt haben

Was sagt mir die Meldung?

LG
Und am Ende des Tunnels ist ein Licht! :)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »AnfängerPaule« (24.11.2017, 18:45)


Beiträge: 584

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: unbekannt

Desktop: unbekannt

Andere Betriebssysteme: Linux 3.16.0-4-686-pae

  • Nachricht senden

2

14.11.2017, 19:47

Da hats Dir wohl die Rechte zerschossen von sudo. Warum auch immer!? 8o

Boote im "recovery modus", so dass Du root bist und führe dann aus:


Quellcode

1
2
3
chown root:root /usr/bin/sudo && chmod 4755 /usr/bin/sudo

reboot
Katzendesktopvideo ohne Windows, für ALLE zum Anschauen:

Click me!

  • »AnfängerPaule« ist männlich
  • »AnfängerPaule« ist der Autor dieses Themas

Beiträge: 71

Registrierungsdatum: 16.02.2016

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: unbekannt

Andere Betriebssysteme: Lubuntu und Windows 10 in Virtueller Box (VirtualBox graphische Benutzeroberfläche Version 5.0.14 r105127)

  • Nachricht senden

3

14.11.2017, 23:39

Danke für die schnelle Antwort!

LG :)
Und am Ende des Tunnels ist ein Licht! :)

  • »AnfängerPaule« ist männlich
  • »AnfängerPaule« ist der Autor dieses Themas

Beiträge: 71

Registrierungsdatum: 16.02.2016

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: unbekannt

Andere Betriebssysteme: Lubuntu und Windows 10 in Virtueller Box (VirtualBox graphische Benutzeroberfläche Version 5.0.14 r105127)

  • Nachricht senden

4

15.11.2017, 15:54

@ Admin

Hallo Admin,

der Button zum erstellen von Themen wird bei mir nicht mehr angezeigt, weshalb ich auf diesem Wege versuche Kontakt aufzunehmen. Habe ich etwas falsch gemacht, oder ist es das Forumssystem?

LG
Und am Ende des Tunnels ist ein Licht! :)

5

15.11.2017, 16:28

der Button zum erstellen von Themen wird bei mir nicht mehr angezeigt
Welcher?


weshalb ich auf diesem Wege versuche Kontakt aufzunehmen
Da hast du Glück, daß der Versuch hier entdeckt wurde.
mir is wurscht

Beiträge: 584

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: unbekannt

Desktop: unbekannt

Andere Betriebssysteme: Linux 3.16.0-4-686-pae

  • Nachricht senden

6

15.11.2017, 16:40

Eventuell wurde Paule nur automatisch abgemeldet. Dann ist der Button weg.
Katzendesktopvideo ohne Windows, für ALLE zum Anschauen:

Click me!

7

15.11.2017, 20:46

Dann hätte er sich aber auch hier nicht bemerkbar machen können.
mir is wurscht

  • »AnfängerPaule« ist männlich
  • »AnfängerPaule« ist der Autor dieses Themas

Beiträge: 71

Registrierungsdatum: 16.02.2016

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: unbekannt

Andere Betriebssysteme: Lubuntu und Windows 10 in Virtueller Box (VirtualBox graphische Benutzeroberfläche Version 5.0.14 r105127)

  • Nachricht senden

8

17.11.2017, 12:55

Fredl schreibt:

Zitat

Da hast du Glück, daß der Versuch hier entdeckt wurde.
Wie gut das Du Adleraugen hast! ;)

Zitat

Zitat


Zitat von »AnfängerPaule«

der Button zum erstellen von Themen wird bei mir nicht mehr angezeigt
Welcher?
Jetzt ist er wieder da. Meine Frau erinnerte sich daran, dass es dieses schon mal gab. Da war aber vermutlich noch der XP-Rechner im Einsatz, ist also schon ca. 2 Jahre her und hat sich dann auch auf wundersame Weise in Luft aufgelöst. (Nur so zur Info)
_______________________________________________________


Horsemanchip schreibt in Beitrag 2, dass ich folgendes machen soll:

Zitat

chown root:root /usr/bin/sudo && chmod 4755 /usr/bin/sudo
Ich habe im "recovery modus"-Menü <root> ausgewählt und dann versucht den Befehl einzutippen. Mittendrin beim Schreiben kommt dann folgende Meldung:

[TIME] Timed out waiting for device dev-di...\x2d9ace\x2d9c25cb21cdc8.device
[DEPEND] Dependency failed for /dev/disk/by-...b7c-dfbc-44c6-9ace-9c25cb21cdc8
[DEPEND] Dependency failed for swap.

Die zweite UUID ist die der Swap-Partition . Die erste kann ich nicht zuordnen, es sind aber die alte C-Platte vom alten XP-Rechner und die externe USB-Platte z.Z. nicht angeschlossen.

Frage:
Was macht man daraus?

LG
Und am Ende des Tunnels ist ein Licht! :)

Beiträge: 584

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: unbekannt

Desktop: unbekannt

Andere Betriebssysteme: Linux 3.16.0-4-686-pae

  • Nachricht senden

9

19.11.2017, 13:02

Gib dann mal ENTER ein und schau ob Du das Prompt wieder bekommst, um mein Kommando einzugeben.

Wenn das nicht geht probier mal STRG + D und schau was passiert.
Katzendesktopvideo ohne Windows, für ALLE zum Anschauen:

Click me!

10

19.11.2017, 13:52

Die zweite UUID ist die der Swap-Partition . Die erste kann ich nicht zuordnen
Es sind beide gleich, nur unter verschiedenen Verzeichnissen.

die alte C-Platte vom alten XP-Rechner und die externe USB-Platte z.Z. nicht angeschlossen
Mit diesen kann es aber nicht zusammenhängen, denn es wird nach swap gesucht.

Mittendrin beim Schreiben kommt dann folgende Meldung
Im Recovery-Modus gibt es nur ein Terminal, und auf dem landen dann auch die Kernelmeldungen. Man sollte davon unbeirrt weiter tippen, als ob sie gar nicht da wären.

Ich habe ad hoc den Verdacht daß nicht nur /usr/bin/sudo betroffen ist, denn warum sollte es gerade nur diese eine Datei erwischt haben...
Vielmehr gibt mir das zu denken:
geschafft, mittels nachstehendem Befehl die Schreibrechte bei ext4-Partitionen auf internen Festplatten zu erlangen
Mich würde interessieren, wie dieser Befehl genau aussah und wofür Du danach diese Schreibrechte benutzt hast. Dann wird man sehen, welche der folgenden Aussagen eher zutrifft:
A)
Hurra ein Erfolgserlebnis!
oder
B)

Zitat

ich lächelte und war froh und es kam schlimmer! ;)
mir is wurscht

  • »AnfängerPaule« ist männlich
  • »AnfängerPaule« ist der Autor dieses Themas

Beiträge: 71

Registrierungsdatum: 16.02.2016

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: unbekannt

Andere Betriebssysteme: Lubuntu und Windows 10 in Virtueller Box (VirtualBox graphische Benutzeroberfläche Version 5.0.14 r105127)

  • Nachricht senden

11

22.11.2017, 19:38

Hallo zusammen,

Fredl schreibt:

Zitat

Mich würde interessieren, wie dieser Befehl genau aussah und wofür Du
danach diese Schreibrechte benutzt hast.
sudo chown peterh /media/peterh/SeagateT4ext4/

Für die anderen Partitionen habe ich mit hoher Wahrscheinlichkeit nur die entsprechenden Partitionen samt Pfaden kopiert. Mache ich zur Vermeidung von Tippfehlern normalerweise standardmäßig. Eine genaue Doku habe ich natürlich nicht. :(
Definitiv habe ich mit dem Dateimanager einfach versucht Ordner anzulegen, was mir vorher verweigert wurde und nun geht. Ich habe unterstellt, dass nun wieder alles geht, also Dateien speichern, verschieben, umbenennen... . Soweit ich es erkennen kann ist dem auch so.
_______________________________________________________________________________________________________

Zitat

Zitat


Zitat von »AnfängerPaule«

Die zweite UUID ist die der Swap-Partition . Die erste kann ich nicht zuordnen
Fredl antwortet:
Es sind beide gleich, nur unter verschiedenen Verzeichnissen.
Huch!? ?(
Ich habe es gerade nochmal mit >blkid< überprüft: Es gibt nur eine Partition mit der UUID!
Frage:
Wieso dann zwei Pfade/Verzeichnisse??? :?: :?: :?:
_________________________________________________________________________

Zitat

Im Recovery-Modus gibt es nur ein Terminal, und auf dem landen dann auch die Kernelmeldungen. Man sollte davon unbeirrt weiter tippen, als ob sie gar nicht da wären.

Ich habe ad hoc den Verdacht daß nicht nur /usr/bin/sudo betroffen ist, denn warum sollte es gerade nur diese eine Datei erwischt haben...
Eure Hinweise muss ich aus zeitlichen Gründen später umsetzten.

Es hat aber auch folgende Begebenheit mit der HDD-Platte gegeben (ich arbeite akutell mit der SSD, also dem Klon, allerdings mit geänderten UUID's bei jeweils 3 Partitionen auf der Platte):
Fredl hat mir hier in Antwort 15 einen Vorschlag zum Eintrag in der fstab gemacht. Den habe ich umgesetzt und die Situation gehabt, dass die Partitionen im Dateimanager u.a. nicht mehr angezeigt wurden. Ich will aber, dass die Partitionen angezeigt werden und ganz normal nutzbar sind (ohne Rechte beachten zu müssen etc.), sobald die USB-Platte eingesteckt ist.

Weil das nicht gegeben war habe ich eine Option nach der anderen gelöscht, jeweils den Neustart gemacht und geschaut was kommt. Bis dann die HDD sich nicht mehr vollständig booten lies. Da sollen Eingaben gemacht werden, die ich aber nicht verstehe. Die SSD war zu dem Zeitpunkt nicht angeschlossen.
Auf die HDD habe ich seither keinen Zugriff mehr, auch wenn die Partitionen z.B. unter blkid oder im Dateimanager noch angezeigt werden.
Nach meiner Logik kann dass ja eigentlich keine Auswirkungen auf das aktuelle Problem haben, schließlich arbeite ich jetzt mit der ursprünglichen fstab, ohne Fredl's Vorschläge. - O d e r doch??? ?(

LG
Und am Ende des Tunnels ist ein Licht! :)

Beiträge: 584

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: unbekannt

Desktop: unbekannt

Andere Betriebssysteme: Linux 3.16.0-4-686-pae

  • Nachricht senden

12

23.11.2017, 04:26

Zitat

[TIME] Timed out waiting for device dev-di...\x2d9ace\x2d9c25cb21cdc8.device
[DEPEND] Dependency failed for /dev/disk/by-...b7c-dfbc-44c6-9ace-9c25cb21cdc8


Wieso 2 Pfade? Einmal steht da TIME, einmal DEPEND. Sind 2 verschiedene Meldungen. Unten wird dann nochmal Swap bestätigt.
Katzendesktopvideo ohne Windows, für ALLE zum Anschauen:

Click me!

  • »AnfängerPaule« ist männlich
  • »AnfängerPaule« ist der Autor dieses Themas

Beiträge: 71

Registrierungsdatum: 16.02.2016

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: unbekannt

Andere Betriebssysteme: Lubuntu und Windows 10 in Virtueller Box (VirtualBox graphische Benutzeroberfläche Version 5.0.14 r105127)

  • Nachricht senden

13

23.11.2017, 12:47

Moin, moin,

ich habe diesen Befehl:

chown root:root /usr/bin/sudo && chmod 4755 /usr/bin/sudo

eingeben können. Sowohl das Weiterschreiben, als auch 'Enter' drücken war eingabetechnisch erfolgreich. :thumbsup:
Die Rückmeldung allerdings weniger: "Zugriff auf '/user/bin/sudo' nicht möglich: Datei oder Verzeichnis nicht gefunden." :(

Frage:
Wie repariert man das?

LG
Und am Ende des Tunnels ist ein Licht! :)

Beiträge: 584

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: unbekannt

Desktop: unbekannt

Andere Betriebssysteme: Linux 3.16.0-4-686-pae

  • Nachricht senden

14

23.11.2017, 14:21

"Zugriff auf '/user/bin/sudo' nicht möglich: Datei oder Verzeichnis nicht gefunden."


Hast Du wirklich "user" geschrieben oder doch "usr"? user wäre nämlich falsch.

Eventuell ist deine Partition auch nicht gemounted. Dann müsstest Du das machen. Kannst auch mal im recovery mode das Kommando "mount -a" probieren
und dann den Befehl erneut eingeben.
Katzendesktopvideo ohne Windows, für ALLE zum Anschauen:

Click me!

  • »AnfängerPaule« ist männlich
  • »AnfängerPaule« ist der Autor dieses Themas

Beiträge: 71

Registrierungsdatum: 16.02.2016

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: unbekannt

Andere Betriebssysteme: Lubuntu und Windows 10 in Virtueller Box (VirtualBox graphische Benutzeroberfläche Version 5.0.14 r105127)

  • Nachricht senden

15

23.11.2017, 16:13

Horsemanchip schreibt:

Zitat

Hast Du wirklich "user" geschrieben oder doch "usr"? user wäre nämlich falsch.
Danke für den Hinweis!

Horsemanchip schreibt:

Zitat

Eventuell ist deine Partition auch nicht gemounted. Dann müsstest Du das machen. Kannst auch mal im recovery mode das Kommando "mount -a" probieren und dann den Befehl erneut eingeben.
"Mount -a", okay, aber in der fstab steht nichts drin. - Wird wohl nicht schaden.

LG

_____________________
Nachtrag:

Ich habe gemountet und dann habe eben den Befehl eingegeben und bin leider nur bis zum "&&" gekommen, der chmod-Teil fehlt. Da tauchte die Swap-Meldung (s.o.) auf und ich habe wohl "enter" gedrückt und erhalte diese Meldung:
chown: der Eigentümer von '/usr/bin/sudo' wird geändert: Das Dateisystem ist nur lesbar

Dann habe ich 'chmod 4755 /usr/bin/sudo' eingegeben und diese Meldung erhalten:
chmod: Beim Setzten der Zugriffsrechte für '/usr/bin/sudo': Das Dateisystem ist nur lesbar

Ist die letzte eine Erfolgsmeldung?

LG
Und am Ende des Tunnels ist ein Licht! :)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »AnfängerPaule« (23.11.2017, 16:43)


  • »AnfängerPaule« ist männlich
  • »AnfängerPaule« ist der Autor dieses Themas

Beiträge: 71

Registrierungsdatum: 16.02.2016

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: unbekannt

Andere Betriebssysteme: Lubuntu und Windows 10 in Virtueller Box (VirtualBox graphische Benutzeroberfläche Version 5.0.14 r105127)

  • Nachricht senden

16

24.11.2017, 18:44

Okay,

dieser Befehl
sudo chown peterh /media/peterh/SeagateT4ext4/
funktioniert wieder, dann gehe ich mal davon aus, dass sich das mit den zerschossenen Sudo-Rechten erledigt hat.

Fredl schreibt:

Zitat

Mich würde interessieren, wie dieser Befehl genau aussah und wofür Du danach diese Schreibrechte benutzt hast. Dann wird man sehen, welche der folgenden Aussagen eher zutrifft:
A)

Zitat


Zitat von »AnfängerPaule«

Hurra ein Erfolgserlebnis!
oder

B)

Zitat


Zitat

ich lächelte und war froh und es kam schlimmer! ;)
Fredl, ich sage A), und Du?

Einmal mehr: mit Dank für die Hilfe :thumbsup: ,
LG
Und am Ende des Tunnels ist ein Licht! :)

17

24.11.2017, 23:04

Fredl, ich sage A), und Du?
Ich kann mich nicht entscheiden.
Einerseits kann auf einem read-only Dateisystem kein chown funktionieren. Wenn sudo jetzt wieder fehlerlos arbeitet, kann diese Aktion nicht dazu geführt haben, denn die ist fehlgeschlagen. Das letzte war jedenfalls keine Erfolgsmeldung.
Wenn Du ansonsten nichts getan hast, ist fraglich woran sudo zuvor gescheitert war.

Wie auch immer, wenn es läuft ist es gut. Also sage ich C) Keiner weiß warum aber es ist so. :)
mir is wurscht

  • »AnfängerPaule« ist männlich
  • »AnfängerPaule« ist der Autor dieses Themas

Beiträge: 71

Registrierungsdatum: 16.02.2016

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: unbekannt

Andere Betriebssysteme: Lubuntu und Windows 10 in Virtueller Box (VirtualBox graphische Benutzeroberfläche Version 5.0.14 r105127)

  • Nachricht senden

18

24.11.2017, 23:55

@ Fredl:

:thumbsup: :thumbsup: :thumbsup: :thumbsup: :thumbsup:

Frage:
was bedeutet EDV?

Antwort:
Ende der Vernunft! ;)

LG
Und am Ende des Tunnels ist ein Licht! :)