Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

DJ3MG

User

  • »DJ3MG« ist der Autor dieses Themas

Beiträge: 3

Registrierungsdatum: 09.05.2017

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: Windows 7

  • Nachricht senden

1

09.05.2017, 07:35

Windows 7 deaktiviert Grub2 (UEFI)

Hallo Ubuntugemeinde,

seit ca. einem Jahr beschäftige ich mich immer eingehender mit Linux (Vorher OS X und Windows 7) und meine Begeisterung wächst nach einigen Startschwierigkeiten immer mehr.

Aber leider finde ich nach einiger Recherche leider keine Lösung für das folgende Problem und hoffe, dass ich hier Hilfe finde:

Ich habe einen PC mit zwei physikalischen Festplatten.
sda ist eine SSD, sdb ist eine konventionelle HDD.

Auf der SSD habe ich zuerst Windows 7 installiert und anschließend Ubuntu 16.04.
Die HDD habe ich in zwei Partitionen geteilt und dient als Speicher für eigene Dateien (sowohl unter Windows, als auch unter Ubuntu).
Hier eine Auflistung meiner Festplatten:

device fs_type label mount point
------------------------------------------------------------------------------
/dev/sda1 vfat /boot/efi
/dev/sda3 ntfs (not mounted)
/dev/sda4 ext4 /
/dev/sda5 swap [SWAP]
/dev/sdb1 ntfs Daten (not mounted)
/dev/sdb5 ext3 /home
/dev/sda2 (not mounted)

Bootloader ist Grub2, ich nutze UEFI-Boot.

Nun passiert folgendes:
Ich starte Linux, arbeite mit Linux und alles funktioniert wie gewohnt alles läuft wunderbar.
Ich starte Windows, arbeite wie gewohnt, alles läuft wunderbar.
Fahre ich Linux herunter, kann ich anschließend wieder über Grub2 auswählen, was gebootet wird.
Fahre ich Windows 7 herunter, startet er anschließend nur noch Windows 7 im Reparaturmodus.
Nach dem WIndows Reparaturmodus startet Windows 7 immer direkt und der Bootmanager Grub2 wird nicht mehr angezeigt.

Ich kann zwar den Bootloader jedesmal reparieren (nach dieser Anleitung: https://wiki.ubuntuusers.de/GRUB_2/Reparatur/), aber das funktioniert genau so lange, bis ich wieder Windows 7 nutze.
Hat jemand schonmal ein ähnliches Problem gehabt und dieses erfolgreich gelöst?

  • »Klaus P« ist männlich

Beiträge: 4 500

Registrierungsdatum: 25.10.2009

Derivat: anderes Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: 7/10

  • Nachricht senden

2

09.05.2017, 09:42

Hallo und willkommen im Forum!

Klicke bitte mal unten den Link in meiner Signatur an und gehe ganz nach unten zu "Informationsgewinnung". Bitte alle Befehle via Terminal abfragen und hier posten. Den Befehl "efibootmgr -v" wenn möglich einmal "normal" und einmal nachdem Windows den Ubuntueintrag gekillt hat (letzteres per Live-CD/USB im UEFI-Boot-Modus also bevor du Grub reparierst).
Welches Rechnermodell ist das genau?

Tipp: Nachdem Windows den Ubuntu-Eintrag gekillt hat, schau mal in den Windows-Bootmanager ob dort der Eintrag noch vorhanden ist. Wie/Wo ist im Artikel unter 1.6. am Ende erklärt. Auch im direkten Bootmenü des Rechners, das schnell aufgerufen werden kann (meist über hohe F-Taste aufrufbar) sollte ein Eintrag vorhanden sein.

Gruß
Des modernen Menschen Computer ist sein Himmelreich! :rolleyes: Der Weg zur Hölle, ist allzu kurz auf dem falschen "EFI-Pfad" ;( : Kleiner Leitfaden zur UEFI-Installation

DJ3MG

User

  • »DJ3MG« ist der Autor dieses Themas

Beiträge: 3

Registrierungsdatum: 09.05.2017

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: Windows 7

  • Nachricht senden

3

09.05.2017, 15:39

Hallo Klaus,

danke für die Antwort. Deinen Thread finde ich klasse :-) . Hier nun die Informationen:

Quellcode

1
2
mount | grep efivars:
efivarfs on /sys/firmware/efi/efivars type efivarfs (rw,nosuid,nodev,noexec,relatime)


Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
sudo parted -l:
Modell: ATA Corsair Force GT (scsi)
Festplatte /dev/sda: 240GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: gpt
Disk-Flags: 

Nummer Anfang Ende Größe Dateisystem Name Flags
1 1049kB 106MB 105MB fat32 EFI system partition boot, esp
2 106MB 240MB 134MB Microsoft reserved partition msftres
3 240MB 120GB 120GB ntfs Basic data partition msftdata
4 120GB 223GB 103GB ext4
5 223GB 240GB 17,1GB linux-swap(v1)


Modell: ATA ST32000542AS (scsi)
Festplatte /dev/sdb: 2000GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: msdos
Disk-Flags: 

Nummer Anfang Ende Größe Typ Dateisystem Flags
1 1049kB 1000GB 1000GB primary ntfs
2 1000GB 2000GB 1000GB extended
5 1000GB 2000GB 1000GB logical ext3


Modell: Generic Flash HS-MS/SD (scsi)
Festplatte /dev/sdd: 2015MB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: msdos
Disk-Flags: 

Nummer Anfang Ende Größe Typ Dateisystem Flags
1 116kB 2015MB 2015MB primary fat16


Quellcode

1
2
3
4
5
6
sudo apt-get install efibootmgr:
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut. 
Statusinformationen werden eingelesen.... Fertig
»efibootmgr« ist bereits die neuste Version (0.12-4).
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 67 nicht aktualisiert.


Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
sudo dmidecode -t 0:
# dmidecode 3.0
Getting SMBIOS data from sysfs.
SMBIOS 2.7 present.

Handle 0x0000, DMI type 0, 24 bytes
BIOS Information
	Vendor: American Megatrends Inc.
	Version: P1.60
	Release Date: 06/17/2016
	Address: 0xF0000
	Runtime Size: 64 kB
	ROM Size: 4096 kB
	Characteristics:
PCI is supported
BIOS is upgradeable
BIOS shadowing is allowed
Boot from CD is supported
Selectable boot is supported
BIOS ROM is socketed
EDD is supported
5.25"/1.2 MB floppy services are supported (int 13h)
3.5"/720 kB floppy services are supported (int 13h)
3.5"/2.88 MB floppy services are supported (int 13h)
Print screen service is supported (int 5h)
8042 keyboard services are supported (int 9h)
Serial services are supported (int 14h)
Printer services are supported (int 17h)
ACPI is supported
USB legacy is supported
BIOS boot specification is supported
Targeted content distribution is supported
UEFI is supported
	BIOS Revision: 4.6


Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
sudo dmidecode -t 1:
# dmidecode 3.0
Getting SMBIOS data from sysfs.
SMBIOS 2.7 present.

Handle 0x0001, DMI type 1, 27 bytes
System Information
	Manufacturer: To Be Filled By O.E.M.
	Product Name: To Be Filled By O.E.M.
	Version: To Be Filled By O.E.M.
	Serial Number: To Be Filled By O.E.M.
	UUID: 03000200-0400-0500-0006-000700080009
	Wake-up Type: Power Switch
	SKU Number: To Be Filled By O.E.M.
	Family: To Be Filled By O.E.M.


Quellcode

1
2
3
4
5
6
7
8
9
10
sudo efibootmgr -v:
BootCurrent: 0000
Timeout: 2 seconds
BootOrder: 0000,0002,0003,000B,0001,000E
Boot0000* ubuntu	HD(1,GPT,b1ff9ba8-2439-463e-b345-d8b72e1e2644,0x800,0x32000)/File(\EFI\ubuntu\shimx64.efi)
Boot0001* Hard Drive BBS(HD,,0x0)AMGOAMNO........o.C.o.r.s.a.i.r. .F.o.r.c.e. .G.T....................A...........................>..Gd-.;.A..MQ..L.2.1.4.2.9.7.6.0.0.0.0.0.4.1.4.9.0.0.5.1......AMBOAMNO........o.S.T.3.2.0.0.0.5.4.2.A.S....................A...........................>..Gd-.;.A..MQ..L. . . . . . . . . . . . .X.5.2.W.0.7.H.3......AMBO
Boot0002* UEFI: Built-in EFI Shell VenMedia(5023b95c-db26-429b-a648-bd47664c8012)AMBO
Boot0003* USB BBS(USB,,0x0)AMGOAMNO........i.G.e.n.e.r.i.c. .F.l.a.s.h. .H.S.-.C.F....................A.......................<..Gd-.;.A..MQ..L.G.e.n.e.r.i.c. .F.l.a.s.h. .H.S.-.C.F......AMBOAMNO........w.G.e.n.e.r.i.c. .F.l.a.s.h. .H.S.-.M.S./.S.D....................A...............................B..Gd-.;.A..MQ..L.G.e.n.e.r.i.c. .F.l.a.s.h. .H.S.-.M.S./.S.D......AMBOAMNO........q.G.e.n.e.r.i.c. .F.l.a.s.h. .H.S.-.S.M....................A...............................<..Gd-.;.A..MQ..L.G.e.n.e.r.i.c. .F.l.a.s.h. .H.S.-.S.M......AMBO
Boot000B* UEFI: Generic Flash HS-MS/SD	PciRoot(0x0)/Pci(0x16,0x2)/USB(1,0)/SCSI(0,1)/HD(1,MBR,0x0,0xe3,0x3c0b1d)AMBO
Boot000E* CD/DVD Drive BBS(CDROM,,0x0)AMGOAMNO........o.H.L.-.D.T.-.S.T. .D.V.D.R.A.M. .G.H.2.0.N.S.1.0....................A...........................>..Gd-.;.A..MQ..L.6.K.8.L.T.4.2.N.5.8. .2. . . . . . . . ......AMBO


Die weiteren Informationen poste ich dann nach einem Reboot ;-)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »DJ3MG« (09.05.2017, 17:36)


DJ3MG

User

  • »DJ3MG« ist der Autor dieses Themas

Beiträge: 3

Registrierungsdatum: 09.05.2017

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: Windows 7

  • Nachricht senden

4

09.05.2017, 16:15

... und jetzt, nachdem mir Windows 7 den Bootmanager zerschossen hat:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
[u]sudo efibootmgr -v:[/u]
BootCurrent: 000F
Timeout: 2 seconds
BootOrder: 0004,0002,0003,000B,000F,0001,000E
Boot0001* Hard Drive BBS(HD,,0x0)AMGOAMNO........o.C.o.r.s.a.i.r. .F.o.r.c.e. .G.T....................A...........................>..Gd-.;.A..MQ..L.2.1.4.2.9.7.6.0.0.0.0.0.4.1.4.9.0.0.5.1......AMBOAMNO........o.S.T.3.2.0.0.0.5.4.2.A.S....................A...........................>..Gd-.;.A..MQ..L. . . . . . . . . . . . .X.5.2.W.0.7.H.3......AMBO
Boot0002* UEFI: Built-in EFI Shell VenMedia(5023b95c-db26-429b-a648-bd47664c8012)AMBO
Boot0003* USB BBS(USB,,0x0)AMGOAMNO........i.G.e.n.e.r.i.c. .F.l.a.s.h. .H.S.-.C.F....................A.......................<..Gd-.;.A..MQ..L.G.e.n.e.r.i.c. .F.l.a.s.h. .H.S.-.C.F......AMBOAMNO........w.G.e.n.e.r.i.c. .F.l.a.s.h. .H.S.-.M.S./.S.D....................A...............................B..Gd-.;.A..MQ..L.G.e.n.e.r.i.c. .F.l.a.s.h. .H.S.-.M.S./.S.D......AMBOAMNO........q.G.e.n.e.r.i.c. .F.l.a.s.h. .H.S.-.S.M....................A...............................<..Gd-.;.A..MQ..L.G.e.n.e.r.i.c. .F.l.a.s.h. .H.S.-.S.M......AMBOAMNO........w.L.e.x.a.r. .U.S.B. .F.l.a.s.h. .D.r.i.v.e. .1.1.0.0....................A.......................J..Gd-.;.A..MQ..L.L.e.x.a.r. .U.S.B. .F.l.a.s.h. .D.r.i.v.e. .1.1.0.0......AMBO
Boot0004* Windows Boot Manager HD(1,GPT,b1ff9ba8-2439-463e-b345-d8b72e1e2644,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...a................
Boot000B* UEFI: Generic Flash HS-MS/SD PciRoot(0x0)/Pci(0x16,0x2)/USB(1,0)/SCSI(0,1)/HD(1,MBR,0x0,0xe3,0x3c0b1d)AMBO
Boot000E* CD/DVD Drive BBS(CDROM,,0x0)AMGOAMNO........o.H.L.-.D.T.-.S.T. .D.V.D.R.A.M. .G.H.2.0.N.S.1.0....................A...........................>..Gd-.;.A..MQ..L.6.K.8.L.T.4.2.N.5.8. .2. . . . . . . . ......AMBO
Boot000F* UEFI: Lexar USB Flash Drive 1100 PciRoot(0x0)/Pci(0x16,0x2)/USB(4,0)/HD(1,MBR,0x0,0x2,0x1dd5ffe)AMBO

______________
Code-Tags gesetzt. Bluegrass

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »DJ3MG« (09.05.2017, 17:37)


Beiträge: 568

Registrierungsdatum: 10.09.2009

Derivat: anderes Ubuntu-Derivat

Version: Ubuntu 17.10 - Artful Aardvark

Architektur: 64-Bit PC

Desktop: Cinnamon

Andere Betriebssysteme: Manjaro

  • Nachricht senden

5

09.05.2017, 16:20

Bitte Ausgaben zur besseren Les-, Zitier- und Bearbeitbarkeit immer im Quellcode-Block posten. Hier die korrekte Vorgehensweise:
  1. Terminalausgabe (Code) in den Beitragseditor einfügen
  2. Code markieren
  3. Oben die Schaltfläche klicken
Siehe auch
hier.

Bluegrass
Es geht auch anders, aber so geht's auch.

  • »Klaus P« ist männlich

Beiträge: 4 500

Registrierungsdatum: 25.10.2009

Derivat: anderes Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: 7/10

  • Nachricht senden

6

09.05.2017, 19:24

Hallo!

Was das Modell des Rechners anbetrifft, war die Ausgabe jetzt nicht so erhellend. Sag noch mal was zu Hersteller oder Hersteller Mainboard.

Was mich nun allerdings etwas stutzig macht, ist, dass bei der ersten Ausgabe von efibootmgr überhaupt kein Eintrag für den Windows-Boot-Manager vorhanden ist. Man würde jetzt hier eigentlich den Eintrag für den Win-Boot-Manager auf inaktiv setzen. Wenn du jetzt aber Grub wieder reparierst, ist der möglicher Weise wieder verschwunden. Mach das mal und kontrolliere es mit dem Befehl "sudo efibootmgr -v". Es geht um diesen Eintrag:

Quellcode

1
Boot0004* Windows Boot Manager HD(1,GPT,b1ff9ba8-2439-463e-b345-d8b72e1e2644,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS...............


Kann also sein, dass du, je nach dem, manuell einen Eintrag selbst erstellen musst. Beschrieben ist das hier. Windows hat aber eh schon ein Bootproblem, wie du oben beschrieben hast. Ich würde zunächst mal versuchen, mit einer Installations-DVD von Windows den Reparaturmodus zu starten und schauen ob das wieder gerichtet wird. Danach wird Ubuntu vermutlich wieder nicht starten. Du weisst aber, wie du das reparierst. Darüber hinaus (oder statt dessen) würde ich dir empfehlen, dir eine Super Grub2Disk zu erstellen. Damit kann man vorhandene BS starten.

Gruß
Des modernen Menschen Computer ist sein Himmelreich! :rolleyes: Der Weg zur Hölle, ist allzu kurz auf dem falschen "EFI-Pfad" ;( : Kleiner Leitfaden zur UEFI-Installation