Sie sind nicht angemeldet.

  • »Neu_KUbuntu« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 16.01.2017

Derivat: Kubuntu

Architektur: 64-Bit PC

Desktop: KDE4

Andere Betriebssysteme: Release: 16.10, Codename: yakkety

  • Nachricht senden

1

17.01.2017, 00:07

Tipps zu Realtek rtl8821AU?

Sehr geehrte Damen und Herren,

ich habe heute erstmals Kubuntu installiert: als Dualboot neben Win10;

Quellcode

1
2
3
schreibtisch@Arbeit:~$ lsb_release -rc
Release:    	16.10
Codename:   	yakkety


Quellcode

1
2
3
4
5
6
schreibtisch@Arbeit:~$ uname -a
Linux Arbeit 4.8.0-22-generic #24-Ubuntu SMP Sat Oct 8 09:15:00 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
schreibtisch@Arbeit:~$ lspci -nnk | grep -i net -A2
02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 0c)
    	Subsystem: Elitegroup Computer Systems RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [1019:8116]
    	Kernel driver in use: r8169


Meine Hardware ist der Aldi-Rechner P5360 E.

Ein Problem ist das Erkennen der bzw. die Treiberinstallation für die W-Lan-Karte von Realtek: rtl8821AU. Kann mir dazu jemand einen Tipp geben?

Weitere Informationen kann ich gerne zu Kubuntu/Version/etc. geben sowie zur Hardware.

Mit freundlichen Grüßen
Neu_KUbuntu

Beiträge: 973

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

Andere Betriebssysteme: Debian 9.9 "stretch" / 4.9.0-9-amd64

  • Nachricht senden

2

17.01.2017, 00:15

Liefere mal die Infos, die hier unter WLAN abgefragt werden müssen.

http://wiki.ubuntu-forum.de/index.php?ti…n_gewinnen#WLAN


Einer unserer WLAN Supporter wird sich dann bestimmt bald drum kümmern. :)


PS: Warum nimmst Du 16.10 und nicht 16.04? Damit hättest Du eine LTS Version mit 5 Jahren Support. Bei deiner jetzt nur 9 Monate, bzw. bis Juli 2017. :wacko:

3

17.01.2017, 00:40

Ich habe neulich so einen Medion-Rechner gesehen (weiß nicht welches Modell). Bei dem lief WLAN unter 15.10 einigermaßen einwandfrei (zumindest erkannt, verbunden und Daten transportiert). Ab 16.04 aufwärts aber gar nicht.
Daher würde mich die Lösung auch interessieren, aber die Infos aus unserem Wiki-Skript wären dazu auf jeden Fall nötig.
mir is wurscht

  • »Neu_KUbuntu« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 16.01.2017

Derivat: Kubuntu

Architektur: 64-Bit PC

Desktop: KDE4

Andere Betriebssysteme: Release: 16.10, Codename: yakkety

  • Nachricht senden

4

17.01.2017, 00:45

Sehr geehrter Horsemanchip,

Danke für die schnelle Antwort.

Ich nutze 16.10 wegen der Hoffnung, dass da mehr von meiner relativ neuen Hardware erkannt wird. Und falls ich mit Kubuntu zurecht komme (Installation usw.) kann ich ja später einmal auf eine LTS Version umsteigen.

Bitte entschuldigen Sie die nicht angegebenen Informationen. Ich reiche sie gleich nach:

Quellcode

1
2
3
4
iwconfig 
lo    	no wireless extensions.

enp2s0	no wireless extensions.


Quellcode

1
lsmod
-> Siehe lsmod.txt

Quellcode

1
2
3
4
schreibtisch@Arbeit:~$ cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback


Quellcode

1
2
3
4
schreibtisch@Arbeit:~$ rfkill list
0: hci0: Bluetooth
    	Soft blocked: no
    	Hard blocked: no


Quellcode

1
2
3
4
5
schreibtisch@Arbeit:~$ cat /etc/modules
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.


Ich hoffe, das waren nun alle benötigten Informationen. W-LAN-Netzwerke
kann der Rechner freilich nicht finden, wenn die Karte nicht erkannt
ist:

Quellcode

1
2
3
4
5
schreibtisch@Arbeit:~$ sudo iwlist scan
[sudo] password for schreibtisch: 
lo    	Interface doesn't support scanning.

enp2s0	Interface doesn't support scanning.


Mit freundlichen Grüßen
Neu_KUbuntu
»Neu_KUbuntu« hat folgende Datei angehängt:
  • lsmod.txt (8,58 kB - 3 mal heruntergeladen - zuletzt: 17.01.2017, 16:55)

wowi

Ubuntu-Forum-Team

  • »wowi« ist männlich

Beiträge: 4 102

Registrierungsdatum: 03.05.2007

Derivat: Xubuntu

Architektur: 64-Bit PC

Desktop: XFCE

  • Nachricht senden

5

17.01.2017, 17:08

Hi Neu_KUbuntu,

willkommen im Forum! Bei uns ist es übrigens üblich, dass man sich duzt, soll also kein unflätiges Verhalten darstellen ;)

Gib uns mal noch die Ausgabe von lsusb, vielleicht findest Du da den Adapter :S

Greetz
wowi

  • »Neu_KUbuntu« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 16.01.2017

Derivat: Kubuntu

Architektur: 64-Bit PC

Desktop: KDE4

Andere Betriebssysteme: Release: 16.10, Codename: yakkety

  • Nachricht senden

6

17.01.2017, 17:32

Hallo wowi,

vielen Dank für das freundliche Willkommenheißen.

Anbei die Ausgabe des genannten Befehls: (Bitte entschuldige, ich dachte das sei nur bei USB-Geräten nötig.)

Quellcode

1
2
3
4
5
6
7
schreibtisch@Arbeit:~$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 0bda:0157 Realtek Semiconductor Corp. Mass Storage Device
Bus 001 Device 004: ID 0bda:0823 Realtek Semiconductor Corp. 
Bus 001 Device 003: ID 093a:2510 Pixart Imaging, Inc. Optical Mouse
Bus 001 Device 002: ID 1a81:2014 Holtek Semiconductor, Inc. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


Viele Grüße
Neu_KUbuntu

wowi

Ubuntu-Forum-Team

  • »wowi« ist männlich

Beiträge: 4 102

Registrierungsdatum: 03.05.2007

Derivat: Xubuntu

Architektur: 64-Bit PC

Desktop: XFCE

  • Nachricht senden

7

17.01.2017, 20:44

Hallo Neu_KUbuntu,

ich dachte das sei nur bei USB-Geräten nötig.
Stimmt ja auch, und da scheint sich auch wirklich das WLAN nicht dahinter zu verstecken. Allerdings hatte ich zum rtl8821AU nur Posts mit USB gefunden. Und ich habe noch einen alten Aldi-Rechner, der hat auch einige interne Komponenten über USB angeschlossen!

Aber so wie es aussieht, scheint es nach Ubuntu 14.04 tatsächlich Probleme mit diesem Chipsatz zu geben. Hier gibt es die Liste mit den Bugs. Aber wer weiß, vielleicht kann Dir unser WLAN-Spezialist praseodym trotzdem helfen, Du musst nur etwas Geduld haben :D

Greetz
wowi

Beiträge: 973

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

Andere Betriebssysteme: Debian 9.9 "stretch" / 4.9.0-9-amd64

  • Nachricht senden

8

18.01.2017, 12:22

@Neu_KUbuntu:


Hier hab ich eine Anleitung gefunden, wie man den Treiber installieren kann. Das kannst Du ja mal ausprobieren:

https://blog.danielscrivano.com/installi…d-usb-adapters/


Viel Erfolg!

  • »Neu_KUbuntu« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 16.01.2017

Derivat: Kubuntu

Architektur: 64-Bit PC

Desktop: KDE4

Andere Betriebssysteme: Release: 16.10, Codename: yakkety

  • Nachricht senden

9

18.01.2017, 15:46

Hallo Horsemanchip,

vielen Dank für den Link mit dem Tipp.

Leider hat die Installation bei mir so nicht funktioniert. Siehe Ausgabe in der angehängten Textdatei.

Hat jemand eine Idee, was die Fehlermeldung "modprobe: FATAL: Module 8812au not found in directory /lib/modules/4.8.0-34-generic" bedeutet? Oder was ich falsch gemacht haben könnte?

Ich starte den Rechner jetzt noch einmal neu und gebe Rückmeldung, falls sich dadurch etwas ändert, denn ich habe gelesen, das modprobe irgendetwas mit dem Laden von Modulen zur Laufzeit zu tun hat. Ich melde mich, falls der Neustart helfen sollte. edit: Nein, hat nichts bewirkt.

Viele Grüße
Neu_KUbuntu
»Neu_KUbuntu« hat folgende Datei angehängt:
  • Ausgabe.txt (21,39 kB - 2 mal heruntergeladen - zuletzt: 18.01.2017, 16:16)

10

18.01.2017, 16:22

Wie in Zeile 229 des dumps steht, heißt das Modul richtig: rtl8812au
mir is wurscht

  • »Neu_KUbuntu« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 16.01.2017

Derivat: Kubuntu

Architektur: 64-Bit PC

Desktop: KDE4

Andere Betriebssysteme: Release: 16.10, Codename: yakkety

  • Nachricht senden

11

18.01.2017, 17:28

Hallo,

sorry, was ist denn ein "dump" in diesem Fall? (http://www.gruenderszene.de/lexikon/begriffe/dump scheint hier nicht weiterzuhelfen, oder?)

Danke für den Tipp.

Ich habe das ganze jetzt noch einmal probiert, stelle mich aber gerade anscheinend blöd an:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
schreibtisch@Arbeit:~$ sudo modprobe rtl8812au
[sudo] password for schreibtisch: 
modprobe: ERROR: could not insert 'rtl8812au': Required key not available
schreibtisch@Arbeit:~$ cd rtl8812AU_8821AU_linux
schreibtisch@Arbeit:~/rtl8812AU_8821AU_linux$ sudo modprobe rtl8812au
modprobe: ERROR: could not insert 'rtl8812au': Required key not available
schreibtisch@Arbeit:~/rtl8812AU_8821AU_linux$ make
make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.8.0-34-generic/build M=/home/schreibtisch/rtl8812AU_8821AU_linux  modules                                                    	
make[1]: Entering directory '/usr/src/linux-headers-4.8.0-34-generic'                                                                                                          	
  Building modules, stage 2.                                                                                                                                                   	
  MODPOST 1 modules                                                                                                                                                            	
make[1]: Leaving directory '/usr/src/linux-headers-4.8.0-34-generic'                                                                                                           	
schreibtisch@Arbeit:~/rtl8812AU_8821AU_linux$ sudo make install
install -p -m 644 rtl8812au.ko  /lib/modules/4.8.0-34-generic/kernel/drivers/net/wireless/                                                                                     	
/sbin/depmod -a 4.8.0-34-generic                                                                                                                                               	
schreibtisch@Arbeit:~/rtl8812AU_8821AU_linux$ sudo modprobe rtl8812au
modprobe: ERROR: could not insert 'rtl8812au': Required key not available                                                                                                      	
schreibtisch@Arbeit:~/rtl8812AU_8821AU_linux$ sudo modprobe rtl8821au                                                                                                         	
modprobe: FATAL: Module rtl8821au not found in directory /lib/modules/4.8.0-34-generic                                                                                         	
schreibtisch@Arbeit:~/rtl8812AU_8821AU_linux$ make
make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.8.0-34-generic/build M=/home/schreibtisch/rtl8812AU_8821AU_linux  modules                                                    	
make[1]: Entering directory '/usr/src/linux-headers-4.8.0-34-generic'                                                                                                          	
^[[B  Building modules, stage 2.                                                                                                                                               	
  MODPOST 1 modules                                                                                                                                                            	
make[1]: Leaving directory '/usr/src/linux-headers-4.8.0-34-generic'                                                                                                           	
schreibtisch@Arbeit:~/rtl8812AU_8821AU_linux$ sudo make install
install -p -m 644 rtl8812au.ko  /lib/modules/4.8.0-34-generic/kernel/drivers/net/wireless/                                                                                     	
/sbin/depmod -a 4.8.0-34-generic                                                                                                                                               	
schreibtisch@Arbeit:~/rtl8812AU_8821AU_linux$ sudo modprobe rtl8812au
modprobe: ERROR: could not insert 'rtl8812au': Required key not available 


Viele Grüße
Neu_KUbuntu

12

18.01.2017, 17:39

was ist denn ein "dump" in diesem Fall?
Deine vorhin gepostete Datei war damit gemeint.

Du hättest nicht die ganze Arbeit wiederholen müssen, das Modul war ja schon fertig gebaut und installiert. Ein Aufruf (modprobe) mit seinem richtigen Namen hätte gereicht.
Die neue Meldung:
modprobe: ERROR: could not insert 'rtl8812au': Required key not available
... führt zu einem anderen Hindernis -> http://askubuntu.com/a/762255
mir is wurscht

  • »Neu_KUbuntu« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 16.01.2017

Derivat: Kubuntu

Architektur: 64-Bit PC

Desktop: KDE4

Andere Betriebssysteme: Release: 16.10, Codename: yakkety

  • Nachricht senden

13

22.01.2017, 19:10

Es hat nun ein wenig gedauert, bis ich mich dem Rechner wieder widmen konnte.

Vielen Dank! Nun klappt es, dass er die W-Lan-Karte findet und ich bin damit online. Was ich jetzt noch als Problem der kleineren Art bleibt, ist dass er nach dem Start von KDE mehr als 30 Sekunden sucht und recht lange braucht, bis er sich im W-Lan angemeldet hat und ich darauf zugreifen kann.

Ich werde dazu gleich noch die nötigen Daten posten.

edit: Hier sind die Informationen, die evtl. aussagekräftig sein könnten:

Quellcode

1
2
schreibtisch@Arbeit:~$ uname -a
Linux Arbeit 4.8.0-22-generic #24-Ubuntu SMP Sat Oct 8 09:15:00 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux


Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
schreibtisch@Arbeit:~$ iwconfig
enp2s0	no wireless extensions.

wlx74da3896b828  IEEE 802.11AC  ESSID:"o2-WLAN52"  Nickname:"<WIFI@REALTEK>"
      	Mode:Managed  Frequency:5.18 GHz  Access Point: 58:8B:F3:56:EE:2A   
      	Bit Rate:434 Mb/s   Sensitivity:0/0  
      	Retry:off   RTS thr:off   Fragment thr:off
      	Power Management:off
      	Link Quality=91/100  Signal level=84/100  Noise level=0/100
      	Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
      	Tx excessive retries:0  Invalid misc:0   Missed beacon:0

lo    	no wireless extensions.


Quellcode

1
lsmod
-> Ausgabe.txt

Quellcode

1
2
3
4
schreibtisch@Arbeit:~$ cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback


Quellcode

1
2
3
4
5
6
7
schreibtisch@Arbeit:~$ rfkill list
0: hci0: Bluetooth
    	Soft blocked: yes
    	Hard blocked: no
1: phy0: Wireless LAN
    	Soft blocked: no
    	Hard blocked: no


Quellcode

1
2
3
4
5
schreibtisch@Arbeit:~$ cat /etc/modules
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

Bei diesem Befehl scheine ich wieder etwas falsch gemacht zu haben, oder?

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
schreibtisch@Arbeit:~$ sudo iwlist scan
[sudo] password for schreibtisch: 
enp2s0	Interface doesn't support scanning.

wlx74da3896b828  Scan completed :
      	Cell 01 - Address: 58:8B:F3:56:EE:2A
                	ESSID:"o2-WLAN52"
                	Protocol:IEEE 802.11AC
                	Mode:Master
                	Frequency:5.18 GHz (Channel 36)
                	Encryption key:on
                	Bit Rates:867 Mb/s
                	Extra:rsn_ie=30140100000fac040100000fac040100000fac020c00
                	IE: IEEE 802.11i/WPA2 Version 1
                    	Group Cipher : CCMP
                    	Pairwise Ciphers (1) : CCMP
                    	Authentication Suites (1) : PSK
                	IE: Unknown: DD990050F204104A0001101044000102103B00010310470010A6E9607A604C0CF65E83CCBECA0DF495102100094D69747261537461721023000F6F3220486F6D65426F7820363634311024000F6F3220486F6D65426F78203636343110420007393633363847571054000800060050F20400011011000F6F3220486F6D65426F78203636343110080002200C103C0001031049000600372A000120
                	Quality=94/100  Signal level=84/100  
                	Extra:fm=0003
      	Cell 02 - Address: 58:8B:F3:56:EE:29
                	ESSID:"o2-WLAN52"
                	Protocol:IEEE 802.11bgn
                	Mode:Master
                	Frequency:2.412 GHz (Channel 1)
                	Encryption key:on
                	Bit Rates:300 Mb/s
                	Extra:rsn_ie=30140100000fac040100000fac040100000fac020c00
                	IE: IEEE 802.11i/WPA2 Version 1
                    	Group Cipher : CCMP
                    	Pairwise Ciphers (1) : CCMP
                    	Authentication Suites (1) : PSK
                	IE: Unknown: DD990050F204104A0001101044000102103B00010310470010A6E9607A604C0CF65E83CCBECA0DF495102100094D69747261537461721023000F6F3220486F6D65426F7820363634311024000F6F3220486F6D65426F78203636343110420007393633363847571054000800060050F20400011011000F6F3220486F6D65426F78203636343110080002200C103C0001031049000600372A000120
                	Quality=88/100  Signal level=100/100  
                	Extra:fm=0003
      	Cell 03 - Address: 34:31:C4:5D:C6:7D
                	ESSID:"FRITZ!Box 7312"
                	Protocol:IEEE 802.11bgn
                	Mode:Master
                	Frequency:2.412 GHz (Channel 1)
                	Encryption key:on
                	Bit Rates:300 Mb/s
                	Extra:wpa_ie=dd160050f20101000050f20201000050f20201000050f202
                	IE: WPA Version 1
                    	Group Cipher : TKIP
                    	Pairwise Ciphers (1) : TKIP
                    	Authentication Suites (1) : PSK
                	Extra:
                	IE: IEEE 802.11i/WPA2 Version 1
                    	Group Cipher : TKIP
                    	Pairwise Ciphers (1) : CCMP
                    	Authentication Suites (1) : PSK
                	IE: Unknown: DD6F0050F204104A0001101044000102103B000103104700102F5876F422D4171321FD3431C45DC67D1021000341564D1023000446426F78102400043030303010420004303030301054000800060050F20400011011000446426F78100800022788103C0001031049000600372A000120
                	Quality=67/100  Signal level=70/100  
                	Extra:fm=0003

lo    	Interface doesn't support scanning.


Kann jemand aus diesen Daten sehen, warum die Einwahl so lange dauert?

Viele Grüße
Neu_KUbuntu
»Neu_KUbuntu« hat folgende Datei angehängt:
  • Ausgabe.txt (8,44 kB - 1 mal heruntergeladen - zuletzt: 22.01.2017, 20:39)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Neu_KUbuntu« (22.01.2017, 19:22)


  • »praseodym« ist männlich

Beiträge: 914

Registrierungsdatum: 16.02.2010

Derivat: Xubuntu

Architektur: 64-Bit PC

Desktop: anderer Desktop

  • Nachricht senden

14

22.01.2017, 20:39

Hallo,

dein Netz gibt es zweimal, eins im 2,4 GHz-Band und eins im 5 GHz-Band. Er kann sichnicht "entscheiden". Welches wird dir stärker angezeigt? Nimm die MAC-Adress von eben diesem und trage diese im Feld BSSID im Netzwerkmanager ein:


Quellcode

1
2
3
4
5
        Cell 01 - Address: 58:8B:F3:56:EE:2A
                	ESSID:"o2-WLAN52"
...
      	Cell 02 - Address: 58:8B:F3:56:EE:29
                	ESSID:"o2-WLAN52"


Edit: Brauchst du den Paketfilter/Firewall auf dem Client-Rechner? Falls nein:

Quellcode

1
2
3
sudo iptables -t filter -n -L -v
sudo iptables -F
sudo iptables -X
Was es alles gibt, das ich nicht brauche.
(Aristoteles)
COPY/PASTE funktioniert auch im Terminal

  • »Neu_KUbuntu« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 16.01.2017

Derivat: Kubuntu

Architektur: 64-Bit PC

Desktop: KDE4

Andere Betriebssysteme: Release: 16.10, Codename: yakkety

  • Nachricht senden

15

22.01.2017, 21:14

Danke für den Tipp.

Eines von beiden auszuwählen hat die Verbindungszeit allerdings nicht viel kürzer gemacht. Das Beziehen der Netzwerkadresse dauert recht lange.

Das zu Paketfilter/Firewall lese ich mir noch mal in Ruhe auf der man-page durch (was die verschiedenen Parameter des Befehls bedeuten).

16

24.01.2017, 14:36

Das Beziehen der Netzwerkadresse dauert recht lange.

Dann steht aber die WLAN-Verbindung bereits und dieses Problem liegt am DHCP-Server/Router/Modem oder woanders. Die Ausgaben der Scripts aus unserem Wiki, aber diesmal für LAN wären dann hilfreich.
mir is wurscht