Sie sind nicht angemeldet.

21

20.04.2016, 14:22

Da du den alten Grub wieder willst, solltest du die entsprechende Anleitung nehmen. -> https://wiki.ubuntuusers.de/GRUB/#Method…ein-Live-System. Macht nicht viel Unterschied, aber dennoch.

Statt der Live-CD kannst du besser eine Debian-CD nehmen wie es auch bei der Grub2-Reparatur erwähnt wird. Diese erkennt im Rettungsmodus ziemlich jede Sonderkonfiguration (RAID, LVM, Crypt, usw.). Keine Angst, sie installiert dir kein Debian, sie repariert nur das was du verlangst. :)

In deinem Fall ist natürlich wichtig, daß das Raid aufgebaut ist und dessen Device in /mnt eingehängt wird. Und, ganz wichtig: Auch deine Boot-Partition in /mnt/boot. Sonst hast du weiterhin zwei unterschiedliche Versionen von /boot. Das ist in der verlinkten Anleitung besser beschrieben. BTW könntest Du /boot einmal leeren, BEVOR du die echte /boot-Partition darauf mountest. Damit verhinderst du unterschiedliche Inhalte, je nachdem ob /boot übermountet wird oder nicht.

wie kann ich sicher sein dass grub-install grub-legacy installiert
Wenn ausschließlich grub-legacy vollständig installiert ist, dann kann nur der alte Grub gestartet werden und der wiederum hat nur die eigenen Binaries zum Installieren dabei.
mir is wurscht

  • »peerwal« ist der Autor dieses Themas

Beiträge: 31

Registrierungsdatum: 13.04.2016

Derivat: Kubuntu

Architektur: 64-Bit PC

Desktop: KDE4

  • Nachricht senden

22

20.04.2016, 19:15

chroot hat nun doch funktioniert. Die root-Partition war nicht korrekt eingehängt.

Jetzt ist auch klar, dass ich es hier nur noch mit grub-legacy zu tun habe, da ich grub2 vorher schon mit

Quellcode

1
sudo apt-get purge grub* os-prober

von meinem System komplett entfernt hatte. Ich frage gar nicht erst, weshalb das System dann beim Booten trotzdem mit der grub2-Befehlszeile hochkommt?!


Jedenfalls wird wohl in der chroot-Umgebung laut[/code]

Quellcode

1
2
3
4
5
root@kubuntu:/# dpkg --list | grep grub
ii  grub                                                        0.97-29ubuntu66                                     amd64        GRand Unified Bootloader (Legacy version)
ii  grub-common                                                 2.02~beta2-9ubuntu1.7                               amd64        GRand Unified Bootloader (common files)
ii  grub-emu                                                    2.02~beta2-9ubuntu1.7                               amd64        GRand Unified Bootloader, version 2 (emulated version)
ii  grub-legacy-doc                                             0.97-29ubuntu66                                     all          Documentation for GRUB Legacy


nur noch grub-legacy vorhanden sein.

Leider funktioiert aber auch hier grub-install nicht:

Quellcode

1
2
3
4
root@kubuntu:/# grub-install /dev/sda2
/dev/sda2: Not found or not a block device.
root@kubuntu:/# grub-install /dev/sda
/dev/mapper/isw_bdaecdecfh_ARRAY1 does not have any corresponding BIOS drive.


Ich bin nicht sicher, ob ich als Ziel /dev/mapper/kubuntu--vg-root verwenden kann?

Sorry, habe gerade gesehen, dass sich unsere Antworten überschnitten haben. Wenn ich das hier mit dem grub-install nicht hin bekomme, Versuche ich es noch mal mit der anderen Anleitung und der Debian-CD.

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »peerwal« (21.04.2016, 00:20)


23

21.04.2016, 00:14

weshalb das System dann beim Booten trotzdem mit der grub2-Befehlszeile hochkommt
Weil sein Bootcode immer noch im Startsektor sitzt. Was entfernt wurde, waren nur die Hilfsprogramme und Code, den er zum Arbeiten braucht. Aber in den Startsektor kommt das nötige eben mit grub-install. Deshalb sollte imho ein solches jetzt reichen, sobald ein System läuft, das die notwenidgen Dateien an Board hat. Da du das installierte System nicht mehr booten kannst, bleibt nur eine Live-CD. Die könnte das alleine auch, aber mit chroot werden gewisse Eigenheiten des installierten Systems berücksichtigt. Speziell die notwendigen Treiber werden gleich in die Ramdisk gepackt, damit das System hochfahren kann. In deinem Fall sind (möglicherweise) RAID-Treiber und -tools, sowie LVM und einige Module nötig. Das ist in diversen Einstellungs-Dateien hinterlegt. Damit die berücksichtigt werden muss in das installierte System gewechselt werden. Das macht chroot.
Dabei ist es übrigens wichtig, einen Live-kernel für die gleiche Architektur wie das installierte System zu verwenden! Also, wenn du z.B. 64-Bit Architektur hast, aber ein 32-Bit System installiert ist, musst du auch eine 32-Bit Live-CD verwenden. Sonst passen nämlich die installierten Module nicht, die ja für die Ramdisk von der Festplatte zusammengeklaubt werden.

Debian-CD. Ist damit übrigens die Alternate CD gemeint, die gibt es seit Kubuntu 12.10 nicht mehr
Ich meine die CD von debian.org. (Lass das Weihwasser im Krug, du verwendest nur ihre Reparaturfunktion) http://cdimage.debian.org/debian-cd/8.4.…-amd64-CD-1.iso

Hier ist die Anleitung zur Grub-Reparatur. Demnach wäre das richtige Ziel grub-install '(hd0)' aber sieh dir erstmal an, was die Live-CD macht.
Beim Drüberlesen habe ich selbst erst erfahren, daß der alte Grub mit bestimmten RAID/LVM-Kombinationen evtl. Probleme hat. Also wenn das scheitert, müsstest du es doch mit Grub2 probieren. Wie es aussieht, hattest du aber früher schonmal grub-legacy am Start. Sonst wären keine Reste davon übrig gewesen.

Ins LVM-Volume kannst du ihn nicht installieren. Das ist ziemlich das letzte was verfügbar wird, kann also vom BIOS nicht angesprungen werden.
mir is wurscht

  • »peerwal« ist der Autor dieses Themas

Beiträge: 31

Registrierungsdatum: 13.04.2016

Derivat: Kubuntu

Architektur: 64-Bit PC

Desktop: KDE4

  • Nachricht senden

24

23.04.2016, 15:54

Hallo Fredl,

nachdem ich auch mit der Debian-DVD grub-legacy nicht installieren konnte, habe ich mit Hilfe der Live-CD und chroot grub-PC neu installiert und siehe da, der 85er Kernel startet ohne Probleme. Vielen Dank für deine Unterstützung. Habe ne Menge dazugelernt. Ich werde das Thema auf erledigt setzen.

25

24.04.2016, 00:43

Na, dann passt ja wieder alles. Schön! :)

Möglicherweise hast du tatsächlich so eine RAID/LVM-Kombination, die dem alten Grub Probleme macht. Wie ich schon sagte, wäre dann eine saubere Installation von Grub2 die bessere Lösung, auch wenn er bei Single-Boot eigentlich overkill ist.
Wesentlich war, daß eben nur einer von beiden da ist und alle Änderungen (speziell natürlich kernel-updates) mitbekommt. Das war bei dir nicht mehr der Fall. ->
Nun geht aus deiner Schilderung mit den falschen Menüs für mich hervor, daß zwar Grub2 gebootet wird, der aber keine updates mehr mitbekommt (kommt wohl auch darauf an, wo sich /boot gerade befindet, separat oder im Wurzelsystem). Wenn kernel installiert werden, dann wird die Konfiguration für Grub-Legacy erneuert, der aber nicht im aktiven Einsatz ist.

Deshalb war die über Umwege (chroot) erfolgreiche saubere Installation einer Grub-Version die nachvollziehbare Lösung. Das Thema hat sich daher nicht "erledigt", sondern ist "gelöst".
Wie man ein Thema markiert ist in unseren Einsteiger-Infos erklärt.
mir is wurscht