Sie sind nicht angemeldet.

  • »jgmail« ist der Autor dieses Themas

Beiträge: 14

Registrierungsdatum: 02.04.2016

Derivat: Kubuntu

Architektur: 64-Bit PC

Desktop: KDE4

Andere Betriebssysteme: OpenSuse 42.1, Windows 7

  • Nachricht senden

1

02.04.2016, 23:34

GpsPrune startet nicht mehr

Hallo,

ich hatte mir vor 3 Monaten GpsPrune aus dem Ubuntu Software Center installiert und damit gearbeitet. Jetzt startet es nicht mehr. Ich habe es deinstalliert und wieder neu installiert, auch den Rechner runter und wieder hochgefahren, keine Chance. Ich kann machen was ich will, es reagiert einfach nicht mehr. Ist da was bekannt, warum das nicht mehr funktioniert?

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »jgmail« (25.04.2016, 21:02)


2

03.04.2016, 19:32

Hallo

Ich habe keine Probleme in der Richtung.
Allerdings Installiere ich über das Terminal oder manchmal über die Synaptic.
Software Center Nutze ich nicht.
Dumm sind immer die anderen, weil man ja selbst Klug ist. So halten die Dummen den klugen für Dumm weil sie ja selbst Klug sind.
Aber die Richtig Klugen Menschen sind in der Psychiatrie weil diese schon über ihren Verstand hinaus Geschossen sind.

3

04.04.2016, 18:58

Hallo,

GpsPrune ist doch eine *.jar Datei.

Feststellen wo sie sich befindet z.B. mit

Quellcode

1
locate gpsprune


im Terminal mit

Quellcode

1
java -jar /PATHNAME/DATEINAME


starten.

Fehlermeldungen ansehen/hier zeigen,

mfg

  • »jgmail« ist der Autor dieses Themas

Beiträge: 14

Registrierungsdatum: 02.04.2016

Derivat: Kubuntu

Architektur: 64-Bit PC

Desktop: KDE4

Andere Betriebssysteme: OpenSuse 42.1, Windows 7

  • Nachricht senden

4

05.04.2016, 22:43

Das funktioniert leider nicht. Hier die Ausgabe vom Terminal. Hatte mir die Datein gpsprune_18.3.jar für Linus bei heise heruntergeladen.

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
juergen@juergen-Aspire-E1-530:~$ java -jar /home/juergen/Downloads/gpsprune_18.3.jar
Exception in thread "main" java.awt.AWTError: Assistive Technology not found: org.GNOME.Accessibility.AtkWrapper
    	at java.awt.Toolkit.loadAssistiveTechnologies(Toolkit.java:807)
    	at java.awt.Toolkit.getDefaultToolkit(Toolkit.java:886)
    	at java.awt.Window.getToolkit(Window.java:1362)
    	at java.awt.Window.init(Window.java:506)
    	at java.awt.Window.<init>(Window.java:537)
    	at java.awt.Frame.<init>(Frame.java:420)
    	at javax.swing.JFrame.<init>(JFrame.java:233)
    	at tim.prune.GpsPrune.launch(Unknown Source)
    	at tim.prune.GpsPrune.main(Unknown Source)
juergen@juergen-Aspire-E1-530:~$ cd Downloads
juergen@juergen-Aspire-E1-530:~/Downloads$ java -jar gpsprune_18.3.jar
Exception in thread "main" java.awt.AWTError: Assistive Technology not found: org.GNOME.Accessibility.AtkWrapper
    	at java.awt.Toolkit.loadAssistiveTechnologies(Toolkit.java:807)
    	at java.awt.Toolkit.getDefaultToolkit(Toolkit.java:886)
    	at java.awt.Window.getToolkit(Window.java:1362)
    	at java.awt.Window.init(Window.java:506)
    	at java.awt.Window.<init>(Window.java:537)
    	at java.awt.Frame.<init>(Frame.java:420)
    	at javax.swing.JFrame.<init>(JFrame.java:233)
    	at tim.prune.GpsPrune.launch(Unknown Source)
    	at tim.prune.GpsPrune.main(Unknown Source)
juergen@juergen-Aspire-E1-530:~/Downloads$ 

Beiträge: 992

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

Andere Betriebssysteme: Debian 10 "buster" / 4.19.0-5-amd64

  • Nachricht senden

5

05.04.2016, 22:53

Warum installierst Du nicht das Paket aus der Paketverwaltung und lädst was bei heise runter?

Quellcode

1
sudo apt-get install gpsprune

6

05.04.2016, 23:06

Hallo

Oben steht über das Software Center, oder hab ich was Falsch gelesen ?
Dumm sind immer die anderen, weil man ja selbst Klug ist. So halten die Dummen den klugen für Dumm weil sie ja selbst Klug sind.
Aber die Richtig Klugen Menschen sind in der Psychiatrie weil diese schon über ihren Verstand hinaus Geschossen sind.

7

05.04.2016, 23:09

Oder aktuelle Versionen von hier Activity Workshop .

Scheint aber ein Problem mit der verwendeten Java-Version zu sein.

Siehe hier ask ubuntu

und hier Bug

mfg

  • »jgmail« ist der Autor dieses Themas

Beiträge: 14

Registrierungsdatum: 02.04.2016

Derivat: Kubuntu

Architektur: 64-Bit PC

Desktop: KDE4

Andere Betriebssysteme: OpenSuse 42.1, Windows 7

  • Nachricht senden

8

05.04.2016, 23:32

@Horsemanchip
Habe ich ausgeführt, es hat sich alles installiert, aber es ist das selbe wie nach der Installation aus dem Ubuntu-Software-Center, das Programm startet einfach nicht.

@Parzelle13
Muss hier zugeben, dass ich auch bei OpenSuse bin und habe da mit Hilfe des Forums gpsprune_18.3.jar zum Laufen gebracht.

https://www.opensuse-forum.de/thread/366…93937#post93937

Beiträge: 992

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

Andere Betriebssysteme: Debian 10 "buster" / 4.19.0-5-amd64

  • Nachricht senden

9

05.04.2016, 23:47

@Horsemanchip
Habe ich ausgeführt, es hat sich alles installiert, aber es ist das selbe wie nach der Installation aus dem Ubuntu-Software-Center, das Programm startet einfach nicht.


Starte mal die Anwendung aus einem Terminal heraus per:

Quellcode

1
gpsprune


... und schau ob Du eine Fehlermeldung erhälst. Diese dann hier posten.

  • »jgmail« ist der Autor dieses Themas

Beiträge: 14

Registrierungsdatum: 02.04.2016

Derivat: Kubuntu

Architektur: 64-Bit PC

Desktop: KDE4

Andere Betriebssysteme: OpenSuse 42.1, Windows 7

  • Nachricht senden

10

06.04.2016, 21:31

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
juergen@juergen-Aspire-E1-530:~$ gpsprune
Exception in thread "main" java.awt.AWTError: Assistive Technology not found: org.GNOME.Accessibility.AtkWrapper
    	at java.awt.Toolkit.loadAssistiveTechnologies(Toolkit.java:807)
    	at java.awt.Toolkit.getDefaultToolkit(Toolkit.java:886)
    	at java.awt.Window.getToolkit(Window.java:1362)
    	at java.awt.Window.init(Window.java:506)
    	at java.awt.Window.<init>(Window.java:537)
    	at java.awt.Frame.<init>(Frame.java:420)
    	at javax.swing.JFrame.<init>(JFrame.java:233)
    	at tim.prune.GpsPrune.launch(GpsPrune.java:185)
    	at tim.prune.GpsPrune.main(GpsPrune.java:153)
juergen@juergen-Aspire-E1-530:~$ 

Beiträge: 992

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

Andere Betriebssysteme: Debian 10 "buster" / 4.19.0-5-amd64

  • Nachricht senden

11

06.04.2016, 22:18

Wahrscheinlich fehlt dir ein Java Paket. Sowas wie openjdk-8-jre o.ä.

Mehr kann ich dazu nicht sagen, da Java nicht so meine Baustelle ist.

  • »jgmail« ist der Autor dieses Themas

Beiträge: 14

Registrierungsdatum: 02.04.2016

Derivat: Kubuntu

Architektur: 64-Bit PC

Desktop: KDE4

Andere Betriebssysteme: OpenSuse 42.1, Windows 7

  • Nachricht senden

12

06.04.2016, 22:31

Das ist schon merkwürdig. Ich hatte GpsPrune im Januar über das Ubuntu-Softwar-Center installiert, es funktionierte bis Mitte Februar tadellos, danach hatte ich es nicht mehr genutzt. Und jetzt startet es nicht mehr, aber bei OpenSuse funktioniert es.

13

06.04.2016, 23:05

Hast du denn mal die von mir verlinkten Artikel gelesen?

Terminal öffnen und folgendes eingeben.

Quellcode

1
sudo dpkg -l | grep openjdk


Ausgabe hier zeigen.

Beiträge: 992

Registrierungsdatum: 08.11.2015

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

Andere Betriebssysteme: Debian 10 "buster" / 4.19.0-5-amd64

  • Nachricht senden

14

06.04.2016, 23:25

@Parzelle13:

dpkg -l benötigt keine root Rechte (sudo). sudo nur benutzen, wenn es erforderlich ist! ;)

@jgmail:

Wenn es bei Dir schon mal lief, kannst Du mal die userspezifische Konfiguration löschen und dann versuchen es erneut zu starten im Terminal:

Quellcode

1
2
3
rm -rf .config/gpsprune

gpsprune


Viel Erfolg!

  • »jgmail« ist der Autor dieses Themas

Beiträge: 14

Registrierungsdatum: 02.04.2016

Derivat: Kubuntu

Architektur: 64-Bit PC

Desktop: KDE4

Andere Betriebssysteme: OpenSuse 42.1, Windows 7

  • Nachricht senden

15

07.04.2016, 21:32

@Parzelle13

Quellcode

1
2
3
4
5
6
uergen@juergen-Aspire-E1-530:~$ dpkg -l | grep openjdk
ii  openjdk-7-jre:amd64                       	7u95-2.6.4-0ubuntu0.15.10.2            	amd64    	OpenJDK Java runtime, using Hotspot JIT
ii  openjdk-7-jre-headless:amd64              	7u95-2.6.4-0ubuntu0.15.10.2            	amd64    	OpenJDK Java runtime, using Hotspot JIT (headless)
rc  openjdk-8-jre:amd64                       	8u66-b17-1                             	amd64    	OpenJDK Java runtime, using Hotspot JIT
ii  openjdk-8-jre-headless:amd64              	8u66-b17-1                             	amd64    	OpenJDK Java runtime, using Hotspot JIT (headless)
juergen@juergen-Aspire-E1-530:~$ 


@Horsemanchip

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
juergen@juergen-Aspire-E1-530:~$ rm -rf .config/gpsprune
juergen@juergen-Aspire-E1-530:~$ 
juergen@juergen-Aspire-E1-530:~$ gpsprune
Exception in thread "main" java.awt.AWTError: Assistive Technology not found: org.GNOME.Accessibility.AtkWrapper
    	at java.awt.Toolkit.loadAssistiveTechnologies(Toolkit.java:807)
    	at java.awt.Toolkit.getDefaultToolkit(Toolkit.java:886)
    	at java.awt.Window.getToolkit(Window.java:1362)
    	at java.awt.Window.init(Window.java:506)
    	at java.awt.Window.<init>(Window.java:537)
    	at java.awt.Frame.<init>(Frame.java:420)
    	at javax.swing.JFrame.<init>(JFrame.java:233)
    	at tim.prune.GpsPrune.launch(GpsPrune.java:185)
    	at tim.prune.GpsPrune.main(GpsPrune.java:153)
juergen@juergen-Aspire-E1-530:~$ 

16

07.04.2016, 22:16

Hallo,

das mit der Datei in .config kannst du vergessen. Bei mir gibts die jedenfalls nicht.

Quellcode

1
2
3
4
ii  openjdk-7-jre:amd64
ii  openjdk-7-jre-headless:amd64
rc  openjdk-8-jre:amd64
ii  openjdk-8-jre-headless:amd64


Wie man am ii sieht, hast du openjdk-7-jre , openjdk-7-jre-headless und openjdk-8-jre-headless installiert. Ich würde openjdk-8-jre-headless mal deinstallieren und probieren, ob es dann funktioniert. Bei mir funktioniert es damit jedenfalls. Ob es auch mit openjdk-8-* funktioniert kannst du ausprobieren, dann würde ich aber openjdk-8-jre nachinstallieren.

mfg

  • »jgmail« ist der Autor dieses Themas

Beiträge: 14

Registrierungsdatum: 02.04.2016

Derivat: Kubuntu

Architektur: 64-Bit PC

Desktop: KDE4

Andere Betriebssysteme: OpenSuse 42.1, Windows 7

  • Nachricht senden

17

09.04.2016, 20:35

Kenne mich leider zu wenig aus mit den Befehlen. Wenn ich im Terminal "install openjdk-8-jre" eingebe kommt die Ausgabe "Fehlender Zieldatei Operand..." Ich weiß aber auch gar nicht ob "install" der richtige Befehl ist. Weiterhin habe ich es mit "sudo dpkg -i oprenjdk-8-jre" versucht, dann kommt die Ausgabe "Fehler beim Bearbeiten des Archiv openjdk-8-jre..." Das ist wohl auch völlig daneben. Vielleicht kann mir jemand helfen, wie man das richtig macht.

  • »jgmail« ist der Autor dieses Themas

Beiträge: 14

Registrierungsdatum: 02.04.2016

Derivat: Kubuntu

Architektur: 64-Bit PC

Desktop: KDE4

Andere Betriebssysteme: OpenSuse 42.1, Windows 7

  • Nachricht senden

18

25.04.2016, 21:04

Nachdem ich auf Kubuntu 16.04 LTS geupdated habe läuft GpsPrune wieder, installiert aus dem Ubuntu Software-Center. Alles gut.