Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

CM_HY

User

  • »CM_HY« ist der Autor dieses Themas

Beiträge: 3

Registrierungsdatum: 22.12.2015

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: unbekannt

  • Nachricht senden

1

22.12.2015, 14:49

FT232 USB Converter sendet / empfängt nichts

Hallo,
ich habe einen USB RS232 Converter an meinem Ubuntu angebunden und kann ihn auch via Minicom ansprechen.
wenn ich ihn abziehe bekomme auch auch prompt eine Fehlermeldung von MiniCom.
Ich habe nun auf dem PIN 3 des SUB D 9 pol geschaut ob ich was bekomme. Das habe ich mit dem OSZI gemessen.
Den Converter habe ich am WIN system bereits in betrieb gehabt und konnte ihn nutzen.
hat irgend jemand eine Idee woran das liegen könnte?

Ausschnitt aus meiner Console:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
Willkommen zu minicom 2.7 

Optionen: I18n 
Übersetzt am Jan 1 2014, 17:13:22. 
Port /dev/ttyUSB1, 11:34:10 

Drücken Sie CTRL-A Z für Hilfe zu speziellen Tasten 
hallo 
hallo 
hallo 
hallo 
hallo


Quellcode

1
2
3
4
5
6
7
lsusb

Bus 001 Device 005: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 019: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC
Bus 001 Device 003: ID 13fd:1840 Initio Corporation INIC-1608 SATA bridge
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Quellcode

1
2
3
4
5
6
7
8
9
10
4602.108824] usb 1-1.3: Product: US232B
[ 4602.108828] usb 1-1.3: Manufacturer: FTDI
[ 4602.108832] usb 1-1.3: SerialNumber: FTCDC3AX
[ 4602.110505] ftdi_sio 1-1.3:1.0: FTDI USB Serial Device converter detected
[ 4602.110612] usb 1-1.3: Detected FT232BM
[ 4602.110622] usb 1-1.3: Number of endpoints 2
[ 4602.110631] usb 1-1.3: Endpoint 1 MaxPacketSize 64
[ 4602.110641] usb 1-1.3: Endpoint 2 MaxPacketSize 64
[ 4602.110650] usb 1-1.3: Setting MaxPacketSize 64
[ 4602.111191] usb 1-1.3: FTDI USB Serial Device converter now attached to ttyUSB1


Ich bin für jeden Tip dankbar

Gruß
CM

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »CM_HY« (23.12.2015, 11:55)


2

22.12.2015, 20:02

Willkommen im Forum!

Bis hierhin scheint ja alles in Ordnung zu sein. Was genau meinst du also mit "sendet / empfängt nichts"?

P.S. Für Terminal-Ein/Ausgaben bitte die "#" benutzen, nicht "<?"
me is all sausage
but don't call me Ferdl

CM_HY

User

  • »CM_HY« ist der Autor dieses Themas

Beiträge: 3

Registrierungsdatum: 22.12.2015

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: unbekannt

  • Nachricht senden

3

23.12.2015, 11:42

Hallo Fredl,
danke!
Wenn ich mit dem Oszilloskop an die TX Leitung des Adapters mich anschließe, sehe ich keinerlei Signal im Oszilloskop.
Vergleichsweise habe ich den Adapter am WIN PC angehängt und einfach via Terminal Teraterm Bytes ausgesendet. Die habe ich auch im Oszi gesehen.
Sprich der Adapter ist in Ordnung.
ich vermute irgendwas ist mit der Einbindung in die Ubuntu Welt nicht in Ordnung?

Woran kann das liegen?

Gruß
Claus




4

23.12.2015, 14:01

Schnittstellenparameter stimmen? Baudrate, Parity, Start/Stop-Bit...
2400 oder 9600 Baud sollte eigentlich immer gehen.
Was sagt denn die Software, die damit eigentlich arbeiten soll? DFÜ über Terminal wird ja nicht der vorgesehene Einsatz sein :)
me is all sausage
but don't call me Ferdl

CM_HY

User

  • »CM_HY« ist der Autor dieses Themas

Beiträge: 3

Registrierungsdatum: 22.12.2015

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: unbekannt

  • Nachricht senden

5

23.12.2015, 14:13

Das passt alles. Und eigentlich auch egal, da ich ja irgendwas auf meinem Oszi sehen sollte,
egal welche Parameter eingestellt sind...
Ich benutze Minicom, wie bereits beschrieben, und die SW kann ohne Probleme darauf zugreifen. Wenn ich die USB Verbindung trenne,
dann bekomme ich auch eine Fehlermeldung von der SW MINICOM. stecke ich ihn wieder ein dann geht alles.

Deswegen verstehe ich das nicht...

6

23.12.2015, 20:34

Stimmt schon, daß es für die elektrische Signalverfolgung egal ist. Mir fiel nur als erster Schritt nichts besseres ein und ich dachte, daß damit irgendeine Kommunikation stattfinden soll, die eben nicht funkt.
Als nächstes käme die flow-control in Frage. Wenn die auf Hardware eingestellt ist, wird sich am "offenen" Stecker, also ohne Handshake-Signale eventuell auch nichts tun. Deshalb die Frage nach der eigentlichen Anwendung.
me is all sausage
but don't call me Ferdl