Sie sind nicht angemeldet.

  • »Br0k0li« ist der Autor dieses Themas

Beiträge: 4

Registrierungsdatum: 19.08.2015

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: Unity

Andere Betriebssysteme: Windows 7 Ultimate

  • Nachricht senden

1

19.08.2015, 20:45

GRUB Timeout will sich nicht nullen lassen

Hallo

Ich habe versucht den Timer des Bootmenüs auf 0 zu setzen.
Damit der PC schneller hoch fährt. Das macht er aber nicht. Der Timer
bleibt immer schön auf 10 Sekunden.

/etc/default/grub --> TIMEOUT=0
update-grub

Da
ich stark annehme, dass es egal ist, dass Grub nicht im MBR sondern in
nem Partitionskopf ist, habe ich mal in die Datei /boot/grub/grub.cfg
rein geguckt. Da stehen so schlaue Sachen drin wie:
IF ${TIMEOUT}=0
THEN TIMEOUT=10

Ich
kann nicht sagen, ob der Scriptteil überhaupt ausgeführt wird. Da die
Sekunden sich aber nicht auf 0 stellen lassen, gehe ich aber stark davon
aus.

Jemand ne Idee, wie ich das Problem lösen kann, ohne etwas unbeabsichtigt zu zerstören?

Gruß

Ubuntu 15.x
GRUB 2.x

  • »Klaus P« ist männlich

Beiträge: 4 495

Registrierungsdatum: 25.10.2009

Derivat: anderes Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: 7/10

  • Nachricht senden

2

19.08.2015, 21:16

Hallo!

Bist du so, wie hier beschrieben vorgegangen? Beachte auch "GRUB_HIDDEN_TIMEOUT".

Zitat

Da
ich stark annehme, dass es egal ist, dass Grub nicht im MBR sondern in
nem Partitionskopf ist
Prinzipiell ist das nicht egal! Warum ist das so?

Kopiere doch mal diesen "Endlosbefehl" ins Terminal (STRG + ALT + T) und starte die Abfrage.

Quellcode

1
sudo fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sudo sh -c "hexdump -v -s 0x80 -n  2 -e '2/1 "%x" "\\n"' X | xargs -n1 -IY sh -c "case  "Y" in '48b4') echo X: GRUB 2 v1.96 ;; 'aa75' | '5272') echo X: GRUB Legacy ;; '7c3c') echo X: GRUB 2 v1.97 oder v1.98 ;; '020') echo X: GRUB 2 v1.99 ;; *) echo X: Kein GRUB Y ;; esac"" 
Keine Sorge, die Befehlsausgabe ist recht kurz und sagt uns wo alles Grub platziert ist.

Gruß
Des modernen Menschen Computer ist sein Himmelreich! :rolleyes: Der Weg zur Hölle, ist allzu kurz auf dem falschen "EFI-Pfad" ;( : Kleiner Leitfaden zur UEFI-Installation

  • »Br0k0li« ist der Autor dieses Themas

Beiträge: 4

Registrierungsdatum: 19.08.2015

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: Unity

Andere Betriebssysteme: Windows 7 Ultimate

  • Nachricht senden

3

19.08.2015, 22:40

Bist du so, wie hier beschrieben vorgegangen? Beachte auch "GRUB_HIDDEN_TIMEOUT".
Ich finde nicht, dass dort ein "Vorgang" beschrieben wird. Aber ich hatte es gelesen. Und dann so gemacht, wie angegeben.
Siehe hier:
/etc/default/grub --> TIMEOUT=0
update-grub
Prinzipiell ist das nicht egal! Warum ist das so?
Weil ich es kann :D !!! Ist leichter zu entfernen. Für mich ist fraglich, ob ich Ubuntu auf dem Gerät lasse oder nicht. Daher habe ich es einfach komplett in eine Partition geknallt. Wenn ich keinen Bock mehr drauf habe, dann lösche ich einfach die Partition. Dann muss ich nicht den MBR wiederherstellen oder so n komplizierten Scheiss. Steuere es über den Windows-Boot-Loader an. Funktioniert einwandfrei. Bis auf die nervige Sache mit dem doppelten Timeout.

Keine Sorge, die Befehlsausgabe ist recht kurz und sagt uns wo alles Grub platziert ist.
:D :D Du hast recht!! Die Ausgabe ist echt kurz: "bash: Syntaxfehler beim unerwarteten Wort ")". Selten so gelacht! :D :D
Du suchst nach Stellen, in denen sich GRUB installiert hat?? Warum? Das Ding installiert sich doch hoffentlich nicht wahllos hin und her? Er sollte auf der 2. Platte in der 3. Partition sein.

  • »Br0k0li« ist der Autor dieses Themas

Beiträge: 4

Registrierungsdatum: 19.08.2015

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: Unity

Andere Betriebssysteme: Windows 7 Ultimate

  • Nachricht senden

4

19.08.2015, 22:57

ganz vergessen ...

Den Hidden-Timeout habe ich natürlich nicht angefasst!

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=0

  • »Klaus P« ist männlich

Beiträge: 4 495

Registrierungsdatum: 25.10.2009

Derivat: anderes Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: 7/10

  • Nachricht senden

5

19.08.2015, 22:59

Hallo!

Zitat

Du hast recht!! Die Ausgabe ist echt kurz: "bash: Syntaxfehler beim unerwarteten Wort ")". Selten so gelacht!
Dann hast du es eben falsch eingegeben! Lachhaft....!? Aber is jetzt eh egal!

Zitat

Dann muss ich nicht den MBR wiederherstellen oder so n komplizierten Scheiss
Yepp! Hochkompliziert, würd ich auch dringend von abraten!

Zitat

Steuere es über den Windows-Boot-Loader an. Funktioniert einwandfrei.
Geht doch! Also doch zu ner vernünftigen Erklärung fähig!

Zitat

Das Ding installiert sich doch hoffentlich nicht wahllos hin und her?
Klar macht er das! Aber nur um dich zu ärgern!

Schönen Abend noch!
Des modernen Menschen Computer ist sein Himmelreich! :rolleyes: Der Weg zur Hölle, ist allzu kurz auf dem falschen "EFI-Pfad" ;( : Kleiner Leitfaden zur UEFI-Installation

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Klaus P« (20.08.2015, 11:08)


  • »Br0k0li« ist der Autor dieses Themas

Beiträge: 4

Registrierungsdatum: 19.08.2015

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: Unity

Andere Betriebssysteme: Windows 7 Ultimate

  • Nachricht senden

6

20.08.2015, 12:31

Dann hast du es eben falsch eingegeben
Nein. Ich habe es 1:1 kopiert!

Also es hat definitiv etwas mit den Scripten zu tun! Nicht mit dem System! (siehe Post 1)

Ich habe den TIMEOUT mal auf 1 gesetzt. Das funktioniert! Ich kenne mich nur leider nicht mit den Scripten aus. Und ich kann nicht sagen, wo ich dort etwas ändern darf oder sollte.

Zurzeit ist neben Ihnen 1 Benutzer in diesem Thema unterwegs:

1 Besucher

Verwendete Tags

bootmenü, grub, NULL, TIMEOUT