Sie sind nicht angemeldet.

  • »SpeeFak« ist der Autor dieses Themas

Beiträge: 273

Registrierungsdatum: 23.06.2009

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: GNOME 3.0

Andere Betriebssysteme: Debian 7.0 wheezy

  • Nachricht senden

1

08.08.2015, 15:50

Cups - Login nach neuinstallation nicht mehr über Webinterface möglich

Hallo, ich habe nach der Neuinstalltion von Ubuntu 14.04 folgendes Problem mit cups :


ich kann auf das Webinterface zugreifen ( localhost:631 ) oder keine administrativen Dinge tun, da der Login für den Admin Account nicht funktioniert

cups log :

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
cat /var/log/cups/error_log
E [06/Aug/2015:19:37:21 +0200] Unable to bind socket for address [v1.::1]:631 - Address already in use.
E [06/Aug/2015:19:37:21 +0200] Unable to bind socket for address 127.0.0.1:631 - Address already in use.
W [08/Aug/2015:14:50:19 +0200] CreateProfile failed: org.freedesktop.ColorManager.AlreadyExists:profile id 'MFC5890CN-Gray..' already exists
W [08/Aug/2015:14:50:19 +0200] CreateProfile failed: org.freedesktop.ColorManager.AlreadyExists:profile id 'MFC5890CN-RGB..' already exists
E [08/Aug/2015:14:50:19 +0200] Unable to bind socket for address [v1.::1]:631 - Address already in use.
E [08/Aug/2015:14:50:19 +0200] Unable to bind socket for address 127.0.0.1:631 - Address already in use.
E [08/Aug/2015:14:50:43 +0200] Unable to bind socket for address [v1.::1]:631 - Address already in use.
E [08/Aug/2015:14:50:43 +0200] Unable to bind socket for address 127.0.0.1:631 - Address already in use.
E [08/Aug/2015:14:51:36 +0200] [Client 14] Local authentication certificate not found.
E [08/Aug/2015:14:51:36 +0200] [Client 14] Local authentication certificate not found.
E [08/Aug/2015:14:51:36 +0200] [Client 14] Local authentication certificate not found.
E [08/Aug/2015:14:51:42 +0200] [Client 14] Local authentication certificate not found.
E [08/Aug/2015:14:51:42 +0200] [Client 14] Local authentication certificate not found.
E [08/Aug/2015:14:51:42 +0200] [Client 14] Local authentication certificate not found.
E [08/Aug/2015:15:21:08 +0200] Hostname lookup for "*.631" failed.
E [08/Aug/2015:15:21:08 +0200] Bad Listen address *.631 at line 17.
W [08/Aug/2015:15:21:08 +0200] CreateProfile failed: org.freedesktop.ColorManager.AlreadyExists:profile id 'PDF-Gray..' already exists
W [08/Aug/2015:15:21:08 +0200] CreateProfile failed: org.freedesktop.ColorManager.AlreadyExists:profile id 'PDF-RGB..' already exists
E [08/Aug/2015:15:21:26 +0200] Hostname lookup for "*.631" failed.
E [08/Aug/2015:15:21:26 +0200] Bad Listen address *.631 at line 17.
E [08/Aug/2015:15:21:26 +0200] Hostname lookup for "*.631" failed.
E [08/Aug/2015:15:21:26 +0200] Bad Listen address *.631 at line 17.
E [08/Aug/2015:15:24:13 +0200] Hostname lookup for "*.631" failed.
E [08/Aug/2015:15:24:13 +0200] Bad Listen address *.631 at line 17.
E [08/Aug/2015:15:27:30 +0200] [Client 12] Local authentication certificate not found.
E [08/Aug/2015:15:27:30 +0200] [Client 12] Local authentication certificate not found.
E [08/Aug/2015:15:27:30 +0200] [Client 12] Local authentication certificate not found.
E [08/Aug/2015:15:27:39 +0200] [Client 12] Local authentication certificate not found.
E [08/Aug/2015:15:27:39 +0200] [Client 12] Local authentication certificate not found.
E [08/Aug/2015:15:27:39 +0200] [Client 12] Local authentication certificate not found.
E [08/Aug/2015:15:33:33 +0200] [Client 12] Local authentication certificate not found.
E [08/Aug/2015:15:33:33 +0200] [Client 12] Local authentication certificate not found.
E [08/Aug/2015:15:33:33 +0200] [Client 12] Local authentication certificate not found.
E [08/Aug/2015:15:33:35 +0200] [Client 12] Local authentication certificate not found.
E [08/Aug/2015:15:33:35 +0200] [Client 12] Local authentication certificate not found.
E [08/Aug/2015:15:33:35 +0200] [Client 12] Local authentication certificate not found.
E [08/Aug/2015:15:33:36 +0200] [Client 12] Local authentication certificate not found.
E [08/Aug/2015:15:33:36 +0200] [Client 12] Local authentication certificate not found.
E [08/Aug/2015:15:33:36 +0200] [Client 12] Local authentication certificate not found.
E [08/Aug/2015:15:34:55 +0200] Hostname lookup for "*.631" failed.
E [08/Aug/2015:15:34:55 +0200] Bad Listen address *.631 at line 17.
E [08/Aug/2015:15:34:55 +0200] Hostname lookup for "*.631" failed.
E [08/Aug/2015:15:34:55 +0200] Bad Listen address *.631 at line 17.
E [08/Aug/2015:15:35:25 +0200] Hostname lookup for "*.631" failed.
E [08/Aug/2015:15:35:25 +0200] Bad Listen address *.631 at line 17.
E [08/Aug/2015:15:35:25 +0200] Hostname lookup for "*.631" failed.
E [08/Aug/2015:15:35:25 +0200] Bad Listen address *.631 at line 17.
E [08/Aug/2015:15:35:42 +0200] Hostname lookup for "*.631" failed.
E [08/Aug/2015:15:35:42 +0200] Bad Listen address *.631 at line 17.
E [08/Aug/2015:15:37:27 +0200] Hostname lookup for "localhost.631" failed.
E [08/Aug/2015:15:37:27 +0200] Bad Listen address localhost.631 at line 17.
E [08/Aug/2015:15:37:43 +0200] [Client 13] Local authentication certificate not found.
E [08/Aug/2015:15:37:43 +0200] [Client 13] Local authentication certificate not found.
E [08/Aug/2015:15:37:43 +0200] [Client 13] Local authentication certificate not found.
E [08/Aug/2015:15:37:48 +0200] [Client 14] Local authentication certificate not found.
E [08/Aug/2015:15:37:48 +0200] [Client 13] Local authentication certificate not found.
E [08/Aug/2015:15:37:48 +0200] [Client 13] Local authentication certificate not found.
E [08/Aug/2015:15:38:29 +0200] Unable to bind socket for address [v1.::1]:631 - Address already in use.
E [08/Aug/2015:15:38:29 +0200] Unable to bind socket for address 127.0.0.1:631 - Address already in use.
E [08/Aug/2015:15:38:36 +0200] [Client 13] Local authentication certificate not found.
E [08/Aug/2015:15:38:36 +0200] [Client 13] Local authentication certificate not found.
E [08/Aug/2015:15:38:36 +0200] [Client 13] Local authentication certificate not found.
E [08/Aug/2015:15:38:37 +0200] [Client 13] Local authentication certificate not found.
E [08/Aug/2015:15:38:37 +0200] [Client 13] Local authentication certificate not found.
E [08/Aug/2015:15:38:37 +0200] [Client 13] Local authentication certificate not found.
E [08/Aug/2015:15:39:20 +0200] [Job 1] Unable to queue job for destination "MFC5890CN".


ich habe kein plan mehr wo ich noch suchen sollte oder an was es liegen könnte neu Installation von cups bringt auch nichts.

Einzig die IP habe ich von DHCP via /etc/network/interfaces bzw. networkmanager auf eine feste umgestellt.

es scheint sich um ein Authentifizierungsproblem zu handeln - aber wie und wo kann ich da nach Fehlern und Lösungen suchen ?


grad beim cups reinstall bemerkt :

Quellcode

1
2
3
Updating PPD files for cups ...
cups-pdf (2.6.1-9) wird eingerichtet ...
Das Kennwort für „root“ auf „localhost“?


ein root pw gibs es nicht, muss man für cups manuel noch ein user anlegen, den system user z.b. ? warum greift cups nicht auf sudo oder gksu zurück ?

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »SpeeFak« (15.08.2015, 13:36)


brummbrumm

Gesperrter Benutzer

  • »brummbrumm« wurde gesperrt

Beiträge: 535

Registrierungsdatum: 15.10.2014

Derivat: unbekannt

Architektur: unbekannt

Desktop: unbekannt

Andere Betriebssysteme: Debian Jessie, Android-x86 Vbox

  • Nachricht senden

2

08.08.2015, 21:00

Ist dein User in der Gruppe "lpadmin"?

Quellcode

1
groups

  • »SpeeFak« ist der Autor dieses Themas

Beiträge: 273

Registrierungsdatum: 23.06.2009

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: GNOME 3.0

Andere Betriebssysteme: Debian 7.0 wheezy

  • Nachricht senden

3

08.08.2015, 23:09

jepp, user ist in lpadmin gruppe ?(

brummbrumm

Gesperrter Benutzer

  • »brummbrumm« wurde gesperrt

Beiträge: 535

Registrierungsdatum: 15.10.2014

Derivat: unbekannt

Architektur: unbekannt

Desktop: unbekannt

Andere Betriebssysteme: Debian Jessie, Android-x86 Vbox

  • Nachricht senden

4

09.08.2015, 22:57

Hmmm,okay!

Du könntest mal deine /etc/cups/cupsd.conf posten zum Vergleich. Oder auch mal Cups komplett purgen und neu installieren.

  • »SpeeFak« ist der Autor dieses Themas

Beiträge: 273

Registrierungsdatum: 23.06.2009

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: GNOME 3.0

Andere Betriebssysteme: Debian 7.0 wheezy

  • Nachricht senden

5

11.08.2015, 07:24

letzteres ist schon geschehn :/

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
cat  /etc/cups/cupsd.conf
#
#
# Sample configuration file for the CUPS scheduler.  See "man cupsd.conf" for a
# complete description of this file.
#

# Log general information in error_log - change "warn" to "debug"
# for troubleshooting...
LogLevel warn

# Deactivate CUPS' internal logrotating, as we provide a better one, especially
# LogLevel debug2 gets usable now
MaxLogSize 0

# Only listen for connections from the local machine.
#Listen localhost:631
Listen localhost:631
Listen /var/run/cups/cups.sock

# Show shared printers on the local network.
Browsing Off
BrowseLocalProtocols dnssd

# Default authentication type, when authentication is required...
DefaultAuthType Basic

# Web interface setting...
WebInterface Yes

# Restrict access to the server...
<Location />
  Order allow,deny
</Location>

# Restrict access to the admin pages...
<Location /admin>
  Order allow,deny
</Location>

# Restrict access to configuration files...
<Location /admin/conf>
  AuthType Default
  Require user @SYSTEM
  Order allow,deny
</Location>

# Set the default printer/job policies...
<Policy default>
  # Job/subscription privacy...
  JobPrivateAccess default
  JobPrivateValues default
  SubscriptionPrivateAccess default
  SubscriptionPrivateValues default

  # Job-related operations must be done by the owner or an administrator...
  <Limit Create-Job Print-Job Print-URI Validate-Job>
    Order deny,allow
  </Limit>

  <Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job Resume-Job Cancel-My-Jobs Close-Job CUPS-Move-Job CUPS-Get-Document>
    Require user @OWNER @SYSTEM
    Order deny,allow
  </Limit>

  # All administration operations require an administrator to authenticate...
  <Limit CUPS-Add-Modify-Printer CUPS-Delete-Printer CUPS-Add-Modify-Class CUPS-Delete-Class CUPS-Set-Default CUPS-Get-Devices>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow
  </Limit>

  # All printer operations require a printer operator to authenticate...
  <Limit Pause-Printer Resume-Printer Enable-Printer Disable-Printer Pause-Printer-After-Current-Job Hold-New-Jobs Release-Held-New-Jobs Deactivate-Printer Activate-Printer Restart-Printer Shutdown-Printer Startup-Printer Promote-Job Schedule-Job-After Cancel-Jobs CUPS-Accept-Jobs CUPS-Reject-Jobs>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow
  </Limit>

  # Only the owner or an administrator can cancel or authenticate a job...
  <Limit Cancel-Job CUPS-Authenticate-Job>
    Require user @OWNER @SYSTEM
    Order deny,allow
  </Limit>

  <Limit All>
    Order deny,allow
  </Limit>
</Policy>

# Set the authenticated printer/job policies...
<Policy authenticated>
  # Job/subscription privacy...
  JobPrivateAccess default
  JobPrivateValues default
  SubscriptionPrivateAccess default
  SubscriptionPrivateValues default

  # Job-related operations must be done by the owner or an administrator...
  <Limit Create-Job Print-Job Print-URI Validate-Job>
    AuthType Default
    Order deny,allow
  </Limit>

  <Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job Resume-Job Cancel-My-Jobs Close-Job CUPS-Move-Job CUPS-Get-Document>
    AuthType Default
    Require user @OWNER @SYSTEM
    Order deny,allow
  </Limit>

  # All administration operations require an administrator to authenticate...
  <Limit CUPS-Add-Modify-Printer CUPS-Delete-Printer CUPS-Add-Modify-Class CUPS-Delete-Class CUPS-Set-Default>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow
  </Limit>

  # All printer operations require a printer operator to authenticate...
  <Limit Pause-Printer Resume-Printer Enable-Printer Disable-Printer Pause-Printer-After-Current-Job Hold-New-Jobs Release-Held-New-Jobs Deactivate-Printer Activate-Printer Restart-Printer Shutdown-Printer Startup-Printer Promote-Job Schedule-Job-After Cancel-Jobs CUPS-Accept-Jobs CUPS-Reject-Jobs>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow
  </Limit>

  # Only the owner or an administrator can cancel or authenticate a job...
  <Limit Cancel-Job CUPS-Authenticate-Job>
    AuthType Default
    Require user @OWNER @SYSTEM
    Order deny,allow
  </Limit>

  <Limit All>
    Order deny,allow
  </Limit>
</Policy>

#
#

brummbrumm

Gesperrter Benutzer

  • »brummbrumm« wurde gesperrt

Beiträge: 535

Registrierungsdatum: 15.10.2014

Derivat: unbekannt

Architektur: unbekannt

Desktop: unbekannt

Andere Betriebssysteme: Debian Jessie, Android-x86 Vbox

  • Nachricht senden

6

12.08.2015, 16:54

Sieht doch eigentlich alles gut aus. Kann auf jeden Fall keinen Fehler erkennen.

Da hab ich auch keine weitere Idee dazu. :huh:

  • »SpeeFak« ist der Autor dieses Themas

Beiträge: 273

Registrierungsdatum: 23.06.2009

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: GNOME 3.0

Andere Betriebssysteme: Debian 7.0 wheezy

  • Nachricht senden

7

15.08.2015, 13:35

Problem gelöst : in der /etc/cups/cupsd.conf war für die admin seiten der eintrag der systemuser nicht aktiviert ( kp warum )

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
[...]
# Web interface setting...
WebInterface Yes

# Restrict access to the server...
<Location />
  Order allow,deny
</Location>

# Restrict access to the admin pages...
<Location /admin>
  Order allow,deny
  Require user @SYSTEM
</Location>

# Restrict access to configuration files...
<Location /admin/conf>
  AuthType Default
  Require user @SYSTEM
  Order allow,deny
</Location>
[...]


das installations script von brother verursacht das problem

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »SpeeFak« (17.08.2015, 19:30)