Sie sind nicht angemeldet.

  • »Jules-verzweifelt« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 28.07.2015

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: unbekannt

Andere Betriebssysteme: Windows 7

  • Nachricht senden

1

28.07.2015, 17:48

Ubuntu und Windows 7 total schief gelaufen?

Hallo Leute,

ich bin sowas von ein Neuling bei Ubuntu und habe wahrscheinlich bei der Installation schon einiges falsch gemacht.
Ich hatte auf meinem PC Windows 7 Professional (64bit) installiert und wollte nun neben Windows 7 auch Ubuntu haben, wegen der Arbeit. Ich hab dann Ubuntu 15.04 vom Stick installiert und eine neue Partition erstellt (300GB). Nun habe ich Ubuntu und kann es starten, aber der Boot Manager startet nicht, sodass ich nicht auf Windows 7 zugreifen kann. Ich kann alle Datein, die auf dem Desktop von Windows 7 ligen öffnen und die Programme sehen, aber ich komme nicht mehr auf das Betriebssystem. :(

So, und dann hab ich schon überall und in jede Richtung gesucht (in Foren und auf Wegpages), aber ich finde keine Lösung. Solche einfachen Sachen, wie das BootinfoScript kann ich auch nicht laufen lassen. Das funktioniert irgendwie nicht. Bekomme nicht die Results.txt Datei. Und Internet habe ich auch nicht.

Also kann es schlimmer gehen? Ich würde am liebsten auf Windows 7 zurück und dann nochmal unter Anleitung eines Fachmanns Ubuntu installieren. Ich bin am verzweifeln, weil jetzt nichts mehr auf meinem Rechner geht.
Kann mir jemand helfen und es auch für ganz Dumme bzw. für nicht computer-affine Menschen erklären? Am besten so Schritt für Schritt. Ich danke euch jetzt schon mal für die Zeit. ;)

Bin morgen wieder online - Arbeit ruft!
__________________
Verschoben aus "Andere Betriebssysteme". Bluegrass

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Jules-verzweifelt« (31.07.2015, 10:27)


  • »Klaus P« ist männlich

Beiträge: 4 533

Registrierungsdatum: 25.10.2009

Derivat: anderes Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: 7/10

  • Nachricht senden

2

28.07.2015, 21:41

Hallo und willkommen im Forum!

Wollen wir mal sehen ob wir deine Verzweiflung lindern können....! :)

Eine ausführliche Schritt-für-Schritt Anleitung für Dualboot mit Windows findest du in unserem WIKI!

Vielleicht ist ja aktuell noch was zu mach. Öffne bitte mal das Terminal (am schnellsten mit der Tastenkombi STRG + ALT + T). Und nun gibts du den folgenden Befehl ein (am besten per Kopieren und Einfügen)

Quellcode

1
sudo parted -l


(Falls du den Befehl eintippst: Ohne die führende Ziffer am Anfang und hinten das ist ein kleines L, auf Leerzeichen achten) Die gesamte Befehlsausgabe kopierst du dann und postest sie hier, dann wissen wir mehr über die Plattenbelegung.

Das wird schon! Aller Anfang ist schwer!

Gruß
Des modernen Menschen Computer ist sein Himmelreich! :rolleyes: Der Weg zur Hölle, ist allzu kurz auf dem falschen "EFI-Pfad" ;( : Kleiner Leitfaden zur UEFI-Installation

  • »Jules-verzweifelt« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 28.07.2015

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: unbekannt

Andere Betriebssysteme: Windows 7

  • Nachricht senden

3

29.07.2015, 09:19

Guten Morgen,

also ich hab den code eingegeben und das ist der output:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
Model: ATA WDC WD10EZRX-00A (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 686GB 686GB primary ntfs boot
2 686GB 1000GB 315GB primary ext4


Warning: Unable to open /dev/sr0 read-write (Read-only file system). /dev/sr0
has been opened read-only.
Error: /dev/sr0: unrecognised disk label
Model: TSSTcorp CDDVDW SH-224DB (scsi) 
Disk /dev/sr0: 174MB
Sector size (logical/physical): 2048B/2048B
Partition Table: unknown
Disk Flags:



P.S. Danke für die aufbauenden Worte. ;)

  • »Klaus P« ist männlich

Beiträge: 4 533

Registrierungsdatum: 25.10.2009

Derivat: anderes Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: 7/10

  • Nachricht senden

4

29.07.2015, 12:25

Hallo!

Da scheint einiges schief gelaufen zu sein. Auch bei Ubuntu fehlt eine wichtige Partition für die Arbeitsspeicher-Auslagerung (SWAP).

War Windows verschlüsselt?

Die folgenden Arbeitsschritte wieder über das Terminal. Bitte alles posten, bei dem obigen fehlt oben etwas, ist aber hier nicht so wichtig. Versuche zunächst mal den Bootloader zu aktualisieren mit

Quellcode

1
sudo update-grub


Bringt das nichts, dann versuche es mit einer Neuinstallierung des Bootloaders per

Quellcode

1
2
sudo grub-install /dev/sda
sudo update-grub


Die ganze Befehlsausgabe dann jeweils hier wieder einstellen.

Wen du i.Ü. gleich nach Einschalten des Rechners auf die SHIFT-taste drückst, öffnet sich das Bootloader-Auswahlmenü. Bei Auswahl zwischen OS sollte es aber von selbst kommen.

Fruchtet das alles nichts, dann versuchen wir erst mal Windows in Gang zu bringen mit Linux-Hilfsmitteln. Dazu lädtst du dir die kleine SuperGrub 2 Disk herunter, erstellst damit ein bootfähiges Medium (also wie die Ubuntu-DVD oder Stick auch) und bootest den Rechner davon. Du erhältst ein Auswahlmenü und nimmst "Detect any OS" oder so ähnlich. Ist dein Windows noch bootfähig, wird es angezeigt und du kannst es damit starten.

Was mir nicht gefällt ist, dass keine kleine Bootpartition von Windows vorhanden ist. Die ist zwar nicht zwingend erforderlich, wird aber meist von Windows angelegt. Zur Not müsstest du versuchen mit einer Windows-Installations-CD über deren Reparaturfunktion den Windowsstart wieder herzustellen.

Gruß
Des modernen Menschen Computer ist sein Himmelreich! :rolleyes: Der Weg zur Hölle, ist allzu kurz auf dem falschen "EFI-Pfad" ;( : Kleiner Leitfaden zur UEFI-Installation

  • »Jules-verzweifelt« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 28.07.2015

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: unbekannt

Andere Betriebssysteme: Windows 7

  • Nachricht senden

5

29.07.2015, 13:28

Ok, da ich den output nicht interpretieren kann, hab ich keine Ahnung ob es gut oder schlecht ist.
Ich hab nur Windows 7 gelesen und das hat mich etwas beruhigt. ;)

Hier der output:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
julia@julia-TERRA-PC:~$ sudo update-grup
[sudo] password for julia: 
sudo: update-grup: command not found
julia@julia-TERRA-PC:~$ sudo update-grub
Generating grub configuration file ...
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Found linux image: /boot/vmlinuz-3.19.0-15-generic
Found initrd image: /boot/initrd.img-3.19.0-15-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Found Windows 7 (loader) on /dev/sda1
done

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
julia@julia-TERRA-PC:~$ sudo grub-install /dev/sda
Installing for i386-pc platform.
sudo ubgrub-install: warning: Sector 32 is already in use by the program `FlexNet'; avoiding it.  This software may cause boot or other problems in future.  Please ask its authors not to store data in the boot track.
Installation finished. No error reported.
julia@julia-TERRA-PC:~$ sudo update-grub
Generating grub configuration file ...
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Found linux image: /boot/vmlinuz-3.19.0-15-generic
Found initrd image: /boot/initrd.img-3.19.0-15-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Found Windows 7 (loader) on /dev/sda1
done


Ich hab erst den code "sudo update-group" genommen und dann noch den "sudo grub-install /dev/sda; sudo update-group". Windows sollte nicht verschlüsselt sein. Hab da nur ein Benutzerkonto-Passwort. Da weiß ich aber nicht, ob das jetzt heißt, dass Windows verschlüsselt ist oder nicht.
Herunterladen kann ich mir nichts, denn ich hab kein Internet auf dem Rechner und wenn ich es auf dem Laptop runterlade und mit einem Stick übertragen will, dann führt er die Software unter ubuntu nicht aus.

Also die Shift-Taste hat funktioniert. Ich hab dann 4 Möglichkeiten zur Auswahl, wovon das letzte Windows 7 war. Das hab ich gedrückt und dann wurde mir angezeigt (zur Auswahl) Windows 7 (recovered) und Ubuntu. Da war ich ja schonmal zufrieden, dass ich Windows überhaupt noch habe. DANKE! 8o

Also das funktioniert jetzt. Da kann ich drauf zugreifen. Aber das Problem ist jetzt, dass ich Ubuntu noch habe und das irgendwie nicht funktioniert, ich das Betriebssystem aber für die Arbeit brauche, ohne große Fehler. Aber ich kann ja noch nichtmal mit dem Ubuntu ins Internet und die Programm laufen auch nicht alle. Unter Windows hab ich Internet.

Der eigentliche Plan war es auch: Ich wollte 2 Partitionen für die beiden Betriebssysteme und eine Partition für meine Daten, auf die ich von beiden Betriebssystemen zugreifen kann.
Kann man das überhaupt so machen? :huh:


hmmm... mein Kumpel meinte, dass es sooo einfach ist Ubuntu zu installieren.... Hmmm..... :whistling: ?(

Grüße
____________
Code-Tags gesetzt. Bluegrass

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Jules-verzweifelt« (29.07.2015, 13:43)


  • »Klaus P« ist männlich

Beiträge: 4 533

Registrierungsdatum: 25.10.2009

Derivat: anderes Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: 7/10

  • Nachricht senden

6

29.07.2015, 14:17

Hallo!

Zitat

Also die Shift-Taste hat funktioniert. Ich hab dann 4 Möglichkeiten zur Auswahl, wovon das letzte Windows 7 war. Das hab ich gedrückt und dann wurde mir angezeigt (zur Auswahl) Windows 7 (recovered) und Ubuntu. Da war ich ja schonmal zufrieden, dass ich Windows überhaupt noch habe. DANKE! 8o


Also wenn ich das richtig interprätiere, kannst du dein Windows so wieder starten. Ich würde jetzt vorschlagen, wir machen dein Windows erst mal wieder normal startklar und kümmern uns dann später um Ubuntu, wenn du noch Lust dazu hast. Installiere dir unter Windows das Programm EasyBCD. Damit kannst du den Bootloader von Windows konfigurieren. Ich würde zunächst mal nichts weiter tun als den Winloader wieder in den MBR schreiben (irgendwo findest du diesen Menüpunkt (benutze das Teil selten). Dann funktioniert der Windowsstart wieder wie gewohnt aber Ubuntu startet nicht mehr. Man könnte mit dieser Software auch Ubuntu mit in den Winloader einbinden (entsprechenden Menüpunkt suchen). Tu das wenn du willst. Da aber Ubuntu auch nicht korrekt installiert ist, würde ich trotzdem vorschlagen, dass noch mal richtig zu machen. das WIKI habe ich oben bereits verlinkt, oder frage hier noch mal konkret nach und wir können das "geführt" machen.

Mit dem WLAN das ist dann auch noch lösbar! Aber ggf. ein einem separaten Thread.

Zitat

hmmm... mein Kumpel meinte, dass es sooo einfach ist Ubuntu zu installieren.... Hmmm..... :whistling: ?(
Das ist es im Normalfall auch, jedenfalls wesentlich unkomplizierter als eine Windowsinstallation. Aber der Teufel steckt halt manchmal im Detail.


Gruß
Des modernen Menschen Computer ist sein Himmelreich! :rolleyes: Der Weg zur Hölle, ist allzu kurz auf dem falschen "EFI-Pfad" ;( : Kleiner Leitfaden zur UEFI-Installation

7

29.07.2015, 14:29

Hallo Jules.
Wenn du die Grub konfiguration mit

Quellcode

1
sudo nano /etc/default/grub

öffnest und eine # vor GRUB_HIDDEN_TIMEOUT setzt und ein sudo update-grub abschließend ausfühst, sollte das Grub-Menü beim Start immer erscheinen.
Ich sende hier mal einen Ausschnitt von meiner Konfi, damit du siehst, was ich meine. Diese bitte NICHT!!!!!!!! einfach per Copy'n'Paste einfügen!

Quellcode

1
2
3
4
5
6
7
8
9
10
GRUB_DEFAULT=0
#Kommentar: Der Wert hier über der Zeile ist das Standard-BS.
#GRUB_HIDDEN_TIMEOUT=0
#Kommentar: die Zeile über dieser hier sagt, dass Grub gleich das Standard-BS starten soll. Das kann mit einer Raute vorne deaktiviert werden.
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=30
#Kommentar: die obige Zeile stellt den Countdown ein, der abläuft, bevor das Standard-BS gestartet wird. Dieser wird automatisch angehalten, sobald du eine Taste a.d. Tastatur drückst
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""


Mehr dazu hier: http://wiki.ubuntuusers.de/grub_2/konfiguration (bitte unbedingt durchlesen, sollte ich einen Fehler gemacht haben, bitte undbedingt korrigieren!!)

LG Muhbntu :)
Wissen ist, die richtigen Antworten zu haben.
Intelligenz ist, die richtigen Fragen zu stellen.
Viele Grüße von mir :)
unwichtig

  • »Klaus P« ist männlich

Beiträge: 4 533

Registrierungsdatum: 25.10.2009

Derivat: anderes Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: 7/10

  • Nachricht senden

8

29.07.2015, 14:35

Hallo Muhbuntu!

Ubuntu ist nicht korrekt installiert, deshalb habe ich diesen Vorschlag erst gar nicht gemacht. Ggf. erst noch mal richtig installieren und dann das Problem angehen, wenn es denn noch mal auftauchen sollte.

Und wenn der/die TS ein Standard-Ubuntu benutzt, wird ihr "nano" nicht viel nützen. Und nie nie sudo benutzen für ein grafisches Programm, sondern gksudo.

Gruß
Des modernen Menschen Computer ist sein Himmelreich! :rolleyes: Der Weg zur Hölle, ist allzu kurz auf dem falschen "EFI-Pfad" ;( : Kleiner Leitfaden zur UEFI-Installation

  • »Jules-verzweifelt« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 28.07.2015

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: unbekannt

Andere Betriebssysteme: Windows 7

  • Nachricht senden

9

29.07.2015, 15:02

Hallo,

also: Ja, Windows 7 funktioniert wieder und ich konnte auch das Programm EasyBCD 2.2 herunterladen. Habe die Einstellungen vorgenommen und den PC nochmal runter gefahren. Beim Start zeigt er mir jetzt nur an, ob ich zwischen Ubuntu oder Windows 7 wählen möchte. Oder sollte er mir gar nichts anzeigen und gleich mit Windows starten. Dann sollte ich in der EasyBCD Software vielleich unter Start-Menü beartbeiten die Ubuntu-Version löschen. Aber im MRB sollte Windows 7 Bootloader jetzt drin sein.

Ubuntu würde ich gern unter Anleitung wieder installieren, sodass nichts schief get. Ich brauche das Betriebssystem für die Arbeit, da es mit bioinformatischen Programmen besser umgehen kann und ich einen besseren Einblick in die Programme bekomme. Den Plan, den ich hatte, hab ich ja schon beschrieben. Es wäre toll, wenn das mit deiner/eurer Hilfe klappen könnte. Irgendwann muss ich ja anfangen, mich in die ganze Computer-Sache einzuarbeiten. Und wie du schon meintest, Klaus, aller Anfang ist schwer. Werde den wiki-link detailliert lesen und versuche alles zu verstehen.

Aber um Ubuntu wieder neu zu installieren, muss ich das falsch installierte Betriebssystem ja erstmal wieder los werden, richtig?

Das mit dem Internet ist ja noch nicht einmal WLAN. Es geht über Kabel - also Ethernet. Aber vielleicht hat es einfach nicht funktioniert, weil Ubuntu schon falsch installiert wurde. Ansonsten, sollte ich das Kabel ja einfach reinstecken und Internet funktioniert. So hat es mir jedenfalls die Internetseite von Ubuntu gesagt. :D

Auf jeden Fall schonmal ein riesen Danke an dich. :thumbsup:

  • »alt-medregnet« ist männlich

Beiträge: 571

Registrierungsdatum: 22.01.2015

Derivat: Ubuntu GNOME

Architektur: 32-Bit PC

Desktop: GNOME 3.0

Andere Betriebssysteme: Siduction (Debian 64 Bit), Ubuntu XFCE (64 Bit), Windows 10

  • Nachricht senden

10

29.07.2015, 19:04

Was mir nicht gefällt ist, dass keine kleine Bootpartition von Windows vorhanden ist. Die ist zwar nicht zwingend erforderlich, wird aber meist von Windows angelegt. Zur Not müsstest du versuchen mit einer Windows-Installations-CD über deren Reparaturfunktion den Windowsstart wieder herzustellen.
Gibt es bei mir auch nicht:

Zitat

Ist die Festplatte, auf welcher Windows 7 installiert werden soll, aber bereits mit einer oder mehreren Partitionen ausgestattet (z.B. wenn sich ein vorheriges Windows-System schon auf einer Partition befindet), wird der Bootmanager auf die erste Partition der Festplatte geschrieben und auf eine nachträgliche Erstellung der 100 MByte-Partition verzichtet.
http://www.wintotal.de/das-raetsel-der-1…-von-windows-7/

Ansonsten sieht die Ausgabe von sudo parted -l doch normal aus - sieht man davon ab, das SWAP fehlt https://wiki.ubuntuusers.de/Partitionierung#swap . (Wenn du keine eigene Home-Partition willst https://wiki.ubuntuusers.de/Homeverzeichnis)

Jules-verzeifelt, du könntest, da Windows wieder startet, auch mal in der Datenträgerverwaltung der Systemverwaltung nachsehen, ob alles in Ordnung ist? Ich nehme es aber an.

Gruß v. Uli

  • »Klaus P« ist männlich

Beiträge: 4 533

Registrierungsdatum: 25.10.2009

Derivat: anderes Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: 7/10

  • Nachricht senden

11

29.07.2015, 21:15

Hallo Jules (das verzweifelt lassen wir dann mal weg!)!

Zitat

Beim Start zeigt er mir jetzt nur an, ob ich zwischen Ubuntu oder Windows 7 wählen möchte. Oder sollte er mir gar nichts anzeigen und gleich mit Windows starten. Dann sollte ich in der EasyBCD Software vielleich unter Start-Menü beartbeiten die Ubuntu-Version löschen. Aber im MRB sollte Windows 7 Bootloader jetzt drin sein.
Da muss ich jetzt auch etwas raten, da ich mit EasyBCD nicht allzu viel praktische Erfahrung habe. Wenn du also mit dem Programm den MBR neu beschrieben hast, dann müsste der Bootloader von Windows zu sehen sein. Der und Grub unterscheiden sich eigentlich recht deutlich, zumal bei Grub ganz oben auch die Bezeichnung "Grub Version XY...." steht. Beim Winloader sollte Win an erster Stelle stehen, wenn das nicht geändert wurde per EASYBCD. Ob die Software auch von sich aus Ubuntu mit einbindet kann ich dir gerade nicht sagen. Für das weitere Vorgehen wäre es ganz gut zu wissen, welcher Loader im Einsatz ist.

Zitat

Ich brauche das Betriebssystem für die Arbeit, da es mit bioinformatischen Programmen besser umgehen kann
Klingt hochkompliziert und demzufolge habe ich keine Ahnung davon.....! :whistling:

Zitat

Werde den wiki-link detailliert lesen und versuche alles zu verstehen.
Tu das und bei Unklarheiten hier nachfragen.

Zitat

Aber um Ubuntu wieder neu zu installieren, muss ich das falsch installierte Betriebssystem ja erstmal wieder los werden, richtig?
Nein, das wird bei der Installation dann überschrieben. Bei der automatischen Installation sollte der Installer den Menüpunkt "Ubuntu xx.xx" ersetzen" oder so ähnlich anbieten, bei der manuellen Installation (siehe WIKI) wählt man einfach die gleiche Partition zur Neuinstallation aus.

Das "alte" Ubuntu muss nicht zwangsläufig fehlerhaft sein. Fakt ist halt, dass die SWAP-Partition für die RAM-Auslagerungsdatei fester Bestandteil jeder Linux/Ubuntu-Installation ist, obwohl sie nicht zwangsläufig nötig ist. Braucht man sie allerdings mal und sie ist nicht da, kann es zu Datenverlust kommen. Ich bin deshalb immer etwas skeptisch, wenn dieser integrale Bestandteil eine Linuxinstallation nicht vorhanden ist und gehe mit einer sauberen Neuinstallation lieber auf Nummer sicher, bevor ich einem Einsteiger zumute das nachträglich einzurichten..

Zitat

Das mit dem Internet ist ja noch nicht einmal WLAN. Es geht über Kabel - also Ethernet. Aber vielleicht hat es einfach nicht funktioniert, weil Ubuntu schon falsch installiert wurde.
Davon würde ich mal nicht ausgehen! Aber wie gesagt, im passenden Unterforum einen Thread eröffnen und einer der Netzwerkprofis wird sich gern deiner annehmen.

Zitat

Ansonsten, sollte ich das Kabel ja einfach reinstecken und Internet funktioniert. So hat es mir jedenfalls die Internetseite von Ubuntu gesagt. :D
Ja, das wäre so auch normal..........! ?(

@ alt-medregnet! Es ist mit bekannt, wann die 100 MB Partition von Win angelegt und wann nicht. Und hier war meine Befürchtung ja glücklicher Weise unzutreffend. Aber was glaubst du wie viele Leute ihr Windows schon ins Nirvana geschickt haben, weil diese Partition beschädigt oder gelöscht wurde. Und die ist bei defintiv jeder OEM-Version vorhanden.

Gruß
Des modernen Menschen Computer ist sein Himmelreich! :rolleyes: Der Weg zur Hölle, ist allzu kurz auf dem falschen "EFI-Pfad" ;( : Kleiner Leitfaden zur UEFI-Installation

  • »Jules-verzweifelt« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 28.07.2015

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: unbekannt

Andere Betriebssysteme: Windows 7

  • Nachricht senden

12

30.07.2015, 14:36

Ok, also ich habe jetzt nach der Anleitung von Wiki nochmal Ubuntu installiert und so wie es aussieht, auch richtig mit einer Partition für das System, eriner für Home und einer SWAP. Ubuntu funktioniert auch super. Dann konnte ich aber nicht mehr auf Windows zugreifen. Also, habe ich das vom Anfang wiederholt.

Eingabe bei Ubuntu Terminal:

sudo grub-install /dev/sda
sudo update-grub

Dann hab ich den PC wieder neu gestartet und während dessen "Shift" gedrückt. Ich bekam wieder die Auswahl der 4 Varianten (Ubuntu, 2x irgendwelche Tests und Windows 7). Dann hat sich der Bootmanager geöffnet und ich hab zwischen Windows und Ubuntu gewählt (also zu Windows bin ich gegangen). Danach hab ich wieder EasyBDC geöffnet. Die Einstellungen im MRB geändert, sodass sich der normal Windows Boot Manager wieder beim Start öffnet. Dann dachte ich mir - ja super, so wolltest du das haben - sozusagen, dass du beim Start wählen kannst, ob du heut mit Ubuntu arbeiten willst, oder mit Windows. Um dann Ubuntu einzurichten habe ich im Boot Manager also Ubuntu gewählt. Und dann kam:

Windows failed to start. A recent hardware or software change might be the cause. To fix the problem:
1. Insert your windows instellation disc and restart your computer
2. Choose your language settings, and then click "next"
3. Click "Repair your computer"
If you do not have this disc, contact your system administrator or computer manufacturer for assistance.
File: \ubuntu\winboot\wubildr.mbr
Status: 0xc0000225
Info: The selected entry could not be loaded because the application is missing or corrupt.

Und dann kann ich nur noch Enter drücken und komme wieder zum Boot Manager. Und Windows funktioniert über den Manager.

So, nachdem ich sehr glücklich war, dass ich alles super hinbekommen habe, fängt die Verzweiflung wieder an.
Danke für jede Hilfe.

Gruß,
Jules

  • »Klaus P« ist männlich

Beiträge: 4 533

Registrierungsdatum: 25.10.2009

Derivat: anderes Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: 7/10

  • Nachricht senden

13

30.07.2015, 15:15

Hallo!

Zitat


So, nachdem ich sehr glücklich war, dass ich alles super hinbekommen habe, fängt die Verzweiflung wieder an.
Du weisst doch, das Glück ist eine vergängliche Größe! :whistling:

Wo kommt denn nun auf einmal

File: \ubuntu\winboot\wubildr.mbr

dieser Eintrag her? Du hast doch Ubuntu ganz normal installiert. Zur Erklärung: Wubi ist ein Installationsprogramm, dass Ubuntu innerhalb von Windows installiert, quasi als Programm. Ist aber veraltet und fehleranfällig. Im Normalfall zu meiden. Die Installation würde von Window aus gestartet und auch die Auswahl würde im Win-Loader erfolgen. Schau mal unter "Programme" in der Systemsteuerung in Windows nach, also dort, wo die gelöscht werden. Wenn du da ein Programm "Ubuntu" findest, bitte löschen.

Ansonsten öffne noch mal EasyBCD und dort das Menü "Eintrag hinzufügen". Dort schau mal unter "Linux/BSD" und/oder "Neogrub" nach was da angeboten wird. Dort sollte eigentlich dein richtiges Ubuntu gelistet sein, Ggf. mit in den Loader einbinden und schauen ob es richtig bootet. Falls da noch dieser Wubi-Ubuntu Eintrag irgendwo auftaucht und für dich als solcher erkennbar ist, gleich mit EASYBCD löschen!

Des weiteren hatte ich weiter oben in meinem ersten Beitrag schon mal auf die SuperGrubDisk2 verlinkt. Kann nicht schaden, wenn du die mal parat hast. Damit lassen sich im Notfall alle OS starten. Wir schauen erst mal, ob wir das mit EASYBCD hin bekommen. Wenn nicht, versuchen wir es noch mal mit Linuxmitteln. Warum bei dir der Start nach Neuinstallation partout nich klappt.............? Aber sollte alles machbar sein.

Kopf hoch!

Gruß
Des modernen Menschen Computer ist sein Himmelreich! :rolleyes: Der Weg zur Hölle, ist allzu kurz auf dem falschen "EFI-Pfad" ;( : Kleiner Leitfaden zur UEFI-Installation

  • »Jules-verzweifelt« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 28.07.2015

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: unbekannt

Andere Betriebssysteme: Windows 7

  • Nachricht senden

14

30.07.2015, 16:33

Ok. Ich habe in Easy den Eintrag von Linux geändert. Jetzt kann ich auf Ubuntu und Windows 7 zugreifen. Das bedeutet, dass der Windows Boot Manager mir beides anzeigt es auch funktioniert. Natürlich gibt es noch ein ABER.

Der Boot Manager gibt mir nun 2x Windows 7 (recovered) an und einmal Ubuntu. Ich weiß nicht, wo das herkommt.
Deswegen hier nochmal den output von Ubuntu mit dem code: sudo parted -l


Quellcode

1
2
3
4
5
6
7
8
9
10
11
Modell: ATA WDC WD10EZRX-00A (scsi)
Festplatte  /dev/sda:  1000GB
Sektorgröße (logisch/physisch): 512B/4096B
Partitionstabelle: msdos

Nummer  Anfang  Ende    Größe   Typ       Dateisystem     Flags
 1      1049kB  686GB   686GB   primary   ntfs            boot
 2      686GB   1000GB  315GB   extended
 5      686GB   701GB   15,8GB  logical   ext4
 6      701GB   989GB   288GB   logical   ext4
 7      989GB   1000GB  10,8GB  logical   linux-swap(v1)


Ist hier soweit alles, wie es sein soll?
Denn wenn ich die Partitionen unter dem ganz normalen Windows anzeigen lasse (ohne jegliches Zusatzprogramm, sagt der mir, dass meine Partitionen alle "primary". Was ja eigentlich nicht der Falle sein sollte, oder? Die 2. Partition sollte doch exteded sein und drei logische Partitionen enthalten. Das zeigt mir Ubuntu ja auch an. Wieso macht das Windows nicht? Das aber nur nebenbei.

Das letzte, was nun ist, ist dass ich 2 mal dieses Windows 7 im Boot Manager habe und ich nicht weiß, ob das so korekt ist oder vielleicht auch nur ein Anzeigefehler.

hmmmm....

Achja, ich hatte eine Ubuntu-version als programm und habe sie gelöscht.

So, das dazu. Aber im Allgemeinen ist das Problem gelöst. Hätte es nur gern in einer "saubren" Variante.

Liebe Grüße
_____________
Code-Tags gesetzt. Bluegrass

  • »Klaus P« ist männlich

Beiträge: 4 533

Registrierungsdatum: 25.10.2009

Derivat: anderes Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: 7/10

  • Nachricht senden

15

30.07.2015, 21:31

Hallo!

Zitat


Ok. Ich habe in Easy den Eintrag von Linux geändert. Jetzt kann ich auf Ubuntu und Windows 7 zugreifen. Das bedeutet, dass der Windows Boot Manager mir beides anzeigt es auch funktioniert.
Klingt erst mal gut!

Zitat

Der Boot Manager gibt mir nun 2x Windows 7 (recovered) an und einmal Ubuntu. Ich weiß nicht, wo das herkommt.
Deswegen hier nochmal den output von Ubuntu mit dem code: sudo parted -l
Du musst "gedanklich" Windows und Ubuntu streng trennen. Die einzige "Schnittstelle" die beide Betriebssysteme haben ist der Bootsektor und dessen Konfigurationsdateien. Mit "sudo parted -l" hat das nichts zu tun, hier werden lediglich die vorhandenen Partitionen aufgelistet. Diese Aufteilung wiederum sieht doch nun ganz ordentlich aus. Es ist alles da, was man braucht. Ich würde es etwas anders aufteilen, aber ich bin nicht du!

Zitat

Denn wenn ich die Partitionen unter dem ganz normalen Windows anzeigen lasse (ohne jegliches Zusatzprogramm, sagt der mir, dass meine Partitionen alle "primary". Was ja eigentlich nicht der Falle sein sollte, oder? Die 2. Partition sollte doch exteded sein und drei logische Partitionen enthalten. Das zeigt mir Ubuntu ja auch an. Wieso macht das Windows nicht? Das aber nur nebenbei.
Windows ist in der Hinsicht halt ein bissl dumm, bzw. glaubt es nicht so recht an die Existenz anderer Dateisysteme und Betriebssysteme. Ist also normal! Der Windows-Explorer ist noch schlimmer, der zeigt dir gar nix mehr an. Es gibt Linuxtreiber für Windows, außer im Notfall würde ich die aber nicht einsetzen.

Zitat


Das letzte, was nun ist, ist dass ich 2 mal dieses Windows 7 im Boot Manager habe und ich nicht weiß, ob das so korekt ist oder vielleicht auch nur ein Anzeigefehler.
Vermutlich ist es nicht korrekt, das ist jetzt aber wieder ein Windows-Internes Problem, wo ich mich etwas schwer mit tue. Mach ggf. halt den Try and Error Test. Probiere beide aus. Wenn einer streikt, wirfst du ihn mit EasyBCD raus. Oder du entscheidest dich für "never change a running system" ! :)

Zitat

Achja, ich hatte eine Ubuntu-version als programm und habe sie gelöscht.
Gut, dann wär das geklärt. Du musst dann eben zwischendrin mal (aus Versehen) eine Installation von Windows aus angekurbelt haben und das kam dabei raus.

Zitat

Aber im Allgemeinen ist das Problem gelöst.
Dann sei so nett und markiere den Beitrag ggf. auch so. Ersten Beitrag bearbeiten und oben links den Präfix setzen.

Gruß
Des modernen Menschen Computer ist sein Himmelreich! :rolleyes: Der Weg zur Hölle, ist allzu kurz auf dem falschen "EFI-Pfad" ;( : Kleiner Leitfaden zur UEFI-Installation

  • »Jules-verzweifelt« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 28.07.2015

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: unbekannt

Andere Betriebssysteme: Windows 7

  • Nachricht senden

16

31.07.2015, 10:36

So, Beitrag als gelöst eingestuft.

Ich denke, dass ich mich für die Variante "never change a running system" entscheiden werde. Ich habe auch nochmal in EasyBCD reingeschaut. Da wird nun im Reiter Momentane Einstellungen Windows als Voreinstellung mit dem Startlaufwerk C angegeben und dann kommt nochmal Eintrag #1:

Name: Windows 7
BCD ID: (current)
Laufwerk: C:\
Bootloader Pfad: \Windows\System32\winload.exe

Eintrag #2:
Name: Ubuntu
BCD ID: (d9bde490-1bb4-xxx)
Bootloader Pfad: \NST\AutoNeoGrub0.mbr

Wie ich jetzt Voreinstellung/ Eintrag 1 lösche, bekomm ich vielleicht noch raus. Aber erstmal lass ich das so. Falls jemanden hier noch auffällt, dass an diesen Angaben was komplett falsch ist, kann er mich ja vielleicht noch darauf hinweisen. Beide Windows 7 Angaben im Boot Manager funktionieren und lassen mich auf Windows zugreifen.

Aber erstmal möchte ich mich bedanken für die Hilfe. Wenn ich mal wieder verzweifle, was bestimmt nochmal vorkommt, werde ich mich wieder an euch wenden.

Grüße

  • »Klaus P« ist männlich

Beiträge: 4 533

Registrierungsdatum: 25.10.2009

Derivat: anderes Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: 7/10

  • Nachricht senden

17

31.07.2015, 11:08

Hallo!

Ich würde diesen Eintrag

Quellcode

1
2
3
4
Name: Windows 7
BCD ID: (current)
Laufwerk: C:\
Bootloader Pfad: \Windows\System32\winload.exe


in Ruhe lassen. Ich vermute mal (die Betonung liegt aber sehr stark auf Vermutung), dass sich der 2. Eintrag auf eine Konfigurationsdatei von EasyBCD/NeoGrub bezieht. Löschst du, aus welchem Grund auch immer, EasyBCD, könnte ich mir vorstellen dass es keinen Zugriff mehr gibt. Während der erste Pfad auf den normalen Bootpfad von Windows verweist.

Gruß und viel Erfolg mit Linux!
Des modernen Menschen Computer ist sein Himmelreich! :rolleyes: Der Weg zur Hölle, ist allzu kurz auf dem falschen "EFI-Pfad" ;( : Kleiner Leitfaden zur UEFI-Installation

18

01.08.2015, 20:14

von mir auch nochma senf, ich war ne Zeit lang offline.
@Klaus klar, daran hab ich nicht gedacht, danke. Du sagtest, mit sudo keine grafikprogramme öffnen. Was meinst du damit? Nano ist doch fürs Terminal... Verstehe ich nich, sorry..

Lg Muhbuntu :)
Wissen ist, die richtigen Antworten zu haben.
Intelligenz ist, die richtigen Fragen zu stellen.
Viele Grüße von mir :)
unwichtig

  • »Klaus P« ist männlich

Beiträge: 4 533

Registrierungsdatum: 25.10.2009

Derivat: anderes Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: 7/10

  • Nachricht senden

19

01.08.2015, 20:58

Hallo Muhbuntu!

Du hast völlig recht! Das hatte ich nicht bedacht. Ich bin davon ausgegangen, dass das der Editor eines anderen Derivats ist. Insofern ist natürlich auch meine Anmerkung bzgl. sudo und gksudo unzutreffend.

Sorry!

Gruß
Des modernen Menschen Computer ist sein Himmelreich! :rolleyes: Der Weg zur Hölle, ist allzu kurz auf dem falschen "EFI-Pfad" ;( : Kleiner Leitfaden zur UEFI-Installation

20

08.08.2015, 21:02

Kein Problem, mich hat das nur etwas verwirrt :)

LG Muhbuntu

Ach und entschuldigung, dass ich nur unregelmäßig vorbeischaue, bei der Hitze habe ich keine Lust, meinen Rechner anzumachen... :whistling:
Wissen ist, die richtigen Antworten zu haben.
Intelligenz ist, die richtigen Fragen zu stellen.
Viele Grüße von mir :)
unwichtig