Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

  • »mirrowwinger« ist der Autor dieses Themas

Beiträge: 62

Registrierungsdatum: 10.12.2010

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

1

23.01.2015, 17:01

Einbinden einer Lan-Festplatte beim Bootvorgang

Hallo Ubuntu-Community,

ich möchte eine Lan-Festplatte bei jedem Bootvorgang in meinem System mounten. Ich habe schon der Festplatte eine feste IP (192.168.1.48 ) gegeben. Jetzt möchte ich, dass diese unter /media/label gemountet wird.
Als kurze Begründung warum ich das genre so möchte: Die Seagate-Festplatte hat ein Raid-1-1TB-System (2 mal 1 TB parallel) und soll als redundanter Speicher für Backups dienen.

Mit freundlichem Gruß

mirrowwinger

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »mirrowwinger« (03.02.2015, 12:43)


zitzi

User

  • »zitzi« ist männlich

Beiträge: 434

Registrierungsdatum: 22.10.2009

Derivat: anderes Ubuntu-Derivat

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: Mint 19.1 Tessa MATE 64bit

  • Nachricht senden

2

23.01.2015, 20:38

Hast du den Ordner /media/label erstellt?
Hast du die Platte mit der ip in der fstab eingetragen?
Was für eine Platte ist es genau?
Ein NAS vielleicht?

Tuxgrüße von Zitzi
Versuch macht kluch............

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
ASUS M5A97 EVO R2.0, AMD FX6100, 8 GB DDR3 Corsair, SSD Samsung 830 + Samsung 850 Pro , GeForce MSI 1050ti 4 GB LP

  • »mirrowwinger« ist der Autor dieses Themas

Beiträge: 62

Registrierungsdatum: 10.12.2010

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

3

24.01.2015, 11:56

Ja es ist ein NAS (Seagate Business Storage 2-Bay NAS).
Ja /media/label (wobei label nur als Platzhalter dient) ist erstellt.
Nein in fstab habe ich noch nichts eingetragen (zur not müsste ich auch nachschauen, wie man das macht).
Platte = Seagate Business Storage 2-Bay NAS (2TB Gesamtvolumen in 2 Festplatten die als Raid-1-System konfiguriert sind).

zitzi

User

  • »zitzi« ist männlich

Beiträge: 434

Registrierungsdatum: 22.10.2009

Derivat: anderes Ubuntu-Derivat

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: Mint 19.1 Tessa MATE 64bit

  • Nachricht senden

4

24.01.2015, 20:47

Hat die ein OS wie z.B meine Synology Diskstation mit DSM?
Weches Dateisystemformat?
Hast du da Zugriff über den Browser als ein angelegter Benutzer?

Tuxgrüsse von Zitzi
Versuch macht kluch............

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
ASUS M5A97 EVO R2.0, AMD FX6100, 8 GB DDR3 Corsair, SSD Samsung 830 + Samsung 850 Pro , GeForce MSI 1050ti 4 GB LP

  • »mirrowwinger« ist der Autor dieses Themas

Beiträge: 62

Registrierungsdatum: 10.12.2010

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

5

26.01.2015, 15:27

Zugriff habe ich über eine Weboberfläche, welche ich über die lokale IP erhalte. Deswegen würde ich sagen, ja es ist ein OS (linuxbasiert - Vermutung) installiert. In der Web-Oberfläche, kann ich das vollständig als Admin administrieren. Ich habe das Raid vorgegeben und kann Nutzer, FTP und vieles mehr einstellen. Das Dateiformat habe ich nicht rausfinden können.

zitzi

User

  • »zitzi« ist männlich

Beiträge: 434

Registrierungsdatum: 22.10.2009

Derivat: anderes Ubuntu-Derivat

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: Mint 19.1 Tessa MATE 64bit

  • Nachricht senden

6

26.01.2015, 20:47

OK.
Das läuft bei meiner Synology über Samba.
Ich gehe mal davon aus, dass du auch cifs auf dem NAS hast.
Samba und cif-utils sind installiert.
Dann mit dem Texteditor eine versteckte Datei in deinem Homeverzeichnis namens .smbcredentials anlegen.
Da muss rein:
username="der auf dem NAS angelegte user"
password="das ihm zugewiesene Passwort"

In der /etc/fstab eintragen:
//192.168.1.48/label /media/label cifs credentials=/home/dein_username/.smbcredentials,iocharset=utf8,nounix,file_mode=0777,dir_mode=0777 0 0

So läuft das bei mir.
Falls ein anwesender Netzwerkexperte da einen Fehler sieht möge er mich bitte verbessern!

Tuxgrüsse von Zitzi
Versuch macht kluch............

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
ASUS M5A97 EVO R2.0, AMD FX6100, 8 GB DDR3 Corsair, SSD Samsung 830 + Samsung 850 Pro , GeForce MSI 1050ti 4 GB LP

  • »mirrowwinger« ist der Autor dieses Themas

Beiträge: 62

Registrierungsdatum: 10.12.2010

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

7

02.02.2015, 09:06

welches Samba-Packet muss ich dafür installieren? smbclient?

zitzi

User

  • »zitzi« ist männlich

Beiträge: 434

Registrierungsdatum: 22.10.2009

Derivat: anderes Ubuntu-Derivat

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: Mint 19.1 Tessa MATE 64bit

  • Nachricht senden

8

02.02.2015, 10:56

Bei mir ist dazu folgendes installiert:

cifs-utils
samba
samba-common
samba-common-bin
samba-dsdb-modules
samba-libs
smb-client

und noch ein paar Andere, die aber als Abhängigkeiten mit installiert werden/sein müssten.
Versuch macht kluch............

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
ASUS M5A97 EVO R2.0, AMD FX6100, 8 GB DDR3 Corsair, SSD Samsung 830 + Samsung 850 Pro , GeForce MSI 1050ti 4 GB LP

  • »mirrowwinger« ist der Autor dieses Themas

Beiträge: 62

Registrierungsdatum: 10.12.2010

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

9

02.02.2015, 11:43

Also habe cifs-utils installiert erstmal und habe folgenden link gefunden. Möchte erstmal meine Einstellungen für die NAS testen, indem ich die Festplatte einmalig mounte. Folgende Einstellungen habe ich gemacht:

Zitat

user: myuser
password: "mypassword"
ip: 192.168.1.28
cifs ist freigegeben
nfs nicht freigegeben
sharefolder heist wie der user: "myuser"


Unter Ubuntu sehe ich die Festplatte wie folgt:

Zitat

Netzwerk
|
-> ab-12345 #(Festplatten-ID???)
|
-> myuser #(shared Folder)

gemäß link habe ich jetzt diese versucht wie folgt zu mounten:

Zitat

root@computer# mount -t cifs -o noperm //192.168.1.28/ab-12345/myuser /mnt
root@computer# mount -t cifs -o noperm //192.168.1.28/ab-12345/ /mnt
root@computer# mount -t cifs -o noperm //192.168.1.28/myuser /mnt
root@computer# mount -t cifs -o noperm //192.168.1.28/ /mnt

Jedes mal werde ich nach einem Passwort gefragt, bei dem ich "mypassword" eingebe.
Ich erhalte folgende Fehlermeldung vom System:

Zitat

mount error: cifs filesystem not supported by the system
mount error(19): No such device
Refer to the mount.cifs( 8 ) manual page (e.g. man mount.cifs)

Warum kennt das System cifs nicht obwohl cifs-utils installiert ist? Was mache ich falsch beim mounten? Müssen eventuell doch noch weitere Samba-Packete installiert werden (bis jetzt habe ich nur cifs-utils installiert, da ich dachte die reichen oder installieren automatisch die notwendigen Samba-Packete mit)?

mirrowwinger

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »mirrowwinger« (02.02.2015, 12:00)


zitzi

User

  • »zitzi« ist männlich

Beiträge: 434

Registrierungsdatum: 22.10.2009

Derivat: anderes Ubuntu-Derivat

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: Mint 19.1 Tessa MATE 64bit

  • Nachricht senden

10

02.02.2015, 12:55

Also warum dein System über "cifs" meckert weiss ich nicht.
Versuch doch mal den Eintrag in der fstab und boote neu.
Versuch macht kluch............

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
ASUS M5A97 EVO R2.0, AMD FX6100, 8 GB DDR3 Corsair, SSD Samsung 830 + Samsung 850 Pro , GeForce MSI 1050ti 4 GB LP

  • »mirrowwinger« ist der Autor dieses Themas

Beiträge: 62

Registrierungsdatum: 10.12.2010

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

11

02.02.2015, 13:06

Das meckern über cifs habe ich durch ein Kernelupdate hingekriegt. Leider war der Hinweis nicht so einfach zu finden :( Aber jetzt klappt es. Warum die Festplatte bei meinem Dateimanager "ab-12345" heißt, habe ich keine Ahnung. Wird aber nicht benötigt.

Jetzt kann ich wie folgt meine Festplatte (einmalig) mounten:

Zitat

root@computer# mount -t cifs -o noperm,user=myuser //192.168.1.28/myuser mnt

Abfrage des Passwortes richtig eingeben oder alternativ

Zitat

root@computer# mount -t cifs -o noperm,user=myuser,password=mypassword //192.168.1.28/myuser mnt


Jetzt mache ich mich an die permanente Einbindung. Vielen Dank an dich zitzi für deine Hilfe.

mirrowwinger

12

02.02.2015, 17:57

nfs nicht freigegeben
Gut so.
Sollen die Linux-Kisten zeigen, daß sie auch mit instabilen, unsicheren, proprietären Microsoft-Protokollen klarkommen. Mit genügend Ausdauer und Try&Error wird das schon irgendwie laufen.

*SCNR*
me is all sausage
but don't call me Ferdl