Sie sind nicht angemeldet.

ripz

User

  • »ripz« ist der Autor dieses Themas

Beiträge: 1

Registrierungsdatum: 22.12.2014

Derivat: unbekannt

Architektur: unbekannt

Desktop: unbekannt

  • Nachricht senden

1

22.12.2014, 17:58

Linux Terminal Server wird nicht gefunden

Hallo Gemeinde,



ich komm einfach nicht mehr weiter.

Ich möchte für Testzwecken einen Linux Terminal Server aufsetzen (www.ltsp.org). Leider gibt es auf dieser Seite kein Tutorial für Ubuntu 14.04 Server.

Mein System sieht wie folgt aus:

Ubuntu läuft auf Windows 7 im VMPlayer. IP Adressen wird von der Fritzbox vergeben (DHCP Server). Ubuntu bekommt auch eine eigene Adresse.

Ich habe unter anderem dieses Tutorial getestet:

http://blog.emblemparade.net/using-ubunt…terminal-server

Die Installation und das Clientimage Erstellen ging ohne Probleme.

Ich starte nun meinen Laptop, damit er bootet. Allerdings bekommt der PXE keine Boot Datei.



Habt ihr ne Idee was ich noch machen kann?



Danke schonmal

  • »maettu« ist männlich

Beiträge: 3 299

Registrierungsdatum: 14.09.2005

Derivat: Xubuntu

Architektur: 64-Bit PC

Desktop: XFCE

  • Nachricht senden

2

23.12.2014, 09:45

Ubuntu läuft auf Windows 7 im VMPlayer. IP Adressen wird von der Fritzbox vergeben (DHCP Server). Ubuntu bekommt auch eine eigene Adresse.
Bist du dir da ganz sicher? Das deine IP des "VMPlayer-Ubuntu-Servers" von deiner Fritzbox vergeben wird? Und ist das überhaupt sinnvoll?

Ich starte nun meinen Laptop, damit er bootet. Allerdings bekommt der PXE keine Boot Datei.
Weiss nicht aber die ganze "Netzwerkgeschichte" mit VMPlayer ist eher kompliziert. Ich würde meinen wenn dein Server in einer Virtuellen Maschine ist, musst du dich zuerst mit Netzwerk und VMPlayer beschäftigen...

Alternativ könntest du vielleicht eine zweite virtuelle Maschine starten (das wäre dann ein virtueller Client), dann probieren via deine erste virtuelle Maschine (dein LTSP-Server) zu booten.
Das ganze geht natürlich nur wenn du einigermassen gute Hardware hast und genügend RAM. Und natürlich auch nur falls VMPlayer überhaupt erlaubt via PXE zu booten...

PS: Wenn du es irgendwie einrichten kannst würde ich solche Server-Spielereien mit realer Hardware testen.

3

25.12.2014, 21:24

IP Adressen wird von der Fritzbox vergeben (DHCP Server).
Ich starte nun meinen Laptop, damit er bootet. Allerdings bekommt der PXE keine Boot Datei.
Wenn das erste stimmt, liegt das zweite daran, daß die Fritzbox kein Image für ihn hat.

Beim Netzwerk-Boot holt sich der Client außer einer IP auch weitere Infos über die Netzwerk-Konfiguration. Das sollte dann die Adresse des Bootservers und der Name des Images sein. Ohne diese Info kann er es höchstens noch bei der Maschine versuchen, die ihm die IP gegeben hat. Da die FB aber weder ein Bootserver ist, noch weiß daß da einer herumsteht, kann sie ihm diese Info nicht geben. Also bekommt er auch keine Boot-Datei.

Dein Server in der VM wird sehr wahrscheinlich auch einen DHCP-Server haben, was an sich schon ungünstig wäre, wenn die FB ebenfalls IPs vergibt. Daß du trotzdem keine Probleme im Netzwerk hast, kommt daher daß immer der erste antwortende DHCP zum Zug kommt, und das wird selten der in der VM sitzende sein.

Am einfachsten geht es, wenn der DHCP-Server auch gleichzeitig TFTP-Server ist (was auf den in der VM wahrscheinlich zutrifft). Das ist zwar nicht zwingend, aber anderenfalls muss es der DHCP dem Client eben sagen können. Die FB hat dafür kein Setting vorgesehen. Du könntest versuchen, auf der FB den Port 69 an deinen Server in der VM weiterzuleiten. Das wird wahrscheinlich noch ein bisschen extra Feinarbeit brauchen.
mir is wurscht