Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

  • »Ne0_5345« ist der Autor dieses Themas

Beiträge: 4

Registrierungsdatum: 04.11.2014

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: unbekannt

Andere Betriebssysteme: Windows 8,1

  • Nachricht senden

1

04.11.2014, 21:44

Boot probleme nach update auf 14.10

Hi,

also ich hab folgendes problem und zwar auf meinem Laptop war schon vorab windows 8 intalliert( Samsung New Serie 9). Allerdings hab ichs hinbekommen Ubuntu zu installieren grub einzurichten so das ich beide Betriebsysteme nutzen konnte. Als das Update von Ubuntu 14.10 da war hab ich dieses wie gewohnt installiert. Allerdings kam es zu probleme mit dem Grub, alle versuche scheiterten. Also hab ich Ubuntu neuinstalliert allerdings bootet mein Laptop automatisch Windoof 8.1 anstatts ins Grub zu gehen. Den USB stick von dem ich Ubuntu installiere starte ich im efi. In der Bootreinfolge ist die SSD auf platz 1. ich hab schon alles probiert hat einer von euch noch ne idee?

  • »Klaus P« ist männlich

Beiträge: 4 482

Registrierungsdatum: 25.10.2009

Derivat: anderes Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: 7/10

  • Nachricht senden

2

04.11.2014, 22:23

Hallo!

Wenn du ins UEFI-Bootmenü des Rechners gehst, kannst du dann Ubuntu zum Starten auswählen? Oder über den Windows Bootmanager?

Falls du Ubuntu nicht auf diese Weise starten kannst, starte die Installation bitte in den Live-Modus (Ubuntu ausprobieren). In beiden Fällen Terminal öffnen und bitte folgende Befehle eingeben und alle Terminalausgaben hier posten.

Quellcode

1
2
3
4
sudo parted -l  #-l=kleines L
sudo apt-get install efibootmgr 
sudo efibootmgr
sudo efibootmgr -v


Weitere Infos zu UEFI siehe unten!

Gruß

Klaus P
Des modernen Menschen Computer ist sein Himmelreich! :rolleyes: Der Weg zur Hölle, ist allzu kurz auf dem falschen "EFI-Pfad" ;( : Kleiner Leitfaden zur UEFI-Installation

  • »Ne0_5345« ist der Autor dieses Themas

Beiträge: 4

Registrierungsdatum: 04.11.2014

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: unbekannt

Andere Betriebssysteme: Windows 8,1

  • Nachricht senden

3

04.11.2014, 22:39

Das ist die Ausgabe von sudo parted -l

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
Matching Defaults entries for ubuntu on ubuntu:
	env_reset, mail_badpass,
	secure_path=/usr/local/sbin\:/usr/local/bin\:/usr/sbin\:/usr/bin\:/sbin\:/bin

User ubuntu may run the following commands on ubuntu:
	(ALL : ALL) ALL
	(ALL) NOPASSWD: ALL
ubuntu@ubuntu:~$ 
ubuntu@ubuntu:~$ sudo parted -l
Model: ATA SAMSUNG MZMTD512 (scsi)
Disk /dev/sda: 512GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End	Size	File system 	Name                      	Flags
 1  	1049kB  524MB  523MB   ntfs        	Basic data partition      	hidden, diag
 2  	524MB   839MB  315MB   fat32       	EFI system partition      	boot, esp
 3  	839MB   973MB  134MB               	Microsoft reserved partition  msftres
 4  	973MB   206GB  205GB   ntfs        	Basic data partition      	msftdata
 7  	206GB   475GB  269GB   ext4
 8  	475GB   483GB  8194MB  linux-swap(v1)
 5  	483GB   511GB  27.9GB  ntfs        	Basic data partition      	hidden, diag
 6  	511GB   512GB  1074MB  fat32       	Basic data partition      	hidden, diag


Model: USB Flash Disk (scsi)
Disk /dev/sdb: 2005MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End 	Size	Type 	File system  Flags
 1  	16.4kB  2005MB  2005MB  primary  fat32    	boot


Ausgabe von sudo efibootmgr

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
BootCurrent: 0006
Timeout: 0 seconds
BootOrder: 0006,0003,0004,0005,0008,0007
Boot0000  Setup
Boot0001  Boot Menu
Boot0002  Recovery
Boot0003* SATA HDD:
Boot0004* USB CD:
Boot0005* USB FDD:
Boot0006* USB HDD:
Boot0007* NETWORK:
Boot0008* Windows Boot Manager


Ausgabe von sudo efibootmgr -v

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
BootCurrent: 0006
Timeout: 0 seconds
BootOrder: 0006,0003,0004,0005,0008,0007
Boot0000  Setup	FvFile(721c8b66-426c-4e86-8e99-3457c46ab0b9)
Boot0001  Boot Menu	FvFile(86488440-41bb-42c7-93ac-450fbf7766bf)
Boot0002  Recovery	FvFile(ab4579c4-3bc5-4489-a88e-0f21e6cebf85)
Boot0003* SATA HDD:	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f600)
Boot0004* USB CD:	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,86701296aa5a7848b66cd49dd3ba6a55)
Boot0005* USB FDD:	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,6ff015a28830b543a8b8641009461e49)
Boot0006* USB HDD:	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,33e821aaaf33bc4789bd419f88c50803)
Boot0007* NETWORK:	VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,78a84aaf2b2afc4ea79cf5cc8f3d3803)
Boot0008* Windows Boot Manager	HD(2,fa000,96000,173ecaba-6a84-4e50-a572-d6f1c87287f1)File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...d................

  • »Klaus P« ist männlich

Beiträge: 4 482

Registrierungsdatum: 25.10.2009

Derivat: anderes Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: 7/10

  • Nachricht senden

4

04.11.2014, 23:13

Hallo!

Versuche zunächst mal automatisiert Boot-Repair durchlaufen lassen. Wichtig dabei ist, dass die Live-Session auch im UEFI-Modus gestartet wird und eine Internetverbindung besteht. Es kann während des Programmablaufs zu Nachfragen und Installationen kommen.

Gruß

Klaus P
Des modernen Menschen Computer ist sein Himmelreich! :rolleyes: Der Weg zur Hölle, ist allzu kurz auf dem falschen "EFI-Pfad" ;( : Kleiner Leitfaden zur UEFI-Installation

  • »Ne0_5345« ist der Autor dieses Themas

Beiträge: 4

Registrierungsdatum: 04.11.2014

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: unbekannt

Andere Betriebssysteme: Windows 8,1

  • Nachricht senden

5

05.11.2014, 00:20

Also boot repair klappt auch net hab mal als dateianhang den text der url gepackt
»Ne0_5345« hat folgende Datei angehängt:
  • boot-repair.txt (691,37 kB - 8 mal heruntergeladen - zuletzt: 05.11.2014, 12:27)

  • »Klaus P« ist männlich

Beiträge: 4 482

Registrierungsdatum: 25.10.2009

Derivat: anderes Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: 7/10

  • Nachricht senden

6

05.11.2014, 10:51

Hi!

Bei mir wird kein Text angezeigt! Es reicht auch, wenn du den Link zu Pastebin postest. Wenn du ihn nicht mehr hast, starte BootRepair noch mal, aber ohne die Repairfunktion sondern nur das Summary.

Gruß

Klaus P
Des modernen Menschen Computer ist sein Himmelreich! :rolleyes: Der Weg zur Hölle, ist allzu kurz auf dem falschen "EFI-Pfad" ;( : Kleiner Leitfaden zur UEFI-Installation

  • »Ne0_5345« ist der Autor dieses Themas

Beiträge: 4

Registrierungsdatum: 04.11.2014

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: unbekannt

Andere Betriebssysteme: Windows 8,1

  • Nachricht senden

7

05.11.2014, 13:12


  • »Klaus P« ist männlich

Beiträge: 4 482

Registrierungsdatum: 25.10.2009

Derivat: anderes Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: 7/10

  • Nachricht senden

8

05.11.2014, 14:51

Hallo!

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
============================= Boot Info Summary: ===============================

 => No boot loader is installed in the MBR of /dev/sda.
 => Syslinux MBR (3.61-4.03) is installed in the MBR of /dev/sdb.

sda1: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows 8/2012: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        

sda2: __________________________________________________________________________

    File system:       vfat
    Boot sector type:  Windows 8/2012: FAT32
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /EFI/Boot/bootx64.efi /EFI/ubuntu/MokManager.efi 
                       /EFI/ubuntu/grubx64.efi /EFI/ubuntu/shimx64.efi 
                       /EFI/Microsoft/Boot/bootmgfw.efi 
                       /EFI/Microsoft/Boot/bootmgr.efi 
                       /EFI/Microsoft/Boot/memtest.efi

sda3: __________________________________________________________________________

    File system:       
    Boot sector type:  -
    Boot sector info: 
    Mounting failed:   mount: unknown filesystem type ''

sda4: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows 8/2012: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /bootmgr /Windows/System32/winload.exe

sda5: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows 8/2012: NTFS
    Boot sector info:  According to the info in the boot sector, sda5 starts 
                       at sector 193449984. But according to the info from 
                       fdisk, sda5 starts at sector 943595521.
    Operating System:  
    Boot files:        

sda6: __________________________________________________________________________

    File system:       vfat
    Boot sector type:  Windows 8/2012: FAT32
    Boot sector info:  According to the info in the boot sector, sda6 starts 
                       at sector 247971840. But according to the info from 
                       fdisk, sda6 starts at sector 998117377.
    Operating System:  
    Boot files:        /EFI/Asclepius/bootx64.efi /EFI/Boot/bootx64.efi 
                       /EFI/ubuntu/grubx64.efi 
                       /EFI/Microsoft/Boot/memtest.efi /bootmgr /boot/bcd

sda7: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info: 
    Operating System:  Ubuntu 14.10 
    Boot files:        /boot/grub/grub.cfg /etc/fstab

sda8: __________________________________________________________________________

    File system:       swap
    Boot sector type:  -
    Boot sector info: 



Hmm! Du hast da sowohl auf der sda2, der eigentlichen EFI-Bootpartition, als auch der sda6, EFI-Bootfiles. Also 2 Bootpartitionen. Wie das zustande kommt....? Und es ist kein Ubuntueintrag im NVRAM, also auf dem Board, vorhanden. Hier kann man zwar nachträglich einen Eintrag erzeugen, aber ich weiß nicht, was es mit den Bootfiles auf der sda6 auf sich hat. Daher ist mir die Geschichte zu heikel, dir hier einen Rat zu geben, ohne Gefahr zu laufen, den Windowsboot zu zerschießen oder dir eine Radikalkur zur empfehlen.

Falls sich hier also niemand mehr meldet, eröffne einen Beitrag bei den Kollegen von Ubuntuusers.de. Da hats ein paar UEFI-Koryphäen. Am besten das ganze Boot-Info-Script dort gleich einstellen.

Gruß

Klaus P
Des modernen Menschen Computer ist sein Himmelreich! :rolleyes: Der Weg zur Hölle, ist allzu kurz auf dem falschen "EFI-Pfad" ;( : Kleiner Leitfaden zur UEFI-Installation

Beiträge: 570

Registrierungsdatum: 15.11.2013

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: unbekannt

Desktop: unbekannt

Andere Betriebssysteme: Linux 4.10.1-1

  • Nachricht senden

9

05.11.2014, 15:48

Das Problem ist hier sowieso im falschen Forenbereich. Es gehört eher unter Upgrade-Probleme.
Auch nach 10 Jahren Ubuntu hat sich folgendes noch immer nicht herumgesprochen. Klick

  • »Klaus P« ist männlich

Beiträge: 4 482

Registrierungsdatum: 25.10.2009

Derivat: anderes Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: 7/10

  • Nachricht senden

10

05.11.2014, 17:19


Das Problem ist hier sowieso im falschen Forenbereich. Es gehört eher unter Upgrade-Probleme.
Auch nach 10 Jahren Ubuntu hat sich folgendes noch immer nicht herumgesprochen. Klick



Aha!?

Um das Upgrade ging's hier überhaupt nicht mehr, da der TS mittlerweile neu installiert hatte (siehe Eröffnungspost) und in Folge dessen ein UEFI-Boot-Problem aufgetaucht ist, das hier erörtert wurde. Der Thread ist also völlig korrekt platziert!
Des modernen Menschen Computer ist sein Himmelreich! :rolleyes: Der Weg zur Hölle, ist allzu kurz auf dem falschen "EFI-Pfad" ;( : Kleiner Leitfaden zur UEFI-Installation

Beiträge: 570

Registrierungsdatum: 15.11.2013

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: unbekannt

Desktop: unbekannt

Andere Betriebssysteme: Linux 4.10.1-1

  • Nachricht senden

11

05.11.2014, 19:20

Um das Upgrade ging's hier überhaupt nicht mehr, da der TS mittlerweile neu installiert hatte
Dann gehört es immer noch in Probleme bei der Installation. ;)