Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

  • »shergar« ist der Autor dieses Themas

Beiträge: 18

Registrierungsdatum: 25.07.2014

Derivat: Ubuntu GNOME

Architektur: andere

  • Nachricht senden

1

25.07.2014, 20:15

Schwarzer Screen bei jedem 2. Systemstart

Hallo !
Habe ein L440 Thinkpad, mit einer geteiltet Festplatte mit 2 Betriebssytemen : Ubuntu 12.04 LTS und Windows 7. Benutze fast ausschließlich Ubuntu (trotz nur laienhafte PC-Kenntnisse !). Jetzt ist - vermutlich nach einer Aktualisierung - folgendes Problem aufgetreten: So etwa bei jedem 2. Start taucht zunächst die normale Auswahl auf. Nach dem Anwählen von Ubuntu wird der Bildschirm kurz schwarz, oben links erscheint ein - Zeichen, das blinkt. Ganz selten taucht an dieser Stelle die Anzeige : 'could not write bites : broken pipe' auf. In beiden Fällen wechselt das Display dann nach kurzer Zeit auf einen nicht ganz so tiefschwarzen screen, von dem aus man nicht weiter kommt. Neustart via ALT+Druck+B funktioniert, danach geht es in der gleichen Sequenz w.o.a. weiter, mit dem Unterschied, daß nach kurzer Zeit der 2. schwarze Screen vom normalen Anmeldedisplay abgelöst wird, und alles ab da ganz normal funktioniert.
Für einen Rat wäre ich dankbar, kann aber nur mit GANZ EINFACHEN Anweisungen was anfangen, da ich das ganze Programmiererkauderwelsch nicht verstehe.

besten Dank im Voraus ! :(

fkf

Gesperrter Benutzer

  • »fkf« wurde gesperrt

Beiträge: 535

Registrierungsdatum: 15.10.2014

Derivat: unbekannt

Architektur: unbekannt

Desktop: unbekannt

Andere Betriebssysteme: Debian Jessie, Android-x86 Vbox

  • Nachricht senden

2

25.07.2014, 21:04

Hast Du eine SSD verbaut oder eine herkömmliche Festplatte?

Hatte hier schon mal davon gelesen, dass das Booten einfach zu schnell ging. Was wir damals geraten haben, weiß ich aber leider nicht mehr.
Kann mich bei dem schwülen Wetter auch nicht gut konzentrieren ...

  • »shergar« ist der Autor dieses Themas

Beiträge: 18

Registrierungsdatum: 25.07.2014

Derivat: Ubuntu GNOME

Architektur: andere

  • Nachricht senden

3

25.07.2014, 21:07

herkömmliche Festplatte...Antwort ist auch nicht eilg; d.h. kannst auch warten, bis es sich etwas abgekühlt hat.

fkf

Gesperrter Benutzer

  • »fkf« wurde gesperrt

Beiträge: 535

Registrierungsdatum: 15.10.2014

Derivat: unbekannt

Architektur: unbekannt

Desktop: unbekannt

Andere Betriebssysteme: Debian Jessie, Android-x86 Vbox

  • Nachricht senden

4

25.07.2014, 21:15

Wenn ich raten müsste würde ich auf den Grafiktreiber tippen, dass der etwas rumzickt. Aber einen Tipp kann ich Dir auch nicht geben. Leider.

  • »Klaus P« ist männlich

Beiträge: 4 520

Registrierungsdatum: 25.10.2009

Derivat: anderes Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: 7/10

  • Nachricht senden

5

25.07.2014, 21:26

Hallo!

Schau dir auf jeden Fall mal die Bootoptionen an: Klick mich!
Wie sie eingetragen werden, siehe den Link nach weiter unten. Ich denke, das ist dort auch gut erklärt. Ansonsten noch mal gezielt nachfragen.

Gruß

Klaus P
Des modernen Menschen Computer ist sein Himmelreich! :rolleyes: Der Weg zur Hölle, ist allzu kurz auf dem falschen "EFI-Pfad" ;( : Kleiner Leitfaden zur UEFI-Installation

  • »shergar« ist der Autor dieses Themas

Beiträge: 18

Registrierungsdatum: 25.07.2014

Derivat: Ubuntu GNOME

Architektur: andere

  • Nachricht senden

6

25.07.2014, 21:56

Hallo Klaus P. !

besten Dank für die Antwort, aber der Link hilft mir überhaupt nicht weiter, da es mir nicht möglich ist, unter den vielen aufgelisteten Optionen die für meinen Fall zutreffende herauszufinden (bin, wie erwähnt, IT-Laie, und kann mit den in Programmierer-Idiom gehaltenen Hinweisen nichts anfangen...). ich weiß zB nicht einmal, was für eine Grafikkarte bei mir installiert ist.

beste Grüsse

Shergar

  • »Klaus P« ist männlich

Beiträge: 4 520

Registrierungsdatum: 25.10.2009

Derivat: anderes Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: 7/10

  • Nachricht senden

7

25.07.2014, 22:22

Hallo!

Zitat

bin, wie erwähnt, IT-Laie,
Ich auch! Man muß auch kein Profi sein!

Die beiden ersten aufgeführten Optionen "nomodeset" und "xforcevesa", sind die, die in vergleichbaren Fällen oft hilfreich sind.

Was für eine Grafik verbaut ist, kannst du mit folgendem Befehl herausfinden:

Quellcode

1
lspci -nnk | grep "VGA\|'Kern'\|3D\|Display" -A2
.

Das Terminal öffnest du am einfachsten per STRG + ALT + T. Ggf. aber per Copy und Paste eingeben und nicht abschreiben.

Bin ansonsten leider auch nicht der Grafikprofi, aber es gibt ja noch mehr Kollegen hier.

Gruß

Klaus P
Des modernen Menschen Computer ist sein Himmelreich! :rolleyes: Der Weg zur Hölle, ist allzu kurz auf dem falschen "EFI-Pfad" ;( : Kleiner Leitfaden zur UEFI-Installation

  • »shergar« ist der Autor dieses Themas

Beiträge: 18

Registrierungsdatum: 25.07.2014

Derivat: Ubuntu GNOME

Architektur: andere

  • Nachricht senden

8

25.07.2014, 22:45

VGA compatible controller [0300]: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06)
Subsystem: Lenovo Device [17aa:501e]
Kernel driver in use: i915
Das ist also drin...
Und nu ?

Gruß

Shergar

  • »Klaus P« ist männlich

Beiträge: 4 520

Registrierungsdatum: 25.10.2009

Derivat: anderes Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: 7/10

  • Nachricht senden

9

25.07.2014, 23:05

Zitat

Und nu ?


1. Abwarten bis jemand kommt, der sich besser mit Grakas auskennt als ich

2. Die beiden Bootoptionen testen


Oder in umgekehrter Reihenfolge! Die Bootoptionen lassen sich ja ggf. auch wieder raus nehmen.

Gruß

Klaus P
Des modernen Menschen Computer ist sein Himmelreich! :rolleyes: Der Weg zur Hölle, ist allzu kurz auf dem falschen "EFI-Pfad" ;( : Kleiner Leitfaden zur UEFI-Installation

  • »shergar« ist der Autor dieses Themas

Beiträge: 18

Registrierungsdatum: 25.07.2014

Derivat: Ubuntu GNOME

Architektur: andere

  • Nachricht senden

10

25.07.2014, 23:10

OK. Bis morgen werde ich auf jeden Fall mal abwarten. Falls sich niemand weiter zu dem Thema meldet : Kann man mit den erwähnten boot - Optionen u.U. was "verschlimmbessern" ? (the road to hell is paved with good intentions...)

beste Grüsse

Shergar

11

26.07.2014, 10:27

Hi

mit den Optionen solltest du eigentlich nichts beschädigen können, weder dauerhaft noch temporär.

Mich würde interessieren, ob du in ein Terminal (STRG+ALT+F1) wechseln kannst, wenn der Screen schwarz bleibt. Sollte das möglich sein, melde dich dort mit deinem Nutzernamen + Passwort (blind eingeben, es erscheinen keine Sternchen oder ähnliches) und gebe als nächstes einfach mal

Quellcode

1
startx
ein.
Damit könnten wir den Fehler auf jeden Fall schon einmal eingrenzen.
Sollte sich nach dem Befehl nicht die gewohnte Oberfläche öffnen, dann kannst du mittels

Quellcode

1
sudo reboot
den Rechner neu starten. Alternativ einfach STRG+ALT+ENTF.

VG
"Das Leben ist zum lachen da, `drum nehm´ ich Psychopharmaka" (Die Ärzte, Living Hell)

  • »shergar« ist der Autor dieses Themas

Beiträge: 18

Registrierungsdatum: 25.07.2014

Derivat: Ubuntu GNOME

Architektur: andere

  • Nachricht senden

12

26.07.2014, 13:45

Terminal öffnet sich bei mir via STRG+ALT+T, nicht via F1. Funktioniert aber beim schwarzen Screen leider nicht. Neustart (über ALT+Druck+B) geht bisher immer, danach taucht der schwarze Screen nach Anwahl von Ubuntu (im Grub-Menu) nur kurz auf, dann funktioniert alles normal. Trotzdem blöd.

beste Grüsse, und vorerst schon mal vielen Dank


Shergar

13

27.07.2014, 11:02

Terminal öffnet sich bei mir via STRG+ALT+T, nicht via F1. Funktioniert aber beim schwarzen Screen leider nicht.

Mit STRG+ALT+F1 kannst du bei einem funktionierenden Ubuntu-System immer in eine Konsole wechseln. Kannst es ja mal ausprobieren, mit STRG+ALT+F8 kommst du zurück zur grafischen Oberfläche.
Darum wollte ich ja wissen, ob du in die Konsole wechseln kannst, wenn der Screen schwarz bleibt. Aber es scheint ja nicht, heißt wohl, dass der Kernel nicht ordnungsgemäß startet.

Da es nach der Aktualisierung auftrat, hätte ich noch eine Idee.
Boote doch einmal einen älteren installierten Kernel (Beim Systemstart, frühere Versionen oder so) und schaue, ob es bei diesem auch auftritt. Könnte mir vorstellen, dass eine Aktualisierung im aktuellen Kernel dein Intel-Grafikchip nicht mag und deshalb nicht vollständig bootet.
Sollte das der Fall sein, könntest du den aktuellen Kernel blacklisten und hoffen, dass im folgenden Kernel der Bug wieder behoben wurde.
Wie das geht, schauen wir aber dann.

VG
"Das Leben ist zum lachen da, `drum nehm´ ich Psychopharmaka" (Die Ärzte, Living Hell)

  • »shergar« ist der Autor dieses Themas

Beiträge: 18

Registrierungsdatum: 25.07.2014

Derivat: Ubuntu GNOME

Architektur: andere

  • Nachricht senden

14

27.07.2014, 11:53

Stimmt : Fn-Taste war deaktiviert; habe im L440 Handbuch nachgelesen, und sie dann aktivieren können. Wechsel zurück zur grafischen Oberfläche ( STRG+ALT+F8) funktionierte dann seltsamerweise nicht, so daß ich über den Terminal 'runterfahren und dann neu starten mußte...
Ansonsten : Wie genau kann ich die Kernel-Liste anwählen ? Und wie sindf die Aktualisierungen gelistet (chronologisch von oben nach unten, oder so ?) ?

beste Grüsse

Shergar

Beiträge: 570

Registrierungsdatum: 15.11.2013

Derivat: unbekannt

Version: gar kein Ubuntu

Architektur: unbekannt

Desktop: unbekannt

Andere Betriebssysteme: Linux 4.10.1-1

  • Nachricht senden

15

27.07.2014, 12:56

Zurück kommt man gewöhnlich mit Strg + Alt + F7 nicht mit F8 ;)

16

27.07.2014, 13:35

Zurück kommt man gewöhnlich mit Strg + Alt + F7 nicht mit F8 ;)

Dachte ich an sich auch, bei meinem Mint17 ist es aber komischer Weise F8. Naja Also F7 oder F8 testen ;)

Geh einfach auf den Eintrag "Previous Linux-Versions" (oder wie der auch immer heißen mag) und wähle dort einfach den obersten aus. Das sollte der nächst aktuellste sein. Zu erkennen an der letzten Zahl (32, 30 oder ähnliches).
Wenn dein System läuft, dann kannst du mittels

Quellcode

1
uname -r
nachschauen, mit welchem Kernel du dein System gerade betreibst.
Sollte der Systemstart mit einem älteren Kernel nie zu einem Blackscreen führen, dann liegt es am Kernel.

Da du laut Profil 12.04 verwendest, könnte es sein, dass du auf einen neuen Point-Release mit neuerem Kernel (siehe hier) geupdatet wurdest.
Schau am Besten einfach mal nach, welche Kernel bei dir installiert sind. Geht am besten mit der Synaptic-Paketverwaltung (einfach nach "linux-header" suchen)

MFG
"Das Leben ist zum lachen da, `drum nehm´ ich Psychopharmaka" (Die Ärzte, Living Hell)

  • »shergar« ist der Autor dieses Themas

Beiträge: 18

Registrierungsdatum: 25.07.2014

Derivat: Ubuntu GNOME

Architektur: andere

  • Nachricht senden

17

27.07.2014, 13:54

" 3.13.0. -32- generic" ; kann das evtl die Kernel-Bezeichnung sein ? Und wie genau komme ich zu dem Eintrag "Previous Linux Versions" ?

besten Grüsse

Shergar

18

27.07.2014, 18:41

" 3.13.0. -32- generic" ; kann das evtl die Kernel-Bezeichnung sein ?

Jip, dass ist die aktuelle Kernel-Bezeichnung. Also bist du auf dem noch gepflegten LTS-Zweig.

Um mal zu schauen, welche Kernel überhaupt installiert sind, poste bitte mal die Ausgabe von

Quellcode

1
ls -l /boot/vm*
hier in CODE-Tags (#-Raute Symbol im Editor)

Wenn du schon einmal im Terminal bist, installiere die am Besten auch gleich noch Synaptic.

Quellcode

1
sudo apt-get install synaptic

Damit fällt zumindest mir das Backlisten leichter. Dort kannst du mit einer grafischen Oberfläche dein System besser warten.

MFG
"Das Leben ist zum lachen da, `drum nehm´ ich Psychopharmaka" (Die Ärzte, Living Hell)

  • »shergar« ist der Autor dieses Themas

Beiträge: 18

Registrierungsdatum: 25.07.2014

Derivat: Ubuntu GNOME

Architektur: andere

  • Nachricht senden

19

28.07.2014, 12:06

schwarzer screee

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
thomas@thomas-ThinkPad-L440:~$ ls -1 /boot/vm*
/boot/vmlinuz-3.11.0-15-generic
/boot/vmlinuz-3.11.0-17-generic
/boot/vmlinuz-3.11.0-18-generic
/boot/vmlinuz-3.11.0-19-generic
/boot/vmlinuz-3.11.0-20-generic
/boot/vmlinuz-3.11.0-22-generic
/boot/vmlinuz-3.11.0-23-generic
/boot/vmlinuz-3.11.0-24-generic
/boot/vmlinuz-3.11.0-26-generic
/boot/vmlinuz-3.13.0-30-generic
/boot/vmlinuz-3.13.0-32-generic
/boot/vmlinuz-3.8.0-29-generic
/boot/vmlinuz-3.8.0-35-generic
/boot/vmlinuz-3.8.0-36-generic
/boot/vmlinuz-3.8.0-37-generic
/boot/vmlinuz-3.8.0-38-generic
/boot/vmlinuz-3.8.0-39-generic
/boot/vmlinuz-3.8.0-41-generic
/boot/vmlinuz-3.8.0-42-generic
/boot/vmlinuz-3.8.0-44-generic
thomas@thomas-ThinkPad-L440:~$


Ansonsten scheint einme gewisse "Spontanheiliung" eingetreten zu sein : Die Sequenz beim Booten ist jetzt wie folgt : 1) Grub-Display 2) Ubuntu-Logo 3) fast schwarzer Screen (ganz dunkles Anthrazit) 4) kurzes Flackern 5) ganz schwarzer Screen 6) normaler Startscreen; d.h. der Rechner hat sich (zumindest die letzten 3-4 x) nicht mehr im Stadium des schwarzen Screens aufegehängt. Unter dem Gesichtspunkt meiner laienhaften IT-Kenntnisse : Soll ich's lieber dabei belassen, oder dem Problem weiter nachgehen ?

beste Grüsse

Shergar

20

28.07.2014, 14:17

Also du solltest auf jeden Fall mal ein paar ältere Kernel entfernen, wenn du die nicht mehr brauchst. Am Besten mit Synaptic.
Dazu suchst du in Synaptic nach linux-image und entfernst dort die ältesten, also alle mit 3.8.X und 3.11.x außer vielleicht den letzten 3.11.0-32. Den könntest du sicherheitshalber installiert lassen.

Laut Changelog vom 14.7 wurden einige Bugs im 3.13.0-30 entfernt und zum 3.13.0-32 geupdated. Kann durchaus sein, dass der -30 Kernel auch Probleme gemacht hat, welche im -32 behoben wurde. Was genau angepasst wurde, habe ich mir aber ehrlich gesagt nicht durchgelesen.
Beobachte es einfach weiterhin mal und sollte es nicht wieder auftreten, lag es am Bug im Kernel und du könntest das Thema auf [erledigt] setzen.

VG
"Das Leben ist zum lachen da, `drum nehm´ ich Psychopharmaka" (Die Ärzte, Living Hell)