Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

  • »_Blackbot_« ist der Autor dieses Themas

Beiträge: 3

Registrierungsdatum: 19.06.2014

Derivat: Lubuntu

Architektur: ARM

  • Nachricht senden

1

20.06.2014, 19:02

Festplatte wird unter lubuntu falsch gemountet

Ich habe an meinem Cubietruck das Betriebssystem lubuntu 13 welches mir als Server (NAS) fugieren soll. Nun habe ich dazu ein 2,5" Festplatte mit 320GB ich finde diese auch unter den Festplatten, dort wird sie als sda1 angegeben. Sobald ich diese aber mounte durch
mount -t /dev/sda1 /media/
wird die Festplatte eingehäng aber es existiert nur ein Ordner namens NA(welcher leer ist) in Media, jedoch sollten mehrere Ordner vorhanden sein.

Unter Fedora wird mit dem gleichen Befehl aber die gesamte Festplatte eingehängt. unter /media/NAS/ finde ich dann meine ganzen Dateien.

Meine Frage ist wie mounte ich nun meine Festplatte damit ich auch auf diese Daten zugreifen kann?
Ich habe es auch mit /etc/fstab ausprobiert gleiches Ergebnis.
Danke im Vorauß

  • »hellmi666« ist männlich

Beiträge: 629

Registrierungsdatum: 08.08.2007

Derivat: Kein Ubuntu-Derivat

Architektur: 64-Bit PC

Andere Betriebssysteme: Arch-Linux (Mate-Desktop)

  • Nachricht senden

2

20.06.2014, 19:17

Du musst unter /media/ noch einen Ordner anlegen, worin die Festplatte gemountet werden soll.
z.B.

Quellcode

1
sudo mkdir /media/nas
Grüße Hellmi
_______________________________________________________________________________________________________________________________________________________________________________________
Mein Pc: AMD Athlon 64 4000+, 1024 MB DDR-Ram, nVidia GeForce 7300LE, Festplatten: 2x 250 GB intern, 1x1TB extern (50 GB für Windows, Rest für Linux)

Wenn ich mal groß bin, werde ich bestimmt nicht wieder Schlosser.

DocHifi

unregistriert

3

20.06.2014, 19:18

Ich habe es auch mit /etc/fstab ausprobiert gleiches Ergebnis.

Dann hast du was falsch gemacht, auf meinem CubieBoard läuft es.
Aber dafür brauchen wir mehr Angaben, zum Beispiel die Zeile aus der Fstab.

  • »_Blackbot_« ist der Autor dieses Themas

Beiträge: 3

Registrierungsdatum: 19.06.2014

Derivat: Lubuntu

Architektur: ARM

  • Nachricht senden

4

20.06.2014, 20:16

unter fedora

bereits gemountet
durch /etc/fstab hatte ich folgendes stehen in fedora und ubuntu nach nicht funktionieren hab ich es aus ubuntu gelöscht :

Quellcode

1
2
3
4
5
6
[root@cubietruck ~]# cat /etc/fstab
tmpfs            /tmp           tmpfs    size=80m 0       0   



UUID="23098561736D0D09" /media/NAS ntfs umask=777,noauto  // REchte sind nur momentan aus Testzwecken auf 777


hab es auch mit /dev/sda1 /media/ default 0 0 in ubuntu probiert

die UUID hab ich von hier

Quellcode

1
2
3
4
[root@cubietruck ~]# blkid
/dev/nanda: SEC_TYPE="msdos" LABEL="Volumn" TYPE="vfat"
/dev/nandb: UUID="ad9ca7ef-e4f1-4acc-9cb7-e8de356c9a61" TYPE="ext4"
/dev/sda1: UUID="23098561736D0D09" TYPE="ntfs" PARTUUID="000df6d0-01"


In Fedora kann ich auf den Inhalt zugreifen:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
[root@cubietruck ~]# cd /media/NAS/
[root@cubietruck NAS]# ls -a
.  ..  cubie  Download  Musik
[root@cubietruck NAS]# cd Musik/
[root@cubietruck Musik]# ls -a
.
..
101_tiesto_-_red_lights.mp3
katy_perry_feat_juicy_j_-_dark_horse_.mp3
lorde_-_team.mp3
macklemore_and_ryan_lewis_feat_schoolboy_q_and_hollis_-_white_walls.mp3
mr_probz_-_waves_%28robin_schulz_radio_edit%29.mp3
[root@cubietruck Musik]#


der ORDNER Download und Musik sind grün hinterlegt, das liegt aber glaub ich an den Rechten.


unter ubuntu

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
root@cubietruck:/media# cd /media
root@cubietruck:/media# ls -a
.  ..
root@cubietruck:/media# cat /proc/partitions
major minor  #blocks  name

  93        0    7520256 nand 
  93        1      65536 nand1
  93        2    6291456 nand2
  93        3    1146880 nand3
 179        0    1931264 mmcblk0
 179        1      65536 mmcblk0p1  //SD card mit betriebssystem ubuntu
 179        2    1864704 mmcblk0p2
   8        0  312571224 sda        // Festplatte ntfs formatiert
   8        1  312570200 sda1 

root@cubietruck:/media# mount -t ntfs-3g /dev/sda1 /media/

root@cubietruck:/media# cd /media/

root@cubietruck:/media# ls -a
.  ..  na
root@cubietruck:/media# cd na
root@cubietruck:/media/na# ls    //leer


das ich einen Ordner mit NAS erstellen muss weiß ich, aber die Festplatte wird so ja eigentlich so unter /media angezeigt

glaub ich hab was in fedora zusammen gepfutscht.
wenn ich sie an meinen windows Rechner anschließe wird sie als lokaler DAtenträger erkannt und es existiert nur ein Ordner na .
Wisst ihr aber wie ich auf die Dateien welche ich unter Fedora trotzdem zugreifen kann?

ich habe auch bereits aus Testzwecken einen Samba unter Fedora erstellt mit welchem ich die Dateien Downloads Musik Cubie im Netz mit windows auch finde bzw erstellen kann?
die sind dann auch unter Fedora auffindbar

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »_Blackbot_« (20.06.2014, 20:29) aus folgendem Grund: Neue Erkenntnisse


  • »hellmi666« ist männlich

Beiträge: 629

Registrierungsdatum: 08.08.2007

Derivat: Kein Ubuntu-Derivat

Architektur: 64-Bit PC

Andere Betriebssysteme: Arch-Linux (Mate-Desktop)

  • Nachricht senden

5

21.06.2014, 09:01

das ich einen Ordner mit NAS erstellen muss weiß ich, aber die Festplatte wird so ja eigentlich so unter /media angezeigt

Ich kann mich auch irren, aber wenn du die Festplatte direckt unter /media mounten willst, musst du auch /media schreiben und nicht /media/.
Also statt

Quellcode

1
mount -t ntfs-3g /dev/sda1 /media/

so

Quellcode

1
mount -t ntfs-3g /dev/sda1 /media


Zitat von »'_Blackbot_«

durch /etc/fstab hatte ich folgendes stehen in fedora und ubuntu nach nicht funktionieren hab ich es aus ubuntu gelöscht :

Quellcode

1
2
3
4
5
6
[root@cubietruck ~]# cat /etc/fstab
tmpfs            /tmp           tmpfs    size=80m 0       0   



UUID="23098561736D0D09" /media/NAS ntfs umask=777,noauto  // REchte sind nur momentan aus Testzwecken auf 777

Die UUIDs in der /etc/fstab schreibt man ohne "

Quellcode

1
UUID=23098561736D0D09 /media/NAS ntfs umask=777,noauto  // REchte sind nur momentan aus Testzwecken auf 777

Desweiteren steht doch hier /media/NAS, also musst du doch auch einen Ordner NAS zuvor erstellen.
Grüße Hellmi
_______________________________________________________________________________________________________________________________________________________________________________________
Mein Pc: AMD Athlon 64 4000+, 1024 MB DDR-Ram, nVidia GeForce 7300LE, Festplatten: 2x 250 GB intern, 1x1TB extern (50 GB für Windows, Rest für Linux)

Wenn ich mal groß bin, werde ich bestimmt nicht wieder Schlosser.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »hellmi666« (21.06.2014, 09:11)


  • »_Blackbot_« ist der Autor dieses Themas

Beiträge: 3

Registrierungsdatum: 19.06.2014

Derivat: Lubuntu

Architektur: ARM

  • Nachricht senden

6

21.06.2014, 19:20

hat sich erledigt, irgendetwas stimmt mit feodora nicht.
hab meine Festplatte ja mit FSTAB gemountet dachte ich zumindest in Wirklichkeit kann ich sie nach dem start wieder mit

Quellcode

1
mount /dev/sda1 /media/NAS

mounten.
nun habe ich im Ordner NAS meinen ordner na von der Festplatte. Jedoch sind die anderen Ordner spurlos verschwunden ?(

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
[root@cubietruck ~]# cd /media/NAS
[root@cubietruck NAS]# ls -a
.  ..  cubie  Download  Musik
[root@cubietruck NAS]# mount /dev/sda1 /media/NAS
[root@cubietruck NAS]# cd
[root@cubietruck ~]# cd /media/
[root@cubietruck media]# ls -a
.  ..  NAS
[root@cubietruck media]# cd NAS/
[root@cubietruck NAS]# ls -a
.  ..  na  $RECYCLE.BIN
[root@cubietruck NAS]# cd na/


recht merkwürdig, wo ich wohl die Ordner cubie Download Musik erstellt habe ?( ?(

7

21.06.2014, 20:18

Deine Texte sind nicht ganz leicht zu lesen, aber ich versuche ein bisschen Licht in die Sache zu holen.
hab meine Festplatte ja mit FSTAB gemountet dachte ich zumindest in Wirklichkeit kann ich sie nach dem start wieder mit
mount /dev/sda1 /media/NAS
mounten.
Wenn das mit dieser fstab passiert, ist es klar:
UUID="23098561736D0D09" /media/NAS ntfs umask=777,noauto
Siehst du das rote?

nun habe ich im Ordner NAS meinen ordner na von der Festplatte. Jedoch sind die anderen Ordner spurlos verschwunden
Spurlos sicher nicht. Die liegen immer noch unter /media/, nur sind sie jetzt durch die darüber gemountete Festplatte verdeckt. Du hast sie angelegt als diese nicht gemountet war.
Was auf der Platte selbst passiert ist, weiß ich natürlich nicht.
mir is wurscht