Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

  • »Leroy-Fiddler« ist männlich
  • »Leroy-Fiddler« ist der Autor dieses Themas

Beiträge: 36

Registrierungsdatum: 28.01.2012

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: Unity

Andere Betriebssysteme: Gentoo mit XFCE 4.10 (64 bit), Xubuntu 12.04 (32 und 64 bit), Slacko Puppy

  • Nachricht senden

1

27.04.2014, 15:44

Tastaturbelegung bleibt Englisch, obwohl deutsch eingestellt ist

Hallo Leute,

nachdem ich nun einige Zeit von Ubuntu fern war, um Gentoo auszuprobieren, hab ich mich mit dem Release von 14.04 dazu entschieden, es noch einmal mit Ubuntu zu versuchen. Vielleicht wäre es klüger gewesen, das erste Point Release abzuwarten, aber ich war halt gespannt, wie sich Unity so entwickelt hat (unter Gentoo hatte ich XFCE).

Nachdem jetzt eine Weile alles gut gegangen ist, tauchen langsam die ersten Problemchen auf. Das gravierendste ist das folgende, das ein Arbeiten mit Unity fast unmöglich macht.

Das eigentliche Problem
Ich habe das System auf Deutsch installiert, doch seit etwa 2 Tagen stellt sich die Tastaturbelegung automatisch auf Englisch um (US anscheinend), obwohl im Indicator "de" angezeigt wird. Ich benutze gelegentlich "en_GB", weil ich damit intuitiver im Terminal arbeiten kann und in englischen IRC-Channels unterwegs bin, und Griechisch (polytonisch), was ich fürs Studium brauche. Dazwischen zu wechseln ist auch kein Problem, aber das tatsächliche Problem ist die deutsche Belegung.

Offenbar wird deutsch nicht als richtige Einstellung erkannt, obwohl sie angezeigt wird. An und für sich scheint die Funktion aber zu funktionieren, denn wenn ich zwischen den Belegungen durchwechsle, bis wieder "de" eingestellt ist, geht es für eine Weile. Diese Weile dauert genau genommen so lange, bis eine der folgenden Möglichkeiten eintritt:

  • eine der F-Tasten wird gedrückt
  • ein anderes Fenster wird angewählt
  • eine gewisse Zeit verstreicht (?)
  • eine "System"-Taste wie Ctrl, Alt wird gedrückt


Das Problem ist, dass das manchmal mitten zwischen zwei Tastenanschlägen geschieht. Wenn man schnell tippt und nicht hinschaut, hat man plötzlich einen völlig unleserlichen Text, den man gerade nochmal neu schreiben kann.

Problemlösungsstrategien
Weil ich ja brav bin, hab ich versucht, das Problem selbst zu lösen. Folgendes habe ich versucht (Reihenfolge stimmt allerdings sicherlich nicht):

  • aus dieser Wiki-Anleitung die Lösungsvorschläge ausprobiert, entsprechende Pakte installiert/aktualisiert
  • /etc/X11/xorg.conf mit folgenden Eintragungen angelegt (anschließend Neustart):

    Quellcode

    1
    2
    3
    4
    5
    6
    
    Section "InputClass"
            Identifier "keyboard"
            MatchIsKeyboard "yes"
            Option "XkbLayout" "de"
            Option "XkbVariant" "nodeadkeys"
    EndSection

  • die xorg.conf in xorg.conf.backup verschoben (anschließend Neustart)
  • sudo locale-gen de_DE@euro ausgeführt (nach Hinweis aus dem Wiki in einer virtuellen Konsole, nachdem ich mich von der graphischen Sitzung abgemeldet hatte)
  • in /etc/default/locale und /etc/environment "LANG="de_DE.ISO-8859-15@euro"" eingetragen (wie oben nichtgraphisch)
  • localepurge ausgeführt


Leider hat keine dieser Herangehensweisen zu etwas geführt. Allerdings verschärft sich das Problem, weil offenbar (aber vielleicht ist das auch ein anderes Problem, deswegen warte ich jetzt erst mal, was ihr so sagt) nun durch die Tastenkombination Alt+F2 Unity zum Neustart gezwungen wird - bei zweimaligem Anwenden wird Unity abgeschossen und ich kann nicht mal mehr in ein virtuelles Terminal wechseln (überhaupt kann man dann mit keiner Tastenkombination mehr in andere Fenster wechseln - wenn Firefox dann zufällig die oberste, aktive Anwendung ist, kann man nur noch FF benutzen). Das ist extrem unpraktisch, weil man den Befehlsstarter nun mal zum Arbeiten braucht. Im Zuge der genannten Maßnahmen ist übrigens auch die Uhr aus dem Benachrichtigungsfeld verschwunden (ich glaube zwar, dass das möglicherweise doch andere Ursachen hat, aber nenne es mal der Vollständigkeit halber).
Jetzt weiß ich leider nicht weiter, im IRC herrscht ebenfalls Ratlosigkeit. Darum bitte ich um Hilfe, weil ich alleine nicht weiterkomme und wirklich nicht schon wieder neu installieren möchte.

Eine noch vielleicht nicht unerhebliche Anmerkung ist, dass Lightdm anscheinend keine Probleme hat; im Anmeldedialog nach dem Hochfahren kann ich mein Passwort noch normal eingeben; auch der Gast-Account ist von dem Problem nicht betroffen. Der Screenlocker (Ubuntus Standardanwendung dafür meine ich) kann das allerdings nicht, ich muss mir merken, welche Tasten ich zum PW in englischer Tastaturbelegung eingeben muss, sonst hab ich Pech oder muss den Umweg gehen, indem ich auf das Zahnrad > Abmelden gehe, um wieder bei Lightdm rauszukommen (der ja wie gesagt das Problem nicht zu haben scheint). Versteckte Dateien im Home-Ordner habe ich daraufhin nach auffälligen Fehlermeldungen überprüft, aber nichts gefunden, was so aussah, als gehört es dazu. Bei Interesse liefere ich die Ausgaben aber natürlich gern nach.

So, genug geredet, ich hoffe, das reicht als Appetithappen. Hoffentlich könnt ihr mir helfen.

Viele Grüße,
Leroy-Fiddler

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Leroy-Fiddler« (30.04.2014, 13:25)


2

27.04.2014, 18:41

Hallo

hast du schon mal folgendes versucht?

Quellcode

1
sudo dpkg-reconfigure keyboard-configuration 


lg

  • »Leroy-Fiddler« ist männlich
  • »Leroy-Fiddler« ist der Autor dieses Themas

Beiträge: 36

Registrierungsdatum: 28.01.2012

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: Unity

Andere Betriebssysteme: Gentoo mit XFCE 4.10 (64 bit), Xubuntu 12.04 (32 und 64 bit), Slacko Puppy

  • Nachricht senden

3

28.04.2014, 18:22

Hallo Imhotep,

ja, hab es versucht. Hat aber nicht zu Erfolg geführt.

Grüße,

Leroy-Fiddler

  • »Leroy-Fiddler« ist männlich
  • »Leroy-Fiddler« ist der Autor dieses Themas

Beiträge: 36

Registrierungsdatum: 28.01.2012

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: Unity

Andere Betriebssysteme: Gentoo mit XFCE 4.10 (64 bit), Xubuntu 12.04 (32 und 64 bit), Slacko Puppy

  • Nachricht senden

4

30.04.2014, 13:25

Inzwischen hat mich die Sache so genervt, dass ich folgendes getan habe, was zur Lösung/Erledigung beigetragen hat:

aus /home die wichtigen Daten (Dokumente, Bilder etc.) gesichert.
alle .folder aus /home gelöscht (außer .mozilla, .thunderbird, .purple, um den Spaß nicht neu anlegen zu müssen).

Danach geht alles wieder. Thema also erledigt (gelöst würde ich es nicht nennen, da ich nicht weiß, was den eigentlichen Fehler verursacht hat. Aber es hat geholfen ;-) )

Viele Grüße und danke,
Leroy Fiddler

fkf

Gesperrter Benutzer

  • »fkf« wurde gesperrt

Beiträge: 535

Registrierungsdatum: 15.10.2014

Derivat: unbekannt

Architektur: unbekannt

Desktop: unbekannt

Andere Betriebssysteme: Debian Jessie, Android-x86 Vbox

  • Nachricht senden

5

30.04.2014, 15:15

Schön, dass es wieder geht. :thumbup:

Beiträge: 1

Registrierungsdatum: 18.10.2014

Architektur: 64-Bit PC

Andere Betriebssysteme: E19

  • Nachricht senden

6

18.10.2014, 21:29

Hallo,

ich hatte dasselbe Problem. Es war alles auf Deutsch eingestellt, nur nach dem Neustart war die Konsole und Englightenment E19 auf Englisch. Trotz der Einstellung auf Deutsch. Dann habe unter /usr/share/X11/xorg.conf.d die Datei "20-keyboard.conf" mit folgendem Inhalt erstellt:

Quellcode

1
2
3
4
5
6
Section "InputClass"
        Identifier "keyboard"
        MatchIsKeyboard "yes"
        Option "XkbLayout" "de"
        Option "XkbVariant" "nodeadkeys"
EndSection

Seitdem ist die Tastatur nach dem Neustart auf das deutsche Layout gestellt.

Gruß Mike