Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

  • »hallowelt« ist männlich
  • »hallowelt« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 02.03.2014

Derivat: Kein Ubuntu-Derivat

Architektur: 32-Bit PC

Andere Betriebssysteme: Puppy Linux

  • Nachricht senden

1

02.03.2014, 14:45

.run dateien ausführen

Ich habe folgendes Problem:
Ich habe mir vor kurzen mal Puppy linux zugelegt um ein bisschen zu programmieren. Nun habe ich mir dafür XAMPP heruntergeladen (ja die Linux-Version :D) aber das ganze wird als .run datei gespeichert nun habe ich schon alles probiert was ich so gefunden habe
  • ins Verzeichnis navigiert und chmod ausgeführt
  • ./ xampp-linux-x64*-installer.run ausgeführt
  • dann kam folgender Error: cannot execute binary file
was kann ich da machen?
Danke im Vorraus

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »hallowelt« (06.03.2014, 22:06)


2

02.03.2014, 16:33

ins Verzeichnis navigiert und chmod ausgeführt
"chmod" alleine bringt nichts außer seinem Verwendungshinweis.

./ xampp-linux-x64*-installer.run ausgeführt
Leerzeichen sind nicht nichts. Wenn es nicht so gemeint war, poste bitte komplette Ein-/Augaben in Code-Tags.

Ansonsten noch -> Linux Frequently Asked Questions, erste Frage.
mir is wurscht

  • »hallowelt« ist männlich
  • »hallowelt« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 02.03.2014

Derivat: Kein Ubuntu-Derivat

Architektur: 32-Bit PC

Andere Betriebssysteme: Puppy Linux

  • Nachricht senden

3

02.03.2014, 18:28

Ich hab das Leerzeichen ausversehen reingemacht. Und was sind Code-Tags (Sorry bin totaler Anfänger)
Ok hab den Link ausprobiert.
Es kommt leider immer noch die Fehlermeldung "cannot execute binary file"

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »hallowelt« (02.03.2014, 18:33)


fkf

Gesperrter Benutzer

  • »fkf« wurde gesperrt

Beiträge: 535

Registrierungsdatum: 15.10.2014

Derivat: unbekannt

Architektur: unbekannt

Desktop: unbekannt

Andere Betriebssysteme: Debian Jessie, Android-x86 Vbox

  • Nachricht senden

4

02.03.2014, 18:34

Und was sind Code-Tags


Damit sind Quellcodefenster gemeint, die der besseren Lesbarkeit dienen. Hier mal ein Quellcodefenster:

Quellcode

1
Hier steht Code drin. Also alle Terminalein- und ausgaben!


Du setzt Code-Tags mit dem #-Button im Postingeditor.

Nachtrag:

Zitat


poste bitte komplette Ein-/Augaben in Code-Tags.

  • »hallowelt« ist männlich
  • »hallowelt« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 02.03.2014

Derivat: Kein Ubuntu-Derivat

Architektur: 32-Bit PC

Andere Betriebssysteme: Puppy Linux

  • Nachricht senden

5

02.03.2014, 18:40

ok danke dann habe ich folgendes gemacht

Quellcode

1
chmod xampp-linux-x64*.installer.run

Quellcode

1
sudo ./xampp-linux-x64*.installer.run

Quellcode

1
bash: cannot execute binary file

fkf

Gesperrter Benutzer

  • »fkf« wurde gesperrt

Beiträge: 535

Registrierungsdatum: 15.10.2014

Derivat: unbekannt

Architektur: unbekannt

Desktop: unbekannt

Andere Betriebssysteme: Debian Jessie, Android-x86 Vbox

  • Nachricht senden

6

02.03.2014, 18:42

Zitat


chmod xampp-linux-x64*.installer.run


Hier bist Du nicht der Anleitung gefolgt. In der Anleitung steht:

Quellcode

1
chmod 755 xampp-linux-x64*.installer.run


Du musst bei chmod schon noch die Rechte angeben, die gesetzt werden sollen.

7

02.03.2014, 18:44

zu spät

hab meinen Text wieder gelöscht ;( ;)

  • »hallowelt« ist männlich
  • »hallowelt« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 02.03.2014

Derivat: Kein Ubuntu-Derivat

Architektur: 32-Bit PC

Andere Betriebssysteme: Puppy Linux

  • Nachricht senden

8

02.03.2014, 19:08

entschuldige: ich hab das schon so gemacht nur falsch angegeben :whistling: .
Es kommt weiterhin genannte Fehlermeldung.

fkf

Gesperrter Benutzer

  • »fkf« wurde gesperrt

Beiträge: 535

Registrierungsdatum: 15.10.2014

Derivat: unbekannt

Architektur: unbekannt

Desktop: unbekannt

Andere Betriebssysteme: Debian Jessie, Android-x86 Vbox

  • Nachricht senden

9

02.03.2014, 19:11

Poste mal die Ausgabe von:

Quellcode

1
ls -la xampp-linux-x64*.installer.run


und von:

Quellcode

1
cat /etc/fstab


und von:

Quellcode

1
getconf LONG_BIT

  • »hallowelt« ist männlich
  • »hallowelt« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 02.03.2014

Derivat: Kein Ubuntu-Derivat

Architektur: 32-Bit PC

Andere Betriebssysteme: Puppy Linux

  • Nachricht senden

10

03.03.2014, 21:34

Quellcode

1
2
3
4
5
6
7
8
-rwxr-xr-x 1 root root 130848622 Mär  2 14:28 xampp-linux-x64-1.8.3-3-installer.run
[und von dem 2.:]
none                	/proc           	proc              	defaults   	                    0 0
none                	/sys             	sysfs             	defaults                       	0 0
none                	/dev/pts       	devpts          	gid=2,mode=620       	0 0
/dev/fd0           	/mnt/floppy  	auto             	noauto, rw                   	0  0
[und vom 3.:]
32

11

03.03.2014, 22:20

Du hast ein 32Bit-System laufen. Die .run-Datei ist aber für 64Bit-Systeme.
mir is wurscht

fkf

Gesperrter Benutzer

  • »fkf« wurde gesperrt

Beiträge: 535

Registrierungsdatum: 15.10.2014

Derivat: unbekannt

Architektur: unbekannt

Desktop: unbekannt

Andere Betriebssysteme: Debian Jessie, Android-x86 Vbox

  • Nachricht senden

12

03.03.2014, 22:26

[und vom 3.:] 32


So siehts aus. Es ist ein 32 Bit System installiert. ;)

Korrigiere dies bezüglich auch noch dein Profil!

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »fkf« (03.03.2014, 22:47)


  • »hallowelt« ist männlich
  • »hallowelt« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 02.03.2014

Derivat: Kein Ubuntu-Derivat

Architektur: 32-Bit PC

Andere Betriebssysteme: Puppy Linux

  • Nachricht senden

13

04.03.2014, 16:48

ok mach ich danke!
Ich hab nur gedacht das ich ein 64-bit system hab, weil das bei Windows auch so ist.

  • »hallowelt« ist männlich
  • »hallowelt« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 02.03.2014

Derivat: Kein Ubuntu-Derivat

Architektur: 32-Bit PC

Andere Betriebssysteme: Puppy Linux

  • Nachricht senden

14

04.03.2014, 17:10

gut klappt jetzt mit der 32-bit installation. Wie kann ich das Thema schließen?

fkf

Gesperrter Benutzer

  • »fkf« wurde gesperrt

Beiträge: 535

Registrierungsdatum: 15.10.2014

Derivat: unbekannt

Architektur: unbekannt

Desktop: unbekannt

Andere Betriebssysteme: Debian Jessie, Android-x86 Vbox

  • Nachricht senden

15

04.03.2014, 18:00

Wie kann ich das Thema schließen?


Dein Startposting bearbeiten und am Titel das Präfix [gelöst] setzen und abspeichern.

  • »hallowelt« ist männlich
  • »hallowelt« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 02.03.2014

Derivat: Kein Ubuntu-Derivat

Architektur: 32-Bit PC

Andere Betriebssysteme: Puppy Linux

  • Nachricht senden

16

04.03.2014, 21:01

installation geglückt-nur leider funktioniert es immer noch nicht

Die Installation hat soweit geklappt. Danke nochmal für die gute Hilfe. Nur leider werden bei der Installation nun error-Meldungen vom installer angezeigt und wenn ich die testdatei 'index.php' öffnen will kommt die Meldung: something went wrong with xampp installation :-(. Kennt da jemand ein gutes Forum oder ne Lösung?

fkf

Gesperrter Benutzer

  • »fkf« wurde gesperrt

Beiträge: 535

Registrierungsdatum: 15.10.2014

Derivat: unbekannt

Architektur: unbekannt

Desktop: unbekannt

Andere Betriebssysteme: Debian Jessie, Android-x86 Vbox

  • Nachricht senden

17

04.03.2014, 21:18

Die Installation hat soweit geklappt. .... Nur leider werden bei der Installation nun error-Meldungen vom installer angezeigt


Sehr aufschlußreich! 8o

Hast Du Dir mal selber überlegt, wie man bei so ungenauen Infos gezielt helfen soll? So wird das aber nix. Fehlermeldungen gibt man immer genaustens an.

18

04.03.2014, 21:52

Wir haben im Forum gewisse Vorstellungen, wo welche Themen hingehören. Das Thema "Ausführen einer .run-Datei" ist ja gelöst, deshalb bitte kennzeichnen und beenden. Da es eigentlich um das Installieren ging und nur sekundär mit dem Terminal zu tun hatte, habe ich es verschoben.
Probleme mit diesem Programm behandle bitte im passenden Unterforum.
--
Verschoben aus "Software » Terminal". Bitte die Forenbeschreibungen beachten, danke!

Kennt da jemand ein gutes Forum
Nein. :)
Vielleicht dieses, aber dahin wurde weiter oben schon verlinkt.
mir is wurscht