Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

  • »Rutherford« ist der Autor dieses Themas

Beiträge: 12

Registrierungsdatum: 01.02.2014

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

1

01.02.2014, 13:53

Scanner vom HP Photosmart 5525 wird nicht erkannt

Hallo
der Scanner vom HP Photosmart 5525 wird nicht erkannt.
Ich benutze Ubuntu 12.04 und bin noch völlig neu im Geschäft. Der Drucker wurde ohne Probleme erkannt. (als Photosmart 5520) Das Drucken funktioniert, aber nicht scannen.
Wenn ich im Terminal:

scanimage -L eingebe,
oder
sane-find-scanner

dann bekomme ich nur die Meldung, dass kein Scanner vorhanden ist.
Gibt es da eine Lösung die auch ein Neuling hinbekommt.
(Lustigerweise kann ich mir den Scann als e-Mail schicken lassen, das macht der Drucker. Schöner wäre es aber per USB)

vielen Dank schon mal

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Rutherford« (02.02.2014, 09:24)


fkf

Gesperrter Benutzer

  • »fkf« wurde gesperrt

Beiträge: 535

Registrierungsdatum: 15.10.2014

Derivat: unbekannt

Architektur: unbekannt

Desktop: unbekannt

Andere Betriebssysteme: Debian Jessie, Android-x86 Vbox

  • Nachricht senden

2

01.02.2014, 13:58

Ist dein User Mitglied der Gruppe "scanner"? Kannst Du im Terminal prüfen mit dem Kommando:

Quellcode

1
groups

  • »Rutherford« ist der Autor dieses Themas

Beiträge: 12

Registrierungsdatum: 01.02.2014

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

3

01.02.2014, 14:17

ich scheine nicht Mitglied zu sein, da steht:
mein Name adm cdrom sudo dip plugdev lpadmin sambashare

... hier sollte wohl auch scanner stehen, oder?

(der Befehl groups war mir neu, danke schon mal)

fkf

Gesperrter Benutzer

  • »fkf« wurde gesperrt

Beiträge: 535

Registrierungsdatum: 15.10.2014

Derivat: unbekannt

Architektur: unbekannt

Desktop: unbekannt

Andere Betriebssysteme: Debian Jessie, Android-x86 Vbox

  • Nachricht senden

4

01.02.2014, 14:22

Ja, da sollte auch scanner stehen, damit der User den auch nutzen darf!

Dann füge deinen User mal in die Gruppe "scanner" mit ein per:

Quellcode

1
sudo usermod -aG scanner dein_username


Danach meldest Du Dich ab und wieder an und der Scanner sollte nun genutzt werden dürfen.

Als Scannertool empfehle ich Dir xsane oder simple-scan. Kannst Du beides aus den Paketquellen nachinstallieren, wenn es nicht schon drauf ist.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »fkf« (01.02.2014, 14:27)


5

01.02.2014, 16:42

--
Verschoben aus "Hardware » Drucker". Bitte die Forenbeschreibungen beachten, danke!
me is all sausage
but don't call me Ferdl

  • »Rutherford« ist der Autor dieses Themas

Beiträge: 12

Registrierungsdatum: 01.02.2014

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

6

01.02.2014, 17:12

Hallo Fremdkörperfalle,
vielen Dank für die Antwort, es hat leider nicht funktioniert (zumindest weiß ich jetzt wieder mehr über das System)

sudo usermod -aG scanner meinName
habe ich getestet und Ubuntu hat auch brav nach meinem admin-Passwort gefragt.

wenn ich danach groups eingebe erscheint die Gruppe scanner leider nicht.

wenn ich
cat /etc/group
eingeben, dann erhalte ich unter anderem:
...
scanner:x:107:meinName
...
bin ich jetzt vielleicht doch in der Gruppe? Das Drucken ist nach wie vor kein Problem.

vielen Dank schon mal

fkf

Gesperrter Benutzer

  • »fkf« wurde gesperrt

Beiträge: 535

Registrierungsdatum: 15.10.2014

Derivat: unbekannt

Architektur: unbekannt

Desktop: unbekannt

Andere Betriebssysteme: Debian Jessie, Android-x86 Vbox

  • Nachricht senden

7

01.02.2014, 17:15

Du musst Dich nach dem Hinzufügen einmal ab- und wieder anmelden, damit es wirksam wird. Hast Du das gemacht?

Kannst auch rebooten, wenn Du magst.

  • »Rutherford« ist der Autor dieses Themas

Beiträge: 12

Registrierungsdatum: 01.02.2014

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

8

01.02.2014, 17:28

Hallo Fremdkörperfalle,
ja, jetzt bin ich in der Gruppe scanner, ist schon mal gut. Aber leider läuft das scannen immer noch nicht ...

bei
sane-find-scanner
erscheint
found USB scanner ... [Photosmart 5520 series]
# Your USB scanner was (probably) detected. It may or may not be supported by SANE. Try Scanimage -L ... usw
mit Scanimage -L finde ich nix:

No scanners were identified. ...

Ist es ein Problem, dass ich den Potosmart 5525 habe und Ubuntu den Photosmart 5520 erkennt? Ich glaube das sind die gleichen Treiber.

fkf

Gesperrter Benutzer

  • »fkf« wurde gesperrt

Beiträge: 535

Registrierungsdatum: 15.10.2014

Derivat: unbekannt

Architektur: unbekannt

Desktop: unbekannt

Andere Betriebssysteme: Debian Jessie, Android-x86 Vbox

  • Nachricht senden

9

01.02.2014, 17:34

Starte mal xsane aus dem Terminal und probiere es damit. Gefunden hat er ihn ja.

  • »Rutherford« ist der Autor dieses Themas

Beiträge: 12

Registrierungsdatum: 01.02.2014

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

10

01.02.2014, 17:39

xsane startet, ... sucht nach Geräten, ... und findet keine Geräte

rätselhaft,
zumindest weiß ich jetzt wie man Programme im Terminal öffnet. :)

fkf

Gesperrter Benutzer

  • »fkf« wurde gesperrt

Beiträge: 535

Registrierungsdatum: 15.10.2014

Derivat: unbekannt

Architektur: unbekannt

Desktop: unbekannt

Andere Betriebssysteme: Debian Jessie, Android-x86 Vbox

  • Nachricht senden

11

01.02.2014, 17:43

Starte xsane mal "ausnahmsweise" mit Root Rechten und schau, ob der Scan dann damit geht. Du startest es dann so:

Quellcode

1
sudo xsane

  • »Rutherford« ist der Autor dieses Themas

Beiträge: 12

Registrierungsdatum: 01.02.2014

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

12

01.02.2014, 17:51

"keine Geräte erreichbar"

Irgendwie mag der Scanner gar nicht, aber die Hinweise waren alle wertvoll, Danke!

fkf

Gesperrter Benutzer

  • »fkf« wurde gesperrt

Beiträge: 535

Registrierungsdatum: 15.10.2014

Derivat: unbekannt

Architektur: unbekannt

Desktop: unbekannt

Andere Betriebssysteme: Debian Jessie, Android-x86 Vbox

  • Nachricht senden

13

01.02.2014, 18:03

Versuch mal folgendes:

1) Datei erstellen und öffnen:

Quellcode

1
sudo gedit /etc/udev/rules.d/40-libsane.rules


2. Folgendes in die Datei einfügen:

Quellcode

1
SYSFS{idVendor}=="03f0", MODE="0666", GROUP="scanner", ENV{libsane_matched}="yes"


3. Abspeichern, rebooten und ausprobieren.

Wenn das nichts bringt kannst Du die erstellte Datei wieder löschen. Vielleicht ist dein Scanner noch zu neu für die alte libsane von Ubuntu 12.04. Was mich wundert, weil der Scanner ja im Terminal gefunden wurde.
Hatte noch nie deratige Probleme mit einem HP Gerät.

  • »Rutherford« ist der Autor dieses Themas

Beiträge: 12

Registrierungsdatum: 01.02.2014

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

14

01.02.2014, 18:13

... läuft einfach nicht.

... der Drucker ist neu, habe schon daran gedacht eher ein Auslaufmodell zu nehmen. Wäre vielleicht schlauer gewesen.

fkf

Gesperrter Benutzer

  • »fkf« wurde gesperrt

Beiträge: 535

Registrierungsdatum: 15.10.2014

Derivat: unbekannt

Architektur: unbekannt

Desktop: unbekannt

Andere Betriebssysteme: Debian Jessie, Android-x86 Vbox

  • Nachricht senden

15

01.02.2014, 18:16

Du kannst ja mal die Live-CD vom neusten Ubuntu (13.10) ausporobieren, nur um zu schauen, ob der Scanner damit läuft.

Ansonsten hab ich keine weitere Idee. Der Scanner scheint einfach zu neu zu sein, für das Ubuntu 12.04.

  • »Rutherford« ist der Autor dieses Themas

Beiträge: 12

Registrierungsdatum: 01.02.2014

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

16

01.02.2014, 18:18

Vielen Dank für die Mühen,
das mit der CD probiere ich noch aus. Sonst behelfe ich mich irgendwie anders.
noch einen schönen Abend

fkf

Gesperrter Benutzer

  • »fkf« wurde gesperrt

Beiträge: 535

Registrierungsdatum: 15.10.2014

Derivat: unbekannt

Architektur: unbekannt

Desktop: unbekannt

Andere Betriebssysteme: Debian Jessie, Android-x86 Vbox

  • Nachricht senden

17

01.02.2014, 18:20

Sollte der Scanner mit der neusten Ubuntu Version laufen, könnte man versuchen das sane backend selber zu kompilieren (mit der aktuellen Entwicklerversion).
Das wird dann aber auch alles etwas intensiver und anspruchsvoller.

18

01.02.2014, 18:45

hplip müsste sich eigentlich darum kümmern.
Vielleicht reicht es auch, eine der Configs um die USB-ID zu ergänzen. Was sagt denn

Quellcode

1
lsusb
me is all sausage
but don't call me Ferdl

fkf

Gesperrter Benutzer

  • »fkf« wurde gesperrt

Beiträge: 535

Registrierungsdatum: 15.10.2014

Derivat: unbekannt

Architektur: unbekannt

Desktop: unbekannt

Andere Betriebssysteme: Debian Jessie, Android-x86 Vbox

  • Nachricht senden

19

01.02.2014, 21:02

hplip müsste sich eigentlich darum kümmern.


Auch für den Scanner? Dann würde ich wohl die neuste hplip von der Projektseite installieren. Musste ich für meinen Drucker unter Debian auch und lief.

  • »Rutherford« ist der Autor dieses Themas

Beiträge: 12

Registrierungsdatum: 01.02.2014

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

20

01.02.2014, 21:20

OK, das habe ich jetzt herausgefunden:

ich brauche die Version hplip 3.12.6 und scheinbar habe ich die Version 3.12.2 ... das könnte es sein.

Dank eurer Hilfe bin ich jetzt schon weiter, die Installation mache ich dann morgen.

Zurzeit ist neben Ihnen 1 Benutzer in diesem Thema unterwegs:

1 Besucher