Sie sind nicht angemeldet.

  • »Gindler« ist männlich
  • »Gindler« ist der Autor dieses Themas

Beiträge: 18

Registrierungsdatum: 22.02.2011

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: GNOME 2.x

  • Nachricht senden

1

26.01.2014, 13:57

Erstellung eines Hotspots scheitert am DNSMASQ

Hi@all. Ich bin momentan am Step-by-Step umstieg von Windoof7 auf Kubuntu. Momentan hänge ich an einem Problem mit dnsmasq. Ich versuche eine UMTS Verbindung (ppp0) über meinen Wlan-Stick (wlan0) via Hotspot an andere Geräte wie z.B. mein Android-Handy weiterzuleiten.

Ich habe es mit dieser Variante versucht und habe eine SSID in die Luft bekommen bei der allerdings mein Handy keine IP-Adresse beziehen konnte.

Danach habe ich es hiermit versucht aber gleich gesehen das es hierbei um die Ad-Hoc Variante handelt mit der mein Handy garnichts anfangen kann.

Also habe ich weitergesucht und das probiert. Auch hier habe ich eine SSID bekommen aber keine IP Adresse.

Nach untersuchung mit dem Debug modus bekamm ich die Meldung:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
andreas@andreas-pc02:~$ sudo ./instant_AP-N.sh -start
[sudo] password for andreas: 
starte gewählte Konfiguration ...
starte alle Dienste, und Verbindungen ...

WLAN-Schnittstelle initialisieren ...

deaktiviere Stromsparmechanismen für wlan0 ...

Starte hostapd-Service ...

Configuration file: /etc/hostapd.conf
Could not open configuration file '/etc/hostapd.conf' for reading.
starte IP-Forward, Masquerading und NAT

net.ipv4.ip_forward = 1
starte dnsmasq-base

dnsmasq: Kein Prozess gefunden
DHCP-Range dnsmasq-base - Startadresse: 192.168.3.2 Endadresse: 192.168.3.11

dnsmasq: failed to create listening socket for 127.0.0.1: Die Adresse wird bereits verwendet
nameserver 10.64.64.64
DNS-Konfiguration

nameserver 10.64.64.64

Kernel-IP-Routentabelle
Ziel            Router          Genmask         Flags Metric Ref    Use Iface
0.0.0.0         10.64.64.64     0.0.0.0         UG    0      0        0 ppp0
10.64.64.64     0.0.0.0         255.255.255.255 UH    0      0        0 ppp0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 ppp0
192.168.3.0     0.0.0.0         255.255.255.0   U     0      0        0 wlan0

Konfiguration LAN:

ppp0      Link encap:Punkt-zu-Punkt-Verbindung  
          inet Adresse:77.24.25.88  P-z-P:10.64.64.64  Maske:255.255.255.255

Konfiguration WLAN:
wlan0     Link encap:Ethernet  Hardware Adresse 00:1b:11:bd:dc:e9  
          inet Adresse:192.168.3.1  Bcast:192.168.3.255  Maske:255.255.255.0

wlan0     IEEE 802.11bg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Power Management:off

mon.wlan0  No such device


Mit sudo netstat -anlp | grep -w LISTEN bekamm ich:

Quellcode

1
2
3
4
5
6
7
8
tcp        0      0 127.0.0.1:5939          0.0.0.0:*               LISTEN      2032/teamviewerd
tcp        0      0 77.24.25.88:53          0.0.0.0:*               LISTEN      1299/named      
tcp        0      0 127.0.0.1:53            0.0.0.0:*               LISTEN      1299/named      
tcp        0      0 127.0.0.1:631           0.0.0.0:*               LISTEN      1093/cupsd      
tcp        0      0 127.0.0.1:953           0.0.0.0:*               LISTEN      1299/named      
tcp6       0      0 :::53                   :::*                    LISTEN      1299/named      
tcp6       0      0 ::1:631                 :::*                    LISTEN      1093/cupsd      
tcp6       0      0 ::1:953                 :::*                    LISTEN      1299/named 


Was ich mir auch noch auffiel war das ich nebenher immer einen Internetradiostream offen hatte und nach den Starts dieser Programme dieser zwar problemlos weiterlief aber ich keine Internetseiten mehr öffnen konnte ?(
Also hatte ich zwar noch eine Internetverbindung, den der Stream lief ja weiter, aber irgendwie hatte ich doch kein Internet mehr um Seiten zu öffnen. ?( ?( ?(

Welche Kubuntu Version ich habe? Hmm, im Infozentrum steht Linux 3.2.0-52-generic und KDE 4.8.5. Aber welche Version das nun ist weiß ich nicht mehr, habe sie vor ca. 1 Monat erst geladen. Also denke ich >12

  • »flash63« ist männlich

Beiträge: 167

Registrierungsdatum: 05.07.2010

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: Unity

  • Nachricht senden

2

29.01.2014, 09:23

Hallo,
der Artikel mit dem Sript ist wegen dem Problem mit dnsmasq inzwischen aktualisiert.

Achte auf die Fehlermeldungen, Du hast da sicherlich die hostapd-Konfiguration nicht angelegt oder den Pfad zur Konfigurationsdatei im Skript nicht entsprechend angepasst.

Quellcode

1
Could not open configuration file '/etc/hostapd.conf' for reading.


Hast Du überhaupt geprüft, ob die WLAN-Hardware mit hostapd kompatibel ist?

Es wird (K)Ubuntu 12.04-1-LTS verwendet. Deine öffentlichen IP-Adressen der ppp0-Schnittstelle solltest Du übrigens besser unkenntlich machen.