Sie sind nicht angemeldet.

  • »ro0kie4« ist männlich
  • »ro0kie4« ist der Autor dieses Themas

Beiträge: 7

Registrierungsdatum: 27.10.2013

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: Unity

  • Nachricht senden

1

03.11.2013, 22:14

WLan Hotspot. Erstellt aber nicht auffindbar

Guten Abend zusammen,

hatte vor ein paar Tagen hier schon mal ein Problem mit meinem Graka Treiber geschildert und super schnell Hilfe bekommen, deswegen dachte ich, ich frage noch mal :)
Ich versuche verzweifelt einen WLAN Hotspot zuerstellen, da ich in meiner Studentenwohnung kein WLAN aufbauen kann. Hier wird ein VPN benutzt und ich habe keinen WLAN-Router, der VPN unterstützt. Also muss einer meine Laptops dran. Entweder Windows 8.1, wo ein Ad-Hoc Netz irgendwie nicht klappt oder halt mein Ubuntu 13.10 Laptop. Ich habe einen Lenovo g500s doch wenn ich ein Hotspot einschalte kann ich ihn auf keinem Gerät finden. Kann mir jemand sagen woran das liegt, oder ob es andere bessere Methoden gibt?

Danke schon mal :)

2

04.11.2013, 00:22

Ich glaube das wirst du genauer erläutern müssen.
Wofür wird das VPN benutzt und wozu brauchst du den eigenen Hotspot? Und was für eine Rolle spielt AdHoc dabei?
mir is wurscht

  • »ro0kie4« ist männlich
  • »ro0kie4« ist der Autor dieses Themas

Beiträge: 7

Registrierungsdatum: 27.10.2013

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: Unity

  • Nachricht senden

3

04.11.2013, 00:36

also ich möchte zum beispiel nicht in meinem zimmer überall lan kabel rum liegen haben, nur um 2-3 laptops/pcs am netz zuhaben. also möchte ich eine art wlan einrichten. Und dann bräuchte ich auch nicht immer den Traffic von meinem Smartphone zu verbrauchen.
Das VPN wird zum einloggen in das Wohnheimsnetz genutzt, da der Traffic auf 500GB im Monat begrentzt ist.

4

04.11.2013, 00:46

Ok, also der Laptop soll übers LAN-Kabel die VPN-Verbindung zum wohnheim-Netz machen und mit seinem WLAN als Access-Point arbeiten.
1. Frage: klappt das mit dem VPN?
2. Frage: Was für eine WLAN-Karte hat er drin?

Quellcode

1
lspci -knn
mir is wurscht

  • »ro0kie4« ist männlich
  • »ro0kie4« ist der Autor dieses Themas

Beiträge: 7

Registrierungsdatum: 27.10.2013

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: Unity

  • Nachricht senden

5

04.11.2013, 00:48

1. also es soll mit einem Router funktionieren, deswegen gehe ich mal davon aus, dass wen man einen Laptop als Router nimmt geht es auch.
2.

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
00:00.0 Host bridge [0600]: Intel Corporation 3rd Gen Core processor DRAM Controller [8086:0154] (rev 09)
	Subsystem: Lenovo Device [17aa:3977]
00:01.0 PCI bridge [0604]: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port [8086:0151] (rev 09)
	Kernel driver in use: pcieport
00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)
	Subsystem: Lenovo Device [17aa:3912]
	Kernel driver in use: i915
00:14.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller [8086:1e31] (rev 04)
	Subsystem: Lenovo Device [17aa:3977]
	Kernel driver in use: xhci_hcd
00:16.0 Communication controller [0780]: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 [8086:1e3a] (rev 04)
	Subsystem: Lenovo Device [17aa:3977]
	Kernel driver in use: mei_me
00:1a.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 [8086:1e2d] (rev 04)
	Subsystem: Lenovo Device [17aa:3977]
	Kernel driver in use: ehci-pci
00:1b.0 Audio device [0403]: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller [8086:1e20] (rev 04)
	Subsystem: Lenovo Device [17aa:3977]
	Kernel driver in use: snd_hda_intel
00:1c.0 PCI bridge [0604]: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 [8086:1e10] (rev c4)
	Kernel driver in use: pcieport
00:1c.1 PCI bridge [0604]: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 [8086:1e12] (rev c4)
	Kernel driver in use: pcieport
00:1d.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 [8086:1e26] (rev 04)
	Subsystem: Lenovo Device [17aa:3977]
	Kernel driver in use: ehci-pci
00:1f.0 ISA bridge [0601]: Intel Corporation HM76 Express Chipset LPC Controller [8086:1e59] (rev 04)
	Subsystem: Lenovo Device [17aa:3977]
	Kernel driver in use: lpc_ich
00:1f.2 SATA controller [0106]: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] [8086:1e03] (rev 04)
	Subsystem: Lenovo Device [17aa:3977]
	Kernel driver in use: ahci
00:1f.3 SMBus [0c05]: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller [8086:1e22] (rev 04)
	Subsystem: Lenovo Device [17aa:3977]
01:00.0 3D controller [0302]: NVIDIA Corporation GF117M [GeForce 610M/710M / GT 620M/625M/630M/720M] [10de:1140] (rev ff)
02:00.0 Ethernet controller [0200]: Qualcomm Atheros QCA8172 Fast Ethernet [1969:10a0] (rev 10)
	Subsystem: Lenovo Device [17aa:3804]
	Kernel driver in use: alx
03:00.0 Network controller [0280]: Qualcomm Atheros AR9485 Wireless Network Adapter [168c:0032] (rev 01)
	Subsystem: Lenovo Device [17aa:3218]
	Kernel driver in use: ath9k

DocHifi

unregistriert

6

04.11.2013, 10:30

Ein VPN, wird auf dem Computer im Netzwerk-Manager eingerichtet, nicht im Router.

  • »ro0kie4« ist männlich
  • »ro0kie4« ist der Autor dieses Themas

Beiträge: 7

Registrierungsdatum: 27.10.2013

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: Unity

  • Nachricht senden

7

04.11.2013, 10:36

Ich meine, dass ich einen VPN Zugang brauche um die Netzwerk dose in meinem Zimmer nutzen zu können. Aber es geht auch nicht um den router , sondern darum wie ich am laptop einen Hotspot einrichte, sodass ich ins Netz komme.

8

04.11.2013, 13:36

deswegen gehe ich mal davon aus, dass wen man einen Laptop als Router nimmt geht es auch.
Klar, wenn man den VPN-Zugang hat und eine WLAN-Karte die Master-mode beherrscht. (Meine Vermutung: ja)

Ich meine, dass ich einen VPN Zugang brauche um die Netzwerk dose in meinem Zimmer nutzen zu können.
Darum war die Frage auch so gemeint, ob du den VPN-Zugang mit dem Laptop bereits erfolgreich eingerichtet hast. Vorher hat es gar keinen Sinn, sich mit der Hotspot-Frage zu beschäftigen.

Ganz trivial ist übrigens beides nicht. Wenn es auch Windows sein darf (mit all seinen Schwächen), kommst du wahrscheinlich mit der Option "diese Verbindung teilen" in dessen Adapter-Einstellungen schneller zum Ziel. Schlimmstenfalls musst du einen Treiber installieren, der den "Master-mode" erlaubt.
mir is wurscht

Beiträge: 2

Registrierungsdatum: 14.01.2014

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: Unity

  • Nachricht senden

9

15.01.2014, 18:29

Ich hatte ähnliche Probleme in meinem Studentenwohnheim.
Einen Router anschließen durfte ich nicht und so hab ich meinen Laptop erst unter Windows und später unter Ubuntu als Hotspot verwendet.

Da ich damals nur auf eine englische Anleitung gestoßen bin hab ich die hier mal auf deutsch niedergeschrieben:
http://www.captain-malu.com/anleitungen/…spot-verwenden/


Die integrierte Hotspotfunktion konnte ich nicht nutzen, da meine Androiden mit Ad hoc Netzwerken nichts anfangen konnten. Sie haben sie also nicht gefunden.

10

15.01.2014, 23:40

Da ich damals nur auf eine englische Anleitung gestoßen bin hab ich die hier mal auf deutsch niedergeschrieben

Gute Anleitung. :thumbup:
Habe sie zwar nicht getestet, aber sie sieht zumindest einfach und effektiv aus.

Nur drei kleine Anmerkungen:
a) Es fehlt ein Hinweis, daß die Treiber ath5k/ath9k nur für Atheros-Karten zuständig sind. Wer einen anderen Chipsatz hat, sollte an diesem Punkt nicht gleich zum Aufgeben verleitet werden.
b) Es ist nicht beschrieben, wie die Karte in den adhoc- oder ap- Modus gebracht wird. Auch in dem einen Screeshot ist sie im sta-Modus.
c) In dem Script fehlen mir Parameterabfragen und entsprechende Sprungziele. Momentan (und so wie der Aufruf beschrieben ist), läuft es einfach durch. Das heißt es aktiviert erst alles und dann dreht es wieder alles ab. Würde es einen Parameter "start" bzw. "stop" einlesen und entsprechend reagieren, hätte es sicher einen Mehrwert ;) und wäre schon ein annähernd vollständiges init-Script.
x) Ich würde besonders darauf hinweisen, daß die /etc/hostapd/hostapd.conf nur für root lesbar sein soll, zumal darin Passwörter untergebracht sind. (Die könnte man übrigens auch auslagern.)
mir is wurscht