Sie sind nicht angemeldet.

  • »Ülstianer« ist der Autor dieses Themas

Beiträge: 9

Registrierungsdatum: 08.10.2013

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

1

08.10.2013, 16:41

Schreibender Zugriff auf Windows-Partition aus Ubuntu 12

Mein Rechner hat 2 physische Festplatten. Auf der einen ist nach wie vor Windows Vista, auf der anderen sind wie gehabt die Daten sowie auf einer separaten Partition seit kurzem Ubuntu 12.

Die Daten-Partition soll von beiden Systemen aus auch beschrieben werden können und ist wie folgt in fstab eingehängt:

Quellcode

1
/dev/sdb1	/media/Datapart\040D	ntfs	defaults,uid=1000,gid=1000	0	0


Aus Ubuntu heraus kann ich auf die Partition zugreifen und auch Dateien speichern. Sobald ich mich jedoch in Vista anmelde, sind die neuen Dateien verschwunden und bleiben es anschließend auch beim erneuten Start von Ubuntu.

Ich habe mich bereits durch das wiki (http://wiki.ubuntuusers.de/fstab ,[url]http://wiki.ubuntuusers.de/mount#Optionen[/url] )
und das Forum gearbeitet, ohne allerdings eine Lösung zu finden.

Vielen Dank vorab!

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Ülstianer« (15.10.2013, 22:44)


  • »maettu« ist männlich

Beiträge: 3 299

Registrierungsdatum: 14.09.2005

Derivat: Xubuntu

Architektur: 64-Bit PC

Desktop: XFCE

  • Nachricht senden

2

08.10.2013, 17:36

Wieso hast du ein "\040D" im Ordnername? Hat das irgend ein Zweck? Ist das ein Sonderzeichen? Ich würde solche Bezeichnungen vermeiden! Den Ordnernamen wählst ja schliesslich du selbst...

Du willst sagen unter Vista gibts die Partition nicht mehr? Oder wie meinst du die "neuen Daten"? Heisst das du speicherst unter Ubuntu was und es landet nicht auf der richtigen Festplatte?

Sonst gilt bei Festplatten immer der Befehl:

Quellcode

1
sudo fdisk -l

dadurch kann man sehen wie es aussieht...

  • »Ülstianer« ist der Autor dieses Themas

Beiträge: 9

Registrierungsdatum: 08.10.2013

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

3

09.10.2013, 12:42

Das Sonderzeichen "Leerzeichen" habe ich bewusst gewählt.

Es ist mit der Partition "D" so, dass ich unter Vista noch alles machen kann, was ich will: Lesen, schreiben, ...
Unter Ubuntu kann ich ebenfalls lesen und schreiben.

Aber:
-Dateien, die ich unter Vista neu auf "D" speicher, kann ich anschließend unter Ubuntu lesen, bearbeiten, ...
-Dateien, die ich unter Ubuntu neu auf "D" speicher, kann ich anschließen unter Vista gar nicht erst sehen. Schlimmer noch: Speicher ich eine neue Datei unter Ubuntu auf "D", greife anschließend aus Vista auf "D" zu und dann erneut aus Ubuntu, dann ich die neue Datei auch in Ubuntu verschwunden.

Sieht fast aus, als würde etwas mit den Rechten nicht stimmen, ich weiß aber leider keine Abhilfe!

  • »maettu« ist männlich

Beiträge: 3 299

Registrierungsdatum: 14.09.2005

Derivat: Xubuntu

Architektur: 64-Bit PC

Desktop: XFCE

  • Nachricht senden

4

09.10.2013, 13:23

Das Sonderzeichen "Leerzeichen" habe ich bewusst gewählt.
Du hast also bewusst entschieden alles schwieriger zu machen ;) Ersetz doch mal das Leerzeichen mit einem "_" Underliner oder schreib doch nur Datapartion. Einfach mal zum Testen! (klar du musst dann diesen Mount-Point-Ordner zuerst noch erstellen)
Im Normalfall braucht man keine Sonderzeichen in Dateinamen, also ausser man ist scharf sich mit allfälligen Problemen zu beschäftigen.

  • »Ülstianer« ist der Autor dieses Themas

Beiträge: 9

Registrierungsdatum: 08.10.2013

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

5

09.10.2013, 23:57

Ok, ich war bereits auf dem Weg, das mit dem Sonderzeichen mal zu probieren. Auf dem Weg deshalb, weil ich erst noch herausfinden musste, wie das erstellen des Einhängepunkts noch gleich funktioniert... dabei stieß ich zufällig auf die Ursache des Problems:

Für "D" waren die Zugriffsrechte so definiert, dass ich mit Ordnern machen kann, was ich will, für Dateien war jedoch gar nichts angegeben. Das habe ich in den Eigenschaften (nach Rechtsklick auf die Partition) geändert und konnte plötzlich Dateien auf "D" speichern, die auch den Systemwechsel überdauert haben.

Letzter Haken: Wie ich eben sah, waren die manuell korrigierten Zugriffsrechte für Dateien leider nur temporär. Ich schätze, dann ist der Eintrag in der fstab fehlerhaft. Jetzt muss ich nur noch herausfinden (oder mir jemand sagen), was bei

Quellcode

1
defaults,uid=1000,gid=1000

geändert oder ergänzt werden muss!

PS: Auf die Idee mit dem Leerzeichen bin ich überhaupt erst gekommen, weil genau das als Beispiel im Wiki angegeben war. http://wiki.ubuntuusers.de/fstab angegeben war.

Beiträge: 6 679

Registrierungsdatum: 04.06.2005

Derivat: Kein Ubuntu-Derivat

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: Arch Linux

  • Nachricht senden

6

11.10.2013, 18:17

Hallo,

Zitat

media/Datapart\040D


müsste der slahs nicht anders rum sein?

Zitat

media/Datapart/040D


m.f.g.
Carl-Heinz
###--- Gott sei Dank, ich bin weg vom Fenster ---###


Hilfen:
- Mir eine Nachricht senden - - Meine Homepage - - Linux-Beginnerforum -

  • »Ülstianer« ist der Autor dieses Themas

Beiträge: 9

Registrierungsdatum: 08.10.2013

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

7

11.10.2013, 19:02

Nein, es soll kein Unterverzeichnis angesteuert werden, sondern lediglich das Sonderzeichen "Leerzeichen" im Namen der Partition enthalten sein.

  • »maettu« ist männlich

Beiträge: 3 299

Registrierungsdatum: 14.09.2005

Derivat: Xubuntu

Architektur: 64-Bit PC

Desktop: XFCE

  • Nachricht senden

8

11.10.2013, 19:29

Ich glaube du hast mich nicht verstanden! Probier mal als Ordnername/Mountpoint: "Datapart_D", damit hast du allfällige negativ Effekte wegen Schriftcodierungen (das ist nämlich ein Grund für Probleme mit Sonderzeichen! Wie Leerzeichen in Dateinamen)

  • »Ülstianer« ist der Autor dieses Themas

Beiträge: 9

Registrierungsdatum: 08.10.2013

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

9

12.10.2013, 00:13

Vielleicht ist das die Naivität eines Linux-Neulings, aber wenn die Partition bei jedem Systemstart erfolgreich gemounted wird, dann kann es doch eigentlich keine Probleme mit dem Leerzeichen geben, oder!?

Ich habe mal einen Screenshot angehängt, der die für die Partition vergebenen Rechte zeigt. Ich müsste jetzt nur noch wissen, wie ich die fehlenden Rechte für Dateien ergänzen kann. Soweit ich las, wird bei ntfs standardmäßig umask=0000 (kein Rechteentzug) gesetzt. Leider ist selbst beim manuellen Ergänzen von umask=0000 das Problem unverändert vorhanden.
»Ülstianer« hat folgendes Bild angehängt:
  • Eigenschaften D.jpg

Beiträge: 6 679

Registrierungsdatum: 04.06.2005

Derivat: Kein Ubuntu-Derivat

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: Arch Linux

  • Nachricht senden

10

12.10.2013, 15:59

Hallo,

Zitat

dann kann es doch eigentlich keine Probleme mit dem Leerzeichen geben, oder!?


na dann lese dich mal in die shell ein wie da ein Leerzeichen interpretiert wird und wie die shell ein Leerzeichen in einer Befehlszeile oder in einem Verzeichnisnamen verarbeitet.

Warum schlägt man sich mit Dingen rum, die erst mal nur Probleme bereiten könnten, wenn es mal geht dann kann man ja immer noch rumexperimentieren.

Ich persönlich würde dies allerdings nicht tun.

Links zum Thema:
http://bingin.de/~bschiffner/bash2/content.html
http://www.fhvr-aiv.de/fileadmin/user_up…INUX_Shells.pdf

m.f.g.
Carl-Heinz
###--- Gott sei Dank, ich bin weg vom Fenster ---###


Hilfen:
- Mir eine Nachricht senden - - Meine Homepage - - Linux-Beginnerforum -

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Linuxtal« (12.10.2013, 16:05)


  • »Ülstianer« ist der Autor dieses Themas

Beiträge: 9

Registrierungsdatum: 08.10.2013

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

11

13.10.2013, 00:29

Ich werfe mein Haupt virtuell in Asche: Es scheint nun zu funktionieren - mit einem Unterstrich statt mit dem Leerzeichen. Wobei die Zugriffsrechte auch nicht anders angezeigt werden als zuvor.

Vielen Dank!!!
»Ülstianer« hat folgendes Bild angehängt:
  • Eigenschaften_D.jpg

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Ülstianer« (13.10.2013, 01:31)