Sie sind nicht angemeldet.

  • »RubertIV« ist männlich
  • »RubertIV« ist der Autor dieses Themas

Beiträge: 7

Registrierungsdatum: 24.08.2013

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

1

24.08.2013, 17:23

Open XChange installation

Hallo,

ich versuche gerade Open XChange auf meinem Server zu installieren. Jedoch bekomme ich schon bei den ersten paar Befehlen ein paar Probleme.
Hier das Tutorial welches ich nutze:

http://oxpedia.org/wiki/index.php?title=…or_Ubuntu_12.04

zu Beginn sollte ich diese beiden Zeilen in die Source List eintragen:

deb http://download.opensuse.org/repositorie…/xUbuntu_12.04/ / dieser Link scheint nicht mehr funktionsfähig zu sein, gibt es dafür irgendwo einen neuen?
deb http://download.opensuse.org/repositorie…/xUbuntu_12.04/ /

wenn ich dann mit

sudo apt-get update

die Source List aktualisieren möchte erhalte ich folgenden Fehler:

W: GPG-Fehler: http://download.opensuse.org Release: Die folgenden Signaturen konnten nicht überprüft werden, weil ihr öffentlicher Schlüssel nicht verfügbar ist: NO_PUBKEY 0EB11CDE44F9512B
root:~# sudo vim /etc/apt/sources.list

Könntet Ihr mir helfen?
Wurden möglicherweise die Downloadlinks geändert?

fkf

Gesperrter Benutzer

  • »fkf« wurde gesperrt

Beiträge: 535

Registrierungsdatum: 15.10.2014

Derivat: unbekannt

Architektur: unbekannt

Desktop: unbekannt

Andere Betriebssysteme: Debian Jessie, Android-x86 Vbox

  • Nachricht senden

2

25.08.2013, 16:31

dieser Link scheint nicht mehr funktionsfähig zu sein, gibt es dafür irgendwo einen neuen?



Für das backend gibt es auf dem Server kein Verzeichnis namens xUbuntu_12.04, sondern nur ein xUbuntu_10.04. Kannst Du auch selber im Browser nachschauen, wenn Du Dich mal durch das benutzte Repo klickst:

http://download.opensuse.org/repositorie…x6.22:/backend/

Ob es klappt wenn Du in der sources.list das Verzeichnis von 10.04 angibst, kann ich Dir nicht sagen, aber ich glaube nicht, weil es scheint leer zu sein. Sprich, da kann man keine Pakete beziehen.
Im Verzeichnis frontend scheint alles da zu sein für xUbuntu_12.04.

Und den GPG Fehler bekommst Du, weil der öffentliche Schlüssel für das benutzte Repo nicht hinzugefügt wurde. Wie das geht, findest Du im Forum häufig beschrieben.
Der Schlüssel ist zwar nicht zwingend erforderlich, sollte aber hinzugefügt werden, um die Software auf die Signatur hin zu überprüfen.


Nachtrag:

Nimm deine beiden Einträge mal aus der sources.list raus und setze diesen ein:

Quellcode

1
deb http://download.opensuse.org/repositories/server:/OX:/ox6/xUbuntu_12.04/ /


Danach die Paketlisten neu einlesen und die Installation versuchen. Den Schlüssel für das Repo müsstest Du aber auch hier einpflegen.

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »fkf« (25.08.2013, 16:54)


  • »RubertIV« ist männlich
  • »RubertIV« ist der Autor dieses Themas

Beiträge: 7

Registrierungsdatum: 24.08.2013

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

3

26.08.2013, 13:22

wiel geil

nice

hat funktioniert mit dem Link

vielen Dank

  • »supergudrun« ist männlich

Beiträge: 20

Registrierungsdatum: 31.10.2011

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

  • Nachricht senden

4

17.09.2013, 11:07

Hallo RubertIV

Hast du es aufgegeben oder hinbekommen? Auf meinem Ubuntu 12.04 Server läuft open-xchange. Als Quellen für die Installation habe ich folgende verwendet:

HTML

1
http://software.open-xchange.com/products/appsuite/7.2.2/backend/DebianSqueeze/

HTML

1
http://software.open-xchange.com/products/appsuite/7.2.2/appsuiteui/DebianSqueeze/


Eine aktuelle Anleitung findest du hier:

HTML

1
http://oxpedia.org/wiki/index.php?title=AppSuite:Open-Xchange_Installation_Guide_for_Debian_6.0


Das Ganze ist zwar auf Debian Squeeze ausgelegt, läßt sich nach meiner Erfahrung (schon über mehrere OX Generationen inkl. Updates etc.) 1:1 auf Ubuntu 12.04 übertragen.

Bei Fragen helfe ich gerne weiter.

VG
Supergudrun
Viele Grüße
Supergudrun

  • »RubertIV« ist männlich
  • »RubertIV« ist der Autor dieses Themas

Beiträge: 7

Registrierungsdatum: 24.08.2013

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

5

19.09.2013, 11:17

ich probiere es mal aus

  • »RubertIV« ist männlich
  • »RubertIV« ist der Autor dieses Themas

Beiträge: 7

Registrierungsdatum: 24.08.2013

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

6

23.09.2013, 14:54

ich kann den server nicht registrieren:

wenn ich diese Zeile einegebe:
$ /opt/open-xchange/sbin/registerserver -n oxserver -A oxadminmaster -P admin_master_password

bekomme ich folgende Fehlermeldung:

server could not be registered:
Server response:
com.openexchange.admin.rmi.exceptions.PoolException: DBP-0001 Categories=SERVICE_DOWN Message='Cannot get connection to nfig DB.' exceptionID=-544626183-3
at com.openexchange.admin.storage.mysqlStorage.OXToolMySQLStorage.existsServerName(OXToolMySQLStorage.java:2088)
at com.openexchange.admin.storage.mysqlStorage.OXToolMySQLStorage.existsServerName(OXToolMySQLStorage.java:2112)
at com.openexchange.admin.rmi.impl.OXUtil.registerServer(OXUtil.java:409)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:616)
at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:322)
at sun.rmi.transport.Transport$1.run(Transport.java:177)
at java.security.AccessController.doPrivileged(Native Method)
at sun.rmi.transport.Transport.serviceCall(Transport.java:173)
at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:553)
at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run0(TCPTransport.java:808)
at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:667)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:679)
at sun.rmi.transport.StreamRemoteCall.exceptionReceivedFromServer(StreamRemoteCall.java:273)
at sun.rmi.transport.StreamRemoteCall.executeCall(StreamRemoteCall.java:251)
at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:160)
at java.rmi.server.RemoteObjectInvocationHandler.invokeRemoteMethod(RemoteObjectInvocationHandler.java:194)
at java.rmi.server.RemoteObjectInvocationHandler.invoke(RemoteObjectInvocationHandler.java:148)
at sun.proxy.$Proxy0.registerServer(Unknown Source)
at com.openexchange.admin.console.util.server.RegisterServer.<init>(RegisterServer.java:83)
at com.openexchange.admin.console.util.server.RegisterServer.main(RegisterServer.java:91)

Ich habe den Fehler mal mit Google gesucht und dort stand das es wohl an der MySQL-Datenbank liegt.

wenn ich mir die datei configdb.properties angucke, wie es auf der Seite als Lösung steht:
http://oxpedia.org/index.php?title=Check…database_access

ist dort nur zusätzlich ein Prt eingetragen:
readUrl=jdbc:mysql://localhost:3306/configdb

daran liegt es aber nicht

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »RubertIV« (23.09.2013, 15:01)


  • »supergudrun« ist männlich

Beiträge: 20

Registrierungsdatum: 31.10.2011

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

  • Nachricht senden

7

24.09.2013, 08:43

wenn du nach der Anleitung in OXPedia vorgegangen bist hast du sicherlich die Schritte 'initconfigdb' und 'oxinstaller' zuvor durchgeführt. Sind die ohne Fehlermeldung durchgelaufen?

Anschließend muss der Service 'open-xchange' gestartet werden. Achtung: Das dauert recht lange, also bitte min. 1 Minute Wartezeit einlegen, bevor man mit 'registerserver' weitermacht.

Wenn du das alles gemacht hast und der Fehler trotzdem kommt, habe ich im Moment auch keine Idee. Hast du dich schon mal an das OX Forum gewendet? Da wird einem ebenfalls gut und schnell geholfen.
Viele Grüße
Supergudrun

  • »RubertIV« ist männlich
  • »RubertIV« ist der Autor dieses Themas

Beiträge: 7

Registrierungsdatum: 24.08.2013

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

8

24.09.2013, 11:31

woher wusstest du das?

bei diesem Befehl:
/opt/open-xchange/sbin/initconfigdb --configdb-pass=db_password -a

musste ich vorübergehend das mysql-passwort rausnehmen und zwar damit:
mysqladmin -u root -p password "WUNSCHPASSWORT"

und dann konnte ich das initconfigdb passwort eingeben

  • »RubertIV« ist männlich
  • »RubertIV« ist der Autor dieses Themas

Beiträge: 7

Registrierungsdatum: 24.08.2013

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

9

24.09.2013, 12:01

an der Stelle wo ich die Benutzer einrichte sollte ich, wenn ich in meinem Webbrowser die IP von meinem Server eingebe, einen Login-Screen bekommen. Der ist jedoch nicht da, weißt du woran das liegen könnte?

Mit freundlichen Grüßen aus der Windmühlenstadt Woldegk
RubertIV

  • »supergudrun« ist männlich

Beiträge: 20

Registrierungsdatum: 31.10.2011

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

  • Nachricht senden

10

24.09.2013, 12:44

Hab ich dich richtig verstanden, die Befehle "serverregister", "registerfilestore" und "registerdatabase", sowie "createcontext" und "createuser" sind nun durchgelaufen?

Wenn das Frontend nicht erscheint, kann das entweder daran liegen, dass es nicht komplett installiert ist oder Apache nicht korrekt konfiguriert ist.

Für das Appsuite-Frontend müssen folgende Pakete installiert sein:

open-xchange-appsuite
open-xchange-appsuite-manifest
open-xchange-appsuite-l10n-de-de
open-xchange-appsuite-help-de-de

Hinsichtlich der Apache-Einrichtung solltest du dir nochmal das HowTo anschauen ...
Viele Grüße
Supergudrun

  • »RubertIV« ist männlich
  • »RubertIV« ist der Autor dieses Themas

Beiträge: 7

Registrierungsdatum: 24.08.2013

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

11

24.09.2013, 15:36

so ein walfischdreck.

ich sollte die Datei:
$ vim /etc/apache2/conf.d/proxy_http.conf
bearbeiten.

Dabei habe ich versehentlich das Kommentarzeichen # nicht mit rüberkopiert, woraufhin der der Apache einen Fehler bekam. hehe

  • »joerghildering« ist männlich

Beiträge: 13

Registrierungsdatum: 10.03.2014

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

12

11.03.2014, 11:46

http://oxpedia.org/wiki/index.php?title=AppSuite:Open-Xchange_Installation_Guide_for_Debian_6.0

Hallo RubertIV

Hast du es aufgegeben oder hinbekommen? Auf meinem Ubuntu 12.04 Server läuft open-xchange. Als Quellen für die Installation habe ich folgende verwendet:

HTML

1
http://software.open-xchange.com/products/appsuite/7.2.2/backend/DebianSqueeze/

HTML

1
http://software.open-xchange.com/products/appsuite/7.2.2/appsuiteui/DebianSqueeze/


Eine aktuelle Anleitung findest du hier:

HTML

1
http://oxpedia.org/wiki/index.php?title=AppSuite:Open-Xchange_Installation_Guide_for_Debian_6.0


Das Ganze ist zwar auf Debian Squeeze ausgelegt, läßt sich nach meiner Erfahrung (schon über mehrere OX Generationen inkl. Updates etc.) 1:1 auf Ubuntu 12.04 übertragen.

Bei Fragen helfe ich gerne weiter.

VG
Supergudrun

Hallo,

ich habe OX wie unter http://oxpedia.org/wiki/index.php?title=…_for_Debian_6.0 erfolgreich unter Ubuntu 12.04 installieren können.
Der Server läuft als virtueller Server mit Plesk bei Hosteurope.
Meine Frage:
Wie mache ich nach der Installation weiter? Wie komme ich auf den Login? Kann die Loginseite irgendwie nicht aufrufen.

Gruß,

Jörg

Broco

User

  • »Broco« ist männlich

Beiträge: 266

Registrierungsdatum: 05.12.2008

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: GNOME 3.0

Andere Betriebssysteme: Debian Wheezy, Knoppix, Fedora

  • Nachricht senden

13

12.03.2014, 10:21

Naja, eigentlich schreibt OX standardmäßig die entsprechenden Einträge in die Apache-Konfiguration rein.
Schau doch mal unter /etc/apache2/sites-enabled, ob die entsprechenden Einträge angelegt wurden.

Falls du das als Produktivsystem verwenden willst, würde ich dir übrigens noch dringend dazu raten, SSL zu verwenden und einen redirect anzulegen.

Dazu erst einmal die default-Seiten deaktivieren:

Quellcode

1
2
a2dissite default
a2dissite default-ssl


Dann legst du eine neue Datei mit dem Namen openxchange an unter /etc/apache2/sites-available mit folgendem Inhalt:

Quellcode

1
2
3
4
5
<VirtualHost *:80>
    	Redirect 301 / https://ox.deinedomain.de/
    	ServerAdmin webmaster@deinedomain.de
    	ServerName ox.deinedomain.de
</VirtualHost>


Dann noch eine neue Datei (openxchange-ssl) mit den Einträgen für SSL:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
NameVirtualHost *:443
<VirtualHost *:443>
    	SSLEngine On
    	ServerAdmin webmaster@domain.de
    	ServerName ox.deinedomain.de
    	SSLProtocol all -SSLv2
    	SSLCipherSuite ALL:!ADH:!SSLv2:RC4+RSA:+HIGH:+MEDIUM
    	SSLCertificateFile /etc/apache2/certs/deinzertifikat.crt
    	SSLCertificateKeyFile /etc/apache2/certs/deinkey.key

#Je nachdem, ob du eine Chainfile oder ein CA-Zertifikat verwendest entsprechend auskommentieren:
    	SSLCertificateChainFile /etc/apache2/certs/deinechainfile.cabundle
#SSLCACertificateFile /etc/apache2/certs/deinecafile.pem
  	
    	SetEnvIf User-Agent ".*MSIE.*" nokeepalive ssl-unclean-shutdown

    	DocumentRoot /var/www/

    	<Directory /var/www/>
            	AllowOverride None
            	Order allow,deny
            	allow from all
            	RedirectMatch ^/$ /ox-webordner/
           	Options +FollowSymLinks +SymLinksIfOwnerMatch
    	</Directory>
 # deflate
    	AddOutputFilterByType DEFLATE text/html text/plain text/javascript application/javascript text/css text/xml application/xml text/x-js application/x-javascript
    	# pre-compressed files
    	AddType text/javascript .jsz
    	AddType text/css .cssz
    	AddType text/xml .xmlz
    	AddType text/plain .po

    	AddEncoding gzip .jsz .cssz .xmlz
    	SetEnvIf Request_URI "\.(jsz|cssz|xmlz)$" no-gzip

    	ExpiresActive On
    	<Location /ox-webordner>
            	# Expires (via ExpiresByType to override global settings)
            	ExpiresByType image/gif "access plus 6 months"
            	ExpiresByType image/png "access plus 6 months"
            	ExpiresByType image/jpg "access plus 6 months"
            	ExpiresByType image/jpeg "access plus 6 months"
            	ExpiresByType text/css "access plus 6 months"
            	ExpiresByType text/html "access plus 6 months"
            	ExpiresByType text/xml "access plus 6 months"
            	ExpiresByType text/javascript "access plus 6 months"
            	ExpiresByType text/x-js "access plus 6 months"
            	ExpiresByType application/x-javascript "access plus 6 months"
            	ExpiresDefault "access plus 6 months"
            	Header append Cache-Control "private"
            	Header unset Last-Modified
            	Header unset Vary
            	# Strip version
            	RewriteEngine On
            	RewriteRule v=\w+/(.+) $1 [L]
            	# Turn off ETag
            	Header unset ETag
            	FileETag None
    	</Location>
    	<Location /ox-webordner/index.html>
            	ExpiresByType text/html "now"
            	ExpiresDefault "now"
            	Header unset Last-Modified
            	Header set Cache-Control "no-store, no-cache, must-revalidate, post-check=0, pre-check=0"
            	# Turn off ETag
            	Header unset ETag
            	FileETag None
    	</Location>
</VirtualHost>


ox-webordner muss in diesem Fall natürlich durch den entsprechenden Ordner bei dir ersetzt werden, bei OX 6 war es ox6 (zu finden unter /var/www), bei 7 wird es wahrscheinlich ox7 sein (habe nur Version 6 im Einsatz, tut mir leid); außerdem musst du natürlich die Zertifikate anpassen.

Für das SSL brauchst du natürlich noch entsprechend Zertifikate und Schlüssel, das oben ist eine Beispieleinrichtung, die du eventuell noch anpassen musst.

Danach die Seiten aktivieren mit

Quellcode

1
2
a2ensite openxchange
a2ensite openxchange-ssl


Ich glaube nämlich dass open-xchange standardmäßig die default-Werte (/etc/apache2/sites-available/default überschreibt, was eventuell nicht gewünscht ist, wenn du zum Beispiel den Server für mehrere Seiten betreiben willst (zum Beispiel ox.deinedomain.de für OX und www.deinedomain.de für eine Website).
In den o.g. Beispielen übrigens noch unbedingt die Domain anpassen, also was jetzt ox.deinedomain.de ist, müsste dann auf deinen gewünschten Domainnamen geändert werden.

Nach der Installation legt ox aber soweit ich weiß keinen Domainnamen in den apache-Einstellungen fest, weshalb du *eigentlich* einfach über die IP des Servers direkt auf der Login-Maske landen solltest.

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Broco« (12.03.2014, 10:27)


  • »joerghildering« ist männlich

Beiträge: 13

Registrierungsdatum: 10.03.2014

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

14

12.03.2014, 11:20

Naja, eigentlich schreibt OX standardmäßig die entsprechenden Einträge in die Apache-Konfiguration rein.
Schau doch mal unter /etc/apache2/sites-enabled, ob die entsprechenden Einträge angelegt wurden.

Falls du das als Produktivsystem verwenden willst, würde ich dir übrigens noch dringend dazu raten, SSL zu verwenden und einen redirect anzulegen.

Dazu erst einmal die default-Seiten deaktivieren:

Quellcode

1
2
a2dissite default
a2dissite default-ssl


Dann legst du eine neue Datei mit dem Namen openxchange an unter /etc/apache2/sites-available mit folgendem Inhalt:

Quellcode

1
2
3
    	Redirect 301 / https://ox.deinedomain.de/
    	ServerAdmin webmaster@deinedomain.de
    	ServerName ox.deinedomain.de


Dann noch eine neue Datei (openxchange-ssl) mit den Einträgen für SSL:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
NameVirtualHost *:443

    	SSLEngine On
    	ServerAdmin webmaster@domain.de
    	ServerName ox.deinedomain.de
    	SSLProtocol all -SSLv2
    	SSLCipherSuite ALL:!ADH:!SSLv2:RC4+RSA:+HIGH:+MEDIUM
    	SSLCertificateFile /etc/apache2/certs/deinzertifikat.crt
    	SSLCertificateKeyFile /etc/apache2/certs/deinkey.key

#Je nachdem, ob du eine Chainfile oder ein CA-Zertifikat verwendest entsprechend auskommentieren:
    	SSLCertificateChainFile /etc/apache2/certs/deinechainfile.cabundle
#SSLCACertificateFile /etc/apache2/certs/deinecafile.pem
  	
    	SetEnvIf User-Agent ".*MSIE.*" nokeepalive ssl-unclean-shutdown

    	DocumentRoot /var/www/

    	
            	AllowOverride None
            	Order allow,deny
            	allow from all
            	RedirectMatch ^/$ /ox-webordner/
           	Options +FollowSymLinks +SymLinksIfOwnerMatch
    	
 # deflate
    	AddOutputFilterByType DEFLATE text/html text/plain text/javascript application/javascript text/css text/xml application/xml text/x-js application/x-javascript
    	# pre-compressed files
    	AddType text/javascript .jsz
    	AddType text/css .cssz
    	AddType text/xml .xmlz
    	AddType text/plain .po

    	AddEncoding gzip .jsz .cssz .xmlz
    	SetEnvIf Request_URI "\.(jsz|cssz|xmlz)$" no-gzip

    	ExpiresActive On
    	
            	# Expires (via ExpiresByType to override global settings)
            	ExpiresByType image/gif "access plus 6 months"
            	ExpiresByType image/png "access plus 6 months"
            	ExpiresByType image/jpg "access plus 6 months"
            	ExpiresByType image/jpeg "access plus 6 months"
            	ExpiresByType text/css "access plus 6 months"
            	ExpiresByType text/html "access plus 6 months"
            	ExpiresByType text/xml "access plus 6 months"
            	ExpiresByType text/javascript "access plus 6 months"
            	ExpiresByType text/x-js "access plus 6 months"
            	ExpiresByType application/x-javascript "access plus 6 months"
            	ExpiresDefault "access plus 6 months"
            	Header append Cache-Control "private"
            	Header unset Last-Modified
            	Header unset Vary
            	# Strip version
            	RewriteEngine On
            	RewriteRule v=\w+/(.+) $1 [L]
            	# Turn off ETag
            	Header unset ETag
            	FileETag None
    	
    	
            	ExpiresByType text/html "now"
            	ExpiresDefault "now"
            	Header unset Last-Modified
            	Header set Cache-Control "no-store, no-cache, must-revalidate, post-check=0, pre-check=0"
            	# Turn off ETag
            	Header unset ETag
            	FileETag None


ox-webordner muss in diesem Fall natürlich durch den entsprechenden Ordner bei dir ersetzt werden, bei OX 6 war es ox6 (zu finden unter /var/www), bei 7 wird es wahrscheinlich ox7 sein (habe nur Version 6 im Einsatz, tut mir leid); außerdem musst du natürlich die Zertifikate anpassen.

Für das SSL brauchst du natürlich noch entsprechend Zertifikate und Schlüssel, das oben ist eine Beispieleinrichtung, die du eventuell noch anpassen musst.

Danach die Seiten aktivieren mit

Quellcode

1
2
a2ensite openxchange
a2ensite openxchange-ssl


Ich glaube nämlich dass open-xchange standardmäßig die default-Werte (/etc/apache2/sites-available/default überschreibt, was eventuell nicht gewünscht ist, wenn du zum Beispiel den Server für mehrere Seiten betreiben willst (zum Beispiel ox.deinedomain.de für OX und www.deinedomain.de für eine Website).
In den o.g. Beispielen übrigens noch unbedingt die Domain anpassen, also was jetzt ox.deinedomain.de ist, müsste dann auf deinen gewünschten Domainnamen geändert werden.

Nach der Installation legt ox aber soweit ich weiß keinen Domainnamen in den apache-Einstellungen fest, weshalb du *eigentlich* einfach über die IP des Servers direkt auf der Login-Maske landen solltest.

Hallo,

super. Danke schon mal für deine Antwort. Ich habe da nur noch folgende Probleme:

1. unter /var/www habe ich nur appsuite stehen was ich in Verbindung mit OX bringen kann. irgendein ox6 oder 7 gibt es da nicht.
2. Mit der IP kann ich es leider auch nicht aufruden. Die IP verweisst Standardmäßig auf eine Standardseite von Parallels.
2. Ist es möglich den OX für mehrere Domains zu konfigurieren? Auf dem Server sollen nachher mehrere Domains unter /var/www/vhost laufen. Ich würde gerne für jede Domain OX zur Verfügung stellen.

Gruß,

Jörg

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »joerghildering« (12.03.2014, 15:23)


  • »supergudrun« ist männlich

Beiträge: 20

Registrierungsdatum: 31.10.2011

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: LXDE

  • Nachricht senden

15

12.03.2014, 16:53

Hallo,

der Link lautet:

Quellcode

1
http(s)://Hostname(www.name.com)/appsuite
Viele Grüße
Supergudrun

  • »joerghildering« ist männlich

Beiträge: 13

Registrierungsdatum: 10.03.2014

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

16

12.03.2014, 16:59

Hallo,

der Link lautet:

Quellcode

1
http(s)://Hostname(www.name.com)/appsuite

Habe ich alles probiert. Leider ohne Erfolg. Hat noch mal jemand eine gute komplette Anleitung für mich? Ich habe den Server komplett neu aufgesetzt. Ist jetzt nur Ubuntu 12.04 und Plesk drauf. Ziel ist es den OX für alle Domains die unter var/www/vhosts angelegt werden zum laufen zu bringen. Wer kann mich da unterstützen. Ideal wäre jemand der das Ganze vielleicht auch bei Hosteurope auf einen virtuellen Server laufen hat. Vielleicht gibt es da ja irgendwelche Besonderheiten.

Gruß,

Jörg

Broco

User

  • »Broco« ist männlich

Beiträge: 266

Registrierungsdatum: 05.12.2008

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: GNOME 3.0

Andere Betriebssysteme: Debian Wheezy, Knoppix, Fedora

  • Nachricht senden

17

13.03.2014, 16:03

Du meinst, du willst für jede Domain ein eigenes OX installieren?
Das käme mir leicht übertrieben vor. Ich meine, OX wäre Multidomainfähig, damit habe ich leider aber keine Erfahrungen.
Ich habe nur das OX 6 für eine Domain in meiner alten Firma installiert und administriert (und dabei auch nur ca. 100 User) und das war ein wenig anders aufgebaut scheinbar. Bei meinen Kunden setze ich heute Zimbra ein, weil mir das neue OX von der Optik her nicht gefällt und die Administration in der OX Open-Source-Edition immer ein Krampf war. Vor allem das Eintippen von Klartextpasswörtern auf der Konsole ging mir gegen den Strich.

Das neue ist doch mehr Tablet-optimiert, oder? Mir gefiel nämlich das alte Look & Feel besser.

  • »joerghildering« ist männlich

Beiträge: 13

Registrierungsdatum: 10.03.2014

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

18

13.03.2014, 16:16

Du meinst, du willst für jede Domain ein eigenes OX installieren?
Das käme mir leicht übertrieben vor. Ich meine, OX wäre Multidomainfähig, damit habe ich leider aber keine Erfahrungen.
Ich habe nur das OX 6 für eine Domain in meiner alten Firma installiert und administriert (und dabei auch nur ca. 100 User) und das war ein wenig anders aufgebaut scheinbar. Bei meinen Kunden setze ich heute Zimbra ein, weil mir das neue OX von der Optik her nicht gefällt und die Administration in der OX Open-Source-Edition immer ein Krampf war. Vor allem das Eintippen von Klartextpasswörtern auf der Konsole ging mir gegen den Strich.

Das neue ist doch mehr Tablet-optimiert, oder? Mir gefiel nämlich das alte Look & Feel besser.
OX gibt es auch in einer Hosting Edition. Wäre das dann die richtige Version für mich? Hat damit jemand Erfahrung? Es geht mir darum das über Tablets und Smartphones die Mail vernünftig verwaltet werden können, zusätzlich per Outlook oder Webinterface drauf zugegriffen werden kann. Denke das sollt mit OX doch gehen, oder?
Zimbra habe ich mir noch gar nicht angeschaut. Ist das von der Funktionalität ähnlich wie OX? Dachte OX wäre da 1.Wahl....Zudem kann man OX auch scheinbar in Plesk integrieren um die Benutzer zu verwalten.
Ich hoste zur Zeit 5 Domains mit jeweils 5-10 Mailadressen. Momentan läuft darauf standardmäßig Horde. Würde gerne die Funktionalität eines Exchange für alle Mailadressen zur Verfügung stellen. Nach Möglichkeit sollte das Mailsystem nur einmal installiert werden. Bin über jeden Tipp dankbar.

Gruß,

Jörg

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »joerghildering« (13.03.2014, 16:57)


  • »joerghildering« ist männlich

Beiträge: 13

Registrierungsdatum: 10.03.2014

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

19

20.03.2014, 18:47

Hallo,

denke die Installation habe ich jetzt richtig hinbekommen. Habe jetzt nur norch das Problem das ich die Loginseite nicht aufrufen kann.Wenn ich die IP eingebe geht der Server standardmäßig auf /var/www/vhosts/default der appsuite Ordner liegt aber unter /var/www
Ich denke das ich den Pfad einfach in einer Config Datei ändern muss. Finde aber noch nicht die richtige. Kann mir da jemand helfen?

Gruß,

Jörg

  • »joerghildering« ist männlich

Beiträge: 13

Registrierungsdatum: 10.03.2014

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

20

21.03.2014, 11:57

Hallo,

neuer Lösungsansatz. Habe von Hosteurope folgende Aussager bekommen:
"
Sehr geehrte Damen und Herren,



vielen Dank für Ihre Anfrage.



> wie bekomme ich es hin das als Standardpfad /var/www anstatt /var/www/vhosts

> /default genommen wird wenn ich die IP in den Browser eingebe?



Diese Konfiguration ist bei einem System mit Plesk nicht möglich.

Dort kann auch der Pfad zur Defaultdomain nicht umgestellt werden.
"
Bekomme ich das trotzdem irgendwie mit anderen Pfaden installiert. Das Ganze müsste dann unter /var/www/vhosts anstatt unter /var/www installiert werden. Geht das so ohne weiteres?
Wenn ja, worauf muss ich achten bzw. welche Dateien wären davon alles betroffen?

Gruß,

Jörg