Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

  • »Matze01« ist der Autor dieses Themas

Beiträge: 3

Registrierungsdatum: 09.05.2013

Derivat: Ubuntu

Architektur: 32-Bit PC

Desktop: Unity

  • Nachricht senden

1

09.05.2013, 16:14

Keine aktiven Verbindungen unter Firestarter.

Hallo Leute,

ich habe das Programm
"Firestarter" in der Version 1.0.3 über das Ubuntu Software-Center installiert. Sobald ich das Programm öffne, erscheint die Meldung "Öffnen des Systemlogs fehlgeschlagen. Es
werden keine Informationen zu Ereignissen verfügbar sein." Des Weiteren werden keine aktiven Verbindungen unter dem Register "Status" angezeigt. Mein Anliegen ist es, den überwiegenden Teil der internetaktiven Programme einsehen zu können, doch dies scheint gegenwärtig mit Firestarter unter einem 3.5.0 Kernel nicht möglich zu sein.

Quellcode

1
2
uname -r
3.5.0-27-generic

Meine Erfahrungen mit Firestarter unter einem 3.2.0 Kernel zeigten, dass mir hier keine Fehlermeldung und unter dem Register "Status" alle aktiven Verbindungen angezeigt werden.

Als Lösungsansatz habe ich die Anleitung von der Intenteseite "
http://answers.launchpad.net/ubuntu/+source/firestarter/+question/155614" praktiziert. Diese gilt zwar für Ubuntu 11.04 (Natty Narwhal), doch sah ich bisher keine andere Lösung in Sicht.
1. Datei "50-default.conf" öffnen. Hierzu über Alt + F2 eine Eingabezeile öffnen und folgendes eingeben.

Quellcode

1
gksudo gedit /etc/rsyslog.d/50-default.conf

2. Alle "#" am Anfang der Zeilen 38 bis 41 entfernen.

Quellcode

1
2
3
4
#*.=info;*.=notice;*.=warn;\
# auth,authpriv.none;\
# cron,daemon.none;\
# mail,news.none -/var/log/messages

Fazit: Das Problem mit der fehlenden Systemlog-Datei beim Starten von Firestarter ist behoben. Allerdings werden weiterhin keine aktiven Verbindungen unter dem Register "Status" angezeigt.

Was kann ich tun, damit letztendlich alle aktiven Verbindungen unter einem 3.5.0 Kernel angezeigt werden?

Soni

User

Beiträge: 204

Registrierungsdatum: 13.12.2009

Derivat: Kein Ubuntu-Derivat

Architektur: 64-Bit PC

  • Nachricht senden

2

09.05.2013, 16:29

Warum willst du mit Firestarter deine aktiven Verbindungen ansehen - ist doch bloß ein Frontend für iptables?

Um deine aktiven Verbindungen anzuschauen, reicht ein

Quellcode

1
netstat
http://wiki.ubuntuusers.de/netstat
völlig aus ...

Zitat von ».user«

doch, die ganze Welt besteht aus fenstern!

  • »Matze01« ist der Autor dieses Themas

Beiträge: 3

Registrierungsdatum: 09.05.2013

Derivat: Ubuntu

Architektur: 32-Bit PC

Desktop: Unity

  • Nachricht senden

3

09.05.2013, 20:09

Hallo Soni,

wie Du es bereits erwähnt hast, möchte ich ein Frontend für iptables haben, bei dem ich über eine Art Benutzerführung diverse Aufgaben einsteuern kann bzw. eine komplexitätsreduzierte Übersicht aller internetaktiven Programme habe. So umgehe ich unter anderem das Risiko durch Fehleingaben, sei es aus Unkenntnis der erforderlichen Befehlskette oder der falschen Schreibweise eines Kommandos, etwas Unbeabsichtigtes zu vollziehen oder womöglich das System zu schädigen. Falls es ein „grafisches“ Programm geben sollte, welches der Funktionsweise von Firestarter ebenbürtig ist oder gar noch besser in der Handhabung ist, so würde ich mich freuen, wenn Du bzw. ein Leser dieses Beitrags mir dieses nennen könntet. Ansonsten wäre ich für jeglichen Lösungsansatz meines Problems mit Firestarter dankbar. Notgedrungen würde ich auf Deinen Vorschlag mit dem Befehl „netstat“ zurückgreifen und Firestarter vom System entfernen. Allerdings ist dies keine Lösung für das von mir angesprochene grundsätzliche Problem mit der defizitären Funktion von Firestarter unter dem aktuellen Kernel der LTS-Version von Ubuntu (3.5.0).

Um Fehler bei der Installation von Ubuntu 12.04.2 LTS (32-Bit) auszuschließen, möchte ich auch alle Nutzer ansprechen, bei denen Firestarter unter der angegeben Ubuntu-Version mit dem 3.5.0 Kernel funktioniert. Sollte Firestarter aktiven Verbindungen unter dem Register „Status“ angezeigt, so könnte auch die Installation des Betriebssystems fehlerhaft sein.

Danke für Deine Hilfe.

Bye

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Matze01« (09.05.2013, 20:24)


4

12.05.2013, 19:21

Hallo Matze01,

ich habe auch unter 12.04 die Fehlermeldung, allerdings mit dem 3.2.X-Kernel.
Aktive Verbindungen kann ich einsehen nur die Log-Datei für die blockierten Verbindungen kann nicht geöffnet werden. Würde spontan vermuten, dass es mit Ubuntu an sich zu tun hat, da es nicht weiter auf Standard-Werkzeuge sondern Eigenbauten wie UpStart setzt.
Wahrscheinlich wird einfach das gesuche .log-File nicht mehr erzeugt oder heißt anders.

VG
"Das Leben ist zum lachen da, `drum nehm´ ich Psychopharmaka" (Die Ärzte, Living Hell)

  • »Matze01« ist der Autor dieses Themas

Beiträge: 3

Registrierungsdatum: 09.05.2013

Derivat: Ubuntu

Architektur: 32-Bit PC

Desktop: Unity

  • Nachricht senden

5

12.05.2013, 19:51

Hallo Wau Wie Lein,

danke für Deine Antwort.

Ich hatte Ubuntu erstmals über die ISO-Datei 12.04.1 LTS (32-Bit) installiert, unter welcher standartmäßig ein 3.2.X-Kernel arbeitet. Hier funktionierte Firestarter tadellos. Beim Start kam keine Fehlermeldung (fehlendeSystemlog-Datei) noch wurden mir alle internetaktiven Verbindungen unter dem Register "Status" angezeigt. Allerdings hatte ich hardwareseitige Probleme, sodass ich meinen Computer mit der ISO-Datei 12.04.2 LTS (32-Bit) neu aufgesetzt habe. Über diesen Schritt konnte ich die hardwareseitigen Probleme weitestgehend eindämmen, jedoch besteht seitdem das Problem mit Firestarter. Ich vermute, dass dieses Problem auf den 3.5.X-Kernel zurückzuführen ist. Um allerdings Fehler in der Installationsrutine auszuschließen, möchte ich alle Nutzer der ISO-Datei 12.04.2 LTS (32-Bit) um Rückmeldung bitten.

Tschüss