Sie sind nicht angemeldet.

  • »alex1974« ist männlich
  • »alex1974« ist der Autor dieses Themas

Beiträge: 8

Registrierungsdatum: 13.09.2012

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

1

24.02.2013, 20:31

Ubuntu Server 12.04 - Brauche Hilfe bei Internet mit wlan AP einrichten

Liebe Community,

ich habe seit kurzem einen Server mit Ubuntu Server 12.04. Beim Einrichten der Internetanbindung scheitere ich vollkommen.

Der Server besitzt ein Atheros AR8161 Gigabit Ethernet Interface (eth) und einen Atheros AR922x Wireless Network Adapter (wlan). Mein ISP ist chello/UPC, über den ich eine dynamische IP beziehe. Der Server ist mit eth mit dem ISP-Modem verbunden und soll über wlan ein lokales Netzwerk anbieten.
auf dem Server läuft:
isc-dhcp-server
bind9
hostapd
ssh

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
alex@alex-server:~$ sudo ifconfig -a
eth       Link encap:Ethernet  HWaddr 94:de:80:05:9d:10
          inet addr:213.47.124.5  Bcast:255.255.255.255  Mask:255.255.255.0
          inet6 addr: fe80::96de:80ff:fe05:9d10/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:17010 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1118 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1190607 (1.1 MB)  TX bytes:188022 (188.0 KB)
          Interrupt:18 
lo    Link encap:Local Loopback
     inet addr:127.0.0.1  Mask:255.0.0.0
     inet6 addr: ::1/128 Scope:Host
     UP LOOPBACK RUNNING  MTU:16436  Metric:1
     RX packets:178 errors:0 dropped:0 overruns:0 frame:0
     TX packets:178 errors:0 dropped:0 overruns:0 carrier:0
     collisions:0 txqueuelen:0
     RX bytes:13009 (13.0 KB)
     TX bytes:13009 (13.0 KB)
mon.wlan  Link encap:UNSPEC  HWaddr 64-70-02-D2-65-A0-00-00-00-00-00-00-00-00-00-00
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
           RX packets:35927 errors:0 dropped:0 overruns:0 frame:0
           TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
           collisions:0 txqueuelen:1000
           RX bytes:7796577 (7.7 MB)
           TX bytes:0 (0.0 B)
wlan      Link encap:Ethernet  HWaddr 64:70:02:d2:65:a0
          inet addr:192.168.3.1  Bcast:192.168.3.255  Mask:255.255.255.0
          inet6 addr: fe80::6670:2ff:fed2:65a0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:20 errors:0 dropped:5 overruns:0 frame:0
          TX packets:239 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2700 (2.7 KB)
          TX bytes:74865 (74.8 KB)

/etc/network/interfaces

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
# The loopback network interface
auto lo
iface lo inet loopback
# The extern network interface
auto eth
iface eth inet dhcp
# The intern network interface
# mit statischer Konfiguration
auto wlan
iface wlan inet static
        network 192.168.3.0
        address 192.168.3.1
        netmask 255.255.255.0
        broadcast 192.168.3.255
        gateway 192.168.3.1

# iptables neu laden hostapd und dnsmasq neu starten
pre-up iptables-restore < /etc/firewall.conf
up /etc/init.d/hostapd restart
up /etc/init.d/isc-dhcp-server restart

die iptables sind zum Testen ganz offen.
/etc/hosts

Quellcode

1
2
3
4
5
6
7
8
9
10
11
127.0.0.1       localhost
## Lokales Netzwerk
#   = IP =      = Rechnername =
196.168.3.1     alex-server     alex-server.alex.home   # der Server
196.168.3.20    alex-laptop     alex-laptop.alex.home   # alex-laptop
# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

/etc/dhcp/dhcpd.conf
(entgegen vieler Tutorials und auch Bücher heißt die Datei nichts mit dhcp3)

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
# Globale Optionen
authoritative;
default-lease-time 600;
max-lease-time 7200;
use-host-decl-names on;
# Log Optionen
log-facility local7;
# dynamische Konfiguration lokaler Rechnernamen
include "/etc/bind/rndc.key";
ddns-updates on;
ddns-update-style interim;
ddns-domainname "home.";
update-static-leases on;
zone home. {
        primary 127.0.0.1;
        key "rndc-key";
};
zone 0.168.192.in-addr.arpa. {
        primary 127.0.0.1;
        key "rndc-key";
};
# Eckdaten des lokalen Netzes
option broadcast-address 192.168.3.255;
option subnet-mask 255.255.255.0;
option routers 192.168.3.1;
option domain-name "alex.home";
option domain-name-servers 192.168.3.1,8.8.8.8;
# dynamischer Addressbereich
subnet 192.168.3.0 netmask 255.255.255.0 {
        range 192.168.3.50 192.168.3.200;
};
# statische Addressen
host alex-laptop {
        hardware ethernet 00:1b:77:71:4d:96;
        fixed-address 192.168.3.10;
        option host-name "alex-laptop";
};

die Zone Infos und rndc-key Angaben stammen aus einem Tutorial und erlauben dhcp dynamisch die hosts in die named-Datenbanken zu schreiben.
/etc/resolv.conf

Quellcode

1
2
3
4
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.0.1
search chello.at

wie im Header empfohlen, hab ich da drin nichts geändert.

Mit diesen Einstellungen scheint es nicht zu gehen. Meine Tests soweit:

Quellcode

1
2
3
alex@alex-server:~$ sudo /etc/init.d/isc-dhcp-server restart
(...)
start: Job failed to start

bind9 scheint zu funktionieren. Zumindest gibt er keinen Fehler beim Lesen der named.conf aus

Quellcode

1
2
3
4
5
alex@alex-server:~$ sudo /etc/init.d/bind9 restart
 * Stopping domain name service... bind9 
waiting for pid 1286 to die                                   [ OK ]
 * Starting domain name service... bind9             [ OK ]
 

mich selber kann ich pingen ...

Quellcode

1
2
3
4
5
6
7
8
9
alex@alex-server:~$ ping -c3 192.168.3.1
PING 192.168.3.1 (192.168.3.1) 56(84) bytes of data.
64 bytes from 192.168.3.1: icmp_req=1 ttl=64 time=0.040 ms
64 bytes from 192.168.3.1: icmp_req=2 ttl=64 time=0.022 ms
64 bytes from 192.168.3.1: icmp_req=3 ttl=64 time=0.026 ms

--- 192.168.3.1 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 1998ms
rtt min/avg/max/mdev = 0.022/0.029/0.040/0.008 ms

nach außen geht's nicht

Quellcode

1
2
alex@alex-server:~$ ping -c3 www.ubuntu-forum.de
ping: unknown host www.ubuntu-forum.de


Ein weiserer als ich muß dies Problem lösen.
P.S.: ich habe es auch schon mit dnsmasq ohne Erfolg probiert.
ubuntu-server 12.04 LTS

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »alex1974« (25.02.2013, 09:04)


2

24.02.2013, 21:46

Mir fällt auf:
Bei iface wlan ist seine eigene IP als Gateway eingetragen. Diese Maschine kann nicht ins Internet finden. Die fehlende Ausgabe von "route -n" würde klären, daß dadurch der Gateway des ISP nachrangig wird.
Bei iface wlan sind keine "wireless-" Angaben (mode, essid, ...). Der Name der Schnittstelle "mon.wlan" lässt vermuten, daß die Karte im Monitor-Mode läuft. Als Access-Point sollte sie im Master-Mode sein. Könnte sein, daß diese Einstellungen von /etc/init.d/isc-dhcp-server erledigt werden, die wir nicht sehen.

In /etc/hosts ist die Maschine selbst als DNS-Server eingetragen, was soweit richtig ist wenn dieser funktioniert. Daß bind9 keinen Fehler beim Lesen der named.conf ausgibt, heißt nicht, daß er einen vorgelagerten DNS kennt und auch benutzt. Die conf wäre interessant zu sehen.
Die Angabe "search chello.at" macht nur Sinn, wenn dein internes Netz auch so heißt.

"Offene" iptables sind gut und schön, routing und forwarding sollte für einen Routerbetrieb auch eingerichtet sein.

Soweit für's erste.
mir is wurscht

  • »alex1974« ist männlich
  • »alex1974« ist der Autor dieses Themas

Beiträge: 8

Registrierungsdatum: 13.09.2012

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

3

25.02.2013, 09:04

Danke Fredl

Ich habe bind9 und isc-dhcp-server wieder gekillt und bin retour zu dnsmasq. Deine Hinweise habn mir aber soweit geholfen, das mein Internet und Heimnetzwerk jetzt laufen. Zumindest soweit :)
Ein paar Probleme habe ich noch, aber der Übersichtshalber poste ich die in einem eigenen Thread.
Falls du Zeit hast, freue ich mich über weitere Hilfe.
ubuntu-server 12.04 LTS