Sie sind nicht angemeldet.

Nandl

User

  • »Nandl« ist männlich
  • »Nandl« ist der Autor dieses Themas

Beiträge: 8

Registrierungsdatum: 28.01.2013

Derivat: Ubuntu

Architektur: 32-Bit PC

Desktop: Unity

  • Nachricht senden

1

14.02.2013, 11:39

Welche Grafiktreiber unterstützt Ubuntu 12.4 ?

Hallo zusammen
Ich bin Nandl und will auf meine alten Tage noch ins Linux / Ubuntu einsteigen.
Ich habe einen etwas älteren PC auf Ubuntu 12.04 Lts umgestellt. So ganz einfach, Festplatte formatiert und Ubuntu installiert ohne irgendwelche Eingriffe.
Das Ergebnis war zufriedenstellen, alles läuft.
Bis auf die Grafikkarte, sie ist eine ATI für die es keine Treiber für Linux gibt.

Ich würde sie gerne austauschen, habe aber bis jetzt nirgends herausfinden können welche Karten von Ubuntu unterstützt werden ohne dass extra Treiber installiert werden müssen.

Kann mir jemand helfen

Gruss

Nandl
Man ist nie zu alt um zu Ubuntu zu wechseln

Beiträge: 456

Registrierungsdatum: 14.03.2011

Derivat: Lubuntu

Architektur: 64-Bit PC

  • Nachricht senden

2

14.02.2013, 22:25

Hallo,

ich glaube, dass du keine neue Grafikkarte für deinen Rechner brauchst, die meisten von ATI/AMD werden unterstützt.
Die Treiber-Installation wird bei 12.04 soweit ich weiß über das Programm "Software-Paketquellen" geregelt. Dies kannst du über das Ubuntu-Softwarecenter erreichen, indem du oben in der Menüleiste bei Paket, so glaube ich, "Software-Paketquellen" auswählst. Dort dann auf den Reiter "Zusätzliche Treiber" wechseln. Dort müsste dir mindestens ein Treiber angeboten werden. Wenn dir kein Treiber angeboten wird, dann kannst du uns helfen die Grafikkarte zu Laufen zu bringen, indem du uns die Ausgabe von folgendem Befehl mitteilst: Öffne ein Terminal (Strg + Alt +T) und kopiere folgendes rein (und Enter drücken):

Quellcode

1
lspci -nnk | grep -i VGA -A2 


Gruß,
Clemens

Nandl

User

  • »Nandl« ist männlich
  • »Nandl« ist der Autor dieses Themas

Beiträge: 8

Registrierungsdatum: 28.01.2013

Derivat: Ubuntu

Architektur: 32-Bit PC

Desktop: Unity

  • Nachricht senden

3

15.02.2013, 00:14

Hallo Clemes

Vielen Dank für Deine schnelle Reaktion

Mit dem Tipp Paketquellen hatte ich kein Glück, ich habe nirgends eine Reiter "Zusätzliche Treiber" gefunden, ausser in den Systemeinstellungen aber der hilft auch nicht weiter.

Mit der Terminalabfrage war ich erfolgreich:


ferdinand@fryLinX:~$ sudo lspci -nnk |
grep -i VGA -A2



01:00.0 VGA compatible controller
[0300]: Advanced Micro Devices [AMD] nee ATI RV350 AS [Radeon 9550]
[1002:4153]


Subsystem: Device [1fd3:4153]


Kernel driver in use: radeon

Ich hoffe das hilft weiter.
nochmals das Problem
in den Systemeinstellungen wird die Grafikkarte nicht erkannt und es können keine Veränderungen vorgenommen werden
Mit der Auflösung könnte man zur Not leben, aber es ist nicht optimal
Vielen Dank
Ferdinand
Man ist nie zu alt um zu Ubuntu zu wechseln

Beiträge: 456

Registrierungsdatum: 14.03.2011

Derivat: Lubuntu

Architektur: 64-Bit PC

  • Nachricht senden

4

15.02.2013, 03:04

Hallo,

hast du denn versucht die Auflösung zu ändern? Bei "Bildschirmeinstellungen" müsste das funktionieren, wenn dir keine optimale Auflösung vorgeschlagen wird, dann gibt es, glaube ich, ein ATI oder AMD Control Center, bei dem man Einstellungen über die Auflösung vornehmen kann.

Gruß,
schmetterlin

DocHifi

unregistriert

5

15.02.2013, 09:09

Hi,
ein ATI oder AMD Control Center, bei dem man Einstellungen über die Auflösung vornehmen kann.
aber nicht in Verbindung mit dem freien Treiber Radeon.
Diese Karte läuft aber nur noch damit.
Da der Rechner vermutlich noch AGP hat, wird einer mit einer neueren Karte auch eher nichts.
Gruß DH

Nandl

User

  • »Nandl« ist männlich
  • »Nandl« ist der Autor dieses Themas

Beiträge: 8

Registrierungsdatum: 28.01.2013

Derivat: Ubuntu

Architektur: 32-Bit PC

Desktop: Unity

  • Nachricht senden

6

15.02.2013, 17:43

Hallo zusammen

Ich will kurz auf die neu eingegangenen Anregungen antworten.

Hallo DocHifi, du hattest recht mit Deinem Verdacht....... Es ist ein AGP - Slot

und es sind nur 2 AMD Packete installiert (etwas für Hintergrund und kernel) aber keine Kontrollcenter

Ich hatte in meinen vorherigen Versuchen auf Anregung einer Wiki Paget folgendes probiert:

cd ~/; mkdir catalyst12.4; cd catalyst12.4/

wget -O amd-driver-installer-12-4-x86.x86_64.run goo.gl/VGYWP

chmod +x amd-driver-installer-12-4-x86.x86_64.run

sudo sh ./amd-driver-installer-12-4-x86.x86_64.run

Leider hat es nicht funktioniert und ich musste komplett neu installieren, denn ich hatte keine funktionsfähige Bildschirmanzeige mehr

Trotzdem vielen Dank für die Unterstützung
Ich hoffe noch weiter auf eine "Zauberformel" die weiterhilft

Gruss
Ferdinand
Man ist nie zu alt um zu Ubuntu zu wechseln

DocHifi

unregistriert

7

15.02.2013, 19:10

Leider hat es nicht funktioniert und ich musste komplett neu installieren, denn ich hatte keine funktionsfähige Bildschirmanzeige mehr

Weil du mit Gewalt einen Treiber installiert hast, der deine Karte nicht (mehr) unterstützt.
Gruß DH

8

15.02.2013, 20:17

Diese Karte dürfte generell schlecht unterstützt sein. Am besten dürfte sie mit dem Treiber "radeonfb" laufen. Quelle
Ich kann leider keine einfache Umschaltung dafür per GUI beschreiben - jemand anderer vielleicht?

Ansonsten: Wir sind hier in "Hardware-Beratung" und die eigentliche Frage war nach besser unterstützten Karten.
Daher fange ich mal an: Alle halbwegs neueren Nvidia sollten laufen. Intel auch, aber nicht zu neu. Leistungsumfang nach Bedarf und Budget. Oder auf obiger Seite etwas passendes suchen. Oder eine bei den einschlägigen Händern aussuchen und vor dem Kauf nach der genauen Typenbezeichnung +Precise googeln. Oder auch mit der Typenbezeichnung hier fragen, ob jemand Erfahrungen damit hat...

sie ist eine ATI für die es keine Treiber für Linux gibt
Stimmt ja nicht, du hast ja einen am Laufen ;)
mir is wurscht

Nandl

User

  • »Nandl« ist männlich
  • »Nandl« ist der Autor dieses Themas

Beiträge: 8

Registrierungsdatum: 28.01.2013

Derivat: Ubuntu

Architektur: 32-Bit PC

Desktop: Unity

  • Nachricht senden

9

19.02.2013, 20:14

Hallo zusammen

Ich muss Euch nochmals belästigen.
Ich habe im Internet folgendes gefunden:

Mit einer NIVIDA Geforce 6200 AGP
und den Linux Display Driver X86 Version 96.43.18 von NIVIDA
sollte es möglich sein unter Ubuntu 12.04 "richtig" zu arbeiten und auch verschiedene Auflösungen einstellen zu können.

Hat jemand damit Erfahrung ???
Ich wäre dann auch für Installationstipps dankbar

Grüße aus dem nicht ganz so kalten Spanien

Ferdinand
Man ist nie zu alt um zu Ubuntu zu wechseln

Beiträge: 456

Registrierungsdatum: 14.03.2011

Derivat: Lubuntu

Architektur: 64-Bit PC

  • Nachricht senden

10

19.02.2013, 21:24

Hallo,

Ich hatte selber eine NVIDIA Geforce 6200. Es gab keine Probleme mit dem Treiber. Habe sie nur aus Gründen einer besseren Karte eingetauscht.

Gruß,
schmetterling

11

20.02.2013, 00:12

Mit einer NIVIDA Geforce 6200 AGP
und den Linux Display Driver X86 Version 96.43.18 von NIVIDA
sollte es möglich sein unter Ubuntu 12.04 "richtig" zu arbeiten und auch verschiedene Auflösungen einstellen zu können.
Diese Karte wird unter 12.04 nicht laufen.
Nur mit dem freien Nouveau Treiber geht es noch. Allerdings ohne 3D Unterstützung.
Ich habe selbige Karte hier am laufen. 8o

12

20.02.2013, 14:43

@Mitleser: Weißt du zufällig woran es liegt? Hat es mit der neuen Version des XServers zu tun?
mir is wurscht

DocHifi

unregistriert

13

20.02.2013, 15:50

Hi,
laut UU-Wiki, sollte die Karte sogar mit dem "nvidia-current" laufen.

Zitat

nvidia-current: (NV40 - NVAF) GeForce 6/7
meine alte 7500er tut es auch noch.
Gruß DH

14

20.02.2013, 22:29

Weißt du zufällig woran es liegt? Hat es mit der neuen Version des XServers zu tun?
Ich denke ja. Ist zwar Debian Wheezy, sollte aber von der verwendeten Version das gleiche sein wie bei Ubuntu 12.04.
Der Treiber aus den Paketquellen und vom Hersteller unterstützen diese Karte nicht.

Nandl

User

  • »Nandl« ist männlich
  • »Nandl« ist der Autor dieses Themas

Beiträge: 8

Registrierungsdatum: 28.01.2013

Derivat: Ubuntu

Architektur: 32-Bit PC

Desktop: Unity

  • Nachricht senden

15

21.02.2013, 03:55

Hallo zusammen

Jetzt läuft es !!! :thumbsup:

Ich kanns Euch nicht technisch erklären, dazu fehlt mir noch das Inseiderwissen.

Also, ich habe die "neue" Geforce 6200 AGP eingebaut und dann Ubuntu gestartet.
Dann mit "Systemeinstellungen" "zusätzliche Treiber" gesucht und es wurden mehrere Versionen von NIVIDA Treiben angeboten,
dieses hatte mit der ATI - Karte nie funktioniert.
Ich habe die neueste von den stabilen Versionen aktiviert.

Danach konnte ich mit "Einstellungen" "Hardware" "Anzeigegeräte" die Auflösung verändern obwohl der Bildschirm immer noch nicht erkannt wird,
aber das liegt wohl an dem Museumstück (ACER AL1912)
Wenn ich einen etwas moderneren Bildschirm (16:9) hätte wäre es sogar ideal.

Ich bin jetzt sehr zufrieden, denn ich habe dank Eurer Anregungen eine Menge gelernt :)

und bin positiv überrascht. welche tolle Fundgrube das UBUNTU WIKIPEDIA ist. :thumbsup:

Da könnte sich Microsoft eine dicke Scheibe ab schneiden

Nochmals vielen Dank

Ferdinand
Man ist nie zu alt um zu Ubuntu zu wechseln

DocHifi

unregistriert

16

21.02.2013, 10:35

Hi,
sag ich doch die läuft mit dem "current". :D
Das hat auch nicht mit Ubuntu zu tun, oder Debian.
Meine 7500er läuft unter SolusOS, das basiert ja auch auf Debian Wheezy.
Gruß DH

17

21.02.2013, 11:05

Das hat auch nicht mit Ubuntu zu tun, oder Debian.
Da wäre ich vorsichtig.
Ich hätte spontan auch gesagt sie müsste laufen, wie ich das auch schon vorher über nahezu alle Nvidias behauptet habe. Zumal der neueste Treiber auf der NVIDIA-Seite (Version 304.64) die 6200 auch auflistet und ich selbst zur Zeit eine 6150LE laufen habe. Aber eben unter Debian Squeeze.

In dem Fall habe ich mich lieber zurückgehalten, denn ich weiß nicht, wie weit vorne Precise mit dem XServer ist. Aber ich weiß, daß es da vor etwa einem Jahr eine Meldung gab, daß irgend ein Treiber nicht mehr an den neuen XServer angepasst wird. Ich wollte jedenfalls nicht schuld sein, wenn eine Karte gekauft wird, die dann doch nicht läuft.

Aber ich freue mich mit Nandl, daß er das so glatt hinbekommen hat! :thumbsup:

--
Wenn das Problem damit gelöst/erledigt ist setze bitte noch das passende Präfix vor die Überschrift, damit das jeder gleich erkennen kann. Einfach den ersten Beitrag "bearbeiten" -> Präfix setzen. Danke!
mir is wurscht

DocHifi

unregistriert

18

21.02.2013, 11:48

Hi Fredl,
Aber ich weiß, daß es da vor etwa einem Jahr eine Meldung gab, daß irgend ein Treiber nicht mehr an den neuen XServer angepasst wird

jo, das war der hier:

Zitat

nvidia-96: (NV11 und NV17-28) Legacy-Treiber funktioniert nicht mit aktuellem X-Server, kein Hersteller-Update für X-Server ABI 1.13 mehr geplant.
Gruß DH

19

21.02.2013, 12:25

Legacy-Treiber
PLING. Genau, der war's.
Na gut, dann brauche ich auch keine System-Updates befürchten. :)
Und Mitleser dürfte mit seinem Wheezy auf Kriegsfuß stehen :D
mir is wurscht

20

21.02.2013, 23:23

Und Mitleser dürfte mit seinem Wheezy auf Kriegsfuß stehen :D
Stimmt. Debian ist Scheisse..... :D

Auf jeden Fall gut das es bei Nandl jetzt läuft :thumbup:

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Mitleser« (21.02.2013, 23:30)