Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

  • »oesterreicherfel« ist der Autor dieses Themas

Beiträge: 17

Registrierungsdatum: 26.12.2012

Derivat: Kein Ubuntu-Derivat

Architektur: 64-Bit PC

  • Nachricht senden

21

03.01.2013, 14:43

Ich habe jetzt nochmal eine andere Möglichkeit genutzt, die 2.
Nach dem ersten Befehl im terminal kam das hier raus was soll ich jetzt machen?
source_dir existiert nicht. Bitte geben Sie --target oder --directory an

  • »Klaus P« ist männlich

Beiträge: 4 543

Registrierungsdatum: 25.10.2009

Derivat: anderes Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: 7/10

  • Nachricht senden

22

03.01.2013, 14:54

1. Du beantwortest die Fragen nicht!

2.Was steht bei Möglichkeit Nr. 2:

Du versuchst mit Hilfe der SuperGrubDisk (als bootfähige CD brennen, einlegen und Neustart) dein bereits installiertes Ubuntu zu starten und .....................


Ich bezweifle mal, dass du das gemacht hast. Wenn nicht kann da auch nichts bei rauskommen.

  • »oesterreicherfel« ist der Autor dieses Themas

Beiträge: 17

Registrierungsdatum: 26.12.2012

Derivat: Kein Ubuntu-Derivat

Architektur: 64-Bit PC

  • Nachricht senden

23

03.01.2013, 15:01

Ich habe mein bereits installiertes ubuntu gestartet

  • »Klaus P« ist männlich

Beiträge: 4 543

Registrierungsdatum: 25.10.2009

Derivat: anderes Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: 7/10

  • Nachricht senden

24

03.01.2013, 15:12

.....mit Hilfe der SuperGrubDisk? Verwechslung mit Live-System ausgeschlossen?

Gruß

Klaus P

  • »oesterreicherfel« ist der Autor dieses Themas

Beiträge: 17

Registrierungsdatum: 26.12.2012

Derivat: Kein Ubuntu-Derivat

Architektur: 64-Bit PC

  • Nachricht senden

25

03.01.2013, 16:21

Ja mit hilfe der supergrubdisk. Und das Live-System ist doch wenn man ubuntu ohne installation über die live-CD startet oder?

  • »Klaus P« ist männlich

Beiträge: 4 543

Registrierungsdatum: 25.10.2009

Derivat: anderes Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: 7/10

  • Nachricht senden

26

03.01.2013, 17:38

Ja, LIVE-CD ist, wenn du die Installations CD startest und anstatt "installieren", "Ubuntu ausprobieren/testen" wählst. Das Beitriebssystem wird dann für die Länge der Sitzung in den Arbeitsspeicher geladen.

Die SuperGrubDisk sucht bei Neustart des Computers, ob ein Ubuntu (oder anderes) Betriebssystem vorhanden ist und startet es.

Stimmen wir also überein, dass letzteres der Fall ist und du tatsächlich in deiner neuen Ubuntuinstallation drin bist :?:

Wenn ja, wäre das ja schon mal soweit gut, dass die Installation geklappt hat und du nun weißt, wie du wenigstens Hilfsweise in dein System kommst und damit arbeiten kannst. Wiederhole dann doch bitte nochmal den Schritt, den ich weiter vorne unter Punkt 2. gepostet habe und gebe ins Terminal noch mal die Befehle ein:

sudo grub-install /dev/sda

und dann noch

sudo update-grub

Bitte wieder nicht abschreiben sondern kopieren und einfügen. Ausgabe und/oder Fehlermeldungen bitte hier posten.

Gruß

Klaus P

  • »oesterreicherfel« ist der Autor dieses Themas

Beiträge: 17

Registrierungsdatum: 26.12.2012

Derivat: Kein Ubuntu-Derivat

Architektur: 64-Bit PC

  • Nachricht senden

27

07.01.2013, 15:31

Hier die Ausgaben: und wir sind uns einig das ich im bereits installiertem ubuntu drinnen bin.



felix@Felix-Lappi:~$ sudo grub-install /dev/sda
[sudo] password for felix:
source_dir existiert nicht. Bitte geben Sie --target oder --directory an
felix@Felix-Lappi:~$ sudo update-grub
grub.cfg wird erstellt …
Linux-Abbild gefunden: /boot/vmlinuz-3.5.0-17-generic
initrd-Abbild gefunden: /boot/initrd.img-3.5.0-17-generic
Found memtest86+ image: /boot/memtest86+.bin
Windows 7 (loader) auf /dev/sda1 gefunden
Windows 7 (loader) auf /dev/sda2 gefunden
erledigt
felix@Felix-Lappi:~$

DocHifi

unregistriert

28

07.01.2013, 15:43

Hi.
kopiere diesen Befehl mal in den Terminal und poste die Aussgbe.

Quellcode

1
sudo fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sudo sh -c "hexdump -v -s 0x80 -n  2 -e '2/1 "%x" "\\n"' X | xargs -n1 -IY sh -c "case  "Y" in '48b4') echo X: GRUB 2 v1.96 ;; 'aa75' | '5272') echo X: GRUB Legacy ;; '7c3c') echo X: GRUB 2 v1.97 oder v1.98 ;; '020') echo X: GRUB 2 v1.99 ;; *) echo X: Kein GRUB Y ;; esac""

Gruß DH

  • »Klaus P« ist männlich

Beiträge: 4 543

Registrierungsdatum: 25.10.2009

Derivat: anderes Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: 7/10

  • Nachricht senden

29

07.01.2013, 15:45

Hallo!

Gib bitte folgende 'Befehlskette nacheinander ins Terminal ein:

Quellcode

1
2
3
4
5
6
7
8
9
sudo apt-get purge grub* 

sudo apt-get update 

sudo apt-get --reinstall install grub-common grub-pc os-prober 

sudo grub-install /dev/sda 

sudo update-grub 


(wie immer ohne die Nummern davor)!

Falls das nichts bringt, dann installiere bitte das Boot-info-script, und hänge die Textausgabe an deinen nächsten Post dran: siehe hier.

Gruß

Klaus P

  • »oesterreicherfel« ist der Autor dieses Themas

Beiträge: 17

Registrierungsdatum: 26.12.2012

Derivat: Kein Ubuntu-Derivat

Architektur: 64-Bit PC

  • Nachricht senden

30

07.01.2013, 16:23

Ich glaube ich habe da was falsch gemacht habe also nochmal von vorne angefangen und jetzt kam das hier raus:

felix@Felix-Lappi:~$ sudo grub-install /dev/sda
[sudo] password for felix:
sudo: grub-install: Befehl nicht gefunden
felix@Felix-Lappi:~$ sudo update-grub
sudo: update-grub: Befehl nicht gefunden
felix@Felix-Lappi:~$ sudo fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sudo sh -c "hexdump -v -s 0x80 -n 2 -e '2/1 \"%x\" \"\\n\"' X | xargs -n1 -IY sh -c \"case \"Y\" in '48b4') echo X: GRUB 2 v1.96 ;; 'aa75' | '5272') echo X: GRUB Legacy ;; '7c3c') echo X: GRUB 2 v1.97 oder v1.98 ;; '020') echo X: GRUB 2 v1.99 ;; *) echo X: Kein GRUB Y ;; esac\""
/dev/sda: Kein GRUB a78
/dev/sda1: Kein GRUB 55aa
/dev/sda2: Kein GRUB 55aa
/dev/sda3: Kein GRUB 55aa
/dev/sda4: Kein GRUB 00
/dev/sda5: Kein GRUB 00
/dev/sda6: Kein GRUB 00
felix@Felix-Lappi:~$ ^C
felix@Felix-Lappi:~$

DocHifi

unregistriert

31

07.01.2013, 16:38

Hi,
also wirklich kein Grub installiert, ohne Worte.
Ist das evtl. ein neues Gerät ? Stichwort UEFI /SecureBoot.
Gruß DH

  • »oesterreicherfel« ist der Autor dieses Themas

Beiträge: 17

Registrierungsdatum: 26.12.2012

Derivat: Kein Ubuntu-Derivat

Architektur: 64-Bit PC

  • Nachricht senden

32

07.01.2013, 16:39

Ja es ist ein neues gerät

DocHifi

unregistriert

33

07.01.2013, 16:46

Hi,
und hat es ein UEFI, oder noch ein Standard Bios ?
Handbuch nachschauen. :thumbup:
Gruß DH

  • »Klaus P« ist männlich

Beiträge: 4 543

Registrierungsdatum: 25.10.2009

Derivat: anderes Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: 7/10

  • Nachricht senden

34

07.01.2013, 17:25

Ja es ist ein neues gerät


Und ganau deswegen hatte ich dich anfangs deines Beitrags schon mehrfach um diese Angaben gebeten und dir auch einen Link gepostet, wie man das feststellen kann. In meinem letzten Post hatte ich dich um das Boot-Info-Script gebeten.....!!??

Einfach machtst du es einem wirklich nicht :!:

Gruß

Klaus P

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Klaus P« (07.01.2013, 17:36)


  • »oesterreicherfel« ist der Autor dieses Themas

Beiträge: 17

Registrierungsdatum: 26.12.2012

Derivat: Kein Ubuntu-Derivat

Architektur: 64-Bit PC

  • Nachricht senden

35

07.01.2013, 18:59

Hallo!

Mein Laptop verfügt über UEFI mit CSM

Nach der 3. Angabe deiner Befehlskette kommt das hier raus:
Paketkonfiguration




┌─────────────────────┤ Konfiguriere grub-pc ├──────────────────────┐
│ Für das Paket grub-pc wird gerade ein Upgrade durchgeführt. In │
│ diesem Menü können Sie auswählen, ob und für welche Geräte │
│ grub-install automatisch ausgeführt werden soll. │
│ │
│ Für die Mehrzahl der Fälle wird empfohlen, grub-install │
│ automatisch laufen zu lassen. So wird vermieden, dass das │
│ installierte GRUB-Image nicht zu den GRUB-Modulen oder grub.cfg │
│ passt. │
│ │
│ Wenn Sie nicht sicher sind, welches Gerät das BIOS zum Booten │
│ benutzt, ist es oft eine gute Idee, GRUB auf allen Geräten zu │
│ installieren. │
│ │
│ Hinweis: Sie können GRUB auch in die Boot-Blöcke von Partionen │
│ schreiben.Hier werden auch einige geeignete Partitionen │
│ angeboten. Das zwingt GRUB allerdings dazu, den │
│ Blocklist-Mechanismus zu verwenden. Dieser ist weniger │
│ zuverlässig und wird daher nicht empfohlen. │
│ │
│ Geräte für die GRUB-Installation: │
│ │
│ [ ] /dev/sda (500107 MB; HITACHI_HTS725050A7E630) │
│ [ ] - /dev/sda5 (197360 MB; /) │
│ │
│ │
│ <Ok> │
│ │
└───────────────────────────────────────────────────────────────────┘

Was soll ich da jetzt auswählen??
Soll ich dir jetzt noch die Ausgaben vom Boot-Info-sript schicken, oder
erst das hier zu ende führen?

Gruß
Felix (Mein Vater sagt ich soll euch mal sagen, dass ich 11 Jahre alt bin - daher bitte etwas Rücksicht :)

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »oesterreicherfel« (07.01.2013, 19:16)


  • »Klaus P« ist männlich

Beiträge: 4 543

Registrierungsdatum: 25.10.2009

Derivat: anderes Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: 7/10

  • Nachricht senden

36

07.01.2013, 19:24

Vergiss das mal mit der Befehlskette von weiter oben. Mit EFI ist das alles etwas anders/komplizierter. Lies dir bitte dazu den Thread durch, den ich dir ganz am Anfang verlinkt hatte, als ich dich gebeten hatte, festzustellen, ob es ein EFI-Gerät ist. Ehe du jedoch da weiter machst, solltest du das Secure-Boot (falls vorhanden) im EFI/BIOS deaktivieren. Hättest du diese Infos schon an Weihnachten geliefert, wärst du vermutlich schon weiter.

ich verabschiede mich dann mal aus diesem Thread, da ich keine Erfahrung mit EFI-Installationen habe.

Viel Erfolg!

Klaus P

  • »oesterreicherfel« ist der Autor dieses Themas

Beiträge: 17

Registrierungsdatum: 26.12.2012

Derivat: Kein Ubuntu-Derivat

Architektur: 64-Bit PC

  • Nachricht senden

37

07.01.2013, 19:44

Lieber Klaus (und andere),
hier meldet sich kurz der Vater von Felix. Ich finde super, daß er hier so viel Unterstützung und Anleitung (bisher am meisten ja von Klaus) erhält. Macht doch bitte weiter mit ihm. Er saugt jeden Tipp auf und beschäftigt sich damit. (Und ich als Papa finde das natürlich super, nichts besser, als wenn der Sohn sich reinarbeitet und selbst die Dinge erwirkt.) Gutes Ergebnis bisher: Ubuntu ist installiert und er kann es mit der Super-Grub-Disk starten, dann ohne Disk damit arbeiten - bis zum nächsten Start. Fehlt also jetzt "nur noch", daß er - ohne Disk - bei Hochfahren zwischen Ubuntu und Windows auswählen kann.

Mit "Rücksicht nehmen" meinte ich eher Verständnis dafür aufbringen, dass er jeder Anregung bzw. Aufforderung nicht immer vollständig gefolgt ist, weil er sich auch nicht immer so perfekt hier ausdrücken kann.

Danke für all die Unterstützung (ich bin da eher ein Computer-Legastheniker, von daher ist von mir wenig zu erwarten), vielleicht könnt ihr noch etwas weiter helfen - letztlich müssen wir uns sonst hier vor Ort dann an jd. wenden,

gutes neues Jahr
Frank Ö.

  • »Klaus P« ist männlich

Beiträge: 4 543

Registrierungsdatum: 25.10.2009

Derivat: anderes Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: 7/10

  • Nachricht senden

38

07.01.2013, 22:28

Hallo!

Siehe Antwort auf private Nachrichte! Dort etwas ausführlicher! Kurz: Ich kann nur helfen, wenn ich einigermaßen weiß, wovon ich rede. Und bei EFI und Secure-Boot gibts da leider große Defizite. Da muss ich dann leider passen.

Zitat

letztlich müssen wir uns sonst hier vor Ort dann an jd. wenden,

...was auch nicht so ganz einfach sein dürfte. Denn die wenigsten Computerhändler/Schrauber etc. kennen sich damit gut aus. Viele haben von Linux kaum Ahnung und von Linux in Verbindung mit EFI noch weniger.

Gruß

Klaus P

  • »oesterreicherfel« ist der Autor dieses Themas

Beiträge: 17

Registrierungsdatum: 26.12.2012

Derivat: Kein Ubuntu-Derivat

Architektur: 64-Bit PC

  • Nachricht senden

39

11.01.2013, 08:35

Hier habe ich einen neuen thread begonnen:
http://forum.ubuntuusers.de/topic/ubuntu…et-ohne-auswah/