Sie sind nicht angemeldet.

  • »sunnysnowflake« ist der Autor dieses Themas

Beiträge: 15

Registrierungsdatum: 14.11.2012

Derivat: Ubuntu

Architektur: 32-Bit PC

Desktop: GNOME 2.x

  • Nachricht senden

1

14.11.2012, 12:30

Lexmark x2620 treiber?

Hallo,

ja, schon wieder ein verzweifelter Lexmark-benutzer...

Das fragliche Modell ist diesmal der X2620, der im wiki http://wiki.ubuntuusers.de/Lexmark_Drucker
auch aufgeführt ist (siehe X-serie), allerdings wurde der treiber scheinbar für ubuntu 9.04 getestet. Ich hab 12.04.

Downloaden und entpacken (mit ./lexmark-inkjet-08-driver-1.0-1.i386.deb.sh --keep --noexec --target X2620) klappte.
Ich hab alles in /home/download entpackt, ich hoffe das macht nichts?!
Im Ordner X2620, der wie gewünscht entstanden ist, lässt sich nur leider kein ordner namens arch.tar finden.
woran liegt das?

Bin für alle Hilfen dankbar, auch zB wie man sichergeht dass mit dem ls befehl wirklich JEDE datei angezeigt wird^^ ;).

sunnysnowflake

EDIT: Habe gerade den Thread gefunden: Lexmark X2620 scannen geht nicht
Drucken würde mir ja erstmal schon reichen.

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »sunnysnowflake« (19.11.2012, 18:19)


  • »Ullimell« ist männlich

Beiträge: 560

Registrierungsdatum: 17.04.2009

Derivat: Xubuntu

Architektur: 32-Bit PC

Desktop: GNOME 2.x

Andere Betriebssysteme: Lubuntu 10.04 Xubuntu10.10 Xubuntu12.04 mit Mate

  • Nachricht senden

2

14.11.2012, 12:38

Hi sunnysnowflake,
vielleicht ein versteckte Datei
Schon ma im Downloadordner unter Ansicht Versteckte Dateien anzeigen bzw Strg+H
probiert.

ullimelll
Lebensweisheit:
Rechne mit dem Schlimmsten, dann wirst du auch nicht enttäuscht.

  • »sunnysnowflake« ist der Autor dieses Themas

Beiträge: 15

Registrierungsdatum: 14.11.2012

Derivat: Ubuntu

Architektur: 32-Bit PC

Desktop: GNOME 2.x

  • Nachricht senden

3

14.11.2012, 12:59

Hi Ullimel,
danke für den Tip :)
Leider auch kein verstecktes arch.tar auffindbar...
Stimmt es eigentlich, dass man auch ls -a oder so ähnlich schreiben kann, um versteckte dateien anzuzeigen?
lg
sunnysnowflake

DocHifi

unregistriert

4

14.11.2012, 13:07

Hi,
ich würde das besser nicht versuchen, denn:

Zitat

Die Z-Serie zu verwenden ist nur bei alten Kerneln möglich.
was ja auf 12.04 nicht zutrifft.


Gruß DH

  • »sunnysnowflake« ist der Autor dieses Themas

Beiträge: 15

Registrierungsdatum: 14.11.2012

Derivat: Ubuntu

Architektur: 32-Bit PC

Desktop: GNOME 2.x

  • Nachricht senden

5

14.11.2012, 13:17

Hi DocHifi,
dir auch ein Danke für deine Antwort :)
"Die Z-Serie zu verwenden ist nur bei alten Kerneln möglich."
Das stimmt. Aber ich verwende ja einen drucker der x-serie ;)
und dieser thread Lexmark X2620 scannen geht nicht hat mir hoffnung gemacht, dass drucken möglich ist (auch wenn er von 2009 ist).
lg,
Sunnysnowflake

DocHifi

unregistriert

6

14.11.2012, 14:08

Hi,
Das stimmt. Aber ich verwende ja einen drucker der x-serie ;)
sorry, hatte mich irritieren lassen, weil vorne in dem Beitrag beide genannt waren.
Gruß DH

7

14.11.2012, 14:36

Im Ordner X2620, der wie gewünscht entstanden ist, lässt sich nur leider kein ordner namens arch.tar finden.
Scheinbar passt die Anleitung nicht mehr zu der Archivdatei.
Im Verzeichnis X2620 findest du einen Installer namens "startupinstaller.sh". Der führt dich dann durch eine grafische Installation. Doppelklick oder im Terminal:

Quellcode

1
2
cd X2620
./startupinstaller.sh

In X2620/files_extra/readme hast du auch eine genaue Anleitung zum Installieren, Zufügen des Druckers über CUPS und (falls nötig) deinstallieren über die Paketverwaltung. -> den Hinweisen zu "For Debian-based package:" folgen.

Ohne Gewähr, da ich diese Hardware nicht habe.
mir is wurscht

  • »sunnysnowflake« ist der Autor dieses Themas

Beiträge: 15

Registrierungsdatum: 14.11.2012

Derivat: Ubuntu

Architektur: 32-Bit PC

Desktop: GNOME 2.x

  • Nachricht senden

8

15.11.2012, 22:31

@DocHifi
ist ja kein Problem :)

@Fredl
Hi, danke für die Antwort.
Sorry, die readme hatte ich nicht entdeckt :rolleyes: .
Der startupinstaller (wenn mit sudo ausgeführt) funktioniert prima, bis er im Installationsprozess mit der Meldung "failed to install" abbricht.
Spuckt folgenden Error-Report aus:

Extracting file: lexmark-inkjet-08-driver-1.0-1.i386.deb
Extracting file: launcher.c
Extracting file: lsbrowser
Extracting file: lsusbdevice
Extracting file: lxklpia.sh
Extracting file: jre1.6.0_07.bin
Extracting file: launcher
Using dpkg installation
=============================
Execute: dpkg -i lexmark-inkjet-08-driver-1.0-1.i386.deb > /home/anna/Downloads/X2620/pkg/files/dpkg_msgs

dpkg: error processing lexmark-inkjet-08-driver-1.0-1.i386.deb (--install):
parsing file '/var/lib/dpkg/tmp.ci/control' near line 9 package 'lexmark-inkjet-08-driver':
blank line in value of field 'Description'
Errors were encountered while processing:
lexmark-inkjet-08-driver-1.0-1.i386.deb
=============================

=============================
Execute: rm lexmark-inkjet-08-driver-1.0-1.i386.deb

=============================
***** ERROR REPORT *****


Nach der halb erfolgten installation lässt sich jetzt aber "arch.tar" im Ordner X2620 finden. Dort findet sich dann auch ganz wiki-gemäß die lexmark-inkjet-08-driver-1.0-1.i386.deb, die sich über das Software-Center öffnen lässt. Versucht man aber sie zu installieren, gibts
folgende Bemängelung:
"The package doesn't provide a valid Installed-Size control field. See Debian Policy 5.6.20."
Ignoriert man das gibt es wieder den gleichen Error wie mit dem startupinstaller.sh.

Habt ihr Schlauen dafür auch wieder eine Lösung? Ihr habt mich schon ein ganz schönes Stück weitergebracht bis jetzt :) Daanke ;)

9

16.11.2012, 00:12

Nach der halb erfolgten installation lässt sich jetzt aber "arch.tar" im Ordner X2620 finden. Dort findet sich dann auch ganz wiki-gemäß die lexmark-inkjet-08-driver-1.0-1.i386.deb
Soweit habe ich letztes Mal nicht versucht. Aber jetzt...
Interessant, daß sich das in einer VM unter einer älteren Ubuntu-Version dennoch installieren ließ. Aber die control-Datei scheint tatsächlich zwei(!) Syntax-Fehler zu haben. Naja, Lexmark+Linux...

Ok, ich habe das versuchsweise repariert und schicke dir einen Link, weil es mit 10MB zu groß ist.
Versuch's mal damit. Wenn es nicht geht, hab ich noch eine weitere Möglichkeit. Die geht dann sicher, aber eben nicht über die Paketverwaltung. So wär's aber besser.
mir is wurscht

  • »sunnysnowflake« ist der Autor dieses Themas

Beiträge: 15

Registrierungsdatum: 14.11.2012

Derivat: Ubuntu

Architektur: 32-Bit PC

Desktop: GNOME 2.x

  • Nachricht senden

10

16.11.2012, 21:44

Hallo Fredl,
ja deine veränderte Datei lässt sich einwandfrei über das Software-Center installieren! :thumbsup:
Wenn das nicht zu weit führt, würde es mich freuen, wenn du kurz die notwendigen Änderungen in der control-Datei postest, dann können andere Leser mit dem gleichen Problem es auch lösen ;)
(Außerdem interessiert es mich einfach ;) )

Der Drucker wird nach der Installation deiner reparierten Datei automatisch von CUPS erkannt, d.h. ich kann mir das manuelle Hinzufügen (wie in der readme beschrieben) sparen. Bis jetzt funktioniert also alles super.
Drucken kann ich zwar noch nicht, aber die Dokumente werden in der Warteschleife angezeigt und der Drucker befindet sich im Status "Stopped-Printer warning". Nach dem Wochenende setze ich mal vernünftige Patronen ein, dann sollte das Problem auch gelöst sein.

Also, ein dickes Dankeschön für die Mühe, die du dir gemacht hast! :thumbsup: ;)

lg,
sunnysnowflake

11

17.11.2012, 00:20

Hi,
Gern geschehen.
Erstmal freut es mich, daß zumindest die Treiberinstallation funktioniert hat. Lass wissen, wie er sich dann in der Praxis bewährt.
Und zu deiner Frage: Die Änderungen waren eigentlich trivial. Es mussten nur die Fehler ausgebügelt werden, die in deinen Ausgaben schon genannt wurden:
blank line in value of field 'Description'
Die Beschreibung des Pakets enthielt eine Leerzeile und die belegte Größe nach der Installation war nicht eingetragen:
The package doesn't provide a valid Installed-Size control field. See Debian Policy 5.6.20.

Interessant war, wie gesagt, daß sich das Paket auf einer älteren Ubuntu-Version (Lucid?) trotzdem problemlos installieren ließ. Scheinbar legt die neueste Version von dpkg jetzt mehr wert auf eine korrekte Syntax.

Die beiden Änderungen waren also: Eine Leerzeile entfernen (leicht), die Größe nach Installation feststellen (mittelschwer) und eintragen (leicht).
Davor musste halt noch das Paket zerlegt und die Datei aus dem Archiv geholt werden. Nach den Änderungen nur noch die Rechte und Besitzer wieder anpassen, ins Archiv zurückschieben und das Paket wieder zuschnüren. Möchte jemand etwas über die Anatomie von Debian-Paketen lernen? :D
Ich würde das reparierte Paket ja zur Verfügung stellen, aber es ist copyrighted. Daher werde ich vielleicht einen Patch veröffentlichen. Vielleicht.

Hätte nie gedacht, einmal für Lexmark zu arbeiten :whistling:

--
Wenn das Problem gelöst ist setze bitte noch das passende Präfix vor die Überschrift, damit das jeder gleich erkennen kann. Einfach den ersten Beitrag "bearbeiten" -> Präfix setzen. Danke!
mir is wurscht

  • »sunnysnowflake« ist der Autor dieses Themas

Beiträge: 15

Registrierungsdatum: 14.11.2012

Derivat: Ubuntu

Architektur: 32-Bit PC

Desktop: GNOME 2.x

  • Nachricht senden

12

20.11.2012, 00:31

Hi,
erstmal zur Praxis: nach dem Wechsel der Druckerpatrone konnte ich den Drucker dazu bewegen ein Foto auszudrucken, dessen Ursprung mir aber nicht bekannt ist. (Nehme an, es ist eine Art gespeichertes Testbild).
Gezielt eine Datei drucken klappt leider noch nicht. Laut CUPS befindet sich der Druker im Status: "Idle - "File "/usr/local/lexmark/lxk08/bin/printdriver" has insecure permissions (0100775/uid=0/gid=2)."
Woran kann das nun wieder liegen?
Und jetzt zum spannenden Teil: Ah ja, ich hatte mir schon gedacht, dass irgendwo eine Leerzeile gelöscht werden muss, aber wo hätte ich nicht gewusst, geschweige denn, wie man die belegte Größe nach der Installation herausfindet und wo sie hin muss...Gut, dass es Leute gibt, die sich damit auskennen ;) Aber trotzdem fände es cool, wenn ich selber wüsste, wie man das macht ;) Wenn du magst, kannst du mir also gerne mal einen guten Link über Paketaufbau geben :D

lg,
sunnysnowflake

13

20.11.2012, 18:32

Laut CUPS befindet sich der Druker im Status: "Idle - "File "/usr/local/lexmark/lxk08/bin/printdriver" has insecure permissions (0100775/uid=0/gid=2)."
Nachdem ich dazu leider auch nichts im Netz finde, kann ich nur raten. Also versuch einmal das:

Quellcode

1
2
3
sudo chown :0 /usr/local/lexmark/lxk08/bin/printdriver
sudo chmod g-w /usr/local/lexmark/lxk08/bin/printdriver
sudo service cups restart


Wenn du magst, kannst du mir also gerne mal einen guten Link über Paketaufbau geben
Da Debian schon eine Weile da ist, gibt's einige. Das Control-File betreffend wäre etwa dieser interessant. Der "mechanische" Aufbau ist idR. ein ar-gepacktes Archiv mit zumindest zwei weiteren Archiven darin, eines eben mit den Verwaltungsdaten und eines mit den zu installierenden Daten.
mir is wurscht

  • »sunnysnowflake« ist der Autor dieses Themas

Beiträge: 15

Registrierungsdatum: 14.11.2012

Derivat: Ubuntu

Architektur: 32-Bit PC

Desktop: GNOME 2.x

  • Nachricht senden

14

21.11.2012, 00:08

Hi Fredl,
erstmal Dankeschön für den Link :) Ja, ich glaube ich hab noch viel zu lernen über linux ;D

Nun zum Drucken: Geht leider noch nicht. Cups verlangt bei manchen Aktionen auch einen username und ein pw von mir. Die root-Kennung funktioniert dabei nicht. Meine normale Benutzerkennung schon ?(
ich habe zusätzlich zu deinen noch diese beiden Befehle hier ausgeführt:

Quellcode

1
2
sudo chmod 755 /usr/local/lexmark/lxk08/bin
sudo chgrp root /usr/local/lexmark/lxk08/bin/printdriver

->abgewandelt von diesem Post: http://ubuntuforums.org/showthread.php?t=2082570

Nachdem restart von cups ist nun endlich die Fehlermeldung im Status verschwunden, nur noch "Idle"! :D

Wenn ich jetzt aber eine Testseite drucken will, kommt in der Joblist unter "State" (dort stand sonst nur "stopped): "stopped
"/usr/local/lexmark/lxk08/bin/printdriver failed"".
:wacko:
Ich brauche nur noch einen kleinen Schubs in die richtige Richtung, dann klappt es hoffentlich (:

lg,

sunnysnowflake

EDIT:


Quellcode

1
sudo chmod 775 /usr/local/lexmark/lxk08/bin/printdriver

zeigt sich leider auch als uneffektiv..dachte nur vll müsste die Gruppe root auch ausführen dürfen..

Die Tatsache, dass ich den root account nicht aktiviert habe, macht doch nichts, oder?

Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von »sunnysnowflake« (21.11.2012, 00:59)


15

21.11.2012, 10:47

Die root-Kennung funktioniert dabei nicht. Meine normale Benutzerkennung schon
Das passt schon.
sudo chgrp root /usr/local/lexmark/lxk08/bin/printdriver
ist das gleiche wie:
sudo chown :0 /usr/local/lexmark/lxk08/bin/printdriver

Die Tatsache, dass ich den root account nicht aktiviert habe, macht doch nichts, oder?
Nein.

Zeig bitte einmal das Directory-Listing:

Quellcode

1
ls -Rl /usr/local/lexmark/lxk08/
mir is wurscht

  • »sunnysnowflake« ist der Autor dieses Themas

Beiträge: 15

Registrierungsdatum: 14.11.2012

Derivat: Ubuntu

Architektur: 32-Bit PC

Desktop: GNOME 2.x

  • Nachricht senden

16

21.11.2012, 22:33

Hi Fredl,

danke dass du dir immer noch Mühe machst ;)

Hier der Output nach deinem Befehl:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
anna@Xomp:~$ ls -Rl /usr/local/lexmark/lxk08/
/usr/local/lexmark/lxk08/:
total 20
drwxr-xr-x 3 root bin 4096 Nov 16 12:26 bin
drwxrwxr-x 2 root bin 4096 Nov 16 12:26 docs
drwxrwxr-x 2 root bin 4096 Nov 16 12:26 etc
drwxrwxr-x 2 root bin 4096 Nov 16 12:26 jar
drwxrwxr-x 2 root bin 4096 Nov 16 12:26 lib

/usr/local/lexmark/lxk08/bin:
total 164
-rwxrwxr-x 1 root bin  25012 Nov  6  2008 lxkusb
-rwxr-xr-x 1 root root 63851 Nov  6  2008 printdriver
-rwxrwxr-x 1 root bin  72903 Nov  6  2008 prnutility

/usr/local/lexmark/lxk08/docs:
total 48
-rw-rw-r-- 1 root bin 22157 Nov  6  2008 license.txt
-rwxrwxr-x 1 root bin 23546 Nov  6  2008 readme.txt

/usr/local/lexmark/lxk08/etc:
total 23556
-rw-rw-r-- 1 root bin 	583 Nov  6  2008 99-lexmark-2600-series.rules
-rw-rw-r-- 1 root bin	6643 Nov  6  2008 lexijtools_48x48.png
-rw-rw-r-- 1 root bin 	313 Nov  6  2008 lexijtools.desktop
-rwxrwxr-x 1 root bin   12062 Nov  6  2008 Lexmark-logo.xpm
-rw-rw-r-- 1 root bin 	541 Nov  6  2008 Lexmarklxdn.conf
-rw-rw-r-- 1 root bin   24752 Nov  6  2008 lx2600.ppd
-rwxrw-r-x 1 root bin 1273202 Nov  6  2008 lxdnclr1.lut
-rwxrw-r-x 1 root bin 1273202 Nov  6  2008 lxdnclr2.lut
-rwxrw-r-x 1 root bin 1282269 Nov  6  2008 lxdnclr3.lut
-rwxrwxr-x 1 root bin 	640 Nov  6  2008 lxdn.conf
-rwxrw-r-x 1 root bin  401493 Nov  6  2008 lxdncpy4.lut
-rwxrwxr-x 1 root bin   14739 Nov  6  2008 lxdnSCc0.bin
-rwxrwxr-x 1 root bin 	256 Nov  6  2008 lxdnSCg0.bin
-rw-rw-r-- 1 root bin 3735716 Nov  6  2008 lxdpalgn.out
-rw-rw-r-- 1 root bin 1290252 Nov  6  2008 lxdpcaln.out
-rw-rw-r-- 1 root bin  985973 Nov  6  2008 lxdpccln.out
-rw-rw-r-- 1 root bin 1896047 Nov  6  2008 lxdpcln.out
-rwxrw-r-x 1 root bin 1273202 Nov  6  2008 lxdpclr1.lut
-rwxrw-r-x 1 root bin 1273202 Nov  6  2008 lxdpclr2.lut
-rwxrw-r-x 1 root bin 1282269 Nov  6  2008 lxdpclr3.lut
-rw-rw-r-- 1 root bin 	640 Nov  6  2008 lxdp.conf
-rw-rw-r-- 1 root bin 1371444 Nov  6  2008 lxdpkaln.out
-rw-rw-r-- 1 root bin  910181 Nov  6  2008 lxdpkcln.out
-rw-rw-r-- 1 root bin 3831412 Nov  6  2008 lxdpphal.out
-rw-rw-r-- 1 root bin 1643213 Nov  6  2008 lxdpphcl.out
-rw-rw-r-- 1 root bin   24759 Nov  6  2008 lxZ2300.ppd
-rw-rw-r-- 1 root bin  242190 Nov  6  2008 testpage.pdf

/usr/local/lexmark/lxk08/jar:
total 1384
-rw-rw-r-- 1 root bin  264192 Nov  6  2008 appframework-1.0.3.jar
-rw-rw-r-- 1 root bin  110138 Nov  6  2008 CoreMaintenanceUtility.jar
-rw-rw-r-- 1 root bin 1036717 Nov  6  2008 GUIMaintenanceUtility.jar

/usr/local/lexmark/lxk08/lib:
total 3980
-rwxrwxr-x 1 root bin   8081 Nov  6  2008 libCS_ScanCorrect.so
-rwxrwxr-x 1 root bin 140982 Nov  6  2008 libhdctransport.so
-rw-rw-r-- 1 root bin 108712 Nov  6  2008 liblxdnflib.so
-rw-rw-r-- 1 root bin 545081 Nov  6  2008 liblxdnhpec.so
-rw-rw-r-- 1 root bin 761928 Nov  6  2008 liblxdnhpeh.so
-rw-rw-r-- 1 root bin 206700 Nov  6  2008 liblxdnhpep.so
-rw-rw-r-- 1 root bin 108712 Nov  6  2008 liblxdpflib.so
-rw-rw-r-- 1 root bin 545081 Nov  6  2008 liblxdphpec.so
-rw-rw-r-- 1 root bin 761928 Nov  6  2008 liblxdphpeh.so
-rw-rw-r-- 1 root bin 206700 Nov  6  2008 liblxdphpep.so
-rwxrwxr-x 1 root bin  25871 Nov  6  2008 liblxkscan.so
-rwxrwxr-x 1 root bin 190688 Nov  6  2008 libnpa407.so
-rwxrwxr-x 1 root bin 194838 Nov  6  2008 libprintengine.so
-rwxrwxr-x 1 root bin  61418 Nov  6  2008 libprinterdictionary.so
-rwxrwxr-x 1 root bin 109933 Nov  6  2008 libsane-Lexmarklxdn.so.1.0.18
-rwxrwxr-x 1 root bin  23569 Nov  6  2008 libuiocli.so
-rwxrwxr-x 1 root bin  27613 Nov  6  2008 libuiocmd.so
-rwxrwxr-x 1 root bin  10104 Nov  6  2008 libusblp.so

17

23.11.2012, 10:21

Ich glaube, ich komme langsam dahinter. Wie immer bei Lexmark, haben die das Paket aus einem SuSE-Paket umgewandelt. Dort werden andere numerische User- und Gruppen-IDs verwendet.
Ein Backup der Einstellungen haben wir ja jetzt, also können wir experimentieren :)

Versuch bitte einmal das:

Quellcode

1
2
sudo chown -R :lp /usr/local/lexmark
sudo chmod 775 /usr/local/lexmark/lxk08/bin/printdriver


Wenn das nicht hilft, sieh nach, ob Du Mitglied der Gruppe "lp" bist

Quellcode

1
id
Falls nicht:

Quellcode

1
sudo adduser dein_login_name lp
mir is wurscht

  • »sunnysnowflake« ist der Autor dieses Themas

Beiträge: 15

Registrierungsdatum: 14.11.2012

Derivat: Ubuntu

Architektur: 32-Bit PC

Desktop: GNOME 2.x

  • Nachricht senden

18

23.11.2012, 10:45

Hi Fredl,

freut mich, dass es vielleicht doch noch einen weg gibt.
Experimentieren? Immer gerne :D

Also: Nach den ersten beiden Befehlen sind wir leider wieder so gut wie vor den Permission-Änderungen, dh. in der Joblist nur der Status "stopped" (kein "printdriver failed o.ä.) und im Druckerstatus wieder ein Error: ""/usr/local/lexmark/lxk08/bin/printdriver" has insecure permissions (0100775/uid=0/gid=7)". -> Diesmal allerdings mit veränderten Zahlen.

Über diese Gruppe lpadmin meine ich auch schonmal irgendwas gelesen zu haben in dem Zusammenhang.
Ich geb dir mal den Output von "id":

Quellcode

1
2
3
4
5
6
7
8
anna@Xomp:~$ id
uid=1000(anna) gid=1000(anna) groups=1000(anna),4(adm),24(cdrom),27(sudo),30(dip),46(plugdev),109(lpadmin),124(sambashare)
anna@Xomp:~$ sudo adduser anna lp
Adding user `anna' to group `lp' ...
Adding user anna to group lp
Done.
anna@Xomp:~$ id
uid=1000(anna) gid=1000(anna) groups=1000(anna),4(adm),24(cdrom),27(sudo),30(dip),46(plugdev),109(lpadmin),124(sambashare)


EDIT: das war hier: http://www.macuser.de/forum/f24/cups-htt…lhost-520405/#4

EDIT2: Meinst du es könnte helfen, die Passwortabfrage aus der config auszukommentieren (obwohl das ja eigentlich nicht mein Problem ist):

"To disable password authentication you need to edit the /etc/cups/cupsd.conf file and comment out the lines reading:
AuthType Basic
AuthClass System
for the /admin location." http://forum.soft32.com/linux2/CUPS-loca…opict47977.html

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »sunnysnowflake« (23.11.2012, 11:02)


19

23.11.2012, 13:12

Ich habe vergessen zu sagen, daß du dich nach der Gruppenänderung 1x aus- und einloggen musst, damit die Gruppenzugehörigkeit auch wirksam wird.

(lpadmin ist nicht das gleiche wie lp.)

Die Passwortabfrage deaktivieren bringt auch nichts, das betrifft nur den der die Drucker verwalten soll. Drucken können musst du auch ohne Passwort.

Du kannst im aktuellen Zustand zwei Dinge versuchen:
1. Aus- und einloggen und nochmal nachsehen. Wenn die Meldung gleich bleibt, passt ihm die Gruppe "lp" auch nicht. Also dann auf "root" setzen:

Quellcode

1
sudo chown -R :0 /usr/local/lexmark
Du sagtest, da kam keine Permissions-Meldung, aber der Drucker war pausiert? Wenn das danach wieder so ist, dann geh in die Druckereinstellungen und stelle ihn auf "aktiviert" um. Wahrscheinlich war es nämlich, weil der Drucker bei einem Fehler deaktiviert wird. Und der Fehler war, daß der Treiber wegen der Permissions nicht arbeiten konnte. Sobald das gelöst ist, sollte das also auch nicht mehr vorkommen.
mir is wurscht

  • »sunnysnowflake« ist der Autor dieses Themas

Beiträge: 15

Registrierungsdatum: 14.11.2012

Derivat: Ubuntu

Architektur: 32-Bit PC

Desktop: GNOME 2.x

  • Nachricht senden

20

25.11.2012, 23:08

So, zurück vom Wochenende :)

Jetzt bin ich Mitglied der Gruppe lp:

Quellcode

1
2
anna@Xomp:~$ id
uid=1000(anna) gid=1000(anna) groups=1000(anna),4(adm),7(lp),24(cdrom),27(sudo),30(dip),46(plugdev),109(lpadmin),124(sambashare)


Drucker befindet sich aber immernoch im gleichen Druckerstatus: "Idle - "File "/usr/local/lexmark/lxk08/bin/printdriver" has insecure permissions (0100775/uid=0/gid=7).""

Setze ich als group jetzt wieder root statt lp mit deinem Befehl:

Quellcode

1
sudo chown -R :0 /usr/local/lexmark

verändert sich der Druckerstatus von "Idle - "File "/usr/local/lexmark/lxk08/bin/printdriver" has insecure permissions (0100775/uid=0/gid=7).""
zu
"Idle".

Wenn ich dann einen Testseite drucken will, kommt in der Joblist unter "State" erst:
"processing since
Sun 25 Nov 2012 10:36:36 PM CET

"/usr/local/lexmark/lxk08/bin/printdriver failed""
und dann
"stopped "/usr/local/lexmark/lxk08/bin/printdriver failed"".
(
Also das gleiche Verhalten wie auch in Post 14: Druckerstatus "Idle", aber in der Joblist kein simples "stopped", sondern eine Fehlermeldung.)

In den Default-Options ist die "Error Policy" auf "retry job" gestellt. :S
Das Einzige, was mir jetzt noch einfällt, ist, dass bei der automatischen Druckererkennung was schief gelaufen ist. Werde mal versuchen, den Drucker neu manuell zu Cups hinzuzufügen.

EDIT: Das hat leider auch nichts genützt. Jetzt habe ich den Drucker 2x mit leicht unterschiedlichen Namen in Cups :pinch:
In der Joblist immernoch das gleiche Problem: printdriver failed.
In dem Druckerstatus (also bei der Übersicht) diesmal: "Idle - "Sending data to printer."" -und zwar bei den "beiden" Druckern (bzw Einträgen).

Merkwürdig :huh:
Im Moment frage ich mich tatsächlich, ob das noch was wird, denn die permissions-Fehler lassen sich ja mit den von Dir genannten Befehlen prima beheben. Und bei anderen Leuten scheint der Drucker danach auch schon prima zu laufen. Bei mir bleibt nur leider die "stopped-printdriver failed"-Meldung in der Joblist. (Trotzdem konnte ich ja schonmal ein Bild ausdrucken, das wahrscheinlich noch im Drucker gespeichert war.) Also sind die Gründe vielleicht doch im Treiber zu suchen?

Selstsam ist auch, dass unter "Maintanance" -> "Modify Printer" für Model u.a. zwischen "Current Driver-Lexmark 2600 Series, 1.0" und zweimal "Lexmark 2600 Series, 1.0 (en)" (ohne ersichtlichen Unterschied) ausgewählt werden kann.

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »sunnysnowflake« (25.11.2012, 23:28)


Zurzeit ist neben Ihnen 1 Benutzer in diesem Thema unterwegs:

1 Besucher

Ähnliche Themen

Verwendete Tags

Drucker, lexmark, Treiber