Sie sind nicht angemeldet.

12.04 alleine / neben Windows (dualboot) - Bei Neustart erscheint kein Bootscreen

  • »Wolfi1959« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 30.07.2012

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: Unity

  • Nachricht senden

1

30.07.2012, 13:54

Bei Neustart erscheint kein Bootscreen

Hallo Zusammen,

ich versuche Ubuntu 12.04 (64-bit) mit der Desktop-CD neben Windows 7 auf meinem neuen Rechner zu installieren. Die Installation ist auch (scheinbar) komplikationslos abgelaufen … bis zu dem Punkt, wo ein Reboot stattfinden sollte. Der Rechner bootet dann neu und startet sofort Windows, ohne einen Bootscreen oder GRUB anzuzeigen. Ich habe also nicht die Möglichkeit, Ubuntu auszuwählen.

Noch zur Info: mein Rechner hat zwei Festplatten, wobei Windows von der ersten Platte (SSD) bootet. Ubuntu habe ich auf die zweite Platte installiert. Im Partitionsmanager während Installation wurde mir auch nur die zweite Festplatte als Installationsmöglichkeit angezeigt. Kann es sein, dass die Ubuntu Installations-CD die erste Festplatte = SSD nicht erkennt?

Was kann ich machen?

Danke für jeden Tipp! Gruss, Wolfi

2

30.07.2012, 13:58

Die Linuxplatte sollte als erstes booten, damit die GRUB auch gestartet werden kann.
Zu der Erkennung von SSD-Platten unter Ubuntu Live CD/DVD/Stick System kann ich nix sagen.


lg
Freddy

  • »Wolfi1959« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 30.07.2012

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: Unity

  • Nachricht senden

3

30.07.2012, 14:22

Die Linuxplatte sollte als erstes booten, damit die GRUB auch gestartet werden kann.
Zu der Erkennung von SSD-Platten unter Ubuntu Live CD/DVD/Stick System kann ich nix sagen.


lg
Freddy

Hallo Freddy,
wenn ich die Bootreihenfolge im BIOS ändere (also so, dass von der zweiten Festplatte gebootet werden soll), passiert gar nix ... also weder Windows noch Ubuntu bootet.
Gruss Wolfi

4

30.07.2012, 14:38

Was ist den das für eine Platte wo Linux drauf ist, SATA oder IDE? Ok, ich weiß nun nicht ob die SSD als erstes gebootet werden muss.


lg
Freddy

  • »Wolfi1959« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 30.07.2012

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: Unity

  • Nachricht senden

5

30.07.2012, 15:08

Hallo Freddy,
die zweite Platte ist ne SATA ...

Interessant ist ... wenn ich Ubuntu von einer Live-CD starte, dann sehe ich alle Platten (also auch die SSD) und kann die auch mounten. Ich sehe auch, dass Ubuntu auf der zweiten Platte installiert ist.
Gibt es einen Weg, herauszufinden, ob und wo sich GRUB installiert hat?

Gruss, Wolfi

6

30.07.2012, 15:12

Dann poste doch mal bitte die Terminalausgabe von

Quellcode

1
sudo fdisk -l

und

Quellcode

1
sudo fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sudo sh -c "hexdump -v -s 0x80 -n  2 -e '2/1 "%x" "\\n"' X | xargs -n1 -IY sh -c "case  "Y" in '48b4') echo X: GRUB 2 v1.96 ;; 'aa75' | '5272') echo X: GRUB Legacy ;; '7c3c') echo X: GRUB 2 v1.97 oder v1.98 ;; '020') echo X: GRUB 2 v1.99 ;; *) echo X: Kein GRUB Y ;; esac""




lg
Freddy

Beiträge: 2 216

Registrierungsdatum: 25.10.2009

Derivat: Ubuntu

Version: Ubuntu 12.04 LTS (Precise Pangolin)

Architektur: 64-Bit PC

Desktop: anderer

  • Nachricht senden

7

30.07.2012, 15:17

Zitat

Gibt es einen Weg, herauszufinden, ob und wo sich GRUB installiert hat?


Ja!

Entweder diesen Befehl ins Terminal kopieren (die Ausgabe ist kurz) und hier posten

Quellcode

1
sudo fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sudo sh -c "hexdump -v -s 0x80 -n  2 -e '2/1 "%x" "\\n"' X | xargs -n1 -IY sh -c "case  "Y" in '48b4') echo X: GRUB 2 v1.96 ;; 'aa75' | '5272') echo X: GRUB Legacy ;; '7c3c') echo X: GRUB 2 v1.97 oder v1.98 ;; '020') echo X: GRUB 2 v1.99 ;; *) echo X: Kein GRUB Y ;; esac""


oder (besser) das

Boot-Info-script

laufen lassen (und ggf. auch hier posten)

Gruß

Klaus P

  • »Wolfi1959« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 30.07.2012

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: Unity

  • Nachricht senden

8

30.07.2012, 15:39

Hallo Freddy und Klaus P.,

hier die Ausgaben ... es scheint bei der Installation kein GRUB installiert worden zu sein


ubuntu@ubuntu:~$ sudo fdisk -l

Disk /dev/sdb: 2000.4 GB, 2000398934016 bytes
255 heads, 63 sectors/track, 243201 cylinders, total 3907029168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xbead1467

Device Boot Start End Blocks Id System
/dev/sdb1 2048 3641393523 1820695738 7 HPFS/NTFS/exFAT
/dev/sdb2 3641395198 3907028991 132816897 5 Extended
/dev/sdb5 3641395200 3873513471 116059136 83 Linux
/dev/sdb6 3873515520 3907028991 16756736 82 Linux swap / Solaris

Disk /dev/sda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders, total 234441648 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x27a8f764

Device Boot Start End Blocks Id System
/dev/sda1 * 2048 206847 102400 7 HPFS/NTFS/exFAT
/dev/sda2 206848 234438655 117115904 7 HPFS/NTFS/exFAT
ubuntu@ubuntu:~$



ubuntu@ubuntu:~$ sudo fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sudo sh -c "hexdump -v -s 0x80 -n 2 -e '2/1 \"%x\" \"\\n\"' X | xargs -n1 -IY sh -c \"case \"Y\" in '48b4') echo X: GRUB 2 v1.96 ;; 'aa75' | '5272') echo X: GRUB Legacy ;; '7c3c') echo X: GRUB 2 v1.97 oder v1.98 ;; '020') echo X: GRUB 2 v1.99 ;; *) echo X: Kein GRUB Y ;; esac\""
/dev/sdb: Kein GRUB 9f83
/dev/sdb1: Kein GRUB 55aa
/dev/sdb2: Kein GRUB 00
/dev/sdb5: Kein GRUB 00
/dev/sdb6: Kein GRUB 00
/dev/sda: Kein GRUB 9f83
/dev/sda1: Kein GRUB 55aa
/dev/sda2: Kein GRUB 55aa
ubuntu@ubuntu:~$

9

30.07.2012, 15:44

Es ist keine GRUB installiert, dies kannst du nachholen, siehe hier



lg
Freddy

Beiträge: 2 216

Registrierungsdatum: 25.10.2009

Derivat: Ubuntu

Version: Ubuntu 12.04 LTS (Precise Pangolin)

Architektur: 64-Bit PC

Desktop: anderer

  • Nachricht senden

10

30.07.2012, 16:00

....oder eine Etage höher aus dem laufenden System. Vorher muss noch eine bootfähige Super Grub Disc erstellt werden (sollte man eh immer zur Hand haben!).

Gruß

Klaus P

  • »Wolfi1959« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 30.07.2012

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: Unity

  • Nachricht senden

11

30.07.2012, 16:02

Hallo Freddy,

vielen Dank! Wo genau muss ich denn GRUB installieren? Ubuntu ist ja auf sdb5 und sdb6. Die erste Festplatte wird mit sda1 und sda2 angezeigt. Ich denke mal, sda1 ist die Bootpartition und da muss GRUB rein, richtig?

Wird der MBR von Windows dann nicht ueberschrieben?

Gruss Wolfi

12

30.07.2012, 16:05

Standartmässig gehört Grub in den MBR. Das ist sda. Ja der NT-Loader wird überschrieben. Grub übernimmt die Auswahl dann.

13

30.07.2012, 16:06

ich würd sage nach

Quellcode

1
/dev/sdb5 


normalerweise aber auch direkt zu sdb, aber da scheint ja noch ne andere Partition zu sein (HPFS/NTFS/exFAT)


Normalerweise klemmt man auch die Windowsplatte vor der Installation ab, so das die Grub anständig mit installiert wird und bootet die Linux Platte als erstes


lg
Freddy

Beiträge: 2 216

Registrierungsdatum: 25.10.2009

Derivat: Ubuntu

Version: Ubuntu 12.04 LTS (Precise Pangolin)

Architektur: 64-Bit PC

Desktop: anderer

  • Nachricht senden

14

30.07.2012, 16:21

Zitat

Von AtrumCorvus
ich würd sage nach


Quellcod

/dev/sdb5


Warum sdb5 ??

Das macht nur Sinn wenn er unter Windows easybcd installiert und dann den Windows Bootloader damit entsprechend einstellt.

Gruß

Klaus P

15

30.07.2012, 16:29

Das macht nur Sinn wenn er unter Windows easybcd installiert und dann den Windows Bootloader damit entsprechend einstellt.


Damit kommste jetzt, hätte dir auch ettwas früher einfallen können

Weil da linux drauf ist


lg
Freddy

  • »Wolfi1959« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 30.07.2012

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: Unity

  • Nachricht senden

16

30.07.2012, 16:56

so, habe jetzt mal GRUB genau nach Anleitung im MBR von sda installiert. Das ging auch (scheinbar) ohne Fehlermeldung im Terminal. Nach Neustart leider wieder das gleiche Problem ... bootet direkt in Windows. Die Ausgabe des Befehls von Freddy ergab dann auch wieder: kein GRUB installiert.

Ich werde als naechstes mal die erste SSD Festplatte abklemmen und Ubuntu nochmal neu auf die zweite FP installieren und dann versuchen von der zweiten Platte zu booten. Mal schaun ...

Gruss Wolfi

  • »floogy« ist männlich

Beiträge: 3 084

Registrierungsdatum: 10.03.2005

Wohnort: Koblenz

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: GNOME 3.0

Andere Distribution: debian

  • Nachricht senden

17

30.07.2012, 17:06

Ohne jetzt genau geschaut zu haben, nehme ich mal an, dass Du dann von sdb (2TiB Platte) startest und nicht von der SSD. Du solltest mal die Bootreihenfolge im BIOS entsprechend ändern und es einfach nochmal versuchen.

Es könnte auch sein, dass bei diesem Start sda und sdb getauscht wurden, weshalb Grub in den MBR der 2TiB geschrieben wurde (diesmal sda, statt sdb), ka.

Beiträge: 2 216

Registrierungsdatum: 25.10.2009

Derivat: Ubuntu

Version: Ubuntu 12.04 LTS (Precise Pangolin)

Architektur: 64-Bit PC

Desktop: anderer

  • Nachricht senden

18

30.07.2012, 18:14

Das macht nur Sinn wenn er unter Windows easybcd installiert und dann den Windows Bootloader damit entsprechend einstellt.


Damit kommste jetzt, hätte dir auch ettwas früher einfallen können

Weil da linux drauf ist


lg
Freddy


Da meine Glaskugel gerade in Reparatur ist, konnte ich deinen Ratschlag mit sdb5 leider nicht voraussehen. Beim nächsten Mal klappts dann wieder :whistling: !

Gruß

Klaus P

  • »Wolfi1959« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 30.07.2012

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: Unity

  • Nachricht senden

19

30.07.2012, 20:15

so ... wollte mich noch mal kurz melden. Habe versucht, Ubuntu auf die zweite Platte zu installieren, während die erste Platte im BIOS deaktiviert war. Das ist mir leider auch nicht gelungen. Die Installation verlief zwar ohne Fehlermeldung, es wurde aber wieder kein GRUB installiert. Beim Neustart startet sofort Windows. Habe keine Idee, was da los ist.

Jetzt habe ich Ubuntu vorerst mal mit dem Wubi-Installer installiert, das lief wenigstens ohne Probleme. Werde mich jetzt erst mal mit Ubuntu vertraut machen und dann noch mal eine "richtige" Installation versuchen.

Danke noch mal für die Tipps und Hilfestellung! Gruss Wolfi

Beiträge: 2 216

Registrierungsdatum: 25.10.2009

Derivat: Ubuntu

Version: Ubuntu 12.04 LTS (Precise Pangolin)

Architektur: 64-Bit PC

Desktop: anderer

  • Nachricht senden

20

30.07.2012, 23:04

Hallo Wolfi!

Wir wissen ja nun nun nicht genau was du gemacht hast. Deshalb vielleicht erst mal noch zur Abklärung zwei Dinge.

-Es wäre wichtig zu wissen ob dein neuer PC mit (U)EFI - BIOS ausgestattet ist (dann wirds komplizierter).

-Des weiteren hier etwas Lektüre zur Behandlung von SSDs unter Ubuntu.

Wenn das geklärt ist, sollte man noch mal Schritt für Schritt die Installation bzw. Grub-Reparatur durchgehen, denn Wubi ist auf Dauer nicht das Richtige.

Gruß

Klaus P