Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

  • »TobiDerBoss« ist der Autor dieses Themas

Beiträge: 1

Registrierungsdatum: 30.11.2011

Architektur: 64-Bit PC

Desktop: GNOME 3.0

  • Nachricht senden

1

30.11.2011, 18:57

OpenVPN einrichten / "Standardgateway für das Remotenetzwerk verwenden"-Äquivalent gesucht

Hey,

folgende Situation, hab bisher Windows benutzt um mich per OpenVPN mit einem anderem Heimnetz zu verbinden um auf die Freigaben, Netzwerkfestplatte dort zuzugreifen. Internet sollte jedoch weiterhin über meine Internetverbindung laufen. Dies hab ich in Windows dadurch erreicht, dass ich das Häkchen in den Einstellungen der VPN-Verbindung bei "Standardgateway für das Remotenetzwerk verwenden" entfernt hab. Somit hat dann alles funktioniert mit OpenVPN und folgender config-datei:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
dev tap0 
ifconfig 192.168.1.104 255.255.255.0 
secret static.key 
proto udp 
remote abc.zensiert.com 1194 
keepalive 10 60 
resolv-retry infinite 
nobind 
persist-key 
persist-tun 
cipher BF-CBC 
comp-lzo 
verb 3 
float


Mein Netzwerk hat 192.168.1.x IPs und das auf das ich zugreifen will ebenfalls. Mein Router hat die (interne) IP 192.168.1.1 und der auf den ich zugreifen will hat die selbe Interne IP.

Verbinden in Linux mit der config (per "openvpn --config /home/tobiasd/Dokumente/VPN/Home.ovpn") funktioniert auch wunderbar, nur geht dann eben mein Internet nicht mehr. Es funktioniert zumindest insofern, das die Verbindung erfolgreich hergestell wird, auf die Windows-Freigaben kann ich auch noch nicht zugreifen aber das ist denk ich nochmal ein anderes Problem. Deshalb die Frage nach einer Lösung die das selbe tut wie unter Windows das Deaktivieren des Häkchens "Standardgateway für das Remotenetzwerk verwenden".

Kann mir da jemand weiterhelfen? Ich steig da noch nicht so wirklich durch :whistling:

Danke,
Tobi

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »TobiDerBoss« (30.11.2011, 18:59)