Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

  • »maverick5321« ist der Autor dieses Themas

Beiträge: 2

Registrierungsdatum: 08.08.2011

Derivat: Ubuntu

Architektur: 32-Bit PC

Desktop: anderer

  • Nachricht senden

1

08.08.2011, 12:16

Squid benutzt eingetragenen DNS-Server nicht!

Hallo liebe Ubuntu Gemeinde,

vorweg bin ein Linux (Ubuntu) Neueinsteiger und habe die Aufgabe bekommen auf der Arbeit einen neuen Proxy einzurichten auf der Ubuntu Server Version 10.10 basierend.
Als Programm benutzte ich Squid.

Das Netzwerk sieht wie folgt aus:



Das Einrichten war an sich nicht das Problem. Das surfen im I-net klappt ohne Probleme und auch die Seiten im Intranet können aufgerufen werden, aber leider und jetzt kommt das Problem,
mit der Einschränkung das man den fully-quallified-name(xzz.firma.firm) der Intranetseite eingeben muss und sie nicht über den Alias der auf dem DNS-Server liegt aufgerufen werden kann. Heisst für mich das Squid sich nicht
den in der /etc/resolv.conf eingetragenen DNS-Server zieht. Den Versuch ihn direkt in Squid einzutragen ist leider auch misslungen. Im moment sehen meine .conf Files wie folgt aus:

/etc/resolv.conf
#nameserver 192.168.2.1
nameserver xxx.29.230.10 # interner DNS
domain firma.firm
search firma.firm



squid.conf
acl FirmaStd src x.29.230.0/255.255.255.0 # (ip nur hier im post maskiert)
http_access allow FirmaStd

#DNS Server
dns_nameservers x.29.230.10
#dns_nameservers 192.168.2.1
domain firma.firm
search firma.firm


/etc/hosts
127.0.0.1 localhost proxy.firma.firm proxy
#x.29.230.30 proxy.firma.firm proxy


von dem Proxyserver selber kann ich direkt den Alias sowie den fully-quallified-name pingen. Im Browser (in diesem fall Firefox) von einem angeschlossenen Client (im Firefox ist der Proxy eingestellt) geht es wiederrum nur mit dem fully-quallified-name und nicht mit dem Alias.
Wie muss ich denn nun den Squid einstellen damit er den Internen DNS-Server benutzt?

Hoffe jemand hat eine zündende Idee und kann mir bei meinem Problem helfen.

Gruß
Mav

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »maverick5321« (08.08.2011, 13:04)


2

09.08.2011, 01:46

Eigentlich brauchst du ihn gar nicht eintragen, wenn er den aus der resolv.conf verwenden soll.
Warum es nicht geht, wenn der gleiche da auch drinsteht, weiß ich nicht. Ich habe aber auch keinen eingetragen, eben weil ich dann das gleiche Problem hatte.
Mit den besten Empfehlungen der Anstaltsleitung.

  • »maverick5321« ist der Autor dieses Themas

Beiträge: 2

Registrierungsdatum: 08.08.2011

Derivat: Ubuntu

Architektur: 32-Bit PC

Desktop: anderer

  • Nachricht senden

3

09.08.2011, 09:42

hallo Fredl,

danke für die schnelle Antwort. Hab ja wie gesagt beides ausprobiert und jetzt aktuell folgende (so wie du es beschrieben hast) settings in
der resolv.conf und squid.conf benutzt.

squid.conf
#DNS Server
#dns_nameservers x.29.230.10
#dns_nameservers 192.168.2.1
#domain firma.firm
#search firma.firm

/etc/resolv.conf
#nameserver 192.168.2.1
nameserver xxx.29.230.10 # interner DNS
domain firma.firm
search firma.firm

hab jetzt aber leider immer noch den selben fehler das nur der fully-quallified-name funktioniert.

könntest du mir mal deine configs posten so das ich sie übernehmen könnte wenn es bei dir ja funktioniert.

gruß
mav

4

09.08.2011, 11:10

Hi,
Meine vollständige conf wird dir nicht viel weiter helfen, aber sieh dir einmal die Option "append_domain" an... ;)
Mit den besten Empfehlungen der Anstaltsleitung.