Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

  • »koschy« ist der Autor dieses Themas

Beiträge: 9

Registrierungsdatum: 21.03.2011

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: GNOME 2.x

  • Nachricht senden

1

07.06.2011, 14:44

FRITZ!Wlan USB Stick wird nicht erkannt

Hallo,

nachdem ich meinen integrierten WLAN-Adapter nicht zum laufen bekommen habe, habe ich mir nun den o.g. USB-Stick gekauft.
Die Installation startet auch mit wine, das Problem ist, dass ich sie abbrechen muss, weil der Rechner den USB-Stick nicht erkennt.

Ich habe ihn 1000x rein- und rausgesteckt, aber der Rechner erkennt ihn weder als WLAN-Stick noch als USB-Stick, er erkennt ihn garnicht.

Dieser Fehler ist in der Installationsanleitung nicht beschrieben: http://wiki.ubuntuusers.de/FRITZ!WLAN_USB_Stick

Langsam bin ich echt ratlos! Hat jemand einen Tipp?

  • »praseodym« ist männlich

Beiträge: 674

Registrierungsdatum: 16.02.2010

Wohnort: Berlin

Derivat: Xubuntu

Version: Ubuntu 12.04 LTS (Precise Pangolin)

Architektur: 32-Bit PC

Desktop: XFCE

  • Nachricht senden

2

07.06.2011, 14:49

Hallo,

ist Ndiswrapper installiert?

Quellcode

1
sudo apt-get install --reinstall ndisgtk ndiswrapper-common ndiswrapper-utils-1.9

Entpacke die Treiberdatei durch Rechtsklick->Mit Archivmanager öffnen (nicht mit Wine ausführen) und entpacke die Dateien. Danach die .inf-Datei über

Quellcode

1
gksu ndisgtk

anwählen. Wird der Stick durch

Quellcode

1
lsusb

erkannt/angezeigt?
Was es alles gibt, das ich nicht brauche.
(Aristoteles)
COPY/PASTE funktioniert auch im Terminal

  • »koschy« ist der Autor dieses Themas

Beiträge: 9

Registrierungsdatum: 21.03.2011

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: GNOME 2.x

  • Nachricht senden

3

07.06.2011, 14:56

Bei lsusb wird der Stick merkwürdigerweise erkannt:

christian@christian-laptop:~$ lsusb
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 04d9:1133 Holtek Semiconductor, Inc.
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 014: ID 057c:8403 AVM GmbH
Bus 001 Device 002: ID 0402:5602 ALi Corp. M5602 Video Camera Controller
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Das Problem ist, dass mein rechner zwar hier den Stick anzeigt (AVM), aber ich ihn nicht aufrufen kann, er wird nicht angezeigt.


Wenn ich die Installationsdatei entpacken will, zeigt er mir das an:

Archive: /home/christian/Downloads/avm_fritz!wlan_usb_stick_build_100906.exe
[/home/christian/Downloads/avm_fritz!wlan_usb_stick_build_100906.exe]
End-of-central-directory signature not found. Either this file is not
a zipfile, or it constitutes one disk of a multi-part archive. In the
latter case the central directory and zipfile comment will be found on
the last disk(s) of this archive.
note: /home/christian/Downloads/avm_fritz!wlan_usb_stick_build_100906.exe may be a plain executable, not an archive
zipinfo: cannot find zipfile directory in one of /home/christian/Downloads/avm_fritz!wlan_usb_stick_build_100906.exe or
/home/christian/Downloads/avm_fritz!wlan_usb_stick_build_100906.exe.zip, and cannot find /home/christian/Downloads/avm_fritz!wlan_usb_stick_build_100906.exe.ZIP, period.

  • »praseodym« ist männlich

Beiträge: 674

Registrierungsdatum: 16.02.2010

Wohnort: Berlin

Derivat: Xubuntu

Version: Ubuntu 12.04 LTS (Precise Pangolin)

Architektur: 32-Bit PC

Desktop: XFCE

  • Nachricht senden

4

07.06.2011, 15:22

Versuche den 64bit-Treiber von hier:

http://forum.ubuntuusers.de/post/1405034/
Was es alles gibt, das ich nicht brauche.
(Aristoteles)
COPY/PASTE funktioniert auch im Terminal

  • »koschy« ist der Autor dieses Themas

Beiträge: 9

Registrierungsdatum: 21.03.2011

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: GNOME 2.x

  • Nachricht senden

5

07.06.2011, 15:43

Hab ich gemacht und zwar wie folgt:

1.) runtergeladen
2.) entpackt
3.) über ndiswrapper die inf-Datei als Treiber angegeben. Dann kommt folgender Auswurf: "fwlan64 fehlerhafter Treiber".
Dasselbe passiert auch mit dem 32-bit Treiber.

Mein problem ist, dass das System den Stick nicht erkennt, weil die .exe-Installationsdatei kriege ich zm laufen, es geht nur da nicht weiter, wo man den Stick einstecken muss und dieser erkannt werden muss, um die Installation fortzusetzen. Das ist mein Problem!

Was kann ich tun, damit das System den verdammten Stick erkennt?

MfG

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »koschy« (07.06.2011, 15:50)


  • »praseodym« ist männlich

Beiträge: 674

Registrierungsdatum: 16.02.2010

Wohnort: Berlin

Derivat: Xubuntu

Version: Ubuntu 12.04 LTS (Precise Pangolin)

Architektur: 32-Bit PC

Desktop: XFCE

  • Nachricht senden

6

07.06.2011, 16:04

Lösche erstmal die bisherige Konfiguration:

Quellcode

1
2
sudo rm /etc/modprobe.d/ndiswrapper.conf
sudo rm -r /etc/ndiswrapper/*


Die exe brauchst du nicht. Dann erneut den 64bit-Treiber versuchen:

Quellcode

1
2
cd Ordnername/ #anpassen !!!
sudo ndiswrapper -i fwlan64.inf

Kontrollabfragen:

Quellcode

1
2
ndiswrapper -l
cat /etc/modprobe.d/ndiswrapper.conf
Was es alles gibt, das ich nicht brauche.
(Aristoteles)
COPY/PASTE funktioniert auch im Terminal

  • »koschy« ist der Autor dieses Themas

Beiträge: 9

Registrierungsdatum: 21.03.2011

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: GNOME 2.x

  • Nachricht senden

7

07.06.2011, 16:22

Er zeigt mir wieder "fehlerhafter Treiber" an-

christian@christian-laptop:~/fritz$ sudo ndiswrapper -i fwlan64.inf
installing fwlan64 ...
couldn't find models section "AVM" -
installation may be incomplete

christian@christian-laptop:~$ ndiswrapper -1
install/manage Windows drivers for ndiswrapper

usage: ndiswrapper OPTION
-i inffile install driver described by 'inffile'
-a devid driver use installed 'driver' for 'devid' (dangerous)
-r driver remove 'driver'
-l list installed drivers
-m write configuration for modprobe
-ma write module alias configuration for all devices
-mi write module install configuration for all devices
-v report version information

where 'devid' is either PCIID or USBID of the form XXXX:XXXX,
as reported by 'lspci -n' or 'lsusb' for the card


christian@christian-laptop:~$ cat /etc/modprobe.d/ndiswrapper.conf
cat: /etc/modprobe.d/ndiswrapper.conf: Datei oder Verzeichnis nicht gefunden


Langsam wirds echt grausam!!!!!

  • »praseodym« ist männlich

Beiträge: 674

Registrierungsdatum: 16.02.2010

Wohnort: Berlin

Derivat: Xubuntu

Version: Ubuntu 12.04 LTS (Precise Pangolin)

Architektur: 32-Bit PC

Desktop: XFCE

  • Nachricht senden

8

07.06.2011, 16:44

Was es alles gibt, das ich nicht brauche.
(Aristoteles)
COPY/PASTE funktioniert auch im Terminal

  • »flash63« ist männlich

Beiträge: 161

Registrierungsdatum: 05.07.2010

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: Unity

  • Nachricht senden

9

12.06.2011, 23:32

Hallo,
es handelt sich um eine neue Gerätevariante mit ar9170-Chipsatz. Vergiss alle bisherigen Anleitungen und deinstalliere Ndiswrapper und den Windows-Treiber vollständig.

Quellcode

1
Bus 001 Device 014: ID 057c:8403 AVM GmbH 


Edit: Fehler in der Befehlszeile korrigiert. Danke für den Hinweis Bionic_Man!
Erstelle folgende Konfigurationsdatei für den Systemtreiber carl9170:

Quellcode

1
echo 'install carl9170 modprobe --ignore-install carl9170 ; /bin/echo "057c 8403" > /sys/bus/usb/drivers/carl9170/new_id' | sudo tee /etc/modprobe.d/carl9170.conf

Das ist ein langer zusammenhängender Befehl!

Lade nun das Modul

Quellcode

1
2
3
sudo modprobe carl9170
iwconfig
iwlist chan

Der Stick sollte funktionieren.

Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von »flash63« (15.06.2011, 10:39)


Beiträge: 3

Registrierungsdatum: 14.06.2011

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: GNOME 2.x

  • Nachricht senden

10

14.06.2011, 12:56

@flash63

Danke für die Hilfe, aber bei mir funktioniert es leider trotzdem nicht. Er findet einfach den Stick nicht.
Hat eigentlich jemand anders den Stick mit dieser USB ID zum Laufen gebracht??

Neuste Compat Wireless Stabel Version runtergeladen, kompiliert, installiert und deine Konfigurationsdatei erstellt -> nix.
Mit neuster Compat Wireless Bleeding edge Version probiert -> auch nix.
Habe es auch zuerst mit ndiswrapper probiert, genau das selbe.

Keine Treiber scheint mit diesem neuem USB Stick zu funktionieren.
Mach mit dem Stick schon seit 2 Tagen rum und es klappt einfach keine Anleitung. :(

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Bionic_Man« (14.06.2011, 13:08)


  • »flash63« ist männlich

Beiträge: 161

Registrierungsdatum: 05.07.2010

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: Unity

  • Nachricht senden

11

14.06.2011, 13:51

Das brauchst Du alles nicht versuchen, die Geräte-ID ist unbekannt.

Es hat sich noch ein Tippfehler eingeschlichen. Wiederhole den korrigierten Befehl:

Quellcode

1
echo 'install carl9170 modprobe --ignore-install carl9170 ; /bin/echo "057c 8403" > /sys/bus/usb/drivers/carl970/new_id' | sudo tee /etc/modprobe.d/carl9170.conf


Zeige die Ausgabe von

Quellcode

1
2
3
4
cat /etc/modprobe.d/carl9170.conf
sudo modprobe carl9170
lsmod
dmesg | egrep 'ndis|carl|ath|wlan'

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »flash63« (14.06.2011, 17:32)


Beiträge: 3

Registrierungsdatum: 14.06.2011

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: GNOME 2.x

  • Nachricht senden

12

15.06.2011, 10:33

Du hast noch einen kleinen Tippfehler bei dem Pfad "/sys/bus/usb/drivers/carl970/new_id", sollte natürlich carl9170 heißen.

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
1. cat /etc/modprobe.d/carl9170.conf
install carl9170 modprobe --ignore-install carl9170 ; /bin/echo "057c 8403" > /sys/bus/usb/drivers/carl9170/new_id
2. sudo modprobe carl9170  -> keine Ausgabe

3. lsmod
Module              Size  Used by
carl9170           77817  0 
mac80211          290861  1 carl9170
ath                16969  1 carl9170
cfg80211          174015  3 carl9170,mac80211,ath
compat              8675  3 carl9170,mac80211,cfg80211
led_class           3393  2 carl9170,compat
usb_storage        50436  0 
binfmt_misc         7984  1 
snd_hda_codec_intelhdmi11032  1 
snd_hda_codec_realtek   300173  1 
snd_hda_intel      26147  4 
snd_hda_codec     100951  3 snd_hda_codec_intelhdmi,snd_hda_codec_realtek,snd_hda_intel
snd_hwdep           6660  1 snd_hda_codec
snd_pcm            89104  3 snd_hda_intel,snd_hda_codec
snd_seq_midi        5932  0 
snd_rawmidi        22207  1 snd_seq_midi
snd_seq_midi_event  7291  1 snd_seq_midi
snd_seq            57512  2 snd_seq_midi,snd_seq_midi_event
i915              334721  4 
snd_timer          23850  2 snd_pcm,snd_seq
snd_seq_device      6912  3 snd_seq_midi,snd_rawmidi,snd_seq
ppdev               6804  0 
tpm_tis            10022  0 
tpm                16013  1 tpm_tis
parport_pc         30086  1 
tpm_bios            6426  1 tpm
drm_kms_helper     32836  1 i915
snd                64181  16 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
drm               206198  4 i915,drm_kms_helper
i2c_algo_bit        6208  1 i915
video              22176  1 i915
output              2527  1 video
psmouse            62080  0 
serio_raw           4910  0 
soundcore           1240  1 snd
snd_page_alloc      8588  2 snd_hda_intel,snd_pcm
intel_agp          32334  2 i915
lp                 10201  0 
parport            37032  3 ppdev,parport_pc,lp
floppy             65299  0 
usbhid             42030  0 
hid                84710  1 usbhid
e1000e            151787  0 

4. dmesg | egrep 'ndis|carl|ath|wlan'
[0.557059] device-mapper: multipath: version 1.1.1 loaded
[0.557062] device-mapper: multipath round-robin: version 1.0.0 loaded
[ 2098.045329] usbcore: registered new interface driver carl9170


Weiß jetzt nicht, ob dir das hier auch was helfen würde.
Beim Einstecken des Sticks kann man folgendes verfolgen:

Quellcode

1
2
3
4
5
6
 dmesg | egrep 'usb'
[ 2063.410046] usb 1-3: new high speed USB device using ehci_hcd and address 7
[ 2063.710043] usb 1-3: reset high speed USB device using ehci_hcd and address 7
[ 2063.883192] usb 1-3: driver   API: 1.9.2 2011-01-22 [1-1]
[ 2063.883197] usb 1-3: firmware API: 1.9.2 2010-12-25
[ 2064.980042] usb 1-3: firmware upload failed (-110).

  • »flash63« ist männlich

Beiträge: 161

Registrierungsdatum: 05.07.2010

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: Unity

  • Nachricht senden

13

15.06.2011, 10:44

Die Firmware kann nicht geladen werden

Zitat

[ 2064.980042] usb 1-3: firmware upload failed (-110)
Entferne den Stick, entlade das Modul, schließe den Stick wieder an, warte ca. 30 Sekunden und lade carl9170 erneut.

Möglicherweise handelt es sich um einen Stick mit Atheros-HTC Chipsatz. Ersetze alle Modulbezeichnungen in der Befehlszeile carl9170 durch ath9k_htc. Versuche es dann erneut.Als Altenative bleibt Ndiswrapper. Benötigt wird die fwlan4.inf aus dem Treiberpaket welches mit cabextract entpackt werden kann.

Lassen sich durch das halbtransparente Kunststoffgehäuse des Sticks vielleicht die beiden Chipbezeichnug bzw. die Beschriftung ablesen (Lupe)?

Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von »flash63« (15.06.2011, 10:52)


Beiträge: 3

Registrierungsdatum: 14.06.2011

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: GNOME 2.x

  • Nachricht senden

14

15.06.2011, 11:10

Ne, hat geklappt. Einfach alles durch ath9k_htc ersetzt.
Raus und wieder ran gesteckt und der Stick geht jetzt wunderbar.

Dank dir für die Hilfe!!! :thumbup:

  • »flash63« ist männlich

Beiträge: 161

Registrierungsdatum: 05.07.2010

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: Unity

  • Nachricht senden

15

15.06.2011, 11:33

Du kannst noch eine Udev-Regel anlegen um den Treiber automatisch zu laden. Siehe http://forum.ubuntuusers.de/topic/wlan-u…u/#post-3005772