Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

01.12.2005, 19:10

Datentransfer zu langsam

Hallo,

ich habe auf einem Notebook (Compaq nx6110, Sonoma-Plattform, Pentium M 1.6 GHz) Ubuntu installiert. Es läuft sehr stabil, aber der Datentransfer vom CD-Laufwerk auf die Festplatte (Kopieren) ist sehr langsam. Dementsprechend ewig dauert z. B. das Rippen meiner CDs mit Sound Juicer. Über 30 Minuten für ein Album.

In umgekehrter Richtung scheint der Datenstrom aber normal schnell zu laufen, denn beim Brennen gibt es keine Probleme. Hat jemand eine Idee, was die Ursache sein könnte?

Danke

Moses

User

Beiträge: 1 628

Registrierungsdatum: 02.09.2005

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

2

01.12.2005, 19:13

Hallo

DMA eingeschalten?

ansonsten einfach mal in einem terminal folgendes eingeben:

Zitat


hdparm -d1 /dev/hdX

achtung: das X sollte gegen den entsprechenden buchstaben DEINER konfiguration ausgetauscht werden (z.b. /dev/hdc bei mir)

gruß m.

edit: ACHTUNG: ich glaub ich hab das "sudo" vergessen! d.h. der befehl muß lauten: "sudo hdparm -d1 /dev/hdX"
Lebe lang und erfolgreich!
www.One-O-Nine.at

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Moses« (01.12.2005, 19:17)


3

01.12.2005, 19:54

Danke für die Antwort. Es wird nicht aktiviert:

saighdiuir@nx6110:~$ hdparm -d1 /dev/hdb

/dev/hdb:
setting using_dma to 1 (on)
HDIO_SET_DMA failed: Permission denied
using_dma = 0 (off)
saighdiuir@nx6110:~$

Ich habe mich noch weiter über Google belesen und es ist etwas kompliziert, denn angeblich muß man im System nun einstellen, welchen Mainboardchipsatz das Notebook hat. Ich denke, ich werde mich später um das Problem kümmern, denn ich bin gestern erst von Windows umgestiegen und sehe gerade nicht durch *g*

CU

Moses

User

Beiträge: 1 628

Registrierungsdatum: 02.09.2005

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

4

01.12.2005, 19:59

darum hab ich mein edit geschrieben:

es muß lauten:

Zitat


sudo hdparm -d1 /dev/hdb
Lebe lang und erfolgreich!
www.One-O-Nine.at

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Moses« (01.12.2005, 19:59)


5

01.12.2005, 20:07

Danke für Deine Hilfe. Es hat funktioniert. 10 Minuten/Album klingen doch schon wesentlich besser!

Moses

User

Beiträge: 1 628

Registrierungsdatum: 02.09.2005

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

6

01.12.2005, 20:14

na dann...

zur info: nach dem nächsten neustart, wird dieser parameter wieder zurückgesetzt. d.h. DMA wäre wieder deaktiviert...

http://wiki.ubuntuusers.de/DMA

auf dieser seite findest du eine anleitung, wie du DMA für dein laufwerk dauerhaft aktivierst.

viel spaß - m.

ps: willkommen bei linux!
Lebe lang und erfolgreich!
www.One-O-Nine.at